Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Keyboard repeat rate and delay
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Mon Jul 15, 2013 10:50 am    Post subject: Keyboard repeat rate and delay Reply with quote

Hi all,
I want to set the keyboard repeat delay and rate in some X config file - the default is too slow for me. At present I am running the following command on startup
Code:
xset r rate 250 30
to set these parameters. However, they get reset to the default every time the machine suspends and resumes and I have to re-run this command all over again.

1. Is it possible to set these parameters in the xorg.conf file/directory? I suppose the relevant lines will look like this
Code:
Section "InputClass"
    Identifier             "Keyboard default"
    MatchIsKeyboard        "yes"
    Option                # some option that I need to fill in <-- what should this be?
EndSection


2. Is there some other file that X reads on suspend/resume that I can modify to fix the rate to the defaults I want?

Edit: It seems to be a combination of the X server and the Intel graphics driver. I have a different system with nvidia graphics driver and this problem does not arise (i.e., the keyboard repeat delay and rate are not reset) on a suspend/resume cycle.
_________________
emerge --quiet redefined | E17 vids: I, II


Last edited by ppurka on Wed Jul 17, 2013 1:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
geeksheik
n00b
n00b


Joined: 07 Sep 2003
Posts: 70

PostPosted: Tue Jul 16, 2013 2:08 pm    Post subject: Reply with quote

Is your window manager stomping over your settings?

I use the KDE "System Settings / Input Devices / Keyboard" dialog for this . The back-end file that it's written to is:

${HOME}/.kde4/share/config/kcminputrc

I don't know about Gnome or other window managers though.
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Tue Jul 16, 2013 2:25 pm    Post subject: Reply with quote

geeksheik wrote:
Is your window manager stomping over your settings?

I use the KDE "System Settings / Input Devices / Keyboard" dialog for this . The back-end file that it's written to is:

${HOME}/.kde4/share/config/kcminputrc

I don't know about Gnome or other window managers though.
I am using enlightenment. As far as I know it (and I have been using it for several years), enlightenment has no control for setting keyboard rate and delay. It can control the mouse acceleration though.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 841
Location: Montréal

PostPosted: Wed Jul 17, 2013 12:19 pm    Post subject: Reply with quote

You have to put your keyboard command in the ~/.xinitrc file or Bash script file if you use the startx command or in ~/.xsession or .xsessionrc file or Bash script file if you use a display manager to open an X session.
_________________
Paul
Back to top
View user's profile Send private message
ppurka
Advocate
Advocate


Joined: 26 Dec 2004
Posts: 3206

PostPosted: Wed Jul 17, 2013 1:31 pm    Post subject: Reply with quote

Logicien wrote:
You have to put your keyboard command in the ~/.xinitrc file or Bash script file if you use the startx command or in ~/.xsession or .xsessionrc file or Bash script file if you use a display manager to open an X session.
I am already doing something similar. That command is run from a bash script file every time I login. The problem happens when I resume from suspend. The window manager is not playing a role at that point since it is not starting (or even restarting - enlightenment can be restarted without losing windows). It is X which is resetting the previously set keyboard rate and delay.


Edit: It seems to be a combination of the X server and the Intel graphics driver. I have a different system with nvidia graphics driver and this problem does not arise (i.e., the keyboard repeat delay and rate are not reset) on a suspend/resume cycle.
_________________
emerge --quiet redefined | E17 vids: I, II
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum