Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Boot endet in Konsole
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sat Jul 20, 2013 3:16 pm    Post subject: Reply with quote

Code:
(chroot) livecd linux-3.8.13-gentoo # du -h -d1 /usr
133M    /usr/local
6,6G    /usr/share
625M    /usr/lib32
354M    /usr/include
42M     /usr/sbin
7,2M    /usr/x86_64-pc-linux-gnu
39M     /usr/games
6,5G    /usr/src
22G     /usr/lib64
4,0K    /usr/non-portage
52M     /usr/libexec
12G     /usr/portage
617M    /usr/bin
20K     /usr/qt
16K     /usr/lost+found
48G     /usr


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4115

PostPosted: Sat Jul 20, 2013 3:38 pm    Post subject: Reply with quote

uhai wrote:
Code:
(chroot) livecd linux-3.8.13-gentoo # du -h -d1 /usr
133M    /usr/local
6,6G    /usr/share
625M    /usr/lib32
354M    /usr/include
42M     /usr/sbin
7,2M    /usr/x86_64-pc-linux-gnu
39M     /usr/games
6,5G    /usr/src
22G     /usr/lib64
4,0K    /usr/non-portage
52M     /usr/libexec
12G     /usr/portage
617M    /usr/bin
20K     /usr/qt
16K     /usr/lost+found
48G     /usr

wow du musst aber haufen programme installiert haben, wenn allein /usr/lib64 22 GB groß ist. Das passt dann natürlich nicht auf deine root partition. Und du hast anscheinend auch einen haufen an kernel sourcen unter /usr/src liegen. Die größe von /usr/portage (wobei hauptsächlich /usr/portage/distfiles) noch "normal" aussieht, wenn man bedenkt wieviel programme du anscheinend installiert hast.

Da hilft nur noch entweder eine initrd/initramfs zu erstellen um /usr per lvm vor dem start des systems zu mounten. Oder die /usr partition komplett löschen (vorher natürlich ein backup der Daten erstellen :)) und den freien platzt der root partition zuordnen.

EDIT: Unter umständen muss auch /var vor dem start des systems gemounted sein, da /var/run von systemd verwendet wird
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Mon Jul 22, 2013 7:57 pm    Post subject: Reply with quote

die Platten habe ich fast voll... :-)

Die initramfs scheint der einfachere wEg zu sein. Aber mein erster Versuch ist geschietert...

Ich kann in meinen Logs nichts finden, /var/log ist auch ein lvm-Verzeichnis...
sys-fs/udisk konnte ich auch noch nicht installieren, bricht nach wie vor ab. Eventuell fehlt mir ja das Paket einfach beim Start...

Code:
/usr/lib/gcc/x86_64-pc-linux-gnu/4.6.3/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lgudev-1.0
collect2: ld returned 1 exit status
make[4]: *** [udisksd] Fehler 1
make[4]: Leaving directory `/var/tmp/portage/sys-fs/udisks-2.1.0/work/udisks-2.1.0/src'
make[3]: *** [all-recursive] Fehler 1
make[3]: Leaving directory `/var/tmp/portage/sys-fs/udisks-2.1.0/work/udisks-2.1.0/src'
make[2]: *** [all] Fehler 2
make[2]: Leaving directory `/var/tmp/portage/sys-fs/udisks-2.1.0/work/udisks-2.1.0/src'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/sys-fs/udisks-2.1.0/work/udisks-2.1.0'
make: *** [all] Fehler 2
 * ERROR: sys-fs/udisks-2.1.0 failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=sys-fs/udisks-2.1.0'`,
 * the complete build log and the output of `emerge -pqv '=sys-fs/udisks-2.1.0'`.
 * The complete build log is located at '/var/tmp/portage/sys-fs/udisks-2.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-fs/udisks-2.1.0/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-fs/udisks-2.1.0/work/udisks-2.1.0'
 * S: '/var/tmp/portage/sys-fs/udisks-2.1.0/work/udisks-2.1.0'


uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4115

PostPosted: Mon Jul 22, 2013 9:52 pm    Post subject: Reply with quote

das udisks für das starten benötigt wird kann ich nicht glauben.

bei mir wird udisks nur von folgenden paketen benötigt:
wine und kdelibs.

Das problem beim build von udisks kann nur daran liegen, dass nicht alle partitionen bei dir sauber gemountet werden und dadurch unter umständen manche dateien nicht erreichbar sind.

welchen logger hast du installiert und aktiviert?
Mit systemd wurde auch ein eigenes log system kreiert (journal), eventuell steht dort was drin. (Ist ein binary format zum auslesen geht das nur über journalctl)
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Tue Jul 23, 2013 4:29 am    Post subject: Reply with quote

Ich arbeite wieder im chroot und mounte die lvm2-Partitionen von Hand. Alles andere kann ich auch emergen....

das vermisste file lgudev-1.0 kann ich nicht finden bzw. einem Paket zuordnen. Wo kommt das her?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4115

PostPosted: Tue Jul 23, 2013 6:03 am    Post subject: Reply with quote

die datei heißt nicht lgudev-1.0 sondern libgudev-1.0.so
das -l ist ein parameter vom compiler/linker. Und bei diesem Parameter wird nur der Name der lib angegeben ohne den Präfix lib und ohne die Dateiendung .so
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Wed Jul 24, 2013 5:20 am    Post subject: Reply with quote

ok, dann ist das Paket systemd der Auslöser. Das habe ich neu gebaut, und udisk auch gleich.

Dann noch das Scritp für die initramfs

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Wed Jul 24, 2013 7:34 pm    Post subject: Reply with quote

Beim Start bricht er ab, weil /sbin/fsck niicht gefunden wird. Die Datei ist aber da und /sbin ist kein lvm-Laufwerk. Was ist da los?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4115

PostPosted: Wed Jul 24, 2013 8:36 pm    Post subject: Reply with quote

wer sagt das fsck nicht gefunden wird? eventuell die initrd? oder doch der boot vorgang von systemd
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Wed Jul 24, 2013 8:38 pm    Post subject: Reply with quote

Das müßte noch initrd sein, ich lande in einer verkrüppelten Konsole.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Thu Jul 25, 2013 8:45 pm    Post subject: Reply with quote

ok, initramfs von vorne:

Ich bin nach diesen Anleitungen vorgegangen:
initramfs-guide
Dracut im Wiki

So sieht das Ergebnis von emerge dracut aus:
Code:
>>> Original instance of package unmerged safely.
 *
 * If the following test report contains a missing kernel
 * configuration option, you should reconfigure and rebuild your
 * kernel before booting image generated with this Dracut version.
 *
 * Checking for suitable kernel configuration options...                                                                                [ ok ]

 * Autoassembly of special devices like cryptoLUKS, dmraid,
 * mdraid or lvm is off for default as of  >=dracut-024.
 * Use rd.auto option to turn it on.
>>> sys-kernel/dracut-029 merged.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.


Die Zeile " * Use rd.auto option to turn it on." ist mir unklar. Denn die Dracut-Module für lvm & systemd habe ich in der /etc/make.conf gesetzt:

Code:
DRACUT_MODULES="lvm syslog systemd"


und das sind meine USE-Flags:
Code:
sys-kernel/dracut       debug device-mapper


So wie ich das verstanden habe, sollte dann lvm als Modul zur Verfügung stehen.

So sieht der Output von dracut aus:
Code:
(chroot) livecd linux # dracut --hostonly
/usr/lib/dracut/dracut-logger.sh: line 122: : No such file or directory
E: '' is not a writable file
W: Turning off host-only mode: '/run' is not mounted!
W: Turning off host-only mode: udev database not found!
E: dracut module 'fstab-sys' cannot be found or installed.
E: dracut module 'gensplash' cannot be found or installed.
E: dracut module 'fstab-sys' cannot be found or installed.
E: dracut module 'gensplash' cannot be found or installed.
I: *** Including module: dash ***
I: *** Including module: i18n ***
I: *** Including module: dm ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: kernel-modules ***
I: *** Including module: lvm ***
I: Skipping udev rule: 64-device-mapper.rules
I: *** Including module: resume ***
I: *** Including module: rootfs-block ***
I: *** Including module: terminfo ***
I: *** Including module: udev-rules ***
I: Skipping program /lib/udev/create_floppy_devices as it cannot be found and is flagged to be optional
I: Skipping program /lib/udev/edd_id as it cannot be found and is flagged to be optional
I: Skipping program /lib/udev/firmware.sh as it cannot be found and is flagged to be optional
I: Skipping program /lib/udev/firmware.agent as it cannot be found and is flagged to be optional
I: Skipping program /lib/udev/hotplug.functions as it cannot be found and is flagged to be optional
I: Skipping program /lib/udev/fw_unit_symlinks.sh as it cannot be found and is flagged to be optional
I: Skipping program /lib/udev/pcmcia-socket-startup as it cannot be found and is flagged to be optional
I: Skipping program /lib/udev/pcmcia-check-broken-cis as it cannot be found and is flagged to be optional
I: Skipping program /etc/pcmcia/config.opts as it cannot be found and is flagged to be optional
I: *** Including module: usrmount ***
I: *** Including module: base ***
I: *** Including module: fs-lib ***
I: Skipping program xfs_db as it cannot be found and is flagged to be optional
I: Skipping program xfs_check as it cannot be found and is flagged to be optional
I: Skipping program xfs_repair as it cannot be found and is flagged to be optional
I: Skipping program xfs_metadump as it cannot be found and is flagged to be optional
I: Skipping program jfs_fsck as it cannot be found and is flagged to be optional
I: Skipping program reiserfsck as it cannot be found and is flagged to be optional
I: Skipping program btrfsck as it cannot be found and is flagged to be optional
I: *** Including module: shutdown ***
I: Skipping program kexec as it cannot be found and is flagged to be optional
I: *** Including modules done ***
I: *** Installing kernel module dependencies and firmware ***
I: *** Installing kernel module dependencies and firmware done ***
I: *** Pre-linking files ***
I: *** Pre-linking files done ***
I: *** Stripping files ***
I: *** Stripping files done ***
I: *** Creating image file ***
I: *** Creating image file done ***
I: Wrote /boot/initramfs-2.6.30-gentoo-r5.img:
I: -rw------- 1 root root 5174000 25. Jul 22:28 /boot/initramfs-2.6.30-gentoo-r5.img


1) Also lvm-modul doch vorhanden?

--> Hat sich erledigt, Module sind da nach erneutem emerge.

2) /run läßt sich mit ls zeigen, ist nicht in lvm2, keine separate Partition -> aber nicht mounted?
3) Kernel sollte hier 3.8.13 sein. Ist aber nicht so:

Code:

(chroot) livecd linux # uname -a
Linux livecd 2.6.30-gentoo-r5 #1 SMP Fri Oct 9 19:28:18 UTC 2009 x86_64 AMD Phenom(tm) II X4 945 Processor AuthenticAMD GNU/Linux


Liegt das am chroot? eselect kernel list zeigt den Symlink aber korrekt auf 3.8.13...

--> So ist es, manmuss dracut im chroot die Kernelversion mitgeben.

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sat Jul 27, 2013 4:39 pm    Post subject: Reply with quote

ok, mit dracut habe ich jetzt eine initramfs erstellt. Dabei sind noch zwei Fehler aufgetreten, die ich mir nicht erklären kann:

Code:
(chroot) livecd / # dracut -H -lvmconf --force --mount "/dev/mapper/tux-usr /usr" --mount "dev/mapper/tux-var /var" /boot/initramfs-3.8.13.img 3.8.13-gentoo
D: Installing /lib64/libreadline.so.6.2
D: Installing /lib64/libncurses.so.5.9
D: Installing /lib64/libdl-2.15.so
D: Installing /lib64/libc-2.15.so
D: Installing /lib64/ld-2.15.so
D: Installing /bin/bash
D: Executing: /usr/bin/dracut -H -lvmconf --force --mount "/dev/mapper/tux-usr /usr" --mount "dev/mapper/tux-var /var" /boot/initramfs-3.8.13.img 3.8.13-gentoo


W: Turning off host-only mode: '/run' is not mounted!
W: Turning off host-only mode: udev database not found!
device node not found


E: dracut module 'conf' cannot be found or installed.
E: dracut module 'conf' cannot be found or installed.

I: *** Including modules done ***
I: *** Installing kernel module dependencies and firmware ***
D: Installing /lib/modules/3.8.13-gentoo//modules.builtin.bin
D: Installing /lib/modules/3.8.13-gentoo//modules.builtin
D: Installing /lib/modules/3.8.13-gentoo//modules.order
I: *** Installing kernel module dependencies and firmware done ***
D: Installing /etc/ld.so.conf
D: Installing /etc/ld.so.conf.d/05binutils.conf
D: Installing /etc/ld.so.conf.d/05gcc-x86_64-pc-linux-gnu.conf
D: Listing sizes of included files:
D: 4   /var/tmp/initramfs.FxziJ5/bin
D: 4   /var/tmp/initramfs.FxziJ5/dev
D: 4   /var/tmp/initramfs.FxziJ5/etc/cmdline.d
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/cleanup
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/cmdline
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/emergency
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/initqueue/finished
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/initqueue/online
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/initqueue/settled
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/initqueue/timeout
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/mount
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/netroot
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/pre-mount
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/pre-pivot
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/pre-shutdown
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/pre-trigger
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/pre-udev
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/shutdown
D: 4   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/shutdown-emergency
D: 4   /var/tmp/initramfs.FxziJ5/proc
D: 4   /var/tmp/initramfs.FxziJ5/root
D: 4   /var/tmp/initramfs.FxziJ5/run/initramfs
D: 4   /var/tmp/initramfs.FxziJ5/run/lock
D: 4   /var/tmp/initramfs.FxziJ5/sbin
D: 4   /var/tmp/initramfs.FxziJ5/sys
D: 4   /var/tmp/initramfs.FxziJ5/sysroot
D: 4   /var/tmp/initramfs.FxziJ5/tmp
D: 4   /var/tmp/initramfs.FxziJ5/usr/bin
D: 4   /var/tmp/initramfs.FxziJ5/usr/lib64
D: 4   /var/tmp/initramfs.FxziJ5/usr/sbin
D: 4   /var/tmp/initramfs.FxziJ5/var
D: 12   /var/tmp/initramfs.FxziJ5/etc/ld.so.conf.d
D: 12   /var/tmp/initramfs.FxziJ5/run
D: 16   /var/tmp/initramfs.FxziJ5/usr
D: 20   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks/initqueue
D: 32   /var/tmp/initramfs.FxziJ5/etc
D: 56   /var/tmp/initramfs.FxziJ5/lib64/modules/3.8.13-gentoo
D: 60   /var/tmp/initramfs.FxziJ5/lib64/modules
D: 72   /var/tmp/initramfs.FxziJ5/lib64/dracut/hooks
D: 76   /var/tmp/initramfs.FxziJ5/lib64/dracut
D: 140   /var/tmp/initramfs.FxziJ5/lib64
D: 240   total
D: 240   /var/tmp/initramfs.FxziJ5
I: *** Pre-linking files ***
D: Installing /usr/sbin/prelink
D: Installing /etc/prelink.conf
D: Installing /etc/prelink.conf.d/portage.conf
I: *** Pre-linking files done ***
I: *** Stripping files ***
I: *** Stripping files done ***
I: *** Creating image file ***
I: *** Creating image file done ***
I: Wrote /boot/initramfs-3.8.13.img:
I: -rw------- 1 root root 6444 27. Jul 18:33 /boot/initramfs-3.8.13.img


Ich habe dracut im chroot gestartet. /run ist auf /dev/sda3 ein vorhandenes und im chroot lesbares Verzeichnis. und wo finde ich die udev-Database? Wird die beim Bott angelegt? Dann müßte ich aber doch auch eine "alte" haben...
Und wieso sucht der nach einem dracut-Modul "conf"?

Kennt sich jemand damit aus?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sat Jul 27, 2013 7:37 pm    Post subject: Reply with quote

Anscheinend haben die dracut-Module ein Problem beim Handling von lvm-Partitionen:

http://rich0gentoo.wordpress.com/2012/01/21/a-quick-dracut-module/

Oder habe ich das mißverstanden?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sun Jul 28, 2013 11:21 am    Post subject: Grub2 Reply with quote

grub2 soll lvm können. Hat das jemand schon im Einsatz? Kann man das verwenden oder ist das noch zu früh?

uhai

EDIT:
Statt initramfs verwende ich doch lieber /usr und /var ohne lvm. Scheint einfacher umzusetzen zu sein.
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Wed Aug 07, 2013 5:09 am    Post subject: masked by: binchecks strip in RESTRICT Reply with quote

Leider ist meine Sicherung defekt und nicht vollständig lesbar...

Jetzt fehlen die gentoo-sources (3.8.13), deren Kernel hier läuft. Und ein emerge im chroot bringt nur Fehler:

Code:
 emerge -a gentoo-sources

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "gentoo-sources" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-kernel/gentoo-sources-3.10.5-r1::gentoo (masked by: binchecks strip in RESTRICT, ~amd64 keyword)
- sys-kernel/gentoo-sources-3.10.5::gentoo (masked by: binchecks strip in RESTRICT, ~amd64 keyword)
- sys-kernel/gentoo-sources-3.10.4::gentoo (masked by: binchecks strip in RESTRICT, ~amd64 keyword)
- sys-kernel/gentoo-sources-3.10.3-r1::gentoo (masked by: binchecks strip in RESTRICT, ~amd64 keyword)
- sys-kernel/gentoo-sources-3.9.11-r1::gentoo (masked by: binchecks strip in RESTRICT, ~amd64 keyword)
- sys-kernel/gentoo-sources-3.8.13::gentoo (masked by: binchecks strip in RESTRICT)
- sys-kernel/gentoo-sources-3.4.55::gentoo (masked by: binchecks strip in RESTRICT, ~amd64 keyword)
- sys-kernel/gentoo-sources-3.4.54::gentoo (masked by: binchecks strip in RESTRICT, ~amd64 keyword)
- sys-kernel/gentoo-sources-3.2.48::gentoo (masked by: binchecks strip in RESTRICT, ~amd64 keyword)
- sys-kernel/gentoo-sources-3.0.88::gentoo (masked by: binchecks strip in RESTRICT, ~amd64 keyword)
- sys-kernel/gentoo-sources-3.0.87::gentoo (masked by: binchecks strip in RESTRICT, ~amd64 keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Mit dem Handbuch / man pages komme ich nicht klar... Was stimmt da nicht und wie bekomme ich das in den Griff? emerge world klappt übrigens...

uhai

noch so ein Kandidat:
Code:
!!! All ebuilds that could satisfy "x11-libs/cairo[glib]" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-libs/cairo-9999::gentoo (masked by: test in RESTRICT, missing keyword)
- x11-libs/cairo-1.12.14-r4::gentoo (masked by: test in RESTRICT)
- x11-libs/cairo-1.12.14-r3::gentoo (masked by: test in RESTRICT, ~amd64 keyword)
- x11-libs/cairo-1.12.14-r2::gentoo (masked by: test in RESTRICT, ~amd64 keyword)
- x11-libs/cairo-1.12.12-r1::gentoo (masked by: test in RESTRICT, ~amd64 keyword)
- x11-libs/cairo-1.12.12::gentoo (masked by: test in RESTRICT, ~amd64 keyword)
- x11-libs/cairo-1.12.10-r2::gentoo (masked by: test in RESTRICT, ~amd64 keyword)
- x11-libs/cairo-1.12.8::gentoo (masked by: test in RESTRICT, ~amd64 keyword)
- x11-libs/cairo-1.10.2-r3::gentoo (masked by: test in RESTRICT)

(dependency required by "dev-libs/gobject-introspection-1.32.1" [installed])
(dependency required by "sys-apps/systemd-204[introspection]" [ebuild])
(dependency required by "sys-auth/pambase-20120417-r2[systemd]" [installed])
(dependency required by "sys-libs/pam-1.1.6-r2" [installed])
(dependency required by "sys-apps/busybox-1.20.2[pam]" [installed])
(dependency required by "@system" [argument])


Keiner eine Idee?
uhai

noch etwas gefunden:
Code:
Schreibe Datenbankfile /var/cache/eix/portage.eix...
void update(const char*, CacheTable&, PortageSettings&, bool, const std::vector<RepoName>&, const std::vector<std::basic_string<char> >&, Statusline&): Datenbankfile '/var/cache/eix/portage.eix' nicht beschreibbar (mode = 'wb')
 * eix-update schlug fehl
 * Ben��tigte Zeit:
     1 Sekunden f��r syncen
     2 Sekunden f��r eix-update
     3 Sekunden insgesamt
(chroot) livecd / # ls -ali /var/cache/eix/portage.eix
2121 -rw-r--r-- 1 root root 6523363  4. Aug 09:54 /var/cache/eix/portage.eix


Abgesehen von den Umlauten, wie müssten die Rechte denn aussehen, das eix-sync als root die Datenbank beschreiben kann?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Sat Aug 10, 2013 8:29 am    Post subject: Reply with quote

ok, bin auf dem richtigen WEg. Leider war meine Sicherung von /usr defekt, so dass ich ein stage3-Archiv drüberbügeln musste. Jetzt noch revdep-rebuild und emerge auDN wworld, dann soltle die Kiste wieder laufen...

Danke für Eure Hilfe

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum