Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Fresh Install - No Ethernet - Intel 82579LM Adapter
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Tue Jul 09, 2013 7:38 pm    Post subject: [SOLVED] Fresh Install - No Ethernet - Intel 82579LM Adapter Reply with quote

Greetings all,

Can't seem to get networking started on a fresh install. I think I have the right device drivers based on my ethernet controller, listed below, and I've tried selecting a few others that closely match its description, rebuilt my kernel, but still get nothing.

Code:

Intel Corporation 82579LM Gigabit Network Connection (rev 04)


Code:

/etc/init.d/net.eno1 start


gets me...

Code:

Bringing up interface eno1
ERROR: interface eno1 does not exist
Ensure that you have loaded teh correct kernel module fro your hardware
ERROR: net.eno1 failed to start


ifconfig doesn't even show eno1. I've seen a few threads on the web where folks have a similar problem with the same ethernet controller, and tried following the suggestions there with no luck. Any help I can get with this would be highly appreciated.


Last edited by wguayan on Thu Jul 18, 2013 1:28 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32315
Location: 56N 3W

PostPosted: Tue Jul 09, 2013 7:45 pm    Post subject: Reply with quote

wguayan,

Google suggests that you need the e1000e driver.
Code:
<*>     Intel(R) PRO/1000 PCI-Express Gigabit Ethernet support (NEW)

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Tue Jul 09, 2013 10:18 pm    Post subject: Reply with quote

Hi NeddySeagoon,

I also saw that suggestion earlier and enabled that module but nothing. I'll take another look just in case and report back.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32315
Location: 56N 3W

PostPosted: Tue Jul 09, 2013 10:20 pm    Post subject: Reply with quote

wguayan,

Its worth trying e1000 too as support for some cards have been known to move between the two.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Wed Jul 10, 2013 3:14 am    Post subject: Reply with quote

NeddySeagoon,

Unfortunately none of the suggestions seem to work, even with the e1000 drivers. When I configured the system the network interface was eno1, and I then did:
Code:

# cd /etc/init.d
# ln -s net.lo net.eno1


I also installed dhcpcd and set up /etc/conf.d/net...

Code:

config_eno1="dhcp"


Is it possible that it changed from eno1 to eth0, and what command can I run to check that? Not only am I not connected, I don't see the interface at all if I run ifconfig. For example, on my arch box I run "ip link set eno1 up" to bring up the interface.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32315
Location: 56N 3W

PostPosted: Wed Jul 10, 2013 5:26 pm    Post subject: Reply with quote

wguayan,

Code:
ifconfig -a
lists all of your existing network interfaces. They need not be up.

As this is a new install, your interface is likely to be called anything but eth0 as you will have udev doing persistent renaming.
ethX is the kernel name, so that format cannot be reused.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Wed Jul 10, 2013 6:32 pm    Post subject: Reply with quote

ifconfig -a shows another interface named sit0, so I changed all the configuration files to reflect that interface, tried restarting the network, and got a new set of error messages, but eventually it times out. The error message that stands out is:

Code:

dhcpcd[3278]: unsupported interface type 308, falling back to ethernet
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32315
Location: 56N 3W

PostPosted: Wed Jul 10, 2013 6:47 pm    Post subject: Reply with quote

wguayan,

sit0 is an IPv6 over IPv4 tunnel end point, not a real interface. You get it for free if you have IPv6 selected in the kernel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Wed Jul 10, 2013 6:56 pm    Post subject: Reply with quote

NeddySeagoon- thanks for your help so far. I'm out of ideas, not sure what else to check for. I even tried rebuilding the kernel to work with most hardware and that didn't seem to help. I guess I'm off to research quite a bit more on the web in hopes of finding the culprit.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32315
Location: 56N 3W

PostPosted: Wed Jul 10, 2013 7:05 pm    Post subject: Reply with quote

wguayan,

Look at the Debian Hardware Compatibility List

If that doesn't help, post in Pappy's Kernel Seeds Part V.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Wed Jul 10, 2013 7:22 pm    Post subject: Reply with quote

Will do, Thanks again! I'll post back and mark the thread solved once I find a solution.
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5920
Location: Pomona, California.

PostPosted: Fri Jul 12, 2013 7:53 pm    Post subject: Reply with quote

Please post the following information: the results of cat /proc/cpuinfo and lspci -n as well as your current kernel .config (use pastebin), and your /etc/fstab file, and I'll check out your settings, and send back a kernel .config that should do the trick.

Cheers,
Pappy
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Fri Jul 12, 2013 11:38 pm    Post subject: Reply with quote

pappy_mcfae, thanks for taking a look at this for me. Here is the info you requested. I messed with the kernel quite a bit so it's probably not as clean as when it was freshly installed, but that's the latest configuration.

.config
http://pastebin.com/0dRT0vBJ

/proc/cpuinfo
Code:

processor   : 0
vendor_id   : GenuineIntel
cpu family   : 6
model      : 42
model name   : Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz
stepping   : 7
microcode   : 0x14
cpu MHz      : 3100.000
cache size   : 6144 KB
physical id   : 0
siblings   : 4
core id      : 0
cpu cores   : 4
apicid      : 0
initial apicid   : 0
fpu      : yes
fpu_exception   : yes
cpuid level   : 13
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips   : 6187.79
clflush size   : 64
cache_alignment   : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor   : 1
vendor_id   : GenuineIntel
cpu family   : 6
model      : 42
model name   : Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz
stepping   : 7
microcode   : 0x14
cpu MHz      : 3100.000
cache size   : 6144 KB
physical id   : 0
siblings   : 4
core id      : 1
cpu cores   : 4
apicid      : 2
initial apicid   : 2
fpu      : yes
fpu_exception   : yes
cpuid level   : 13
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips   : 6187.79
clflush size   : 64
cache_alignment   : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor   : 2
vendor_id   : GenuineIntel
cpu family   : 6
model      : 42
model name   : Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz
stepping   : 7
microcode   : 0x14
cpu MHz      : 3100.000
cache size   : 6144 KB
physical id   : 0
siblings   : 4
core id      : 2
cpu cores   : 4
apicid      : 4
initial apicid   : 4
fpu      : yes
fpu_exception   : yes
cpuid level   : 13
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips   : 6187.79
clflush size   : 64
cache_alignment   : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor   : 3
vendor_id   : GenuineIntel
cpu family   : 6
model      : 42
model name   : Intel(R) Core(TM) i5-2400 CPU @ 3.10GHz
stepping   : 7
microcode   : 0x14
cpu MHz      : 3100.000
cache size   : 6144 KB
physical id   : 0
siblings   : 4
core id      : 3
cpu cores   : 4
apicid      : 6
initial apicid   : 6
fpu      : yes
fpu_exception   : yes
cpuid level   : 13
wp      : yes
flags      : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips   : 6187.79
clflush size   : 64
cache_alignment   : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:


lspci -n
Code:

00:00.0 0600: 8086:0100 (rev 09)
00:01.0 0604: 8086:0101 (rev 09)
00:16.0 0780: 8086:1c3a (rev 04)
00:16.2 0101: 8086:1c3c (rev 04)
00:16.3 0700: 8086:1c3d (rev 04)
00:19.0 0200: 8086:1502 (rev 04)
00:1a.0 0c03: 8086:1c2d (rev 04)
00:1b.0 0403: 8086:1c20 (rev 04)
00:1c.0 0604: 8086:1c10 (rev b4)
00:1c.4 0604: 8086:1c18 (rev b4)
00:1c.6 0604: 8086:1c1c (rev b4)
00:1c.7 0604: 8086:1c1e (rev b4)
00:1d.0 0c03: 8086:1c26 (rev 04)
00:1e.0 0604: 8086:244e (rev a4)
00:1f.0 0601: 8086:1c4e (rev 04)
00:1f.2 0106: 8086:1c02 (rev 04)
00:1f.3 0c05: 8086:1c22 (rev 04)
01:00.0 0300: 1002:6779
01:00.1 0403: 1002:aa98


/etc/fstab
Code:

# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed); notail increases performance of ReiserFS (at the expense of storage
# efficiency).  It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs>         <mountpoint>   <type>      <opts>      <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/sda1      /boot      ext4      defaults,noatime   0 2
/dev/sda2      /      ext4      noatime         0 1
/dev/sda3      /var      ext4      defaults,noatime   0 2
/dev/sda4      /home      ext4      defaults      0 2
/dev/cdrom      /mnt/cdrom   auto      noauto,user      0 2

Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32315
Location: 56N 3W

PostPosted: Sat Jul 13, 2013 10:42 am    Post subject: Reply with quote

wguayan,

While you wait for pappys response, boot your box and run
Code:
uname -a


You will get something like
Code:
$ uname -a
Linux NeddySeagoon_SSD 3.9.7-gentoo #1 SMP PREEMPT Tue Jun 25 19:36:14 BST 2013 x86_64 AMD Phenom(tm) II X6 1090T Processor AuthenticAMD GNU/Linux


The important information here is
Code:
Tue Jun 25 19:36:14 BST 2013
which is the build time of the running kernel.
Look at yours and ask yourself is this really when I last built my kernel?

If not, you have probably messed up the kernel install by not mounting /boot.
Many users actually fix their issues but never know it because they are not running the kernel they think they are.
Old timers do it from time to time too :)
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Sat Jul 13, 2013 5:39 pm    Post subject: Reply with quote

Hi Neddy,

Well, I got some interesting results.

uname -a

Code:

Mon Jul 8 22:05:45 EDT 2013


But my kernel .config shows

Code:

Jul 11 15:08


There's also a .bak and a .old from Jul 10. So that's the problem?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32315
Location: 56N 3W

PostPosted: Sat Jul 13, 2013 5:55 pm    Post subject: Reply with quote

wguayan,

Mon Jul 8 22:05:45 EDT 2013 is when your running kernel was made.

Lets trace date stamps through the chain of files. Do ls -l on the following files:-

Code:
/usr/src/linux/.config
/usr/src/linux/arch/x86/boot/bzImage


Thats your kernel .config and the bzImage made from it, so normally[1] the bzImage would be newer than .config.

Code:
mount /boot
ls -l /boot
should show a kernel with the same timestamp as the bzImage above. Its not wrong to have several kernels there but the newest should be around Mon Jul 8 22:05:45 EDT 2013.
As you should be using your newest kernel.

[1] The exception is when you have added something as <M> in the .config file and run make modules && make modules_install.
Neither the bzImage, nor the kernels in /boot are changed but the .config file is more recent than the bzImage.

Its also worth looking in /boot when boot is not mounted. It should be empty.
If not, you have forgotten to mount /boot at some time when you updated your kernel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Sat Jul 13, 2013 10:07 pm    Post subject: Reply with quote

Hi Neddy,

Here's ls -l for all three files. Every time I've updated the kernel boot seems to have been mounted to sda1, I verified it a few times with lsblk. Question, when I originally set up the kernel, I did the manual configuration. The other option was running genkernel, if I recall correctly. However, I was running out of patience when I couldn't get networking started and ran genkernel thinking it would solve my problems. Is there any chance that made things worse?

I also umounted /boot and ls shows no files, so at least that part looks good.

/usr/src/linux/.config
Code:

-rw-r--r-- 1 root root 95296 Jul 11 15:08



/usr/src/linux/arch/x86/boot/bzImage
Code:

-rw-r--r-- 1 root root 3500000 Jul 11 15:10



/boot
Code:

total 11727
lrwxrwxrwx 1 root root       1 Jul  9 00:16 boot -> .
drwxr-xr-x 2 root root    1024 Jul  9 00:45 grub
-rw-r--r-- 1 root root 1271596 Jul  8 22:48 initramfs-genkernel-x86_64-3.8.13-gentoo
-rw-r--r-- 1 root root 5307040 Jul  8 22:51 kernel-3.8.13-gentoo
-rw-r--r-- 1 root root 3436512 Jul 10 03:46 kernel-genkernel-x86_64-3.8.13-gentoo
drwx------ 2 root root   12288 Jul  8 17:12 lost+found
-rw-r--r-- 1 root root 1979238 Jul 10 03:46 System.map-genkernel-x86_64-3.8.13-gentoo

Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32315
Location: 56N 3W

PostPosted: Sat Jul 13, 2013 10:35 pm    Post subject: Reply with quote

wguayan,


ls -l /boot:
-rw-r--r-- 1 root root 1271596 Jul  8 22:48 initramfs-genkernel-x86_64-3.8.13-gentoo
-rw-r--r-- 1 root root 5307040 Jul  8 22:51 kernel-3.8.13-gentoo
-rw-r--r-- 1 root root 3436512 Jul 10 03:46 kernel-genkernel-x86_64-3.8.13-gentoo

And

uname -a:
Mon Jul 8 22:05:45 EDT 2013
we can be fairly sure that Your July 10 genkernel kernel is not being loaded.

The datestamps on the initramfs and genkernel kernel sould be within a few minutes of each other too.

What do you have in /boot/grub/grub.conf ?
I suspect the file was never updated to load the genkernel kernel and initramfs.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Sat Jul 13, 2013 11:12 pm    Post subject: Reply with quote

Neddy,

grub.conf

Code:

deault 0
timeout 30

title Gentoo Linux 3.8.13
root (hd0,0)
kernel /boot/kernel-3.8.13-gentoo real_root=/dev/sda2
initrrd /boot/initramfs-genkernel-x86_64-3.8.13-gentoo


real_root should be sda2 right? Or the actual boot partition? I'm feeling pretty dumb right about now.


Last edited by wguayan on Sun Jul 14, 2013 2:35 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32315
Location: 56N 3W

PostPosted: Sun Jul 14, 2013 12:04 am    Post subject: Reply with quote

wguayan,

real_root is where the kernels root filesystem is.

The handbook install uses
/dev/sda1 /boot
/dev/sda2 <swap>
/dev/sda3 / (root), so the handbook would use real_root=/dev/sda3 You put your root in there if you have changed it away from /dev/sda3

The line root (hd0,0) is grubspeak for the boot partition.

grub.cfg ??
Its grub.cfg for grub2 and grub.conf for grub1. The name matters.
The format you provided is for grub1.

You may have several boot stanazas if you have several kernels.
A boot stanza is a section

title
root
kernel
initrd (optional)
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Sun Jul 14, 2013 1:12 am    Post subject: Reply with quote

Hey Neddy,

Yeah, I just realized that I'm using grub 1, which I thought was depricated. My arch system is running grub 2. Okay, so real_root is correct for me as my root partition is sda2 and boot is sda1. When I get networking sorted out I'd like to upgrade to grub 2. The grub configuration I shared only has one boot stanza. I'm still not completely clear on why make menuconfig is not using the latest kernel.

****EDIT***

grub.cfg in the previous post was a typo. It is indeed grub.conf that I am using.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32315
Location: 56N 3W

PostPosted: Sun Jul 14, 2013 10:24 am    Post subject: Reply with quote

wguayan,

make menuconfig is supplied with the kernel.
Which kernel you configure depends on the setting of the /usr/src/linux symbolic link, if you use cd /usr/src/linux to get there, or whatever cd /usr/src/<kernel-version> you do.

None of the kernel make commands configure your boot loader. That step is always for you to do.

grub1 is in Gentoo stable, grub2 is in Gentoo testing. You can keyword it if you want it

My view is that grub2 came too late for the PC. With the move to (U)EFI bios, no boot loader is needed. The kernel is an EFI compliant program.
grub2 has fixed some of the inconviences of grub1 but at the cost of greatly increased complexity.
I don't much care which bootloader I use as it only runs for a few seconds once per kernel update, so I just want it to work when its needed.
Over the years, I've used loadlin, lilo, grub and PXE booting (for diskless). I suppose I will need to learn UEFI too but I plan to skip grub2
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Sun Jul 14, 2013 12:45 pm    Post subject: Reply with quote

Neddy,

the symbolic link linux points to linux-3.8.13-gentoo.

I have a UEFI mobo, but when I set up gentoo I didn't set up a UEFI partition, so maybe I'll just keep grub 1. If I get gentoo working correctly and decide to keep it as my main distro I may do a UEFI partition in the future, but right now it's more of a learning experience for me :-)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32315
Location: 56N 3W

PostPosted: Sun Jul 14, 2013 1:02 pm    Post subject: Reply with quote

wguayan

Your /boot lists two kernels
Code:
-rw-r--r-- 1 root root 5307040 Jul  8 22:51 kernel-3.8.13-gentoo
-rw-r--r-- 1 root root 3436512 Jul 10 03:46 kernel-genkernel-x86_64-3.8.13-gentoo


grub.conf says
Code:
kernel /boot/kernel-3.8.13-gentoo real_root=/dev/sda2

Which is the July 8 kernel, not your genkernel kernel.

Add the following to the end of grub.conf

Code:
title Gentoo Linux 3.8.13 by Genkernel
root (hd0,0)
kernel /boot/kernel-genkernel-x86_64-3.8.13-gentoo real_root=/dev/sda2
initrrd /boot/initramfs-genkernel-x86_64-3.8.13-gentoo


This is a boot stanza for your genkernel kernel built on July 10. It might even work but the differing dates on the genkernel and initrd may mean that the kernel won't like the initrd.

Anyway, the grub menu will now list two kernels. Choose Gentoo Linux 3.8.13 by Genkernel to test.
Run uname -a if it boots to make sure you have the July 10 kernel.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
wguayan
n00b
n00b


Joined: 09 Jul 2013
Posts: 25

PostPosted: Sun Jul 14, 2013 1:34 pm    Post subject: Reply with quote

Neddy,

Since generating kernel-genkernel-x86_64-3.8.13-gentoo didn't help, last night I made a few changes so now my boot shows

Code:

kernel-3.8.13-gentoo
initrrd /boot/initramfs-genkernel-x86_64-3.8.13-gentoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum