Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
blackbox and x windows
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
tnagpal
n00b
n00b


Joined: 23 Apr 2002
Posts: 11

PostPosted: Wed Apr 24, 2002 9:13 pm    Post subject: blackbox and x windows Reply with quote

I get an error stating:

BaseDisplay::BaseDisplay: connection to X server failed

when I try to use fluxbox or blackbox. Anyone know how to fix it?
Back to top
View user's profile Send private message
Jeevz
Bodhisattva
Bodhisattva


Joined: 15 Apr 2002
Posts: 195
Location: Boston, MA

PostPosted: Wed Apr 24, 2002 9:19 pm    Post subject: Reply with quote

How are you trying to start BlackBox? What is the command you type?
Back to top
View user's profile Send private message
tnagpal
n00b
n00b


Joined: 23 Apr 2002
Posts: 11

PostPosted: Wed Apr 24, 2002 9:33 pm    Post subject: Reply with quote

Tried just blackbox (now actually trying "fluxbox") Same error with startblackbox.
Back to top
View user's profile Send private message
freefall
Tux's lil' helper
Tux's lil' helper


Joined: 13 Apr 2002
Posts: 89

PostPosted: Wed Apr 24, 2002 10:43 pm    Post subject: Reply with quote

Add blackbox to your ~/.xinitrc file and start X with 'startx'.
Back to top
View user's profile Send private message
tnagpal
n00b
n00b


Joined: 23 Apr 2002
Posts: 11

PostPosted: Wed Apr 24, 2002 10:52 pm    Post subject: Can't find it Reply with quote

Sorry, I can't "find" .xinitrc anywhere...
Back to top
View user's profile Send private message
Guest






PostPosted: Wed Apr 24, 2002 11:15 pm    Post subject: Re: Can't find it Reply with quote

tnagpal wrote:
Sorry, I can't "find" .xinitrc anywhere...

Howabout trying this:
Code:
echo "exec blackbox" > ~/.xinitrc
Back to top
tnagpal
n00b
n00b


Joined: 23 Apr 2002
Posts: 11

PostPosted: Wed Apr 24, 2002 11:19 pm    Post subject: Reply with quote

After trying startx I get the following message

...
Could not init font path element /usr/X11R6/lib/X11/fonts/Speedo/, removing from list!
/home/name/.xinitrc: exec: blackbox: not found

waiting for X server to shut down
...

Still no luck...
Back to top
View user's profile Send private message
bob_t
n00b
n00b


Joined: 18 Apr 2002
Posts: 23
Location: ithaca, ny, usa

PostPosted: Thu Apr 25, 2002 12:23 am    Post subject: Reply with quote

tnagpal wrote:

/home/name/.xinitrc: exec: blackbox: not found.


What does the output of "which blackbox" give?
Back to top
View user's profile Send private message
tnagpal
n00b
n00b


Joined: 23 Apr 2002
Posts: 11

PostPosted: Thu Apr 25, 2002 12:42 am    Post subject: Which fluxbox Reply with quote

I typed "which fluxbox"

I got

/usr/bin/fluxbox
Back to top
View user's profile Send private message
Jeevz
Bodhisattva
Bodhisattva


Joined: 15 Apr 2002
Posts: 195
Location: Boston, MA

PostPosted: Thu Apr 25, 2002 2:47 pm    Post subject: Reply with quote

Replace blackbox with fluxbox in your .xinitrc
Back to top
View user's profile Send private message
Jeevz
Bodhisattva
Bodhisattva


Joined: 15 Apr 2002
Posts: 195
Location: Boston, MA

PostPosted: Thu Apr 25, 2002 2:49 pm    Post subject: Reply with quote

In other words type this:
Code:
echo "exec fluxbox" >| ~/.xinitrc


Then try starting up X with the command: startx
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum