Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
huge problem with x11 libs and ABI_X86
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 346
Location: Wroclaw, Poland

PostPosted: Mon Jul 08, 2013 9:53 am    Post subject: huge problem with x11 libs and ABI_X86 Reply with quote

So I tried updating world today.

Code:
$ emerge world -uDp

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-util/bsdiff-4.3-r3 [4.3-r2]
[ebuild     U  ] net-misc/dhcpcd-6.0.2 [5.99.7-r1]
[ebuild   R    ] x11-proto/xproto-7.0.24  ABI_X86="32*"
[ebuild   R    ] x11-proto/xextproto-7.2.1-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-proto/inputproto-2.3  ABI_X86="32*"
[ebuild   R    ] x11-proto/renderproto-0.11.1-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-proto/xf86vidmodeproto-2.3.1-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-proto/scrnsaverproto-1.2.2-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-proto/randrproto-1.4.0-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-proto/kbproto-1.0.6-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-proto/xf86bigfontproto-1.2.0-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-libs/libXdmcp-1.1.1-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] dev-libs/libpthread-stubs-0.3-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-libs/libICE-1.0.8-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-proto/fixesproto-5.0-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-libs/libXau-1.0.8  ABI_X86="32*"
[ebuild     U  ] media-libs/libmediainfo-0.7.64 [0.7.63]
[ebuild   R    ] x11-proto/xcb-proto-1.8-r3  ABI_X86="32*"
[ebuild   R    ] x11-libs/libxcb-1.9.1  ABI_X86="32*"
[ebuild     U  ] dev-python/pytools-2013.5.3 [2013.5]
[ebuild     U  ] net-misc/youtube-dl-2013.07.08 [2013.07.05]
[ebuild   R    ] x11-libs/libX11-1.6.0  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXext-1.3.2  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXrender-0.9.8  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXfixes-5.0.1  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXScrnSaver-1.2.2-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-libs/libXrandr-1.4.1  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXcursor-1.1.14  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXxf86vm-1.1.3  ABI_X86="32*"
[ebuild   R    ] x11-libs/libXi-1.7.2  ABI_X86="32*"
[ebuild     U *] sys-apps/portage-2.2.0_alpha187 [2.2.0_alpha186]
[ebuild  NS    ] sys-kernel/pf-sources-3.10.0 [3.9.5] USE="symlink -build"
[ebuild   R    ] x11-libs/libSM-1.2.1-r1  ABI_X86="32* (-x32)"
[ebuild   R    ] x11-libs/libXt-1.1.4  ABI_X86="32*"
[ebuild     U  ] app-text/dvipdfmx-20110311-r1 [20110311]
[ebuild  NS    ] media-libs/libsdl-2.0.0_pre7353 [1.2.15-r4] USE="X alsa asm mmx opengl pulseaudio sse sse2 threads video xcursor xinput xscreensaver -3dnow (-altivec) (-aqua) -fusionsound -gles -nas -oss -static-libs -tslib -xinerama -xrandr -xvidmode" ABI_X86="32 (64) (-x32)"
[ebuild     U  ] x11-libs/gtk+-2.24.20 [2.24.19]
[ebuild     U  ] app-text/acroread-9.5.5 [9.5.4]
[ebuild     U  ] media-video/mediainfo-0.7.64 [0.7.63]
[ebuild     U  ] dev-python/pyopencl-2013.1 [2012.1]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/libX11:0

  (x11-libs/libX11-1.6.0::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXrandr-1.4.1::gentoo, ebuild scheduled for merge)
    >=x11-libs/libX11-1.4.99.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXi-1.7.2::gentoo, ebuild scheduled for merge)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXfixes-5.0.1::gentoo, ebuild scheduled for merge)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXScrnSaver-1.2.2-r1::gentoo, ebuild scheduled for merge)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXxf86vm-1.1.3::gentoo, ebuild scheduled for merge)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXrender-0.9.8::gentoo, ebuild scheduled for merge)
    >=x11-libs/libX11-1.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXext-1.3.2::gentoo, ebuild scheduled for merge)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXt-1.1.4::gentoo, ebuild scheduled for merge)
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXcursor-1.1.14::gentoo, ebuild scheduled for merge)

  (x11-libs/libX11-1.6.0::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXext:0

  (x11-libs/libXext-1.3.2::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXScrnSaver-1.2.2-r1::gentoo, ebuild scheduled for merge)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXxf86vm-1.1.3::gentoo, ebuild scheduled for merge)
    >=x11-libs/libXext-1.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXi-1.7.2::gentoo, ebuild scheduled for merge)
    x11-libs/libXext[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXrandr-1.4.1::gentoo, ebuild scheduled for merge)

  (x11-libs/libXext-1.3.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-proto/xextproto:0

  (x11-proto/xextproto-7.2.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-proto/xextproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXfixes-5.0.1::gentoo, ebuild scheduled for merge)
    x11-proto/xextproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)
    x11-proto/xextproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXrandr-1.4.1::gentoo, ebuild scheduled for merge)
    x11-proto/xextproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libX11-1.6.0::gentoo, ebuild scheduled for merge)
    >=x11-proto/xextproto-7.0.99.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-proto/fixesproto-5.0-r1::gentoo, ebuild scheduled for merge)
    x11-proto/xextproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXxf86vm-1.1.3::gentoo, ebuild scheduled for merge)
    >=x11-proto/xextproto-7.0.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXi-1.7.2::gentoo, ebuild scheduled for merge)
    >=x11-proto/xextproto-7.1.99[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXext-1.3.2::gentoo, ebuild scheduled for merge)

  (x11-proto/xextproto-7.2.1-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXrender:0

  (x11-libs/libXrender-0.9.8::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXrender[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)
    >=x11-libs/libXrender-0.8.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXcursor-1.1.14::gentoo, ebuild scheduled for merge)
    x11-libs/libXrender[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXrandr-1.4.1::gentoo, ebuild scheduled for merge)

  (x11-libs/libXrender-0.9.8::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXt:0

  (x11-libs/libXt-1.1.4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXt-1.1.4::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXt[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)

x11-proto/xproto:0

  (x11-proto/xproto-7.0.24::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-proto/xproto-7.0.24::gentoo, ebuild scheduled for merge) pulled in by
    x11-proto/xproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)
    >=x11-proto/xproto-7.0.17[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libX11-1.6.0::gentoo, ebuild scheduled for merge)
    x11-proto/xproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXfixes-5.0.1::gentoo, ebuild scheduled for merge)
    x11-proto/xproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libSM-1.2.1-r1::gentoo, ebuild scheduled for merge)
    x11-proto/xproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXxf86vm-1.1.3::gentoo, ebuild scheduled for merge)
    x11-proto/xproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXrender-0.9.8::gentoo, ebuild scheduled for merge)
    >=x11-proto/xproto-7.0.13[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXi-1.7.2::gentoo, ebuild scheduled for merge)
    x11-proto/xproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXt-1.1.4::gentoo, ebuild scheduled for merge)
    x11-proto/xproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXau-1.0.8::gentoo, ebuild scheduled for merge)
    x11-proto/xproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libICE-1.0.8-r1::gentoo, ebuild scheduled for merge)

x11-libs/libXScrnSaver:0

  (x11-libs/libXScrnSaver-1.2.2-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXScrnSaver-1.2.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXScrnSaver[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)

x11-proto/inputproto:0

  (x11-proto/inputproto-2.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-proto/inputproto-2.3::gentoo, ebuild scheduled for merge) pulled in by
    x11-proto/inputproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)
    x11-proto/inputproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libX11-1.6.0::gentoo, ebuild scheduled for merge)
    >=x11-proto/inputproto-2.2.99.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXi-1.7.2::gentoo, ebuild scheduled for merge)

x11-libs/libXrandr:0

  (x11-libs/libXrandr-1.4.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXrandr-1.4.1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXrandr[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)

x11-libs/libXcursor:0

  (x11-libs/libXcursor-1.1.14::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXcursor-1.1.14::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXcursor[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)

x11-proto/xf86vidmodeproto:0

  (x11-proto/xf86vidmodeproto-2.3.1-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-proto/xf86vidmodeproto-2.3.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/xf86vidmodeproto-2.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXxf86vm-1.1.3::gentoo, ebuild scheduled for merge)
    x11-proto/xf86vidmodeproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)

x11-proto/scrnsaverproto:0

  (x11-proto/scrnsaverproto-1.2.2-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-proto/scrnsaverproto-1.2.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/scrnsaverproto-1.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXScrnSaver-1.2.2-r1::gentoo, ebuild scheduled for merge)
    x11-proto/scrnsaverproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)

x11-libs/libXxf86vm:0

  (x11-libs/libXxf86vm-1.1.3::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXxf86vm[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)

  (x11-libs/libXxf86vm-1.1.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXi:0

  (x11-libs/libXi-1.7.2::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXi-1.7.2::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXi[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)

x11-proto/renderproto:0

  (x11-proto/renderproto-0.11.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/renderproto-0.9.3[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXrender-0.9.8::gentoo, ebuild scheduled for merge)
    x11-proto/renderproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXrandr-1.4.1::gentoo, ebuild scheduled for merge)
    x11-proto/renderproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)

  (x11-proto/renderproto-0.11.1-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-proto/randrproto:0

  (x11-proto/randrproto-1.4.0-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-proto/randrproto-1.4.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-proto/randrproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXrandr-1.4.1::gentoo, ebuild scheduled for merge)
    x11-proto/randrproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)

x11-libs/libXfixes:0

  (x11-libs/libXfixes-5.0.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXfixes-5.0.1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libXfixes-5[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXi-1.7.2::gentoo, ebuild scheduled for merge)
    x11-libs/libXfixes[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXcursor-1.1.14::gentoo, ebuild scheduled for merge)

x11-proto/fixesproto:0

  (x11-proto/fixesproto-5.0-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-proto/fixesproto-5.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/fixesproto-5[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXfixes-5.0.1::gentoo, ebuild scheduled for merge)

x11-proto/kbproto:0

  (x11-proto/kbproto-1.0.6-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-proto/kbproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libX11-1.6.0::gentoo, ebuild scheduled for merge)
    x11-proto/kbproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXt-1.1.4::gentoo, ebuild scheduled for merge)

  (x11-proto/kbproto-1.0.6-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libSM:0

  (x11-libs/libSM-1.2.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libSM[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXt-1.1.4::gentoo, ebuild scheduled for merge)

  (x11-libs/libSM-1.2.1-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libICE:0

  (x11-libs/libICE-1.0.8-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libICE-1.0.8-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libICE-1.0.5[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libSM-1.2.1-r1::gentoo, ebuild scheduled for merge)
    x11-libs/libICE[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libXt-1.1.4::gentoo, ebuild scheduled for merge)

x11-libs/libxcb:0

  (x11-libs/libxcb-1.9.1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libxcb-1.9.1::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/libxcb-1.8.1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libX11-1.6.0::gentoo, ebuild scheduled for merge)

x11-proto/xf86bigfontproto:0

  (x11-proto/xf86bigfontproto-1.2.0-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-proto/xf86bigfontproto-1.2.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-proto/xf86bigfontproto[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libX11-1.6.0::gentoo, ebuild scheduled for merge)

x11-proto/xcb-proto:0

  (x11-proto/xcb-proto-1.8-r3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-proto/xcb-proto-1.7-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,python_targets_python2_6(-)?,python_targets_python2_7(-)?,python_targets_python3_1(-)?,python_targets_python3_2(-)?,python_targets_python3_3(-)?,python_single_target_python2_6(+)?,python_single_target_python2_7(+)?,python_single_target_python3_1(+)?,python_single_target_python3_2(+)?,python_single_target_python3_3(+)?] required by (x11-libs/libxcb-1.9.1::gentoo, ebuild scheduled for merge)

  (x11-proto/xcb-proto-1.8-r3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/libXdmcp:0

  (x11-libs/libXdmcp-1.1.1-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXdmcp-1.1.1-r1::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXdmcp[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libxcb-1.9.1::gentoo, ebuild scheduled for merge)

x11-libs/libXau:0

  (x11-libs/libXau-1.0.8::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/libXau-1.0.8::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libXau[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libxcb-1.9.1::gentoo, ebuild scheduled for merge)

dev-libs/libpthread-stubs:0

  (dev-libs/libpthread-stubs-0.3-r1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libpthread-stubs[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (x11-libs/libxcb-1.9.1::gentoo, ebuild scheduled for merge)

  (dev-libs/libpthread-stubs-0.3-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.


That's after using --autounmask-write.

Adding -N gives me an error message 1200 line long: http://pastebin.com/NZ93ZtGh

Can anyone make sense of this?

Code:
Portage 2.2.0_alpha186 (default/linux/amd64/13.0/desktop, gcc-4.8.1, glibc-2.17, 3.9.5-pf x86_64)
=================================================================
System uname: Linux-3.9.5-pf-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9450_@_2.66GHz-with-gentoo-2.2
KiB Mem:     4044520 total,   1174740 free
KiB Swap:    4095996 total,   4080344 free
Timestamp of tree: Mon, 08 Jul 2013 09:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5, 3.2.5-r1, 3.3.2-r1
dev-util/cmake:           2.8.11.1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.4_p6-r1, 1.9.6-r3, 1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.6.4, 4.7.3, 4.8.1
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo multimedia sunrise steam-overlay kde roslin dupa
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going --quiet-build=n"
FCFLAGS="-O2 -march=native -pipe -ggdb"
FEATURES="assume-digests binpkg-logs compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles installsources merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=native -pipe -ggdb"
GENTOO_MIRRORS="http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/"
LANG="pl_PL.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/multimedia /usr/local/portage/layman/sunrise /usr/local/portage/layman/steam /usr/local/portage/layman/kde /usr/local/portage/layman/roslin /usr/local/portage/moje"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac aalib acl acpi adobe-cff alsa amd64 amr amrnb amrwb apng async audiofile automount avahi avresample bash-completion berkdb bfq bineditor bluetooth bluray branding bzip2 c++0x cairo cdda cddb cdparanoia cdr chdir clang cli consolekit cracklib crypt css cuda cups curl cxx dbus dirac disk-partition divx djvu dri dts dvd dvdr ebook editor emboss emovix enca encode exchange exif faac faad fam fat ffmpeg fftw firefox firefox3 flac fontconfig fortran g3dvl gd gdbm geoip gif glitz gmedia gnuplot gphoto2 gpm gtk hddtemp iconv id3 id3tag imagemagick inotify iostats ipod jpeg kde kde4 kdehiddenvisibility kipi kompare kpathsea kqemu ladspa lame laptop lastfm latex lcms libass libcaca libnotify libsamplerate lm_sensors lto lzma lzo mad matroska midi mjpeg mmap mmx mmxext mng modules moodbar mp3 mp3tunes mp4 mpeg mplayer mtp mudflap multilib musicbrainz ncurses networkmanager nls nptl nsplugin ntfs nvidia ogg okteta openal opencl opencore-amr opengl openmp optimized-qmake pam pango pch pcre pdf plasma png policykit portage ppds private-headers pulseaudio qt3 qt3support qt4 qthelp raster readline realmedia roe scanner schroedinger sdl secure-delete semantic-desktop sensord session shaders slang sndfile solver soundtouch sourceview sparse spell sse sse2 sse3 sse4 sse41 sse4_1 sse4a ssl ssse3 startup-notification steamruntime suid svg swat symlink syslog tcpd theora threads tiff truetype udev udisks unicode upnp upower usb vaapi vamp vcd vdpau vorbis wifi wmf wmp wxwidgets wxwindows x264 xcb xcomposite xml xscreensaver xv xvid xvmc zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="x86_64 i386" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Title edited for guidelines compliance. peter4, please keep it G-rated outside of OTW. — JRG
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1691
Location: Berlin, Germany

PostPosted: Mon Jul 08, 2013 5:15 pm    Post subject: Reply with quote

Code:
[ebuild   R    ] x11-proto/xproto-7.0.24  ABI_X86="32*"
It appears that recently, ABI_X86=32 got enabled on your system. In addition, you unmasked some package(s) (fontconfig?) that need emul-linux-x86-xlibs-20130224-r1 which you didn't unmask.
Back to top
View user's profile Send private message
Timbers2k
Apprentice
Apprentice


Joined: 03 Oct 2003
Posts: 215

PostPosted: Mon Jul 08, 2013 6:23 pm    Post subject: Reply with quote

I'm getting the same thing. The only thing I did was a sync, then all hell broke loose.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1691
Location: Berlin, Germany

PostPosted: Mon Jul 08, 2013 7:52 pm    Post subject: Reply with quote

Code:
  (x11-libs/libX11-1.6.0::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/libX11[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?] required by (media-libs/libsdl-2.0.0_pre7353::steam-overlay, ebuild scheduled for merge)
So we discussed this on IRC and hasufell pointed out that you use some packages from an overlay. It would probably be good to remove all overlay packages and also check your package.unmask before trying again.
Back to top
View user's profile Send private message
hasufell
Developer
Developer


Joined: 29 Oct 2011
Posts: 257

PostPosted: Mon Jul 08, 2013 8:03 pm    Post subject: Reply with quote

a) don't use steam-overlay since it's not needed for installing or playing on steam
b) if you use steam-overlay, mask ALL packages from that repository via package.mask: */*::steam-overlay
and only unmask the ones you actually need
c) do the same for gamerlay if you happen to use it
d) do NOT set STEAM_RUNTIME=0
Back to top
View user's profile Send private message
peter4
Guru
Guru


Joined: 19 Jul 2005
Posts: 346
Location: Wroclaw, Poland

PostPosted: Mon Jul 08, 2013 9:46 pm    Post subject: Reply with quote

Thank you, masking everything from steam-overlay solved the block.

EDIT: adding =app-emulation/emul-linux-x86-xlibs-20130224-r1 to package.unmask also seems to solve this issue.
Back to top
View user's profile Send private message
azp
Guru
Guru


Joined: 16 Nov 2003
Posts: 354
Location: Stockholm, Sweden

PostPosted: Sat Jul 20, 2013 6:27 pm    Post subject: Reply with quote

hasufell wrote:
a) don't use steam-overlay since it's not needed for installing or playing on steam
b) if you use steam-overlay, mask ALL packages from that repository via package.mask: */*::steam-overlay
and only unmask the ones you actually need
c) do the same for gamerlay if you happen to use it
d) do NOT set STEAM_RUNTIME=0


With the first statement, do you mean we should download the client from the homepage instead of using portage? Otherwise, is there a less experimental way of installing steam via portage, that doesn't depend on steam-overlay och gamerlay? I'm seeing the same issues as peter4, and it's truly painful :)
_________________
Weeks of coding can save you hours of planning.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5743
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Aug 25, 2013 7:04 pm    Post subject: Reply with quote

hasufell wrote:
a) don't use steam-overlay since it's not needed for installing or playing on steam
b) if you use steam-overlay, mask ALL packages from that repository via package.mask: */*::steam-overlay
and only unmask the ones you actually need



that suddenly made things a whole lot easier :D

thank you :)

hasufell wrote:

c) do the same for gamerlay if you happen to use it


not using that overlay - but good to know, I'll avoid using it for now


hasufell wrote:

d) do NOT set STEAM_RUNTIME=0


doesn't work anyway for me ;)

it only works with STEAM_RUNTIME=1 :mrgreen:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3979
Location: Irgendwo im Nirgendwo

PostPosted: Tue Aug 27, 2013 5:54 am    Post subject: Reply with quote

I get a similar issue with lcms blocking update of tiff (which seems to be critical as it's a security update):
Code:
media-libs/tiff:0

  (media-libs/tiff-4.0.3-r4::gentoo, ebuild scheduled for merge) conflicts with
    media-libs/tiff:0=[abi_x86_64(-),abi_x86_64(-)] required by (media-libs/lcms-2.5-r1::gentoo, installed)
  (media-libs/tiff-4.0.3-r4::gentoo, ebuild scheduled for merge) conflicts with
    media-libs/tiff:0/0=[abi_x86_64(-),abi_x86_64(-)] required by (media-libs/lcms-2.5-r1::gentoo, installed)

As you can see there is no overlay involved, just plain main tree.
Code:
Portage 2.2.1 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.10.6-gentoo x86_64)
=================================================================
System uname: Linux-3.10.6-gentoo-x86_64-Intel-R-_Core-TM-_i3-2350M_CPU_@_2.30GHz-with-gentoo-2.2
KiB Mem:     3890984 total,    353512 free
KiB Swap:    5242876 total,   5176796 free
Timestamp of tree: Tue, 27 Aug 2013 04:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
distcc 3.1 x86_64-pc-linux-gnu [enabled]
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1::<unknown repository>
dev-lang/python:          2.7.5-r2, 3.2.5-r2
dev-util/ccache:          3.1.9::<unknown repository>
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28::<unknown repository>
sys-apps/baselayout:      2.2::<unknown repository>
sys-apps/openrc:          0.12
sys-apps/sandbox:         2.6-r1::<unknown repository>
sys-devel/autoconf:       2.13::<unknown repository>, 2.69::<unknown repository>
sys-devel/automake:       1.11.6::<unknown repository>, 1.12.6::<unknown repository>
sys-devel/binutils:       2.23.1::<unknown repository>
sys-devel/gcc:            4.7.3::<unknown repository>
sys-devel/gcc-config:     1.7.3::<unknown repository>
sys-devel/libtool:        2.4-r1::<unknown repository>
sys-devel/make:           3.82-r4::<unknown repository>
sys-kernel/linux-headers: 3.10::<unknown repository> (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo aidecoe ff2000 kde local
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7-avx -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7-avx -O2 -pipe -ggdb"
DISTDIR="/var/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distcc distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j15"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/repositories/gentoo"
PORTDIR_OVERLAY="/var/repositories/aidecoe /var/repositories/ff2000 /var/repositories/kde /var/repositories/local"
USE="2cpi X a52 aac acl acpi alsa amd64 apm berkdb branding bzip2 cairo cdda cdr cli cracklib crypt cups cxx dbus directfb dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm iconv infinality introspection ipv6 jpeg jpeg2k kipi lcdfilter lcms mad mmx mmxext mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp openrc pam pango pcre pdf png ppds qt3support qt4 readline sdl session spell sse sse2 sse3 sse4 sse4_1 ssl ssse3 svg tcpd theora threads tiff truetype udev udisks unicode upower usb vaapi vorbis vpx x264 xcb xcomposite xml xscreensaver xv xvid zlib zsh-completion" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de de_DE" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby20" SANE_BACKENDS="epson epson2" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON

_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 5743
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Aug 28, 2013 10:52 pm    Post subject: Reply with quote

nowadays updating the system with portage >=2.2* seems to be pretty tricky due to handling of reverse dependencies

it usually comes down to circular dependencies & updates

so the only solution (at least for me) with a running system was to update via

--nodeps -1

switches

or to (like in good 'ol times) leave some USE-flags (and thus dependencies) out and then re-emerging the packages
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.3.0-r2
2.6.37.2_plus_v1: BFS, CFS,THP,compaction, zcache or TOI
Hardcore Linux user since 2004 :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum