Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Wireshark starts slowly!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
oniichan
n00b
n00b


Joined: 15 Jun 2012
Posts: 29

PostPosted: Sat Jul 06, 2013 10:51 am    Post subject: Wireshark starts slowly! Reply with quote

Hello!
I emerged wireshark, and upon starting it, it starts "registering dissector X" and then a few minutes later, and later, "Handling of dissector X".
This takes a long time, and on the very same machine running another Linux-based OS with binary package managment, this is instant.
I'm running on a T7700 with 2GB of RAM, using the noveau drivers.
USE="apng jpeg xft imlib2 imlib png acpi qt4 qt3support qt" if that's any help.
I would really like the wireshark startup procedure to be faster, as waiting several minutes really is a pain in the neck.
Back to top
View user's profile Send private message
geeksheik
n00b
n00b


Joined: 07 Sep 2003
Posts: 70

PostPosted: Tue Jul 16, 2013 1:53 pm    Post subject: Reply with quote

...you could try starting it on the command line with strace:

Quote:
strace wireshark


This will show you the specific system call(s) that are hanging or being called in some over-enthusiastic loop.

Note that this produces a huge amount of output and will slow things down further, but it might help you isolate the issue.

You might need to emerge strace if you don't already have it installed.

Good luck.
Back to top
View user's profile Send private message
oniichan
n00b
n00b


Joined: 15 Jun 2012
Posts: 29

PostPosted: Wed Jul 31, 2013 6:58 pm    Post subject: Reply with quote

geeksheik wrote:
...you could try starting it on the command line with strace:

Quote:
strace wireshark


This will show you the specific system call(s) that are hanging or being called in some over-enthusiastic loop.

Note that this produces a huge amount of output and will slow things down further, but it might help you isolate the issue.

You might need to emerge strace if you don't already have it installed.

Good luck.


http://p.pomf.se/930
This is some of the output it throws me - noticing recvfrom ... (Resource temporarily unavailable) which I think might be what's slowing it down. I have no idea what this means, though...
Back to top
View user's profile Send private message
Navar
Guru
Guru


Joined: 20 Aug 2012
Posts: 321

PostPosted: Fri Sep 27, 2013 3:31 am    Post subject: Reply with quote

Greetings oniichan,

I can reproduce your issue with net-analyzer/wireshark -gtk2 -gtk3 (QT4 build) use flags versus net-analyzer/wireshark -qt4 -gtk3 (gtk2 build) which starts immediately. This is an x86 keyworded build in a Gnome2 desktop environment with qt4 and qt3support in global use flags for certain apps.

First time I've encountered it because I had not been forced to exclusively take a QT versus GTK+ option on this particular app in the past. Going by the useflag description on qt4 for wireshark, "Build the wireshark executable with an experimental Qt UI instead of GTK+", I've stopped digging for a particular bug report. After a few minutes of waiting for the many dissectors to load, the interface is also lacking the full functionality they offer in their regular GTK+ setup, so you might want to consider rebuilding with GTK+ support for now until this has had more time to mature.

I have a newer keyworded ~x86 build with KDE 4.11 going. I may try wireshark QT4 there and see if anything improves but I'd expect the same results.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum