Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
eth0 does not exist even if module r8168 is loaded
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
wobbol
n00b
n00b


Joined: 05 Jul 2013
Posts: 9

PostPosted: Fri Jul 05, 2013 11:05 pm    Post subject: eth0 does not exist even if module r8168 is loaded Reply with quote

Hi just joined the Gentoo fight 3 days ago and im having some network troubles.

I have kernel version 3.8.13
without any built-in support for realtek
and did this
Code:
ACCEPT_KEYWORDS="~x86" emerge r8168

and it let me emerge net-misc/r8168-8.035.00-r1 with no errors.
(i did this because net-misc/r8168-8.028.00 failed to compile in ebuild)
to emerge the package i booted to the gentoo install to keep any stray env varibles and drivers at bay.
the module is loaded automatically and lspci -k tells me its using it.
Code:

07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
   Subsystem: ASUSTeK Computer Inc. P8P67 and other motherboards
   Kernel driver in use: r8168
   Kernel modules: r8168

(I don't have a P8P67 mother board i have a P8Z68 but they are probably compatible)
Code:

# ethtool eth0
Cannot get device settings: No such device
Cannot get wake-on-lan settings: No such device
Cannot get message level: No such device
Cannot get link status: No such device
#

there is a init.d script for net.eth0 but it also fails.

i am currently in chroot from my debian.
i don't know where to go anymore.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8911

PostPosted: Fri Jul 05, 2013 11:08 pm    Post subject: Reply with quote

What is the output of ifconfig -a, as run right after ethtool fails?
Back to top
View user's profile Send private message
wobbol
n00b
n00b


Joined: 05 Jul 2013
Posts: 9

PostPosted: Fri Jul 05, 2013 11:24 pm    Post subject: Reply with quote

Code:

patty ~ # cat ifconfig-a
enp7s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether f4:6d:04:64:39:c4  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 51  base 0x4000 

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 4  bytes 240 (240.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 4  bytes 240 (240.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

sit0: flags=128<NOARP>  mtu 1480
        sit  txqueuelen 0  (IPv6-in-IPv4)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


:D thats the command i was looking for
(i still have no idea what to do with that)
Back to top
View user's profile Send private message
wobbol
n00b
n00b


Joined: 05 Jul 2013
Posts: 9

PostPosted: Fri Jul 05, 2013 11:51 pm    Post subject: Reply with quote

thanks for bringing me out of my mental block just did a
Code:

# ln -s /etc/init.d/net.lo /etc/init.d/enp7s0
# /etc/init.d/enp7s0 start

and it works :D
now to fix my xorg.conf witch i somehow broke in trying to fix the network issue.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8911

PostPosted: Sat Jul 06, 2013 12:42 am    Post subject: Reply with quote

Your solution works, but the other option would have been to reconfigure udev so that it does not mangle your interface name. You appear to have only one interface, so the renaming does not help you.
Back to top
View user's profile Send private message
wobbol
n00b
n00b


Joined: 05 Jul 2013
Posts: 9

PostPosted: Sat Jul 06, 2013 6:07 am    Post subject: Reply with quote

how do i reconfigure udev?
im so used to dpkg-reconfigure :P
[edit]:
the only config file for udev in /etc/udev/ is hwdb.bin should i just delete it?
will it create another one?
is this what im looking for?
[edit2]:
found what i needed here http://www.reactivated.net/writing_udev_rules.html
thanks guys!
Back to top
View user's profile Send private message
bug_report
n00b
n00b


Joined: 17 Sep 2010
Posts: 67
Location: Frankfurt, Germany

PostPosted: Sat Jul 06, 2013 1:22 pm    Post subject: Reply with quote

Quote:
found what i needed here http://www.reactivated.net/writing_udev_rules.html

Really? As far as I can see, the proper solution to prevent udev from mangling names is:
Code:
ln -s /dev/null /etc/udev/rules.d/80-net-name-slot.rules

See here http://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/, section: 'I don't like this, how do I disable this?'
Back to top
View user's profile Send private message
wobbol
n00b
n00b


Joined: 05 Jul 2013
Posts: 9

PostPosted: Sat Jul 06, 2013 1:38 pm    Post subject: Reply with quote

if you read a little bit theres a reason you don't want to use the kernel assigned device names. the page i supplied tells of the udev way of keeping interface names sane and consistent not how to circumvent it.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 8911

PostPosted: Sat Jul 06, 2013 3:25 pm    Post subject: Reply with quote

We have read that page. The justifications it gives only apply if you have, or reasonably expect you will someday have, more than one network interface of the same type. As I said, you appear to have only one Ethernet interface, so the rules are worthless for you. The authors of that page seem to be under the mistaken impression that almost everyone falls into the category of having more than one interface, and based on that bad assumption decided to mangle the interface names on all machines.
Back to top
View user's profile Send private message
broken_chaos
Guru
Guru


Joined: 18 Jan 2006
Posts: 370
Location: Ontario, Canada

PostPosted: Sat Jul 06, 2013 3:25 pm    Post subject: Reply with quote

wobbol wrote:
if you read a little bit theres a reason you don't want to use the kernel assigned device names.

They're fine to use if you only have a single ethernet adapter. eth0 will always be eth0 as long as there's only one.
Back to top
View user's profile Send private message
wobbol
n00b
n00b


Joined: 05 Jul 2013
Posts: 9

PostPosted: Sat Jul 06, 2013 4:47 pm    Post subject: Reply with quote

sorry I've just had problems in other distros with interface naming a few years ago and am very sour about it.
also just to draw some parallels remember before grub 2 when sda would just be the first non pata disk detected?
anyway I'm done with this discussion of personal preference.
Peace.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum