Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sentelic touch pad - x300v
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Juan Facundo
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2009
Posts: 128

PostPosted: Tue Jul 02, 2013 6:14 pm    Post subject: Sentelic touch pad - x300v Reply with quote

Hola gente. Tanto tiempo.

Hoy vengo a colaborar con algo que me ha costado mas trabajo de lo pensado configurar y que realmente me dio hasta bronca.
He buscado en muchos foros y listas de correo, intentando hacer funcionar el touch pad de una ultrabook exo nifty, modelo x300v. Parece que son muchas con las marcas con las que se comercializa esta ultrabook. Asi que puede ser para otras marcas tambien.

No es cosa de otro mundo, en si el touchpad se comunica a traves del viejo ps2 mouse. Yo no lo sabia y me quise morir cuando me di cuenta. Asi que lo unico que deben hacer es compilar ese modulo. Yo le agregue por las dudas todas las opciones en la configuracion del nucleo .
Code:

Device drivers -> Input device support ->
 --- Mice
  <*>   PS/2 mouse
   [*]     Elantech PS/2 protocol extension
   [*]     Sentelic Finger Sensing Pad PS/2 protocol extension
   [*]     eGalax TouchKit PS/2 protocol extension

Alguo que debi agregar al booteo, fue la siguiente linea:
Code:
i8042.noloop

y mi linea de grub quedo asi:
Code:
kernel /boot/bzImage root=/dev/sda2 i8042.noloop


Luego agregar como antiguamente se hacia... la configuracion del mouse
Code:
Section "InputDevice"
   Identifier  "Mouse1"
   Driver      "mouse"
   Option       "Protocol" "ImPS/2"
   Option       "Device" "/dev/input/mouse0"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection


antes de probar esto, probe hacer con la aplicacion gpm, usando sus datos como "repeater" y configurar esta alternativa, la que no funciona mal:
Code:
# gpm -m /dev/input/mouse0 -R imps2

luego de esto, deberiamos tener nuestro touchpad funcionando en linea de comandos. Lo siguiente es cambiar:
Code:
Section "InputDevice"
   Identifier  "Mouse1"
   Driver      "mouse"
   Option       "Protocol" "ImPS/2"
   Option       "Device" "/dev/gpmdata"
   Option       "ZAxisMapping" "4 5 6 7"
EndSection

Para poder usar el driver "mouse" de x11, hay que deshabilitar la opción "hotplug". De lo contrario x11 lo deshabilita por defecto. En este fragmento del log de x11 nos lo indica:
Code:
[   135.449] (**) ModulePath set to "/usr/lib/xorg/modules"
[   135.449] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   135.449] (WW) Disabling Mouse0
[   135.449] (WW) Disabling Mouse1

Para ello deberíamos agregar a nuesto xorg.conf:
Code:
Section "ServerFlags"
    Option          "AutoAddDevices" "False"
EndSection

Leí que no es lo mejor deshabilitar esta opción, pero yo no he podido hacer funcionar el mouse ps/2 a través de udev. Si alguien me puede decir como hacer, estría muy agradecido.
Tal vez hayan mejores configuraciones, o alguien puede mejorar esto, lo que seria muy bueno.

Saludos.
Back to top
View user's profile Send private message
Juan Facundo
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2009
Posts: 128

PostPosted: Sat Jul 13, 2013 4:13 pm    Post subject: Reply with quote

Bueno, he seguido investigando al respecto, y modifiqué los siguiente:

- Eliminé el archivo /etc/X11/xorg.conf
- Agregué en la variable $INPUT_DEVICES de modo que quedó:
Code:
$ echo $INPUT_DEVICES
evdev mouse synaptics keyboard

- Re-emerge
Code:
$ emerge xorg-drivers -av

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-base/xorg-drivers-1.13  INPUT_DEVICES="evdev keyboard mouse synaptics -acecad -aiptek -elographics -fpit -hyperpen -joystick -mutouch -penmount -tslib -vmmouse -void -wacom" VIDEO_CARDS="intel -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx -geode -glint -i128 -i740 -mach64 -mga -modesetting -neomagic (-newport) -nouveau -nv -nvidia (-omap) (-omapfb) -qxl -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -via -virtualbox -vmware (-voodoo)" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Así que pasando el limpio, sería compilar el modulo en el kernel, agregar la opción "i8042.noloop" en la linea de booteo y luego agregar en $INPUT_DEVICES la opción "synaptics". Con esto me funciona muy bien.
Back to top
View user's profile Send private message
jemaydup
n00b
n00b


Joined: 07 Sep 2013
Posts: 1
Location: argentina

PostPosted: Sat Sep 07, 2013 3:21 am    Post subject: X300v exo nifty Reply with quote

como configuraste el bios para que la instalacion de linunx reconozca el disco.

mantuviste el windows 8, lo sacaste.

si tenes al animo y me mandas unas fotos de como quedo el bios/uefi y algun paso a paso.

te lo agradesco
Back to top
View user's profile Send private message
Juan Facundo
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2009
Posts: 128

PostPosted: Sun Oct 13, 2013 11:38 pm    Post subject: Reply with quote

Perdon por la demora.

No, en mi maquina no viven windows... :D

Ese tema no lo pude resolver. Lo que hice fue instalar grub (el viejo, no grub 2) en el disco comun y booteaba de ahi, luego el sistema de archivos raiz estaba en el sdd.

Mmm, dificil el paso a paso. recuerdo que para empezar a instalar y reconocer los dispositivos mas facilemnte, use knoppix. Luego instale knoppix en el hd (no sdd) y de ahi empece con gentoo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum