Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Libreoffice4 base reports are empty
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 209

PostPosted: Tue Jul 02, 2013 5:16 pm    Post subject: [Solved] Libreoffice4 base reports are empty Reply with quote

I'm disappointed. On many libreoffice-stable-releases the Base report-generator just seems to be forgotten.

Now reports never get any data from my databases (which are editable). Just one line with the example-text.
Am I the only one? (always?)
How to fix it?

Thanks for your help.

Using app-office/libreoffice-4.0.4.2 amd64
_________________
With nice greetings
Vrenn


Last edited by Vrenn on Sun Jul 14, 2013 12:11 pm; edited 1 time in total
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1674
Location: Berlin, Germany

PostPosted: Wed Jul 03, 2013 11:54 pm    Post subject: Reply with quote

Report a bug and if possible, attach a testcase which demonstrates the problem.
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 209

PostPosted: Sat Jul 06, 2013 6:22 pm    Post subject: Reply with quote

I don't want to file a bug without looking closer to the case. Until now I just had no time :-(

Reproducing the step in some ways and testing on older Gentoo/amd64 with a 3.6-libreoffice I believe the problem lies in the sorting-options of the reports. Making no sorting at all lets you see your data.
This, I believe, was already an issure and solved (3.4?) in the past, but I can't remember/find the bug anymore.
So new one is out now.

I hope somebody will hunt it down as I use it for my work.
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1674
Location: Berlin, Germany

PostPosted: Sun Jul 07, 2013 5:32 pm    Post subject: Reply with quote

app-office/libreoffice-3.6 is expected to go away soon from Gentoo.

Unless the problem is made known to developers (via bugzilla preferably), it probably won't be fixed.
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 209

PostPosted: Sun Jul 07, 2013 5:51 pm    Post subject: Reply with quote

Seems I wasn't to concrete with "new one". I filed a bug at bugs.gentoo.org yesterday. But there are quite a lot of bugs for libreoffice4.
Grml, other OS and firefox prevents me from accessing bugzilla. Does bugs.gentoo.org have a bad certificate?
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1674
Location: Berlin, Germany

PostPosted: Sun Jul 07, 2013 5:56 pm    Post subject: Reply with quote

bugs.gentoo.org uses a CACert certificate. CACert does not want to pay the money that is necessary for inclusion in Mozilla or other browsers.

So you need to import the certifiate from cacert.org or allow an exception for bugs.gentoo.org.
Back to top
View user's profile Send private message
Vrenn
Apprentice
Apprentice


Joined: 15 Dec 2004
Posts: 209

PostPosted: Sun Jul 14, 2013 12:15 pm    Post subject: Reply with quote

This has gone quite quick. The Problem is fixed in libreoffice 4.1.0.2 which is still ~amd64.
If you want to test it use this code I needed in /et/portage/package.keywords
Code:
#libreoffice reporter-bug
=app-office/libreoffice-l10n-4.1.0.2 ~amd64
=app-office/libreoffice-4.1.0.2 ~amd64
=dev-libs/boost-1.53.0 ~amd64
=app-text/libmwaw-0.1.10 ~amd64
=dev-util/boost-build-1.53.0 ~amd64
=app-text/libodfgen-0.0.2 ~amd64
=dev-libs/liborcus-0.5.1 ~amd64
=dev-libs/libixion-0.5.0 ~amd64
Thank you for the fast fix!
_________________
With nice greetings
Vrenn
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum