Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] Multiple package instances within a single pack...
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Mon Jul 01, 2013 8:04 pm    Post subject: [gelöst] Multiple package instances within a single pack... Reply with quote

Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.34.3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.33.12:2 required by (x11-libs/pango-1.32.5::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.


--backtrack=30 hilft nicht...

Was kann ich sonst noch tun?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org


Last edited by uhai on Fri Jul 05, 2013 7:56 am; edited 1 time in total
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Mon Jul 01, 2013 8:28 pm    Post subject: Re: Multiple package instances within a single package slot Reply with quote

uhai wrote:
Code:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.34.3::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.33.12:2 required by (x11-libs/pango-1.32.5::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (dev-libs/glib-2.32.4-r1::gentoo, installed) pulled in by
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.


--backtrack=30 hilft nicht...

Was kann ich sonst noch tun?

uhai


Wie schaut dein emerge Befehl aus? Solche Meldungen kommen mitunter, wenn ein Paket aktualisiert werden muss.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Mon Jul 01, 2013 8:29 pm    Post subject: Reply with quote

emerge -auDN --backtrack=10 system
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Mon Jul 01, 2013 8:38 pm    Post subject: Reply with quote

checke mal bitte welche 'dev-libs/gobject-introspection' version bei dir freigegeben ist.
Laut der Ausgabe soll 'dev-libs/glib-2.34.3' installiert werden; dafür brauchst du ebenfalls '>=dev-libs/gobject-introspection-1.34'
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2277
Location: Germany

PostPosted: Mon Jul 01, 2013 8:53 pm    Post subject: Reply with quote

Hm, wird denn wirklich die x11-libs/pango-1.32.5 testing(?) Version benötigt?
Um welche Architektur geht es denn? (so ohne diese Info kann man meist nur schwer was dazu sagen)

Und statt nur "emerge -auDN --backtrack=10 system" nimm mal bitte world (oder @world)

edit/
Schau doch auch mal was ein
Code:
emerge -avuDN1 =x11-libs/pango-1.30.1 world
(mit der stable pango Version) dazu sagt.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Tue Jul 02, 2013 8:30 pm    Post subject: Reply with quote

Ein komlettes KDE-UPdate:

Code:
emerge -avuDN1 =x11-libs/pango-1.30.1 world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] kde-base/kde-env-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U  ] dev-lang/python-2.7.5:2.7 [2.7.3-r3:2.7] USE="berkdb doc examples gdbm ipv6 ncurses readline sqlite ssl threads tk (wide-unicode) wininst xml -build -hardened" 10,026 kB
[ebuild     U ~] kde-base/oxygen-icons-4.10.5:4 [4.10.4:4] USE="(-aqua) -bindist" 28,647 kB
[ebuild     U  ] media-libs/exempi-2.2.0:2 [2.1.1:2] USE="-examples -static-libs%" 3,473 kB
[ebuild     U  ] dev-util/eric-5.3.2:5 [5.2.5:5] USE="spell" LINGUAS="de -cs -en -es -fr -it -ru -tr -zh_CN" 0 kB
[ebuild     U ~] kde-base/kdelibs-4.10.5:4 [4.10.4:4] USE="3dnow acl alsa bzip2 fam handbook jpeg2k mmx nls opengl (policykit) semantic-desktop spell sse sse2 ssl udev udisks upower (-altivec) (-aqua) -debug -doc -kerberos -lzma -openexr {-test} -zeroconf" 11,742 kB
[ebuild     U ~] kde-base/nepomuk-core-4.10.5:4 [4.10.4:4] USE="exif ffmpeg pdf (-aqua) -debug -taglib" 364 kB
[ebuild     U ~] kde-base/kfmclient-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 2,555 kB
[ebuild     U ~] kde-base/katepart-4.10.5:4 [4.10.4-r1:4] USE="handbook (-aqua) -debug" 2,530 kB
[ebuild     U ~] kde-base/nepomuk-widgets-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 79 kB
[ebuild     U ~] kde-base/kdesu-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 7,064 kB
[ebuild     U ~] kde-base/khelpcenter-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kde-l10n-4.10.5:4 [4.10.4:4] USE="handbook (-aqua)" LINGUAS="de -ar -bg -bs -ca -ca@valencia -cs -da -el -en_GB -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -si -sk -sl -sr -sv -tg -th -tr -ug -uk -vi -wa -zh_CN -zh_TW" 37,061 kB
[ebuild     U ~] kde-base/libkdegames-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug -openal" 5,711 kB
[ebuild     U ~] kde-base/kdepimlibs-4.10.5:4 [4.10.4:4] USE="handbook ldap semantic-desktop (-aqua) -debug -prison {-test}" 2,917 kB
[ebuild     U ~] kde-base/libkworkspace-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 13,252 kB
[ebuild     U ~] kde-base/libkonq-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug {-test}" 0 kB
[ebuild     U ~] kde-base/libkdeedu-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 209 kB
[ebuild     U ~] kde-base/knotify-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kactivities-4.10.5:4 [4.10.4:4] USE="semantic-desktop (-aqua)" 108 kB
[ebuild     U ~] kde-base/kephal-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/libkexiv2-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 132 kB
[ebuild     U ~] kde-base/kcheckpass-4.10.5:4 [4.10.4:4] USE="pam (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/ksysguard-4.10.5:4 [4.10.4:4] USE="handbook lm_sensors (-aqua) -debug {-test}" 0 kB
[ebuild     U ~] kde-base/libkmahjongg-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 1,636 kB
[ebuild     U ~] kde-base/kcmshell-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kde-wallpapers-4.10.5:4 [4.10.4:4] USE="(-aqua)" 88,530 kB
[ebuild     U ~] kde-base/libkipi-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 95 kB
[ebuild     U ~] kde-base/libkcompactdisc-4.10.5:4 [4.10.4:4] USE="alsa (-aqua) -debug" 76 kB
[ebuild     U ~] kde-base/libkcddb-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug -musicbrainz" 162 kB
[ebuild     U ~] kde-base/liboxygenstyle-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kcminit-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kwallet-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 277 kB
[ebuild     U ~] kde-base/okular-4.10.5:4 [4.10.4:4] USE="crypt handbook jpeg pdf postscript tiff (-aqua) -chm -debug -djvu -ebook" 1,354 kB
[ebuild     U ~] kde-base/phonon-kde-4.10.5:4 [4.10.4:4] USE="alsa (-aqua) -debug -pulseaudio" 0 kB
[ebuild     U ~] kde-base/nepomuk-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/libkdcraw-4.10.5:4 [4.10.4:4] USE="lcms%* (-aqua) -debug -jasper%" 342 kB
[ebuild     U ~] kde-base/solid-runtime-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/ktimezoned-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdnssd-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug -zeroconf" 8,819 kB
[ebuild     U ~] kde-base/kdialog-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/libksane-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 81 kB
[ebuild     U ~] kde-base/ffmpegthumbs-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 21 kB
[ebuild     U ~] kde-base/svgpart-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 10 kB
[ebuild     U ~] kde-base/kstartupconfig-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/ksplash-4.10.5:4 [4.10.4:4] USE="3dnow mmx sse sse2 xinerama (-altivec) (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/analitza-4.10.5:4 [4.10.4:4] USE="readline (-aqua) -debug" 175 kB
[ebuild     U ~] kde-base/kdeartwork-wallpapers-4.10.5:4 [4.10.4:4] USE="(-aqua)" 140,416 kB
[ebuild     U ~] kde-base/kdepim-l10n-4.10.5:4 [4.10.4:4] USE="handbook (-aqua)" LINGUAS="de -ar -bg -bs -ca -ca@valencia -cs -da -el -en_GB -es -et -eu -fa -fi -fr -ga -gl -he -hi -hr -hu -ia -is -it -ja -kk -km -ko -lt -lv -mr -nb -nds -nl -nn -pa -pl -pt -pt_BR -ro -ru -si -sk -sl -sr -sv -tg -th -tr -ug -uk -vi -wa -zh_CN -zh_TW" 0 kB
[ebuild     U ~] kde-base/kwalletd-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kuiserver-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kfile-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdebase-menu-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/knewstuff-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/ktraderclient-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdebugdialog-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kioclient-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/renamedlg-plugins-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kiconfinder-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/keditfiletype-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/attica-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/knetattach-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdontchangethehostname-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kpasswdserver-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kglobalaccel-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdebase-menu-icons-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kdebase-desktoptheme-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kquitapp-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kmimetypefinder-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kurifilter-plugins-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kstart-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/dragon-4.10.5:4 [4.10.4:4] USE="handbook xine (-aqua) -debug" 387 kB
[ebuild     U ~] kde-base/kmix-4.10.5:4 [4.10.4:4] USE="alsa handbook (-aqua) -canberra -debug -pulseaudio" 378 kB
[ebuild     U ~] kde-base/juk-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 438 kB
[ebuild     U ~] kde-base/kcolorchooser-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 5 kB
[ebuild     U ~] kde-base/kdegraphics-strigi-analyzer-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 41 kB
[ebuild     U ~] kde-base/kolourpaint-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 1,162 kB
[ebuild     U ~] kde-base/kgamma-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 27 kB
[ebuild     U ~] kde-base/kruler-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 132 kB
[ebuild     U ~] kde-base/kamera-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 37 kB
[ebuild     U ~] kde-base/freespacenotifier-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/ksystraycmd-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kde-base-artwork-4.10.5:4 [4.10.4:4] USE="(-aqua)" 7,249 kB
[ebuild     U ~] kde-base/kwrite-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/qguiplatformplugin_kde-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdebase-cursors-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kwrited-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kbruch-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 888 kB
[ebuild     U ~] kde-base/pairs-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 2,081 kB
[ebuild     U ~] kde-base/kgeography-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 6,567 kB
[ebuild     U ~] kde-base/kig-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug -scripting" 1,495 kB
[ebuild     U ~] kde-base/step-4.10.5:4 [4.10.4:4] USE="gsl handbook qalculate (-aqua) -debug" 368 kB
[ebuild     U ~] kde-base/rocs-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 1,120 kB
[ebuild     U ~] kde-base/kiten-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 11,468 kB
[ebuild     U ~] kde-base/cantor-4.10.5:4 [4.10.4:4] USE="R handbook -analitza (-aqua) -debug -postscript -qalculate" 312 kB
[ebuild     U ~] kde-base/print-manager-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 92 kB
[ebuild     U ~] kde-base/kdf-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 154 kB
[ebuild     U ~] kde-base/kcalc-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug {-test}" 93 kB
[ebuild     U ~] kde-base/ktimer-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 148 kB
[ebuild     U ~] kde-base/sweeper-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 83 kB
[ebuild     U ~] kde-base/filelight-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 285 kB
[ebuild     U ~] kde-base/kcharselect-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 85 kB
[ebuild     U ~] kde-base/krosspython-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" PYTHON_SINGLE_TARGET="python2_7 -python2_5 -python2_6" PYTHON_TARGETS="python2_7 -python2_5 -python2_6" 131 kB
[ebuild     U ~] kde-base/kdeartwork-desktopthemes-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kdeartwork-emoticons-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kdeartwork-sounds-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kdeartwork-colorschemes-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kdeartwork-iconthemes-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kcron-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 647 kB
[ebuild     U ~] kde-base/ksystemlog-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug {-test}" 0 kB
[ebuild     U ~] kde-base/kteatime-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 372 kB
[ebuild     U ~] kde-base/amor-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/krfb-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug -telepathy" 0 kB
[ebuild     U ~] kde-base/krdc-4.10.5:4 [4.10.4:4] USE="handbook jpeg (-aqua) -debug -rdesktop -telepathy -vnc -zeroconf" 0 kB
[ebuild     U ~] kde-base/kdenetwork-filesharing-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kreadconfig-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdesdk-strigi-analyzer-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 5,139 kB
[ebuild     U ~] kde-base/pykde4-4.10.5:4 [4.10.4:4] USE="semantic-desktop (-aqua) -debug -doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1 -python3_3" 1,999 kB
[ebuild     U ~] kde-base/kwin-4.10.5:4 [4.10.4:4] USE="opengl (-aqua) -debug -gles" 0 kB
[ebuild     U ~] kde-base/khotkeys-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kfind-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/libplasmagenericshell-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug {-test}" 0 kB
[ebuild     U ~] kde-base/libtaskmanager-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kscreensaver-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdepasswd-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/plasma-runtime-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/thumbnailers-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 41 kB
[ebuild     U ~] kde-base/plasma-apps-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/keditbookmarks-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug {-test}" 0 kB
[ebuild     U ~] kde-base/libplasmaclock-4.10.5:4 [4.10.4:4] USE="holidays (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdepim-icons-4.10.5:4 [4.10.4:4] USE="(-aqua)" 14,105 kB
[ebuild     U ~] kde-base/kopete-4.10.5:4 [4.10.4:4] USE="addbookmarks autoreplace contactnotes gadu groupwise handbook highlight history meanwhile msn nowlistening oscar otr pipes privacy skype sms ssl statistics texteffect translator urlpicpreview v4l webpresence winpopup xmpp yahoo (-aqua) -debug -jingle -latex -testbed -zeroconf" 0 kB
[ebuild     U ~] kde-base/drkonqi-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdebase-kioslaves-4.10.5:4 [4.10.4:4] USE="bzip2 exif handbook sftp (-aqua) -debug -lzma -openexr -samba" 0 kB
[ebuild     U ~] kde-base/kdebase-data-4.10.5:4 [4.10.4:4] USE="wallpapers (-aqua)" 0 kB
[ebuild     U ~] kde-base/audiocd-kio-4.10.5:4 [4.10.4:4] USE="encode flac handbook vorbis (-aqua) -debug" 56 kB
[ebuild     U ~] kde-base/kscd-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 93 kB
[ebuild     U ~] kde-base/ksnapshot-4.10.5:4 [4.10.4:4] USE="handbook kipi (-aqua) -debug" 259 kB
[ebuild     U ~] kde-base/ksaneplugin-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 14 kB
[ebuild     U ~] kde-base/kdegraphics-mobipocket-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 20 kB
[ebuild     U ~] kde-base/gwenview-4.10.5:4 [4.10.4:4] USE="handbook kipi semantic-desktop (-aqua) -debug" 2,136 kB
[ebuild     U ~] kde-base/kstyles-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/konsole-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug {-test}" 437 kB
[ebuild     U ~] kde-base/kwordquiz-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 1,188 kB
[ebuild     U ~] kde-base/kalgebra-4.10.5:4 [4.10.4:4] USE="handbook opengl plasma readline (-aqua) -debug" 437 kB
[ebuild     U ~] kde-base/khangman-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 3,845 kB
[ebuild     U ~] kde-base/kstars-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug -fits -indi" 12,171 kB
[ebuild     U ~] kde-base/ktouch-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 2,565 kB
[ebuild     U ~] kde-base/parley-4.10.5:4 [4.10.4:4] USE="handbook plasma (-aqua) -debug" 8,016 kB
[ebuild     U ~] kde-base/kalzium-4.10.5:4 [4.10.4:4] USE="handbook plasma (-aqua) -debug -editor -solver {-test}" 3,624 kB
[ebuild     U ~] kde-base/kmplot-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 666 kB
[ebuild     U ~] kde-base/blinken-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 554 kB
[ebuild     U ~] kde-base/kturtle-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 208 kB
[ebuild     U ~] kde-base/kanagram-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 1,042 kB
[ebuild     U ~] kde-base/klettres-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 2,595 kB
[ebuild     U ~] kde-base/ark-4.10.5:4 [4.10.4:4] USE="archive bzip2 handbook lzma (-aqua) -debug" 233 kB
[ebuild     U ~] kde-base/kgpg-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 798 kB
[ebuild     U ~] kde-base/kdeartwork-weatherwallpapers-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kuser-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kabcclient-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/blogilo-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kmines-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 645 kB
[ebuild     U ~] kde-base/kigo-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 1,340 kB
[ebuild     U ~] kde-base/ksudoku-4.10.5:4 [4.10.4:4] USE="handbook opengl (-aqua) -debug" 1,409 kB
[ebuild     U ~] kde-base/klines-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 937 kB
[ebuild     U ~] kde-base/konquest-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 409 kB
[ebuild     U ~] kde-base/kspaceduel-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 259 kB
[ebuild     U ~] kde-base/kollision-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 209 kB
[ebuild     U ~] kde-base/palapeli-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 1,699 kB
[ebuild     U ~] kde-base/kpat-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 3,022 kB
[ebuild     U ~] kde-base/kmahjongg-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 1,056 kB
[ebuild     U ~] kde-base/kblackbox-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 106 kB
[ebuild     U ~] kde-base/ktuberling-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 4,197 kB
[ebuild     U ~] kde-base/kdiamond-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 4,077 kB
[ebuild     U ~] kde-base/ksirk-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 5,818 kB
[ebuild     U ~] kde-base/kshisen-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 143 kB
[ebuild     U ~] kde-base/kbreakout-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 1,345 kB
[ebuild     U ~] kde-base/kjumpingcube-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 102 kB
[ebuild     U ~] kde-base/kbounce-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 1,558 kB
[ebuild     U ~] kde-base/granatier-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 1,362 kB
[ebuild     U ~] kde-base/katomic-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 652 kB
[ebuild     U ~] kde-base/knetwalk-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 774 kB
[ebuild     U ~] kde-base/ksnakeduel-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug (-selinux)" 315 kB
[ebuild     U ~] kde-base/kgoldrunner-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 2,047 kB
[ebuild     U ~] kde-base/killbots-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 953 kB
[ebuild     U ~] kde-base/klickety-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 834 kB
[ebuild     U ~] kde-base/kiriki-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 124 kB
[ebuild     U ~] kde-base/bovo-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 108 kB
[ebuild     U ~] kde-base/kreversi-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 391 kB
[ebuild     U ~] kde-base/bomber-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 384 kB
[ebuild     U ~] kde-base/knavalbattle-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 837 kB
[ebuild     U ~] kde-base/kolf-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 764 kB
[ebuild     U ~] kde-base/kfourinline-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 266 kB
[ebuild     U ~] kde-base/lskat-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug (-selinux)" 937 kB
[ebuild     U ~] kde-base/kblocks-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 1,216 kB
[ebuild     U ~] kde-base/kubrick-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 120 kB
[ebuild     U ~] kde-base/ksquares-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 84 kB
[ebuild     U ~] kde-base/kapman-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 1,541 kB
[ebuild     U ~] kde-base/solid-4.10.5:4 [4.10.4:4] USE="bluetooth (-aqua) -debug -networkmanager -wicd" 0 kB
[ebuild     U ~] kde-base/konqueror-4.10.5:4 [4.10.4:4] USE="bookmarks handbook svg (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdepim-runtime-4.10.5:4 [4.10.4:4] USE="google (-aqua) -debug -kolab" 1,183 kB
[ebuild     U ~] kde-base/dolphin-4.10.5:4 [4.10.4:4] USE="handbook semantic-desktop thumbnail (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/systemsettings-4.10.5:4 [4.10.4:4] USE="gtk handbook opengl semantic-desktop%* usb (-aqua) -debug {-test}" 0 kB
[ebuild     U ~] kde-base/marble-4.10.5:4 [4.10.4:4] USE="designer-plugin gps handbook kde plasma python (-aqua) -debug -shapefile {-test}" 18,982 kB
[ebuild     U ~] kde-base/kdm-4.10.5:4 [4.10.4:4] USE="(consolekit) handbook pam (-aqua) -debug -kerberos" 0 kB
[ebuild     U ~] kde-base/kcontrol-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdeadmin-meta-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kate-4.10.5:4 [4.10.4:4] USE="handbook python (-aqua) -debug" PYTHON_SINGLE_TARGET="python2_7 -python3_1 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_2 -python3_1 -python3_3" 0 kB
[ebuild     U ~] kde-base/kdegraphics-meta-4.10.5:4 [4.10.4:4] USE="scanner (-aqua)" 0 kB
[ebuild     U ~] kde-base/klipper-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug -prison" 0 kB
[ebuild     U ~] kde-base/kmenuedit-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/superkaramba-4.10.5:4 [4.10.4:4] USE="python (-aqua) -debug" PYTHON_SINGLE_TARGET="python2_7 -python2_5 -python2_6" PYTHON_TARGETS="python2_7 -python2_5 -python2_6" 383 kB
[ebuild     U ~] kde-base/kdeartwork-kscreensaver-4.10.5:4 [4.10.4:4] USE="eigen kexiv2 opengl xscreensaver (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdeartwork-styles-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/ktux-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kajongg-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" PYTHON_SINGLE_TARGET="python2_7%* -python2_6%" PYTHON_TARGETS="python2_7%* -python2_6%" 2,432 kB
[ebuild     U ~] kde-base/kdepim-common-libs-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/plasma-workspace-4.10.5:4 [4.10.4-r1:4] USE="gps handbook python rss semantic-desktop (-aqua) -debug -json -qalculate" 0 kB
[ebuild     U ~] kde-base/ksmserver-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdebase-runtime-meta-4.10.5:4 [4.10.4:4] USE="handbook semantic-desktop (-aqua)" 0 kB
[ebuild     U ~] kde-base/kdegames-meta-4.10.5:4 [4.10.4:4] USE="opengl python (-aqua)" 0 kB
[ebuild     U ~] kde-base/kdetoys-meta-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kdeartwork-meta-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/kdeutils-meta-4.10.5:4 [4.10.4:4] USE="cups (-aqua) -floppy -lirc" 0 kB
[ebuild     U ~] kde-base/kdeedu-meta-4.10.5:4 [4.10.4:4] USE="(-aqua)" 0 kB
[ebuild     U ~] kde-base/mplayerthumbs-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 28 kB
[ebuild     U ~] kde-base/powerdevil-4.10.5:4 [4.10.4:4] USE="pm-utils (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kinfocenter-4.10.5:4 [4.10.4:4] USE="handbook opengl (-aqua) -debug -ieee1394" 0 kB
[ebuild     U ~] kde-base/nsplugins-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/konq-plugins-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug -tidy" 0 kB
[ebuild     U ~] kde-base/kget-4.10.5:4 [4.10.4:4] USE="handbook semantic-desktop (-aqua) -bittorrent -debug -mms -sqlite -webkit" 0 kB
[ebuild     U ~] kde-base/kontact-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/krunner-4.10.5:4 [4.10.4:4] USE="opengl (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdepim-kresources-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdepim-strigi-analyzer-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdenetwork-meta-4.10.5:4 [4.10.4:4] USE="(-aqua) -ppp" 0 kB
[ebuild     U ~] kde-base/kdemultimedia-meta-4.10.5:4 [4.10.4:4] USE="ffmpeg mplayer (-aqua)" 0 kB
[ebuild     U ~] kde-base/konsolekalendar-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kalarm-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/akonadiconsole-4.10.5:4 [4.10.4:4] USE="(-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kleopatra-4.10.5:4 [4.10.4:4] USE="handbook (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/korganizer-4.10.5:4 [4.10.4:4] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdebase-startkde-4.10.5:4 [4.10.4:4] USE="wallpapers (-aqua)" 0 kB
[ebuild     U ~] kde-base/kaddressbook-4.10.5:4 [4.10.4:4] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kdeplasma-addons-4.10.5:4 [4.10.4:4] USE="exif semantic-desktop (-aqua) -attica -debug -desktopglobe -fcitx -ibus -json -oauth -qalculate -qwt -scim" 1,750 kB
[ebuild     U ~] kde-base/knode-4.10.5:4 [4.10.4:4] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/ktimetracker-4.10.5:4 [4.10.4:4] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/knotes-4.10.5:4 [4.10.4:4] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/akregator-4.10.5:4 [4.10.4:4] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kjots-4.10.5:4 [4.10.4:4] USE="handbook kontact (-aqua) -debug" 0 kB
[ebuild     U ~] kde-base/kmail-4.10.5:4 [4.10.4:4] USE="handbook kontact (-aqua) -debug {-test}" 0 kB
[ebuild     U ~] kde-base/kdebase-meta-4.10.5:4 [4.10.4:4] USE="wallpapers (-aqua)" 0 kB
[ebuild     U ~] kde-base/kdepim-meta-4.10.5:4 [4.10.4:4] USE="nls (-aqua)" 0 kB
[ebuild     U ~] kde-base/kde-meta-4.10.5:4 [4.10.4:4] USE="nls semantic-desktop -accessibility (-aqua) -sdk" 0 kB

Total: 254 packages (254 upgrades), Size of downloads: 533,087 kB

WARNING: One or more updates have been skipped due to a dependency conflict:

dev-libs/glib:2

  (dev-libs/glib-2.36.3::gentoo, ebuild scheduled for merge) conflicts with
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

x11-libs/gtk+:3

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by kde-base/kdegames-meta-4.10.5
# required by kde-base/kde-meta-4.10.5
# required by @selected
# required by @world (argument)
=kde-base/knavalbattle-4.10.5 ~amd64
# required by kde-base/kdeutils-meta-4.10.5[cups]
# required by kde-base/kde-meta-4.10.5
# required by @selected
# required by @world (argument)
=kde-base/print-manager-4.10.5 ~amd64
# required by kde-base/kdegames-meta-4.10.5
# required by kde-base/kde-meta-4.10.5
# required by @selected
# required by @world (argument)
=kde-base/ksnakeduel-4.10.5 ~amd64
# required by kde-base/akonadiconsole-4.10.5
# required by kde-base/kdepim-meta-4.10.5
# required by kde-base/kde-meta-4.10.5[semantic-desktop]
# required by @selected
# required by @world (argument)
=kde-base/nepomuk-widgets-4.10.5 ~amd64

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


Es ist ein
Code:
Linux tux 3.7.10-gentoo #1 SMP Fri Mar 29 17:55:00 CET 2013 x86_64 AMD Phenom(tm) II X4 945 Processor AuthenticAMD GNU/Linux
.

@renegart:

Code:
eix dev-libs/gobject-introspection
[I] dev-libs/gobject-introspection
     Available versions:  1.32.1 ~1.34.2-r1 [M]~1.36.0 {{cairo doc doctool python_single_target_python2_7 python_targets_python2_7 test}}
     Installed versions:  1.32.1(16:14:22 30.03.2013)(-doc -doctool -test)
     Homepage:            http://live.gnome.org/GObjectIntrospection/
     Description:         Introspection infrastructure for generating gobject library bindings for various languages

[I] dev-libs/gobject-introspection-common
     Available versions:  1.32.1 ~1.34.2 [M]~1.36.0
     Installed versions:  1.32.1(15:40:35 05.08.2012)
     Homepage:            http://live.gnome.org/GObjectIntrospection/
     Description:         Build infrastructure for GObject Introspection

Reicht das?

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2277
Location: Germany

PostPosted: Tue Jul 02, 2013 9:57 pm    Post subject: Reply with quote

uhai wrote:
Code:
emerge -avuDN1 =x11-libs/pango-1.30.1 world
[....]
WARNING: One or more updates have been skipped due to a dependency conflict:

dev-libs/glib:2

  (dev-libs/glib-2.36.3::gentoo, ebuild scheduled for merge) conflicts with
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

x11-libs/gtk+:3

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by kde-base/kdegames-meta-4.10.5
# required by kde-base/kde-meta-4.10.5
# required by @selected
# required by @world (argument)
=kde-base/knavalbattle-4.10.5 ~amd64
# required by kde-base/kdeutils-meta-4.10.5[cups]
# required by kde-base/kde-meta-4.10.5
# required by @selected
# required by @world (argument)
=kde-base/print-manager-4.10.5 ~amd64
# required by kde-base/kdegames-meta-4.10.5
# required by kde-base/kde-meta-4.10.5
# required by @selected
# required by @world (argument)
=kde-base/ksnakeduel-4.10.5 ~amd64
# required by kde-base/akonadiconsole-4.10.5
# required by kde-base/kdepim-meta-4.10.5
# required by kde-base/kde-meta-4.10.5[semantic-desktop]
# required by @selected
# required by @world (argument)
=kde-base/nepomuk-widgets-4.10.5 ~amd64

Jo, schaut doch soweit schon mal gut aus.
Ein Vorschlag: Nimm das ~arch Keyword für x11-libs/pango raus,
und nehme die demaskierung (fürs normal hart maskierte) dev-libs/glib raus
und füge fürs kde Update dann noch wie von emerge vorgeschlagen die keyword changes hinzu - dann sollte es wahrscheinlich schon passen.
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Wed Jul 03, 2013 6:05 am    Post subject: Reply with quote

Josef.95 wrote:
uhai wrote:
Code:
emerge -avuDN1 =x11-libs/pango-1.30.1 world
[....]
WARNING: One or more updates have been skipped due to a dependency conflict:

dev-libs/glib:2

  (dev-libs/glib-2.36.3::gentoo, ebuild scheduled for merge) conflicts with
    <dev-libs/glib-2.33:2 required by (dev-libs/gobject-introspection-1.32.1::gentoo, installed)


!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

x11-libs/gtk+:3

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by kde-base/kdegames-meta-4.10.5
# required by kde-base/kde-meta-4.10.5
# required by @selected
# required by @world (argument)
=kde-base/knavalbattle-4.10.5 ~amd64
# required by kde-base/kdeutils-meta-4.10.5[cups]
# required by kde-base/kde-meta-4.10.5
# required by @selected
# required by @world (argument)
=kde-base/print-manager-4.10.5 ~amd64
# required by kde-base/kdegames-meta-4.10.5
# required by kde-base/kde-meta-4.10.5
# required by @selected
# required by @world (argument)
=kde-base/ksnakeduel-4.10.5 ~amd64
# required by kde-base/akonadiconsole-4.10.5
# required by kde-base/kdepim-meta-4.10.5
# required by kde-base/kde-meta-4.10.5[semantic-desktop]
# required by @selected
# required by @world (argument)
=kde-base/nepomuk-widgets-4.10.5 ~amd64

Jo, schaut doch soweit schon mal gut aus.
Ein Vorschlag: Nimm das ~arch Keyword für x11-libs/pango raus,
und nehme die demaskierung (fürs normal hart maskierte) dev-libs/glib raus
und füge fürs kde Update dann noch wie von emerge vorgeschlagen die keyword changes hinzu - dann sollte es wahrscheinlich schon passen.


Ich würde zuerst Josef.95's Vorschlag ausprobieren, speziell das demaskieren von 'dev-libs/glib-2.36.3' würde ich zurück nehmen.

Ansonsten ist wie vermutet sowohl 'dev-libs/gobject-introspection-1.34.2-r1' also auch 'dev-libs/gobject-introspection-common-1.34.2' mit ~arch maskiert.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Wed Jul 03, 2013 7:09 pm    Post subject: Reply with quote

Nach Entfernung aller glib & pango & gobject-introspection keywords sieht das so aus:

Code:
 emerge -auDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-libs/gobject-introspection-common-1.34.2 [1.32.1]
[ebuild  NS    ] dev-libs/glib-1.2.10-r5 [2.32.4-r1] USE="-hardened"
[ebuild     U ~] dev-libs/glib-2.34.3 [2.32.4-r1]
[ebuild     U ~] dev-libs/gobject-introspection-1.34.2-r1 [1.32.1] PYTHON_SINGLE_TARGET="python2_7%*" PYTHON_TARGETS="python2_7%*"
[ebuild  N     ] app-accessibility/at-spi2-core-2.6.3  USE="introspection"
[ebuild  N    ~] app-accessibility/at-spi2-atk-2.6.2  USE="{-test}"
[ebuild     U ~] kde-base/kopete-4.10.5 [4.10.4]
[ebuild     U ~] media-gfx/darktable-1.2.2 [1.2.1] USE="squish%*"
[ebuild     U ~] x11-libs/gtk+-3.6.3-r2 [3.4.4] USE="(-egl)"
[ebuild     U ~] kde-base/kdenetwork-meta-4.10.5 [4.10.4]
[ebuild     U  ] dev-lang/python-3.2.5-r1 [3.2.3-r2]
[ebuild     U  ] dev-util/eric-5.3.2 [5.2.5]
[ebuild     U ~] kde-base/plasma-workspace-4.10.5-r1 [4.10.5]
[ebuild     U ~] kde-base/kde-meta-4.10.5 [4.10.4]

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by gnome-extra/libgsf-1.14.25
# required by @selected
# required by @world (argument)
=dev-libs/glib-2.34.3 ~amd64
# required by dev-libs/gobject-introspection-1.34.2-r1
# required by x11-libs/gtk+-3.6.3-r2[introspection]
# required by gnome-base/libgdu-3.0.2
# required by gnome-base/gvfs-1.12.3-r1[gdu]
# required by @selected
# required by @world (argument)
=dev-libs/gobject-introspection-common-1.34.2 ~amd64
# required by gnome-base/gconf-2.32.4-r1[introspection]
# required by x11-libs/goffice-0.8.17-r1[gnome]
# required by app-office/gnucash-2.4.11-r1
# required by @selected
# required by @world (argument)emerge -auDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-libs/gobject-introspection-common-1.34.2 [1.32.1]
[ebuild  NS    ] dev-libs/glib-1.2.10-r5 [2.32.4-r1] USE="-hardened"
[ebuild     U ~] dev-libs/glib-2.34.3 [2.32.4-r1]
[ebuild     U ~] dev-libs/gobject-introspection-1.34.2-r1 [1.32.1] PYTHON_SINGLE_TARGET="python2_7%*" PYTHON_TARGETS="python2_7%*"
[ebuild  N     ] app-accessibility/at-spi2-core-2.6.3  USE="introspection"
[ebuild  N    ~] app-accessibility/at-spi2-atk-2.6.2  USE="{-test}"
[ebuild     U ~] kde-base/kopete-4.10.5 [4.10.4]
[ebuild     U ~] media-gfx/darktable-1.2.2 [1.2.1] USE="squish%*"
[ebuild     U ~] x11-libs/gtk+-3.6.3-r2 [3.4.4] USE="(-egl)"
[ebuild     U ~] kde-base/kdenetwork-meta-4.10.5 [4.10.4]
[ebuild     U  ] dev-lang/python-3.2.5-r1 [3.2.3-r2]
[ebuild     U  ] dev-util/eric-5.3.2 [5.2.5]
[ebuild     U ~] kde-base/plasma-workspace-4.10.5-r1 [4.10.5]
[ebuild     U ~] kde-base/kde-meta-4.10.5 [4.10.4]

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by gnome-extra/libgsf-1.14.25
# required by @selected
# required by @world (argument)
=dev-libs/glib-2.34.3 ~amd64
# required by dev-libs/gobject-introspection-1.34.2-r1
# required by x11-libs/gtk+-3.6.3-r2[introspection]
# required by gnome-base/libgdu-3.0.2
# required by gnome-base/gvfs-1.12.3-r1[gdu]
# required by @selected
# required by @world (argument)
=dev-libs/gobject-introspection-common-1.34.2 ~amd64
# required by gnome-base/gconf-2.32.4-r1[introspection]
# required by x11-libs/goffice-0.8.17-r1[gnome]
# required by app-office/gnucash-2.4.11-r1
# required by @selected
# required by @world (argument)
=dev-libs/gobject-introspection-1.34.2-r1 ~amd64

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

=dev-libs/gobject-introspection-1.34.2-r1 ~amd64

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
[/code]

Soll ich die keyword-Changes wieder setzen? dev-libs/glib ist wieder mit zwei slots dabei :-(

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2277
Location: Germany

PostPosted: Thu Jul 04, 2013 12:39 am    Post subject: Reply with quote

Wahrscheinlich ist es das beste so wenig ~arch Keywords wie möglich zu setzen bzw sie möglichst nur für Pakete zu setzen, wo sie auch wirklich benötigt werden.
Quote:
dev-libs/glib ist wieder mit zwei slots dabei :-(
Das sollte, sofern benötigt, normal kein Problem sein.
Back to top
View user's profile Send private message
uhai
l33t
l33t


Joined: 23 Aug 2007
Posts: 872
Location: Eppingen, Germany

PostPosted: Fri Jul 05, 2013 7:55 am    Post subject: Reply with quote

ok, dann halt mit keywords. Scheint zu klappen :-)

Danke für die Hilfe

uhai
_________________
Asus 4A785TD-M EVO mit AMD Phenom(tm) II X4 945
Dell Mini 10v
http://www.openstreetmap.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum