Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] gnome 3.8 unmask
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 253
Location: Veneto

PostPosted: Tue Jun 25, 2013 6:25 pm    Post subject: [solved] gnome 3.8 unmask Reply with quote

i tried to unmask gnome 3.8 but a portage error blocked me:

Code:
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0)

Total: 108 packages (89 upgrades, 19 new, 1 uninstall), Size of downloads: 240,256 kB
Conflict: 4 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/cogl:1.0

  (media-libs/cogl-1.14.0::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/cogl-1.14.0:1.0=[introspection?,pango] required by (media-libs/clutter-1.14.4::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (media-libs/cogl-1.12.2-r1::gentoo, installed) pulled in by
    >=media-libs/cogl-1.10:1.0/11=[introspection] required by (media-libs/clutter-gst-2.0.4::gentoo, installed)

gnome-base/gnome-desktop:3

  (gnome-base/gnome-desktop-3.8.3::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gnome-desktop-3.8.0:3 required by (gnome-base/gnome-core-libs-3.8.0::gentoo, ebuild scheduled for merge)
    (and 4 more with the same problem)

  (gnome-base/gnome-desktop-3.6.3::gentoo, installed) pulled in by
    >=gnome-base/gnome-desktop-3.1.91:3/4= required by (gnome-extra/gnome-screensaver-3.6.1::gentoo, installed)
    (and 1 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/gobject-introspection-1.36.0::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-0.9.6 required by (net-im/telepathy-logger-0.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.7 required by (gnome-base/gnome-desktop-3.6.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-204::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/libgnomekbd-3.6.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (gnome-base/gdm-3.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/clutter-gst-2.0.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (gnome-base/gnome-menus-3.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.4 required by (net-libs/gtk-vnc-0.5.2::gentoo, installed)
    dev-libs/gobject-introspection required by (net-dns/avahi-0.6.31-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.4 required by (x11-libs/mx-1.4.7::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.111::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.36.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.2 required by (net-libs/gnome-online-accounts-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.0:0/0= required by (sys-libs/libosinfo-0.2.6::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-wm/mutter-3.8.3::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.30.0 required by (gnome-base/libgnome-keyring-3.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.34.1.1 required by (dev-python/pygobject-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.10.1 required by (gnome-base/gnome-shell-3.8.3-r1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.7 required by (dev-libs/libgdata-0.13.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.29 required by (dev-libs/libgusb-0.1.6::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/totem-pl-parser-3.4.5::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.22.5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.4 required by (gnome-base/nautilus-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.34.6::gentoo, ebuild scheduled for merge)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.20-r2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (app-i18n/ibus-1.5.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:= required by (gnome-base/gconf-3.2.6-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-base-1.0.7::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (app-editors/gedit-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1 required by (app-text/evince-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.8 required by (x11-misc/colord-0.1.31::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.7 required by (media-video/totem-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.10.8 required by (app-text/liblangtag-0.5.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (media-libs/clutter-1.14.4::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.6:= required by (dev-libs/libgee-0.10.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.19::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (net-libs/libsocialweb-0.25.21::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (media-libs/cogl-1.14.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.3 required by (media-gfx/eog-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.30 required by (net-libs/telepathy-glib-0.20.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.1 required by (dev-libs/libpeas-1.8.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-3.4.5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (media-video/cheese-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.3 required by (app-cdr/brasero-3.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1 required by (gnome-extra/libgsf-1.14.26::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30.0 required by (net-libs/libzapojit-0.0.3::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.42.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/gtksourceview-3.8.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.6.4 required by (x11-libs/libcryptui-3.8.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.32.0 required by (net-libs/webkit-gtk-2.0.3::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.29 required by (app-crypt/libsecret-0.15::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (gnome-extra/evolution-data-server-3.8.3::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/libgweather-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.10.0 required by (media-sound/rhythmbox-2.99.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:0/0= required by (gnome-base/gconf-3.2.6-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (media-libs/cogl-1.12.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.36.0 required by (dev-libs/gjs-1.36.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.31.6 required by (gnome-extra/gnome-documents-3.8.3.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.8 required by (x11-libs/colord-gtk-0.1.24::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (gnome-extra/sushi-3.8.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.7 required by (gnome-base/gnome-desktop-3.8.3::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.10.3 required by (net-misc/networkmanager-0.9.8.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (gnome-extra/nm-applet-0.9.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.34 required by (app-crypt/gcr-3.8.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gstreamer-1.0.7::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.7 required by (app-accessibility/caribou-0.4.11::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/rest-0.7.90::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-wireless/gnome-bluetooth-3.8.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.12 required by (sys-apps/accountsservice-0.6.30::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (app-misc/tracker-0.16.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/clutter-gtk-1.4.4::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6:0/0= required by (dev-libs/libgee-0.10.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0:= required by (sys-libs/libosinfo-0.2.6::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.0::gentoo, installed)

  (dev-lang/vala-0.18.1::gentoo, installed) pulled in by
    dev-lang/vala:0.18 required by (app-misc/tracker-0.16.1::gentoo, ebuild scheduled for merge)
    dev-lang/vala:0.18 required by (net-misc/vinagre-3.8.2::gentoo, ebuild scheduled for merge)


how can i solve this???

thanks
_________________
PC-Desktop: Ubuntu 14.04 amd64
Notebook Sony Vaio VPCEH: Gentoo ~amd64


Last edited by polslinux on Wed Jun 26, 2013 5:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Jun 25, 2013 9:10 pm    Post subject: Reply with quote

I followed this tutorial.

Code:
emerge -C cogl gnome-desktop vala gobject-introspection && emerge -av gnome

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 354

PostPosted: Wed Jun 26, 2013 2:46 pm    Post subject: Reply with quote

You have to unmerge every vala version under 0.20 ( emerge --depclean =dev-lang/vala-0.18 =dev-lang/vala-0.16 )

Then it will work.
Back to top
View user's profile Send private message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 253
Location: Veneto

PostPosted: Wed Jun 26, 2013 5:13 pm    Post subject: Reply with quote

solved!
thanks to eyoung100 :D
_________________
PC-Desktop: Ubuntu 14.04 amd64
Notebook Sony Vaio VPCEH: Gentoo ~amd64
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum