Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Manchmal lernt man Gentoo wieder richtig zu schätzen ..
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1674
Location: Heidelberg - Germany

PostPosted: Tue Jun 25, 2013 6:56 am    Post subject: Manchmal lernt man Gentoo wieder richtig zu schätzen .. Reply with quote

Auf meinem Raspberrypi läuft eine Raspbian als NFS und Webserver ungefähr seit Ende letzten Jahres. Neulich wollte ich mal wieder ein update machen, also apt-get update und apt-get upgrade. Das Ergebnis was ein nicht mehr bootfähiges, kaputtes System.
Zum Glück hatte ich noch eine SD Karte mit Archlinux rumliegen, gleich fertig mit NFS Server und ich steck diese rein und starte gleich mal ein Update. Update klappte nicht, es gab Fehlermeldungen irgendwelche Verzeichnisse würden schon existieren. Da ich keine Erfahrung mit Archlinux habe und auch keine Lust auf große Internetrecherchen hatte, bin ich dann das Risiko eingegangen etwas verbotenes zu tun und benutzte die "force" option - neu flashen kann man ja immer.
Wie fast schon erwartet, war das Ergebnis eine totales Desaster. Kein login mehr möglich, auf bestehenden Shell keine Eingabe mehr möglich. System schrott.

Ich habe ja schon einige Probleme mit Gentoo in den letzten 10 Jahren gehabt aber ein System zerschossen habe ich noch nie. Bisher dachte ich, die Binärstistributionen wären irgendwie idiotensicherer als Gentoo, denn dafür nehmen sie ja einige Restiktionen in Kauf aber diesen Beispiel hat mit gezeigt, dass das wohl ein Irrtum ist.

Mann, wie ich meine Gentoo Kisten wieder lieb habe :D Gentoo rules \o/
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1069
Location: Buchholz/GER

PostPosted: Tue Jun 25, 2013 7:00 am    Post subject: Reply with quote

Das muss ich Dir mal recht geben. Deshalb habe ich auch versucht, meinen raspi mit Gentoo aufzusetzen. Das Wiki gibt dazu ja einiges her. Das hat auch sehr gut funkioniert, aber auf dem Raspi zu kompilieren ist eine Quaaaaaal.

Deshalb habe ich es mit CrossCompiling probiert, aber da muss ich konstatieren ... ich bin echt einfach zu blöde dazu. Ich habe einige Howtos dazu im Netz gefunden, aber je näher ich meinem Ziel kam, desto kaputter wurde mein Hauptsystem. :) Ich habs dann irgendwann abgebrochen und bin doch auf raspbian gewechselt.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1674
Location: Heidelberg - Germany

PostPosted: Tue Jun 25, 2013 7:22 am    Post subject: Reply with quote

Wie lange dauert denn das Kompilieren eines kleinen Paketes auf dem Raspberry PI verglichen mit einem Desktop Rechner?
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1473
Location: Oranienburg/Germany

PostPosted: Tue Jun 25, 2013 7:39 am    Post subject: Reply with quote

Erdie wrote:
Wie lange dauert denn das Kompilieren eines kleinen Paketes auf dem Raspberry PI verglichen mit einem Desktop Rechner?


Was verstehst du unter klein? Für mein Raspberry Pi Gentoo hab ich auf distcc mit crosscompile gesetzt. Hat dafür gesorgt, dass es schneller geht. Und ja, das mit dem System zerschießen kann ich nachvollziehen. Bei mir hat es RaspBMC in die ewigen Jagdgründe geschickt...

MfG. Stefan
_________________
1st: i5-4440 3.1GHz, 16GB, 1.7TB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 320GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB SSD + 3TB RAID5 GF7025
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 32GB SD
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1069
Location: Buchholz/GER

PostPosted: Tue Jun 25, 2013 10:49 am    Post subject: Reply with quote

Erdie wrote:
Wie lange dauert denn das Kompilieren eines kleinen Paketes auf dem Raspberry PI verglichen mit einem Desktop Rechner?

der Vergleich ist natürlich schwer anzustellen, da ich a) keine genauen Zeiten vom raspi mehr im Kopf habe und b) ein "Desktop-Rechner" natürlich schon sehr unterschiedlich gebaut sein kann.

Aber ich war seinerzeit doch ganz schön erschrocken, wie sehr er sich bei "emerge eix" abgemüht hat. :)
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 171
Location: GER / FFM

PostPosted: Tue Jun 25, 2013 11:22 am    Post subject: Reply with quote

Das erlebe ich genauso. Gentoo ist sehr angenehm zu warten. Ich teste regelmäßig andere Linux Distributionen, aber bisher habe ich noch keine einzige gefunden, die auch nur annähernd zu rund läuft wie Gentoo. Mal kurz ein paar Beispiele der letzten Zeit:

Ubuntu 13.04
1. Ärgernis, Bootloader MUSS installiert werden, eigentlich soll Gentoo das übernehmen. Na gut, dann kommt er eben auf eine Partition, wo er nicht gestartet werden kann.
2. Nach jedem Start erhalte die geniale Meldung: Eine Systemanwendung ist abgestürzt. Welche? Was ist los? Keine Informationen...
3. Konsolenausgabe von APT: Katastrophe. Suchen in der Konsole nach Paketen: Katastrophe. Das reinste Chaos. Da blickt doch kein Mensch durch.

OpenSuse 12.3
Direkt nach der Installation startet KDE nicht. Ich komme in den Login Manager (KDM), gebe mein Passwort ein, der fängt an KDE zu starten, die animierten Symbole erscheinen, zwischen dem vierten und fünften wird der Bildschirm schwarz und ich lande wieder im Login Manager. Hatte ich auch noch nicht...Na gut, schuld war letztendlich der proprietäre Grafikkarten-Treiber, den ich im Live Betrieb installiert hatte. Deinstalliert - Einloggen klappt zumindest wieder. Neuer Versuch: Nach der Wiki Anleitung erneut den proprietären Treiber installiert (funktioniert bei anderen Distros ja auch). Dasselbe Ergebnis. Argh, keine Lust mehr...

ROSA Fresh Desktop R (aktuell neben Gentoo und Windows installiert)
Für mich die optisch schönte Linux Distribution überhaupt. KDE hat ein sehr schönes Design. Hinzu kommen einige sehr nützliche eigene Programme wie Stack Folder, Rosa Media Player (kann per 1-Click Youtube Videos herunterladen und die Audiospur als mp3 extrahieren), Rosa Launcher.
Leider gibt es auch hier Ärger.
1. Im Live Betrieb habe ich nur eine Auflösung von 1024x768 (trotz Full HD Monitor).
2. Installation erzwingt den Bootloader in den MBR. Grrrrr, naja kann ich mit Gentoo zur Not wieder überschreiben.
3. Nach der Installation ist immer noch die Auflösung maximal 1024x768. Auch hier muss ich wohl den proprietären Treiber manuell installieren. Paketmanager gestartet, nvidia Treiber ausgewählt (non-free Repository war Standardmäßig aktiviert) und installiert. Bei der Installation gibt es eine Kernel-Panic und der Bildschirm ist voller bunter Streifen. Juhu! Hardreset! Rechner startet neu, ich komme auf die Shell und kann mich einloggen. Mit nvidia-xconfig die xorg.conf erstellt und kdm gestartet. Oh, es hat funktioniert, ich kann mich einloggen und KDE startet mit der gewohnten 1920x1080 Auflösung.
4. Leider startet nun KDM nicht mehr automatisch, ich lande bei jedem Start in der Shell und muss systemctl start kdm jedes Mal manuell eingeben. ein enable kdm -f funktioniert hier nicht. Sch*** systemd


Nach solchen Erfahrungen bin ich jedes Mal über mein Gentoo dankbar :D Das funktioniert einfach. Und wenn es doch mal Probleme gibt, sagt es mir wenigstens, was schief gelaufen ist und wie man das beheben kann.
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 563

PostPosted: Tue Jun 25, 2013 5:10 pm    Post subject: Re: Manchmal lernt man Gentoo wieder richtig zu schätzen .. Reply with quote

Hi
Erdie wrote:
Auf meinem Raspberrypi läuft eine Raspbian als NFS und Webserver ungefähr seit Ende letzten Jahres. Neulich wollte ich mal wieder ein update machen, also apt-get update und apt-get upgrade. Das Ergebnis was ein nicht mehr bootfähiges, kaputtes System.
Zum Glück hatte ich noch eine SD Karte mit Archlinux rumliegen, gleich fertig mit NFS Server und ich steck diese rein und starte gleich mal ein Update. Update klappte nicht, es gab Fehlermeldungen irgendwelche Verzeichnisse würden schon existieren. Da ich keine Erfahrung mit Archlinux habe und auch keine Lust auf große Internetrecherchen hatte, bin ich dann das Risiko eingegangen etwas verbotenes zu tun und benutzte die "force" option - neu flashen kann man ja immer.
Wie fast schon erwartet, war das Ergebnis eine totales Desaster. Kein login mehr möglich, auf bestehenden Shell keine Eingabe mehr möglich. System schrott.

Ich habe ja schon einige Probleme mit Gentoo in den letzten 10 Jahren gehabt aber ein System zerschossen habe ich noch nie. Bisher dachte ich, die Binärstistributionen wären irgendwie idiotensicherer als Gentoo, denn dafür nehmen sie ja einige Restiktionen in Kauf aber diesen Beispiel hat mit gezeigt, dass das wohl ein Irrtum ist.

Mann, wie ich meine Gentoo Kisten wieder lieb habe :D Gentoo rules \o/

Dem kann ich so nicht zustimmen. Bei mir läuft seit Weihnachten ein all in one Server mit Raspbian und ich bin 100% zufrieden,
und der wird richtig gequält. Kurz zu meine Konfiguration. Habe ein Netzteil mit 4 Ampere und real vorhandenen 5,65 Volt.
Da ich auch ein USB Hub benötige habe ich die Stromversorgung so gelöst das ich an meinem Netzteil ein Y-Kabel gelötet habe.
Ein Kabel geht direkt zum Raps als Stromversorgung und das andere zu USB hub. An dem USB Hub hängen Lautsprecher mit Stromversorgung
durch USB (da der Raps nun mal nicht Beepen kann wie ein PC habe ich das so gelöst damit ich auch Akustisch bei Hard oder Software
Fehler eine Nachricht bekommen). Des weiteren ein Tastatur und Mouse Kabel zum Tastatur/Mouse-switch und ein USB zu Ethernet
Adapter da sich der Raps auch ins Internet einwählt (den Ethernet am Raps benötige ich für meinen Ethernet Switch da der Raps
auch als Router/Firewall usw.. für drei Rechner dient. Und zuletzt ein USB Stick auf dem das Tägliche Backup von meine Mails
abgelegt wird (natürlich verschlüsselt (cryptdisks) :)). Und natürlich noch ein HDMI Kabel vom raps zum Monitor in diesem Fall
ein Fernseher.

Mein Karte habe ich folgender maßen eingerichtet: Eine Partition für boot und eine für / unverschlüsselt, für var, /var/spool/squid,
/var/spool/cyrus und /media/usbstick-backup jeweils verschlüsselt.

Auf dem Rabs läuft nun squid3 mit cache auf der 16 GB SD Karte (1 GB für squid cache).
cyrus-imapd mit integriertem postfix, saslauthd, amavis, clamav, und spamassassin.
bind9 als nameserver und noch folgenden Daemons für mein Heimnetzwerk was selbsterklärend ist:
fwlogwatch, gkrellmd, gpm, iptables, ntp, plymouth, pppd, privoxy, rpcbind, ssh, swatchd, tor, vnstat.

Der Raps fungiert also als Router/Firewall für mein Heimnetzwerk, kümmert sich um meine Mails und stellt auch
die Proxys/Daemons usw. für drei Rechner zu Verfügung. Er läuft 24 Stunden am Tag 7 Tage die Wochen mit Raspbian und hat noch
kein mal ärger gemacht. Er schaut aber auch Täglich nach Updates und benachrichtigt mich dann per Mail und auch akustisch so
das ich diese auch zeitnah einspiele.

Einzieger Nachteil zu dem stromfressenden PC der das bei mir vorher erledigt hat ich muss den Raps einmal in der Woche (Sonntags)
neu starten da amavis, clamav, und spamassassin viel Speicher benötigen und wenn 30% von meiner Swappation(gesamt 1,5 GB) belegt
sind kann es zu Kernel Fehler oder Panic kommen, aber damit kann ich leben, starte das Ding eben einmal die Woche neu.

Gentoo habe ich aus dem Grund nicht dafür genommen weil das kompilieren auf dem Raps zu lange dauert und ein Server hat bei mir
auch nur zu laufen und keine Arbeit zu machen.

Und zum Schluss, Backup der Karte vom Raps mach ich einmal im Monat mit dd am PC.

MfG
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2079
Location: Konradsreuth (Germany)

PostPosted: Tue Jun 25, 2013 6:20 pm    Post subject: Reply with quote

Ist doch interessant, wie jeder von uns Freaks ein Raspberry Pi am Laufen hat :-D

Auf meinem Raspberry Pi läuft Gentoo, gebaut mit distcc und Portage sowie allen temporären Verzeichnissen zum Bauen über NFS. Genauso mach ich das mit meinem Alix 3D2, und das Ding läuft jetzt mittlerweile seit dem 03.11.2010 als Web-, FTP-, Mail- und svn-Server.

Alles andere als Gentoo ist mir bisher binnen kürzester Zeit auf den Keks gegangen … damals™ hatte ich sogar Gentoo auf meiner NSLU2 laufen, die hab ich aber mittlerweile in den Ruhestand geschickt.
Back to top
View user's profile Send private message
Jean-Paul
Apprentice
Apprentice


Joined: 13 Apr 2009
Posts: 194

PostPosted: Tue Jun 25, 2013 8:07 pm    Post subject: Reply with quote

@Fijoldar,

möchtest du wirklich solche "Fertig-Disti's" wie Ubuntu, Suse oder ROSA (wtf) mit Gentoo vergleichen, wo du fast alles selbst machst ?

Vergleiche sind eher mit Arch, Crux, Lunar, Funtoo, SourceMage oder LFS sinnvoll (wobei Arch da fast schon wieder rausfällt, so wie die Entwicklung der letzten Jahre verlaufen ist) oder meinetwegen ein *BSD.
Aber ich muss dir Recht geben, in punkto Stabilität gibt's kaum was besseres.

Jean-Paul
_________________
”Everything should be made as simple as possible, but no simpler.” – Albert Einstein
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1674
Location: Heidelberg - Germany

PostPosted: Wed Jun 26, 2013 8:02 am    Post subject: Re: Manchmal lernt man Gentoo wieder richtig zu schätzen .. Reply with quote

fuchur wrote:
Hi

Dem kann ich so nicht zustimmen. Bei mir läuft seit Weihnachten ein all in one Server mit Raspbian und ich bin 100% zufrieden,
und der wird richtig gequält.
...


Nun, wenn es bei mir keine Probleme gegeben hätte, wäre ich natürlich auch zufrieden gewesen. Es muß ja nicht bei jedem schiefgehen. Ich würde Raspbian auch nicht als schlecht bezeichnen, jedoch ist mein Vertrauen etwas getrübt.
Ich bin einfach zu dem Schluß gekommen, dass Gentoo doch noch eine Klasse für sich ist.
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 171
Location: GER / FFM

PostPosted: Wed Jun 26, 2013 8:07 am    Post subject: Reply with quote

@Jean-Paul,

ich finde diesen Vergleich gar nicht so schlimm. Ich möchte damit nämlich zeigen, dass die angebliche Einfachheit und Benutzerfreundlichkeit einer Binärdistribution meist nur auf den ersten Blick vorhanden ist. Selbst ein so hoch gelobtes Ubuntu, das angeblich immer ootb funktionieren soll, macht auf Dauer mehr Probleme als mein Gentoo. Wenn man sich einmal die Zeit nimmt und das richtig einrichtet, läuft das absolut rund und macht auch in einem halben Jahr keine Probleme. Ein Ubuntu wird man meist alle 6 Monate aktualisieren müssen und das heißt oft Neuinstallation, da ein Upgrade schnell mal das System zerschießen kann (selbst erlebt).

Vergleiche ich jetzt den Arbeitsaufwand (sagen wir wir in den letzten 12 Monaten) einer Fertig-Distro mit Gentoo, habe ich auf Dauer gesehen mit der Fertig-Distro mehr zu tun als mit Gentoo. So ist zumindest mein Eindruck.
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 171
Location: GER / FFM

PostPosted: Wed Jun 26, 2013 8:55 am    Post subject: Reply with quote

@all,

wäre denn für Gentoo das Beagle Board Black¹ evtl. die bessere Wahl? Zumindest die Daten klingen für mich interessanter. Preislich ist da ja auch kein großer Unterschied zum Raspberry Pi.


¹http://beagleboard.org/Products/BeagleBone%20Black
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1674
Location: Heidelberg - Germany

PostPosted: Wed Jun 26, 2013 11:37 am    Post subject: Reply with quote

Fijoldar wrote:
@all,

wäre denn für Gentoo das Beagle Board Black¹ evtl. die bessere Wahl? Zumindest die Daten klingen für mich interessanter. Preislich ist da ja auch kein großer Unterschied zum Raspberry Pi.


¹http://beagleboard.org/Products/BeagleBone%20Black


Interessante Frage, die Antworten interessieren mich jetzt auch brennend .. :D
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 171
Location: GER / FFM

PostPosted: Wed Jun 26, 2013 3:26 pm    Post subject: Reply with quote

Hier ist ein netter Vergleich: http://www.cnx-software.com/2013/04/25/beaglebone-black-vs-raspberry-pi-features-and-price-comparison/

Sieht so aus, als ob das Beagle Board klar die Nase vorn hat. Einzig der Video-Output ist etwas schlechter. Hier schafft der RPi locker Full HD während sich das BB mit 720p zufrieden geben muss. Aber wer braucht auf so einem kleinen Teil schon Full HD?

------
Ich hoffe, das passt überhaupt noch zum Thema. Ich möchte diesen Thread nämlich keineswegs entführen.
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 563

PostPosted: Wed Jun 26, 2013 4:27 pm    Post subject: Re: Manchmal lernt man Gentoo wieder richtig zu schätzen .. Reply with quote

Hi
Erdie wrote:
...
Nun, wenn es bei mir keine Probleme gegeben hätte, wäre ich natürlich auch zufrieden gewesen. Es muß ja nicht bei jedem schiefgehen. Ich würde Raspbian auch nicht als schlecht bezeichnen, jedoch ist mein Vertrauen etwas getrübt.
Ich bin einfach zu dem Schluß gekommen, dass Gentoo doch noch eine Klasse für sich ist.

Das hatte ich auch so verstanden. Ich hatte auch deshalb mein Konfiguration gepostet weil viele bei
dem Rasp meinen das wenn Fehler auftauchen das es an der Software oder dem Rasp liegen. Ich habe
hier einige Test gemacht und in den entsprechenden Foren/Howtos gelesen und gehe mit grosser Sicherheit
davon aus das sehr viele Fehler an einem Schwachbrüstigen Netzteil liegen. Wenn du an den beiden
Messpunkten am Rasp nicht mindesten immer (auch unter last usw.) 5 Volt oder 0,1 drunter hast ist ärger
vorprogrammiert (habe hier selber einige versuche gestartet). Und viele oder die meisten 5 Volt Netzteile
"liefern" halt an den Messpunkten nur 4.3 bis 4.8 Volt auf dem Rasp ohne Last bzw. nicht durchgehen und das gibt
reproduzierbar Ärger. Empfohlen wird eine Spannung an den Messpunkten von 4,75 bis 5,25 Volt das heisst
bei einer Spannung ohne Last usw. von etwas über 5 Volt war ich immer auf der sicheren Seite (hatte das
über Tage mit der menge an oben geposteten Zusatzgeräten gemessen und war nie unter 4,9 Volt, falls
es jemanden interessieren sollte :).

MfG
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1473
Location: Oranienburg/Germany

PostPosted: Thu Jun 27, 2013 5:59 am    Post subject: Reply with quote

Hallo fuchur,

du hattest etwas geschrieben von einem 4A/5,65V Netzteil. Hast du zufällig einen Link dazu oder ist es etwas "selbstgebautes"? Ich arbeite mit dem original RS Comp Netzteil. Das liefert 1.2A/5V. Mit dem externen powered USB Hub habe ich keine Probleme mit KVM und anderen Komponenten.

MfG. Stefan
_________________
1st: i5-4440 3.1GHz, 16GB, 1.7TB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 320GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB SSD + 3TB RAID5 GF7025
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 32GB SD
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 563

PostPosted: Thu Jun 27, 2013 11:46 am    Post subject: Reply with quote

Hi
bbgermany wrote:
Hallo fuchur,

du hattest etwas geschrieben von einem 4A/5,65V Netzteil. Hast du zufällig einen Link dazu oder ist es etwas "selbstgebautes"? Ich arbeite mit dem original RS Comp Netzteil. Das liefert 1.2A/5V. Mit dem externen powered USB Hub habe ich keine Probleme mit KVM und anderen Komponenten.

MfG. Stefan

Diesen hier: http://www.amazon.de/USB-HUB-UHN3I-400s-Ladeport-Geraete-Netzteil/dp/B006YPFPI2
Aber auch nur das Netzteil von dem 3.0-USB der 2.0-USB von der gleichen Marke hat weniger "Dampf".
Und noch was der Hub ist absoluter Schrott habe 3 Stück davon und keiner Funktioniert und das scheint
auch bekannt zu sein da ich meine auf dem Flohmarkt (bei so einem Händler für Rücklaufware) pro Stück
für 4 Euros erstanden habe (noch Original verpackt) aber nach dem ich das erste Netzteil getestet habe
war mir das egal weil für den Preis kriegt man sonst nicht so ein Netzteil.

MfG
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1069
Location: Buchholz/GER

PostPosted: Thu Jun 27, 2013 8:31 pm    Post subject: Reply with quote

Manchmal lernt man Gentoo wieder richtig zu schätzen ... und heute war wieder einer dieser Tage.

Ein dist-upgrade von oldstable (squeeze) nach stable (wheezy) stand an. Eigentlich ein Selbstgänger, so steht es oft in Blogs geschrieben.
Durchgeführt, mehrfach unterwegs abgebrochen. Schlussendlich ist's dann doch noch durchgelaufen.

  • dovecot - kaputt
  • postgres - kaputt
  • mysql - kaputt
  • syslog - komplett rausgefallen
  • localhost in /etc/hosts - vanished
  • mailman - relay access denied

Nichts, was man nicht in den Griff kriegen kann, aber so geballt am morgen treibt mir das doch den Blutdruck nach oben. Dann doch lieber Gentoo, das ist vielleicht allwöchentlich etwas mehr Arbeit, aber dafür spart man sich diese Hauruck-Aktionen. Und so viele Server, dass ich es wöchentlich nicht mehr bewältigen kann, habe ich nicht.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3485

PostPosted: Thu Jul 04, 2013 7:42 pm    Post subject: Reply with quote

Ich bin inzwischen auch Gentoo diverse Male fremd gegangen, aber es geht einfach nicht ohne. Man kommt einfach nicht davon los wenn man es einmal schätzen gelernt hat. Nur man muss aufpassen das man immer dran bleibt, es ändert sich oft einiges und "Tricks" von früher klappen nicht mehr o.ä.

Einzig auf meinem kleinen Netbook (Samsung NC10) läuft ein LMDE. Da war mir verschlüsseltes Home-Verz. und Suspend to Swap out of the Box wichtig, ohne lange zu basteln. Sicher würde das auch mit Gentoo gehen, aber das Gerät muss einfach funktionieren. Und das ist mir bei Gentoo in Kombination mit meinem Spieltrieb einfach zu heiß. ;)
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1674
Location: Heidelberg - Germany

PostPosted: Fri Jul 05, 2013 11:51 am    Post subject: Reply with quote

Ohh, der gute alte Slick, das man Dich auch nochmal sieht! Wie wäre es mit einem Veteranen - Treffen? Ich habe in über 10 Jahren noch niemanden aus der Community persönlich getroffen. Vielleicht besser nachholen bevor sie (die Community) ganz verschwindet :P
_________________
Desktop Phenom II X4 8GB RAM, Asus GF 430 fanless. Sound RME Multiface + PCI + Cardbus, 2x RME Quadmic, 1x Behringer ADA8000.
2x IBM Thinkpad T60
Zotag Mag Mini Atom
Raspberry Pi
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1069
Location: Buchholz/GER

PostPosted: Sat Jul 06, 2013 9:46 am    Post subject: Reply with quote

Erdie wrote:
Ohh, der gute alte Slick, das man Dich auch nochmal sieht! Wie wäre es mit einem Veteranen - Treffen? Ich habe in über 10 Jahren noch niemanden aus der Community persönlich getroffen. Vielleicht besser nachholen bevor sie (die Community) ganz verschwindet :P

Ich will den Thread nicht endgültig in die falsche Richtung entführen, aber die ganzen "User-Group-Treffen"-Threads sind leider auch alle ziemlich tot. Ich glaube nicht, das es derzeit überhaupt noch Treffen abseits der etaiblierten Messen gibt. Zur Not starte halt mal 'ne Umfrage, ob überhaupt grundsätzlich Interesse daran besteht. Für die meisten dürfte ein zentrales Treffen sicher an der Wegstrecke scheitern.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
tazinblack
l33t
l33t


Joined: 23 Jan 2005
Posts: 925
Location: Baden / Germany

PostPosted: Fri Jul 26, 2013 10:56 am    Post subject: Reply with quote

bbgermany wrote:
Erdie wrote:
Wie lange dauert denn das Kompilieren eines kleinen Paketes auf dem Raspberry PI verglichen mit einem Desktop Rechner?


Was verstehst du unter klein? Für mein Raspberry Pi Gentoo hab ich auf distcc mit crosscompile gesetzt. Hat dafür gesorgt, dass es schneller geht. Und ja, das mit dem System zerschießen kann ich nachvollziehen. Bei mir hat es RaspBMC in die ewigen Jagdgründe geschickt...

MfG. Stefan


Also distcc rein auf amd64 hatte ich auch schon am laufen, aber crosscompile für arm in der Verbindung hab ich nie zum Laufen bekommen.
Das würde mich mal näher interessieren. Hast Du für die toolchain crossdev verwendet? Das lief bei mir immer auf Fehler. Ich finde da gibts auch zu viele Möglichkeiten.
Hast Du da zufällig ne gute Doku zu? Und evtl. noch ne Anleitung wie man das auf dem Raspi einrichtet?

Ich hab gestern bis in die Nacht an meinem zweit Raspi gebastelt um dem endlich stabil UMTS beizubringen unter raspbian und hab bei der Gelegenheit auch schmerzlich ein gentoo vermisst.
Ist noch die RaspiCam dran. Das ganze soll ne WebCam für unseren Verein an einem Baggersee werden.
Leider lief das mit vwdial total instabil. Immer wenn ich ein Bild ins Netz hochladen wollte, ist die Verbindung abgesemmelt.
Jetzt verwende ich das sakis3g skript und jetzt scheints stabil zu laufen. Jetzt muss ich nur noch basteln, dass der beim Booten automatisch verbindet und beim Wegfall von UMTS neu verbindet, dann noch in nen Abzweigkasten und los gehts. Bin echt mal gespannt, mit was für Problemen ich noch zu kämpfen habe.
_________________
Gruß / Regards
tazinblack
_______________________________________________________
told you so
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1473
Location: Oranienburg/Germany

PostPosted: Fri Jul 26, 2013 8:01 pm    Post subject: Reply with quote

Hi,

Es ist schon eine Weile her, aber vielleicht bekomme ich das noch zusammen. Also ich habe als erstes mit Crossdev die Toolchain gebastelt. Das war eigentlich der problematische Teil, weil es eine zeitl ang immer Probleme bei mir gab, den GCC passend zu übersetzen. Danach noch DISTCC installiert und schon ging das. Man muss jedoch bedenken, dass wie immer mit DISTCC nicht alle Pakete sich verteilen lassen. Besonders ärgerlich ist das bei eine Paket wie GCC. Das dauert dann halt ewig. Den Kernel hab ich dann meistens auf der x86/x86_64 Maschine übersetzt. Das ging wesentlich schneller.

Ich hatte auch mal versucht BINPKGs zu erzeugen, jedoch wanderten viele bei mir nicht durch den Compiler und dann hilft das auch nicht wirklich weiter.

MfG. Stefan
_________________
1st: i5-4440 3.1GHz, 16GB, 1.7TB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 320GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB SSD + 3TB RAID5 GF7025
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 32GB SD
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1069
Location: Buchholz/GER

PostPosted: Sat Jul 27, 2013 5:21 am    Post subject: Reply with quote

Ich glaube, ich hatte seinerzeits das hier probiert, musste dann aber irgendwann abbrechen, weil mein natives x86_64-Setup irgendwie durcheinander geriet. Keine Ahnung, ob ich unterwegs vom Weg abgekommen bin, oder ob das HOWTO fehlerhaft ist. Am Ende drohte jedenfalls alles durcheinander zu geraten und ich wusste nicht mehr so recht, wo oben und unten ist.

Ich wollte es dann irgendwann nochmal sauber angehen ... bei dem Wunsch ist es bislang allerdings geblieben.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1952
Location: My own world! I and Gentoo!

PostPosted: Sat Jul 27, 2013 11:05 am    Post subject: Reply with quote

cryptosteve wrote:
Ich glaube, ich hatte seinerzeits das hier probiert, musste dann aber irgendwann abbrechen, weil mein natives x86_64-Setup irgendwie durcheinander geriet. Keine Ahnung, ob ich unterwegs vom Weg abgekommen bin, oder ob das HOWTO fehlerhaft ist. Am Ende drohte jedenfalls alles durcheinander zu geraten und ich wusste nicht mehr so recht, wo oben und unten ist.

Ich wollte es dann irgendwann nochmal sauber angehen ... bei dem Wunsch ist es bislang allerdings geblieben.


Ich nutze für distcc-crosscompile diesen Tut:
http://www.gentoo.org/doc/de/cross-compiling-distcc.xml

(zzgl zu der crossdev Magic)
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum