Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Lets Talk about Ruby and Gems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1828
Location: Germany

PostPosted: Thu Jun 13, 2013 12:35 pm    Post subject: Lets Talk about Ruby and Gems Reply with quote

Hi all,

today i thought i could restart my investigation on ruby on rails learning, cause there will be a nice talk on the next signit 2013 in cologne. To refresh my ruby-languages skills and ruby on rails playground i want to start with some basics.

Oh what's this? My Gentoo have no up to date packages and actually no maintainer for ruby packages? What about using gem to handle these updates? There is a gentoo bug about security reason's that Rubygems will overwrite binarys in /usr/bin so, i am not sure how to handle this well.

Ill take a look on Archlinux and Ubuntu and how they handle there ruby-installations. But i would prefer a clean solution.

The first time i used rubygems i thought it create just some additional files for the binarys in the users directory. Too bad if the usage of Rubygems is insecure.

If i trust the Rubygems maintainers why shouldn't i use RubyGems? I play with the thought to remove all ruby packages in gentoo and download and install it manually from the web. Could i brake some installations, cause gnome3 or other packages use ruby through the gentoo packages?

Thanks for your time,

Chris
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Thu Jun 13, 2013 2:56 pm    Post subject: Re: Lets Talk about Ruby and Gems Reply with quote

ChrisJumper wrote:
My Gentoo have no up to date packages


You can file bugs about that.

ChrisJumper wrote:
actually no maintainer for ruby packages?


There is the ruby herd. Though, that herd might be a bit undermanned.

ChrisJumper wrote:
What about using gem to handle these updates?


Nope, they can't do that as external tools aren't allowed to fetch things during emerges; so, they fake gem installations.

ChrisJumper wrote:
There is a gentoo bug about security reason's that Rubygems will overwrite binarys in /usr/bin so, i am not sure how to handle this well.


You either use Portage, or you don't; there is no mixed solution.

ChrisJumper wrote:
Ill take a look on Archlinux and Ubuntu and how they handle there ruby-installations. But i would prefer a clean solution.


The clean way is to use Portage. I can't comment on other practices, we don't support them and you would be on your own...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum