Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto] gdm bloccato e X non si avvia con utente normale
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
pingoo
Guru
Guru


Joined: 11 Jul 2006
Posts: 324

PostPosted: Wed Jun 05, 2013 6:08 am    Post subject: [risolto] gdm bloccato e X non si avvia con utente normale Reply with quote

Dovendo portare il notebook in assistenza mi son creato lo "stage4" che al ritorno ho utilizzato per l'installazione. Stavolta però qualcosa sembra essere andata storta, gdm si avvia ma visualizza solo il cursore occupato, mentre se provo ad avviare X da utente normale ottengo:
Code:
xauth: file /home/<user>/.serverauth.20440 does not exist
Fatal server error: cannot move old file "/var/log/Xorg.1.log" to "/var/log/Xorg.1.log.old"
(EE)
Con root invece X parte regolarmente. Qualche info considerando anche che prima della reinstallazione tutto funzionava normalmente:
Code:
 $ groups <user>
wheel audio video usb users plugdev <user>

Code:
# mount
rootfs on / type rootfs (rw)
/dev/sda6 on / type ext4 (rw,noatime,data=ordered)    << no nosuid
proc on /proc type proc (rw,relatime)
tmpfs on /run type tmpfs (rw,nosuid,nodev,relatime,mode=755)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=10240k,nr_inodes=494669,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
shm on /dev/shm type devtmpfs (rw,nosuid,nodev,noexec,relatime,size=10240k,nr_inodes=494669,mode=755)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
cgroup_root on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,size=10240k,mode=755)
openrc on /sys/fs/cgroup/openrc type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib64/rc/sh/cgroup-release-agent.sh,name=openrc)
cpuset on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cpu on /sys/fs/cgroup/cpu type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
cpuacct on /sys/fs/cgroup/cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
freezer on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
/dev/sda7 on /home type ext4 (rw,noatime)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,nodev,noexec,nosuid)
/dev/sda5 on /root/TMP type ext4 (rw)

Code:
 $ cat /etc/fstab
# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>
/dev/sda6               /               ext4            noatime         0 1
/dev/sda7               /home           ext4            noatime         0 1

proc        /proc        proc    defaults             0 0
shm         /dev/shm     devtmpfs   nodev,nosuid,noexec  0 0

Avete qualche idea su cosa fare/controllare?


Last edited by pingoo on Wed Jun 05, 2013 3:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
doom555
n00b
n00b


Joined: 29 Oct 2012
Posts: 57

PostPosted: Wed Jun 05, 2013 10:24 am    Post subject: Reply with quote

Mi vien da pensare che possa trattarsi di qualche problema di permessi, non sono stati correttamente preservati durante la creazione dello stage4 o durante il suo ripristino.
Me lo fa credere questa riga:
Code:
Fatal server error: cannot move old file "/var/log/Xorg.1.log" to "/var/log/Xorg.1.log.old"
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2908
Location: Parma (Italy)

PostPosted: Wed Jun 05, 2013 11:13 am    Post subject: Reply with quote

io controllerei permessi e anche corrispondenza tra groups e i vari groups id

a me è capitato che i gruppi games e printers (e magari altri di cui non mi sono mai accorto) in un pc e nell'installazione clonata (via stage4) da questo differissero, causando assegnazioni balorde di permessi ai file.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
pingoo
Guru
Guru


Joined: 11 Jul 2006
Posts: 324

PostPosted: Wed Jun 05, 2013 2:05 pm    Post subject: Reply with quote

Sì, deve essere un qualche tipo di permesso. Ho dato un'occhiata a /etc/group e mi pare a posto
Code:
 /etc/group
adm:x:4:root,adm,daemon
audio:x:18:pulse,<mio_utente>
bin:x:1:root,bin,daemon
cdrom:x:19:
cdrw:x:80:
colord:x:248:
console:x:17:
daemon:x:2:root,bin,daemon
<mio_utente>:x:1000:
disk:x:6:root,adm
floppy:x:11:root
gdm:x:103:
kdm:x:996:
kmem:x:9:
kvm:x:999:
lpadmin:x:106:
lp:x:7:lp
mail:x:12:
man:x:15:
mem:x:8:
messagebus:x:249:
news:x:13:news
nobody:x:65534:
nogroup:x:65533:
plugdev:x:247:<mio_utente>
polkitd:x:997:
portage:x:250:portage
postmaster:x:102:
pulse-access:x:105:
pulse:x:104:
root:x:0:root
sshd:x:22:
ssmtp:x:101:
sys:x:3:root,bin,adm
tape:x:26:root
tty:x:5:
usb:x:85:<mio_utente>
users:x:100:<mio_utente>
utmp:x:406:
uucp:x:14:uucp
vboxusers:x:998:
video:x:27:root,gdm,<mio_utente>
wheel:x:10:root,<mio_utente>
e grpck termina senza alcun messaggio. Anche in /etc/passwd non noto nulla ma non saprei:
Code:
/etc/passwd
adm:x:3:4:adm:/var/adm:/bin/false
bin:x:1:1:bin:/bin:/bin/false
colord:x:102:248:added by portage for colord:/var/lib/colord:/sbin/nologin
daemon:x:2:2:daemon:/sbin:/bin/false
<mio_utente>:x:1000:1000::/home/<mio_utente>:/bin/bash
gdm:x:104:103:added by portage for gdm:/var/lib/gdm:/sbin/nologin
halt:x:7:0:halt:/sbin:/sbin/halt
kdm:x:106:996:added by portage for kdm:/var/lib/kdm:/sbin/nologin
lp:x:4:7:lp:/var/spool/lpd:/bin/false
mail:x:8:12:added by portage for mailbase:/var/spool/mail:/sbin/nologin
man:x:13:15:added by portage for man:/usr/share/man:/sbin/nologin
messagebus:x:101:249:added by portage for dbus:/dev/null:/sbin/nologin
news:x:9:13:news:/var/spool/news:/bin/false
nobody:x:65534:65534:nobody:/var/empty:/bin/false
operator:x:11:0:operator:/root:/bin/bash
polkitd:x:105:997:added by portage for polkit:/var/lib/polkit-1:/sbin/nologin
portage:x:250:250:portage:/var/tmp/portage:/bin/false
postmaster:x:14:102:added by portage for mailbase:/var/spool/mail:/sbin/nologin
pulse:x:103:104:added by portage for pulseaudio:/var/run/pulse:/sbin/nologin
root:x:0:0:root:/root:/bin/bash
shutdown:x:6:0:shutdown:/sbin:/sbin/shutdown
sshd:x:22:22:added by portage for openssh:/var/empty:/sbin/nologin
sync:x:5:0:sync:/sbin:/bin/sync
uucp:x:10:14:uucp:/var/spool/uucp:/bin/false


EDIT: non facendocela più senza gentoo, mi sono messo a ricompilare diversi pacchetti, in particolare il problema si è risolto dopo che ho rimosso polkit e ricompilato di revdep-rebuild e ricompilando xinit. Grazie
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum