Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Injecting packages of a world file from previous machine
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jeffk
Guru
Guru


Joined: 13 Sep 2003
Posts: 589

PostPosted: Sun Aug 02, 2009 5:10 am    Post subject: Injecting packages of a world file from previous machine Reply with quote

I rebuild my laptop's Gentoo ~x86 to ~x86-64. To make the initial emerge more hands-off, I reused the old world file. Several weeks later, I still get some packages which do not emerge with my daily update regime of emerge world -Du --newuse -pv.

For example, today:
Code:
# emerge -e world -p | grep ' U '
[ebuild     U ] perl-core/IO-Zlib-1.10 [1.09]
[ebuild     U ] virtual/perl-IO-Zlib-1.10 [1.09]
[ebuild     U ] perl-core/ExtUtils-CBuilder-0.26.03 [0.26.02]
[ebuild     U ] virtual/perl-ExtUtils-CBuilder-0.26.03 [0.26.02]
[ebuild     U ] perl-core/ExtUtils-ParseXS-2.20-r1 [2.20]
[ebuild     U ] app-text/docbook-xsl-stylesheets-1.75.2 [1.75.1]
[ebuild     U ] dev-python/setuptools-0.6_rc9-r1 [0.6_rc9]
[ebuild     U ] net-nds/openldap-2.4.17-r1 [2.3.43-r1] USE="berkdb* gnutls%* -cxx% -experimental% -icu% -iodbc% -syslog%"
[ebuild     U ] x11-drivers/nvidia-drivers-185.18.31 [185.18.14]
[ebuild     U ] media-video/nvidia-settings-185.18.31 [180.60]
[ebuild     U ] dev-util/cmake-2.6.4-r2 [2.6.4] USE="-python3%"

Likewise, a few days ago, "emerge gnome" emerged updates to several gnome component files that didn't select with emerge world -Du --newuse -pv.

Any suggested course of action to inject the necessary packages, etc which would correct this?

Thanks.
Back to top
View user's profile Send private message
cyrillic
Watchman
Watchman


Joined: 19 Feb 2003
Posts: 7301
Location: Groton, Massachusetts USA

PostPosted: Sun Aug 02, 2009 8:39 pm    Post subject: Re: Injecting packages of a world file from previous machine Reply with quote

jeffk wrote:
Several weeks later, I still get some packages which do not emerge with my daily update regime of emerge world -Du --newuse -pv.

Try adding "--with-bdeps=y" to your other emerge world options.
Back to top
View user's profile Send private message
jeffk
Guru
Guru


Joined: 13 Sep 2003
Posts: 589

PostPosted: Mon Aug 03, 2009 6:33 pm    Post subject: Reply with quote

Thanks, that does bring in some interesting build-time dependencies, I hadn't noticed with-bdeps before:
Code:
# emerge world -Du --newuse -pv --with-bdeps=y
These are the packages that would be merged, in order:
Calculating dependencies ... done!
[ebuild     U ] x11-base/xorg-server-1.6.3 [1.6.2.901] USE="dmx hal ipv6 kdrive nptl sdl xorg -debug -minimal -tslib" INPUT_DEVICES="evdev -acecad -aiptek -citron -elographics -fpit -hyperpen -joystick -keyboard -mouse -mutouch -penmount -synaptics -tslib -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="fbdev nvidia vesa -apm -ark -ast -chips -cirrus -dummy -epson -fglrx (-geode) -glint -i128 (-i740) (-impact) (-imstt) -intel -mach64 -mga -neomagic (-newport) -nv -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l (-vermilion) -via -virtualbox -vmware -voodoo (-xgi)" 4,543 kB
[ebuild     U ] x11-drivers/xf86-input-evdev-2.2.3 [2.2.2] USE="-debug" 290 kB
[ebuild     U ] x11-drivers/xf86-video-vesa-2.2.1 [2.2.0] USE="-debug" 244 kB
[ebuild     U ] x11-drivers/nvidia-drivers-185.18.31 [185.18.14] USE="acpi gtk (multilib) -custom-cflags" 0 kB

I'm not sure it's selecting the same set I'm missing from the found world file, however, as emerge -e gnome still brings in new dependencies (or tries to, as some are presently blockers).
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7810
Location: Somewhere over Atlanta, Georgia

PostPosted: Mon Aug 03, 2009 7:25 pm    Post subject: Reply with quote

jeffk wrote:
Any suggested course of action to inject the necessary packages, etc which would correct this?
Why, yes! This one-liner will build everything in world that isn't actually installed:
Code:
cat /var/lib/portage/world | xargs emerge -v --noreplace
It'll also install any missing dependencies. :wink:

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
tobibobi
n00b
n00b


Joined: 20 Jan 2011
Posts: 25
Location: Odense, Denmark

PostPosted: Sun Feb 02, 2014 9:33 am    Post subject: --inject not supported anymore? Reply with quote

I was trying to build my own package and then have portage assume the package was already provided.

But following the documentation for emerge didnt help me a lot because packages.provided seems to be ignored and emerge --inject is not a recognized option..

Is threre a new procedure for this?

Br Tobias.
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9009

PostPosted: Sun Feb 02, 2014 5:19 pm    Post subject: Re: --inject not supported anymore? Reply with quote

tobibobi wrote:
I was trying to build my own package and then have portage assume the package was already provided.

But following the documentation for emerge didnt help me a lot because packages.provided seems to be ignored and emerge --inject is not a recognized option..

Is threre a new procedure for this?

Br Tobias.
You are in the wrong thread. This thread is old and solved. This thread does not deal with /etc/portage/profile/package.provided, which is still supported. However, unless you are simply unable to build the named package on your architecture and wish to use an equivalent package, you would be better off using a local overlay to build the package and let Portage manage it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum