Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3 in Fallback Mode
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Edska
n00b
n00b


Joined: 09 Apr 2012
Posts: 17

PostPosted: Tue May 21, 2013 4:14 pm    Post subject: Gnome 3 in Fallback Mode Reply with quote

Hello guys.

I am having some problems with gnome. It always starts in fallback mode. I don't want to use fallback mode. I have ATI Radeon HD 7770 video card. I installed open source Radeon drivers using this article http://wiki.gentoo.org/wiki/Radeon

Couple of days I can't find a solution. Here are some info:

Code:
Gentoo ~ # glxinfo | grep renderer
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.2, 128 bits)


Code:
Gentoo ~ # glxinfo | grep rendering
direct rendering: Yes


Code:
Gentoo ~ # /usr/libexec/gnome-session-check-accelerated-helper
gnome-session-is-accelerated: No hardware 3D support.


opengl is set to xorg-X11

Here is my Xorg.0.log http://pastebin.com/2x7uJuYv
Back to top
View user's profile Send private message
salahx
Guru
Guru


Joined: 12 Mar 2005
Posts: 395

PostPosted: Tue May 21, 2013 5:54 pm    Post subject: Reply with quote

Ok direct rendering seems to be enabled but its indicating the software rendering is being used.

This is a new card, so make sure you have the "glamor" USE flag on x11-drivers/xf86-video-ati enabled. Then you need to add the follow to your X11 config:
Code:

Section "Module"
        Load "dri2"
        Load "glamoregl"
EndSection

Section "Device"
        Identifier "Radeon"
        Driver "Radeon"
        Option "AccelMethod" "glamor"
EndSection


If that doesn't fix it, try Mesa next: check your USE flags (VIDEO_CARDS) in particular (radeonsi in this case).
Back to top
View user's profile Send private message
Edska
n00b
n00b


Joined: 09 Apr 2012
Posts: 17

PostPosted: Tue May 21, 2013 6:40 pm    Post subject: Reply with quote

So I added glamor use flag to x11-drivers/xf86-video-ati and emerged with new flags. I can't find /etc/X11/xorg.conf file. Now I can see new file in /usr/share/X11/xorg.conf.d/glamor.conf which containts this code as you wrote:

Code:
Section "Module"
        Load "dri2"
        Load "glamoregl"
EndSection


Where I have to put other part of your suggested code?

Code:
Section "Device"
        Identifier "Radeon"
        Driver "Radeon"
        Option "AccelMethod" "glamor"
EndSection


Directory /usr/share/X11/xorg.conf.d contains two files:
glamor.conf and 10-evdev.conf
Back to top
View user's profile Send private message
Edska
n00b
n00b


Joined: 09 Apr 2012
Posts: 17

PostPosted: Tue May 21, 2013 6:50 pm    Post subject: Reply with quote

I added device info in 40-monitor.conf file and now i get error:

Code:
failed to open /usr/lib64/dri/radeonsi_dri.so : No such file or directory


Directory /usr/lib64/dri/ contains these files:

r200_dri.so
r300_dri.so
r300g_dri.so
r600_dri.so
r600g_dri.so
radeon_dri.so
Back to top
View user's profile Send private message
salahx
Guru
Guru


Joined: 12 Mar 2005
Posts: 395

PostPosted: Tue May 21, 2013 7:12 pm    Post subject: Reply with quote

You need to add radeonsi to VIDEO_CARDS and re-emerge mesa.
Back to top
View user's profile Send private message
Edska
n00b
n00b


Joined: 09 Apr 2012
Posts: 17

PostPosted: Tue May 21, 2013 7:16 pm    Post subject: Reply with quote

I have radeonsi all the time since I did this tutorial http://wiki.gentoo.org/wiki/Radeon My VIDEO_CARDS="radeon radeonsi"
Back to top
View user's profile Send private message
Edska
n00b
n00b


Joined: 09 Apr 2012
Posts: 17

PostPosted: Tue May 21, 2013 7:44 pm    Post subject: Reply with quote

emerge -pqv mesa shows

VIDEO_CARDS="radeon -i915 -i964 -intel inouveau -r100 -r200 -r300 -r600 (-radenosi) -vmware"

When I try emerge like that:

VIDEO_CARDS="radeon radeonsi" emerge mesa - nothing changes

but when I try

VIDEO_CARDS="radeonsi" emerge mesa - it tries to drop radeon support ant things that it has radeonsi

[ebuild R ] media-libs/mesa-9.1.2-r1 VIDEO_CARDS="-radeon*"
Back to top
View user's profile Send private message
salahx
Guru
Guru


Joined: 12 Mar 2005
Posts: 395

PostPosted: Tue May 21, 2013 9:58 pm    Post subject: Reply with quote

radeonsi is use.masked on your system. That's why it doesn't work. Its not use.masked on mine, though. The reason being is because I'm on stable and you're on unstable.

If we look in /usr/portage/profiles/base/package.use.mask we found out why:
Code:

# Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org> (19 Mar 2013)
# Depends on llvm-3.3 which is not in ~arch yet
=media-libs/mesa-9.1* r600-llvm-compiler video_cards_radeonsi


So unmasking the flag alone won't help us here. So at this point you've got 2 options: Pull in missing dependencies from elsewhere (possibly an overlay) and unmask the USE flag (via /etc/portage/package.profiles/use.mask), or revert to stable mesa (which can cause of a chain reaction of other packages needing to be reverted)
Back to top
View user's profile Send private message
Edska
n00b
n00b


Joined: 09 Apr 2012
Posts: 17

PostPosted: Wed May 22, 2013 2:52 pm    Post subject: Reply with quote

I unflaged that flag for mesa with radeonsi and tried to emerge mesa again. It installed radeonsi_dri.so drivers, but now when I try to launch startx I get black screen. No errors, nothing is missing, but nothing starts :) Xorg log always ends with "Backtrace:"

Xorg.0.log - http://bpaste.net/show/100989
Back to top
View user's profile Send private message
Edska
n00b
n00b


Joined: 09 Apr 2012
Posts: 17

PostPosted: Wed May 22, 2013 3:36 pm    Post subject: Reply with quote

When I remove this line:

Code:
Option "AccelMethod" "glamor"


gnome loads in fallback mode. With that line I have black screen with freezed white corsor mark in top left corner.
Back to top
View user's profile Send private message
dragos240
Apprentice
Apprentice


Joined: 19 Apr 2009
Posts: 231

PostPosted: Mon Aug 12, 2013 9:14 pm    Post subject: Reply with quote

Hello,

Sorry to gravedig, but my problem is the exact same one down to the smallest detail with the exception of my card, which is the 7970M. As with Edska, I've removed the "Option "AccelMethod" "glamor" line and it allows me to do what I was doing before without reinstalling things. When the line is present, the screen is black with a white cursor in the upper left hand corner. Checking in /var/log/Xorg.log.0 reveals nothing unusual, it looks as though everything is normal, but X doesn't launch.

-Dragos240
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum