Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nm-applet as user fails, as root works
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1242
Location: 42.68n 85.41w

PostPosted: Mon May 20, 2013 4:55 am    Post subject: nm-applet as user fails, as root works Reply with quote

1st a bit about my system...

grub2 > linux 3.9.2 > systemd > xdm execing gdm

network manager is running. as a user running nm-applet from terminal produces this...

Code:

** (nm-applet:2740): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Rejected send message, 2 matched rules; type="method_call", sender=":1.29" (uid=1000 pid=2740 comm="nm-applet ") interface="org.freedesktop.DBus.Properties" member="GetAll" error name="(unset)" requested_reply="0" destination="org.freedesktop.NetworkManager" (uid=0 pid=1900 comm="/usr/sbin/NetworkManager --no-daemon ")
** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area
** Message: applet now removed from the notification area


rebuilding dbus-glib does not resolve this. (this entire build of gentoo is kinda rubbing me the wrong way, i keep trying to send a background to grub2 and tell it another resolution but it wont do anything other than like 640x480 with generic text)[/code]
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
wswartzendruber
Veteran
Veteran


Joined: 23 Mar 2004
Posts: 1227
Location: Jefferson, USA

PostPosted: Mon May 20, 2013 5:15 am    Post subject: Reply with quote

Damnit. I had this same problem awhile back. I think it was a ConsoleKit vs. systemd issue. I'll post if I remember what I did to fix it.
Back to top
View user's profile Send private message
paulusbrand
Tux's lil' helper
Tux's lil' helper


Joined: 20 May 2009
Posts: 96

PostPosted: Fri Jun 14, 2013 4:15 pm    Post subject: Reply with quote

https://bbs.archlinux.org/viewtopic.php?pid=1122362#p1122362

solved it for me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum