Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problème de conflits lors de l'installation de systemd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Sat May 18, 2013 10:42 am    Post subject: problème de conflits lors de l'installation de systemd Reply with quote

Salut salut!

Bon, je sais que ce sujet va faire hérisser les cheuveux de plus d'un, mais soit! Bon, j'suis en train de faire une nouvelle installation et je souhaite installer systemd, sauf que là, c'est le drame! C'est excessivement compliqué, y'a des blocages et des conflits dans tous les sens et le wiki ne mentionne même pas ces problèmes!

Donc, pour l'instant, j'ai ça désinstallé consolekit, packagekit, mis -systemd -udev -consolekit -packagekit dans les use flags, mais ça n'aboutit pas! J'ai aussi du rajouter le flag udev pour le paquet hwids car sinon, ça gueulait.

J'vais vous copier la sortie de la commande, mais ça ne va pas vous plaire non plus :lol: c'est du paludis...

Quoiqu'il en soit, un coup de main serait vivement apprécié! sytemd remplace (inclus) udev,consolekit,pakagekit si je n'm'abuse, y'a d'autre chose auquelles je n'ai pas pensé?

cave resolve systemd:
cave resolve sys-apps/systemd
Done: 1125 steps             

These are the actions I will take, in order:

r   sys-apps/hwids:0::gentoo 20130514 to ::installed replacing 20130514
    udev* build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: sys-apps/systemd-204:0::gentoo, x11-libs/libpciaccess-0.13.1-r1:0::installed

s   app-text/docbook-xml-dtd:4.2::gentoo 4.2-r2 to ::installed [cycle 1]
    "Docbook DTD for XML"
    build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: sys-apps/systemd-204:0::gentoo
    76.59 kBytes to download
    In dependency cycle with existing packages: app-text/docbook-xml-dtd:4.2, sys-apps/systemd:0, net-libs/libmicrohttpd:0

n   net-libs/libmicrohttpd:0::gentoo 0.9.27 to ::installed [cycle 1]
    "A small C library that makes it easy to run an HTTP server as part of another application."
    -messages ssl -static-libs (-test) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: sys-apps/systemd-204:0::gentoo
    858.92 kBytes to download

n   sys-apps/systemd:0::gentoo 204 to ::installed [cycle 1]
    "System and service manager for Linux"
    acl -audit cryptsetup -doc -firmware-loader gcrypt -gudev http introspection keymap kmod lzma -openrc pam -policykit python -qrcode (-selinux) -static-libs -tcpd -van
illa xattr (-test) PYTHON_SINGLE_TARGET: python2_7 PYTHON_TARGETS: python2_7 build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: target

Total: 1 reinstalls, 1 new slot installs, 2 new installs, 935.51 kBytes to download

Build Options:
    dwarf_compress:                Compress DWARF2+ debug information
    optional_tests:                Run tests considered by the package to be optional
    symbols:                       How to handle debug symbols in installed files
    trace:                         Trace actions executed by the package (very noisy, for debugging broken builds only)
    work:                          Whether to preserve or remove working directories

USE:
    acl:                           Adds support for Access Control Lists
    audit:                         Enable support for sys-process/audit
    cryptsetup:                    Use libcryptsetup
    doc:                           Adds extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally
    firmware-loader:               Enable user-space firmware loader (for kernels prior to 3.8)
    gcrypt:                        Enable sealing of journal files using gcrypt
    gudev:                         enable libudev gobject interface
    http:                          Enable embedded HTTP server in journald
    introspection:                 Adds support for GObject based introspection
    keymap:                        Map custom hardware's multimedia keys
    kmod:                          Enable kernel module loading via sys-apps/kmod
    lzma:                          Support for LZMA (de)compression algorithm
    messages:                      enable error messages
    openrc:                        Depend on sys-fs/udev-init-scripts
    pam:                           Adds support for PAM (Pluggable Authentication Modules) - DANGEROUS to arbitrarily flip
    policykit:                     Enable PolicyKit authentication support
    python:                        Adds optional support/bindings for the Python language
    qrcode:                        Enable qrcode output support in journal
    selinux:                       !!internal use only!! Security Enhanced Linux support, this must be set by the selinux profile or breakage will occur
    ssl:                           Adds support for Secure Socket Layer connections
    static-libs:                   Build static libraries
    tcpd:                          Adds support for TCP wrappers
    test:                          Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2 handles this internally, so don't set it in make.conf/pa
ckage.use anymore
    udev:                          Enable sys-fs/udev integration (device discovery, power and storage device support, etc)
    vanilla:                       Disable Gentoo-specific behavior and compatibility quirks
    xattr:                         Adds support for extended attributes (filesystem-stored metadata)

python_single_target:
    python2_7:                     Build for Python 2.7 only

python_targets:
    python2_7:                     Build with Python 2.7

I encountered the following errors:

!   sys-fs/udev
    Reasons: !<sys-fs/udev-133 from sys-apps/openrc-0.11.8:0::installed, !<sys-fs/udev-186 from sys-fs/udev-init-scripts-26:0::installed, !sys-fs/udev from sys-apps/syste
md-204:0::gentoo, virtual/udev-197-r3:0::installed
    Unsuitable candidates:
      * sys-fs/udev-127:0::layman (in ::v-fox)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !<sys-fs/udev-133, use existing if possible, installing to / (nothing is fine too) from !<sys-fs/udev-133 from sys-apps/openrc-0.11.8:0::installed
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
      * sys-fs/udev-151-r1:0::layman (in ::embedded-cross)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
      * sys-fs/udev-171-r5:0::layman (in ::emg-overlay)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
      * sys-fs/udev-171-r5:0::layman (in ::sabayon-distro)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
      * sys-fs/udev-189:0::layman (in ::sabayon-distro)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
      * sys-fs/udev-189:0::layman (in ::udev)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
      * sys-fs/udev-190:0::layman (in ::udev)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
      * sys-fs/udev-195:0::layman (in ::udev)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
      * sys-fs/udev-197-r4:0::layman (in ::sabayon-distro)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
      * sys-fs/udev-197-r8:0::layman (in ::poly-c)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
            Flag 'introspection' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'; Flag 'keymap' enabled if it is enabled for 'virtual/udev-197-r3:0::insta
lled'; Flag 'kmod' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'
      * sys-fs/udev-197-r8:0::layman (in ::sabayon-distro)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
            Flag 'introspection' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'; Flag 'keymap' enabled if it is enabled for 'virtual/udev-197-r3:0::insta
lled'; Flag 'kmod' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'
      * sys-fs/udev-197-r8:0::gentoo
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
      * sys-fs/udev-200:0::layman (in ::poly-c)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
            Flag 'introspection' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'; Flag 'keymap' enabled if it is enabled for 'virtual/udev-197-r3:0::insta
lled'; Flag 'kmod' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'
      * sys-fs/udev-200:0::gentoo
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
      * sys-fs/udev-201:0::layman (in ::poly-c)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
            Flag 'introspection' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'; Flag 'keymap' enabled if it is enabled for 'virtual/udev-197-r3:0::insta
lled'; Flag 'kmod' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'
      * sys-fs/udev-202:0::layman (in ::poly-c)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
            Flag 'introspection' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'; Flag 'keymap' enabled if it is enabled for 'virtual/udev-197-r3:0::insta
lled'; Flag 'kmod' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'
      * sys-fs/udev-203:0::layman (in ::poly-c)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
            Flag 'introspection' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'; Flag 'keymap' enabled if it is enabled for 'virtual/udev-197-r3:0::insta
lled'; Flag 'kmod' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'
      * sys-fs/udev-204:0::layman (in ::poly-c)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
            Flag 'introspection' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'; Flag 'keymap' enabled if it is enabled for 'virtual/udev-197-r3:0::insta
lled'; Flag 'kmod' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'
      * sys-fs/udev-204:0::gentoo
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
      * sys-fs/udev-9999:0::layman (in ::udev)
        Masked by unavailable (In a repository which is unavailable)
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo
        Did not meet >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?], use existing if possible, installing to / from virtual/udev-19
7-r3:0::installed
            Flag 'introspection' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'; Flag 'keymap' enabled if it is enabled for 'virtual/udev-197-r3:0::insta
lled'; Flag 'kmod' enabled if it is enabled for 'virtual/udev-197-r3:0::installed'
      * sys-fs/udev-9999:0::gentoo
        Masked by keyword
            Keywords
        Did not meet !sys-fs/udev, use existing if possible, installing to / (nothing is fine too) from !sys-fs/udev from sys-apps/systemd-204:0::gentoo


help! :!:
_________________
The End of the Internet!
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 819

PostPosted: Sat May 18, 2013 2:01 pm    Post subject: Reply with quote

J'ai pas trop l'habitude des logs paludis, mais déjà tu peut tenter d'unmasquer les usesflags systemd de certains paquets, ça permettra normalement d'utiliser systemd comme dépendances à la place de consolekit.

/etc/portage/profile/package.use.mask/systemd
Code:

sys-auth/polkit -systemd
sys-power/upower -systemd
media-sound/pulseaudio -systemd
sys-fs/udisks -systemd

il s'agit bien de -systemd vu qu'on masques un masque :P

Après depuis peu systemd est dans virtual/udev, donc udev va devoir sauter, pour éviter que portage/paludis gueule il faut que systemd ai les mêmes useflags que virtual/udev.

J'ai une installation parfaitement fonctionnelle de systemd, mais elle date d'avant l’intégration de udev, j'ai juste conservé les paquets sysvinit et openrc, gentoo n’est pas encore prêt pour rendre ces dépendances optionnelles (mais ça progresse tous les jours)
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Sat May 18, 2013 5:20 pm    Post subject: Reply with quote

Merci pour ta réponse! Curieusement, l'option systemd n'est pas masquée chez moi, pourtant mon profile est supposé être standart! ( default/linux/amd64/13.0/desktop)

En attendant, je suis parvenu à installer systemd en feintant comme un vieux port! j'ignore où ça va me mener tout ça! Probablement sur un système non bootable!
_________________
The End of the Internet!
Back to top
View user's profile Send private message
El_Goretto
Advocate
Advocate


Joined: 29 May 2004
Posts: 2876
Location: Paris

PostPosted: Sun May 19, 2013 11:11 am    Post subject: Reply with quote

truc wrote:
En attendant, je suis parvenu à installer systemd en feintant comme un vieux port!

Un vieux porc, nom d'un gruik! :P
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, ARC1220+5xWD500RE3, M4 256Go
-Home servers (hardened): µ-serv N40L, 2Go ECC ; NF9D-2700, 4Go ; DS61, i3 2100T, 16Go
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
http://boycottsystemd.org/
Back to top
View user's profile Send private message
truc
Advocate
Advocate


Joined: 25 Jul 2005
Posts: 3199

PostPosted: Sun May 19, 2013 8:45 pm    Post subject: Reply with quote

El_Goretto wrote:
truc wrote:
En attendant, je suis parvenu à installer systemd en feintant comme un vieux port!

Un vieux porc, nom d'un gruik! :P


Roh j'ai honte!

T'aurais pu m'envoyer un pm au moins que je corrige ni vu ni connu! :P :oops: :wink:


Bon, sinon, j'n'ai pas poursuit mes aventures et n'ai donc pas encore redémarré... par contre, juste un commentaire en passant, du coup, ça fait un moment que j'm'étais lancé avec exherbo (v'savez, la distrib des extremistes à l'origine de paludis, tout ça), alors, exherbo, c'est nice, mais niveau disponibilité de soft, c'est pas encore gérable pour en faire une station de _travail_ parée à toute épreuve. Du coup, j'installe gentoo, quelques réactions en vrac:
  • y'a cave avec paludis! (j'pensais que cave n'était disponible que pour exherbo!), cave, c'est la nouvelle nterface cli à paludis, kewl, j'suis pas perdu!
  • pfiou, cette stricte-attitude n'est pas toujours la bienvenue, j'ai un conflit dont je n'arrive pas à me défaire, même en m'y prenant comme un porc!(et j'ai l'impression qu'en bourrant avec portage, ça s'rait passé...
  • J'ai pas encore compris comment systemd était intégré? en mode compatibilité? avec les initscripts?

_________________
The End of the Internet!


Last edited by truc on Mon May 20, 2013 5:44 am; edited 1 time in total
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 819

PostPosted: Sun May 19, 2013 9:36 pm    Post subject: Reply with quote

Y'a un mode de compatibilité openrc, je crois, mais vaut mieux l'utiliser en natif, normalement les paquets installent les services systemd associés, il en manque encore quelques-uns, mais les .service traînent sur les wiki & forums. perso j'ai dû rajouter dans /etc/systemd/system/ :
atd.service
dcron.service
iptables.service
ip6tables.service
ntpd.service
postfix.service
sshguard.service

Et depuis mon install y'en a peut-être qui ne sont plus nécessaires, a voir donc.

Bien que systemd fonctionne parfaitement en mode natif, les paquets openrc et sysvinit sont encore impossibles à désinstaller sans grosses bidouilles, une des raisons est /etc/init.d/functions.sh, utilisé par beaucoup de programmes de gestion des paquets & administration de Gentoo.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum