Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] RTL8723au not working, HELP
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
cazdli
n00b
n00b


Joined: 15 May 2013
Posts: 17

PostPosted: Wed May 15, 2013 8:50 pm    Post subject: [solved] RTL8723au not working, HELP Reply with quote

Hey guys, I have installed gentoo on my laptop yesterday, but I haven't been able to get the wireless driver working.
I'm pretty new to linux and I have no idea what else to do at this point.
My laptop is the Lenovo Yoga 13".

I installed gentoo on my laptop through the gentoo liveDVD EOTW edition. On the liveDVD, the wireless wasn't working either.
However, through the liveDVD I installed the drivers through make/make install of the RTL8723AS-VAU linux driver.
When I used ifconfig -a on the liveDVD, it would appear as wlan0, and the wireless would work just fine through wicd.

This is not the case for my base system, after I installed the system, I tried to install the very same driver as well, and while I could get it to install, after using modprobe 8723au, instead of getting wlan0 I got enp0s26u1u4i2 when I ran ifconfig -a.
I tried typing that exact name on wicd to see if I could use my wireless, but no avail.

Here's what I got from dmesg

Code:


[    1.830770] Netfilter messages via NETLINK v0.30.
[    1.831912] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
[    1.833181] ctnetlink v0.93: registering with nfnetlink.
[    1.834438] ip_tables: (C) 2000-2006 Netfilter Core Team
[    1.835603] TCP: cubic registered
[    1.836742] Initializing XFRM netlink socket
[    1.838131] NET: Registered protocol family 10
[    1.839413] ip6_tables: (C) 2000-2006 Netfilter Core Team
[    1.840605] sit: IPv6 over IPv4 tunneling driver
[    1.841926] NET: Registered protocol family 17
[    1.843088] Key type dns_resolver registered
[    1.844674] PM: Hibernation image not present or could not be loaded.
[    1.844689] registered taskstats version 1
[    1.846049]   Magic number: 13:536:287
[    1.847194] tty tty20: hash matches
[    1.848338] console [netcon0] enabled
[    1.849458] netconsole: network logging started
[    1.851393] ALSA device list:
[    1.852522]   #0: HDA Intel PCH at 0xe0418000 irq 42
[    1.855472] ehci_hcd 0000:00:1a.0: GetStatus port:1 status 001803 0  ACK POWER sig=j CSC CONNECT
[    1.855478] hub 1-0:1.0: port 1: status 0501 change 0001
[    1.877414] ehci_hcd 0000:00:1d.0: GetStatus port:1 status 001803 0  ACK POWER sig=j CSC CONNECT
[    1.877420] hub 2-0:1.0: port 1: status 0501 change 0001
[    1.955312] hub 1-0:1.0: state 7 ports 2 chg 0002 evt 0000
[    1.955328] hub 1-0:1.0: port 1, status 0501, change 0000, 480 Mb/s
[    2.006431] ehci_hcd 0000:00:1a.0: port 1 reset complete, port enabled
[    2.006438] ehci_hcd 0000:00:1a.0: GetStatus port:1 status 001005 0  ACK POWER sig=se0 PE CONNECT
[    2.038154] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    2.040159] ata1.00: ATA-8: SAMSUNG MZMPC256HBGJ-000L1, CXM13L1Q, max UDMA/133
[    2.041310] ata1.00: 500118192 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[    2.042825] ata1.00: configured for UDMA/133
[    2.044182] scsi 0:0:0:0: Direct-Access     ATA      SAMSUNG MZMPC256 CXM1 PQ: 0 ANSI: 5
[    2.045576] sd 0:0:0:0: [sda] 500118192 512-byte logical blocks: (256 GB/238 GiB)
[    2.045763] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    2.048039] sd 0:0:0:0: [sda] Write Protect is off
[    2.049202] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    2.049223] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    2.050987]  sda: sda1 sda2 sda3
[    2.052664] sd 0:0:0:0: [sda] Attached SCSI disk
[    2.057172] usb 1-1: new high-speed USB device number 2 using ehci_hcd
[    2.109402] ehci_hcd 0000:00:1a.0: port 1 reset complete, port enabled
[    2.109408] ehci_hcd 0000:00:1a.0: GetStatus port:1 status 001005 0  ACK POWER sig=se0 PE CONNECT
[    2.172136] ehci_hcd 0000:00:1a.0: set dev address 2 for port 1
[    2.172144] ehci_hcd 0000:00:1a.0: LPM: no device attached
[    2.172362] usb 1-1: udev 2, busnum 1, minor = 1
[    2.172367] usb 1-1: New USB device found, idVendor=8087, idProduct=0024
[    2.173561] usb 1-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.174899] usb 1-1: usb_probe_device
[    2.174904] usb 1-1: configuration #1 chosen from 1 choice
[    2.175072] usb 1-1: adding 1-1:1.0 (config #1, interface 0)
[    2.175172] hub 1-1:1.0: usb_probe_interface
[    2.175175] hub 1-1:1.0: usb_probe_interface - got id
[    2.175178] hub 1-1:1.0: USB hub found
[    2.176568] hub 1-1:1.0: 6 ports detected
[    2.177749] hub 1-1:1.0: standalone hub
[    2.177751] hub 1-1:1.0: individual port power switching
[    2.177754] hub 1-1:1.0: individual port over-current protection
[    2.177755] hub 1-1:1.0: Single TT
[    2.177757] hub 1-1:1.0: TT requires at most 8 FS bit times (666 ns)
[    2.177759] hub 1-1:1.0: power on to power good time: 100ms
[    2.177936] hub 1-1:1.0: local power source is good
[    2.178374] hub 1-1:1.0: enabling power on all ports
[    2.179088] hub 2-0:1.0: state 7 ports 2 chg 0002 evt 0000
[    2.179097] hub 2-0:1.0: port 1, status 0501, change 0000, 480 Mb/s
[    2.230221] ehci_hcd 0000:00:1d.0: port 1 reset complete, port enabled
[    2.230228] ehci_hcd 0000:00:1d.0: GetStatus port:1 status 001005 0  ACK POWER sig=se0 PE CONNECT
[    2.279223] hub 1-1:1.0: port 3: status 0101 change 0001
[    2.279495] hub 1-1:1.0: port 4: status 0101 change 0001
[    2.279785] hub 1-1:1.0: port 5: status 0101 change 0001
[    2.280835] usb 2-1: new high-speed USB device number 2 using ehci_hcd
[    2.332943] ehci_hcd 0000:00:1d.0: port 1 reset complete, port enabled
[    2.332949] ehci_hcd 0000:00:1d.0: GetStatus port:1 status 001005 0  ACK POWER sig=se0 PE CONNECT
[    2.379657] usb 1-1: link qh256-0001/ffff880224f74a00 start 1 [1/0 us]
[    2.395736] ehci_hcd 0000:00:1d.0: set dev address 2 for port 1
[    2.395743] ehci_hcd 0000:00:1d.0: LPM: no device attached
[    2.395981] usb 2-1: udev 2, busnum 2, minor = 129
[    2.395985] usb 2-1: New USB device found, idVendor=8087, idProduct=0024
[    2.397283] usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[    2.398787] usb 2-1: usb_probe_device
[    2.398791] usb 2-1: configuration #1 chosen from 1 choice
[    2.398887] usb 2-1: adding 2-1:1.0 (config #1, interface 0)
[    2.398972] hub 2-1:1.0: usb_probe_interface
[    2.398975] hub 2-1:1.0: usb_probe_interface - got id
[    2.398977] hub 2-1:1.0: USB hub found
[    2.400224] hub 2-1:1.0: 8 ports detected
[    2.401523] hub 2-1:1.0: standalone hub
[    2.401527] hub 2-1:1.0: individual port power switching
[    2.401529] hub 2-1:1.0: individual port over-current protection
[    2.401532] hub 2-1:1.0: Single TT
[    2.401534] hub 2-1:1.0: TT requires at most 8 FS bit times (666 ns)
[    2.401535] hub 2-1:1.0: power on to power good time: 100ms
[    2.401794] hub 2-1:1.0: local power source is good
[    2.402435] hub 2-1:1.0: enabling power on all ports
[    2.403404] hub 1-1:1.0: state 7 ports 6 chg 0038 evt 0000
[    2.403469] hub 1-1:1.0: port 3, status 0101, change 0000, 12 Mb/s
[    2.463907] psmouse serio1: synaptics: Touchpad model: 1, fw: 8.1, id: 0x1e2b1, caps: 0xd00223/0x840300/0x123c00, board id: 1800, fw id: 1148377
[    2.465697] usb 1-1.3: new high-speed USB device number 3 using ehci_hcd
[    2.477614] hub 1-1:1.0: port 3 not reset yet, waiting 10ms
[    2.502914] hub 2-1:1.0: port 2: status 0101 change 0001
[    2.503912] hub 2-1:1.0: port 5: status 0101 change 0001
[    2.504391] hub 2-1:1.0: port 7: status 0101 change 0001
[    2.520861] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio1/input/input5
[    2.525654] md: Waiting for all devices to be available before autodetect
[    2.526834] md: If you don't use raid, use raid=noautodetect
[    2.528257] md: Autodetecting RAID arrays.
[    2.529425] md: Scanned 0 and added 0 devices.
[    2.530589] md: autorun ...
[    2.531739] md: ... autorun DONE.
[    2.533417] EXT4-fs (sda2): couldn't mount as ext3 due to feature incompatibilities
[    2.534705] EXT4-fs (sda2): couldn't mount as ext2 due to feature incompatibilities
[    2.541654] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
[    2.542812] VFS: Mounted root (ext4 filesystem) readonly on device 8:2.
[    2.545249] devtmpfs: mounted
[    2.547497] Freeing unused kernel memory: 632k freed
[    2.548713] Write protecting the kernel read-only data: 12288k
[    2.551874] usb 1-1.3: default language 0x0409
[    2.552247] usb 1-1.3: udev 3, busnum 1, minor = 2
[    2.552251] usb 1-1.3: New USB device found, idVendor=0bda, idProduct=0129
[    2.554088] Freeing unused kernel memory: 872k freed
[    2.554092] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.554094] usb 1-1.3: Product: USB2.0-CRW
[    2.554096] usb 1-1.3: Manufacturer: Generic
[    2.554098] usb 1-1.3: SerialNumber: 20100201396000000
[    2.555390] kworker/u:6 (993) used greatest stack depth: 4592 bytes left
[    2.555401] usb 1-1.3: usb_probe_device
[    2.555404] usb 1-1.3: configuration #1 chosen from 1 choice
[    2.555619] usb 1-1.3: adding 1-1.3:1.0 (config #1, interface 0)
[    2.555993] hub 1-1:1.0: port 4, status 0101, change 0000, 12 Mb/s
[    2.566476] hub 1-1:1.0: port 4 not reset yet, waiting 10ms
[    2.566653] Freeing unused kernel memory: 1812k freed
[    2.604319] usb 2-1: link qh256-0001/ffff880224f74800 start 1 [1/0 us]
[    2.628390] usb 1-1.4: new high-speed USB device number 4 using ehci_hcd
[    2.640384] hub 1-1:1.0: port 4 not reset yet, waiting 10ms
[    2.714510] usb 1-1.4: skipped 1 descriptor after configuration
[    2.714630] usb 1-1.4: default language 0x0409
[    2.715003] usb 1-1.4: udev 4, busnum 1, minor = 3
[    2.715008] usb 1-1.4: New USB device found, idVendor=0bda, idProduct=1724
[    2.716198] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.717374] usb 1-1.4: Product: 802.11n WLAN Adapter
[    2.718534] usb 1-1.4: Manufacturer: Realtek
[    2.718536] usb 1-1.4: SerialNumber: 00e04c000001
[    2.718652] usb 1-1.4: usb_probe_device
[    2.718654] usb 1-1.4: configuration #1 chosen from 1 choice
[    2.718751] usb 1-1.4: adding 1-1.4:1.0 (config #1, interface 0)
[    2.718956] usb 1-1.4: adding 1-1.4:1.1 (config #1, interface 1)
[    2.719193] usb 1-1.4: adding 1-1.4:1.2 (config #1, interface 2)
[    2.719499] hub 1-1:1.0: port 5, status 0101, change 0000, 12 Mb/s
[    2.729244] hub 1-1:1.0: port 5 not reset yet, waiting 10ms
[    2.791155] usb 1-1.5: new full-speed USB device number 5 using ehci_hcd
[    2.872025] hub 1-1:1.0: port 5 not reset yet, waiting 10ms
[    2.881791] udevd (1113) used greatest stack depth: 4584 bytes left
[    2.881827] systemd-udevd[1114]: starting version 200
[    2.924926] udevadm (1127) used greatest stack depth: 4320 bytes left
[    2.945800] usb 1-1.5: ep0 maxpacket = 8
[    3.017315] usb 1-1.5: skipped 1 descriptor after interface
[    3.017428] usb 1-1.5: default language 0x0409
[    3.017929] usb 1-1.5: udev 5, busnum 1, minor = 4
[    3.017933] usb 1-1.5: New USB device found, idVendor=04f3, idProduct=000a
[    3.017935] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.017938] usb 1-1.5: Product: Touchscreen
[    3.017940] usb 1-1.5: Manufacturer: ELAN
[    3.018013] usb 1-1.5: usb_probe_device
[    3.018017] usb 1-1.5: configuration #1 chosen from 1 choice
[    3.018181] usb 1-1.5: adding 1-1.5:1.0 (config #1, interface 0)
[    3.018213] usbhid 1-1.5:1.0: usb_probe_interface
[    3.018216] usbhid 1-1.5:1.0: usb_probe_interface - got id
[    3.026467] hub 1-1:1.0: state 7 ports 6 chg 0000 evt 0020
[    3.026537] hub 2-1:1.0: state 7 ports 8 chg 00a4 evt 0000
[    3.026668] hub 2-1:1.0: port 2, status 0101, change 0000, 12 Mb/s
[    3.088770] usb 2-1.2: new low-speed USB device number 3 using ehci_hcd
[    3.100766] hub 2-1:1.0: port 2 not reset yet, waiting 10ms
[    3.177662] usb 2-1.2: skipped 1 descriptor after interface
[    3.178262] usb 2-1.2: default language 0x0409
[    3.180266] usb 2-1.2: udev 3, busnum 2, minor = 130
[    3.180271] usb 2-1.2: New USB device found, idVendor=1c4f, idProduct=0032
[    3.180273] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.180275] usb 2-1.2: Product: Usb Mouse
[    3.180277] usb 2-1.2: Manufacturer: SIGMACHIP
[    3.180352] usb 2-1.2: usb_probe_device
[    3.180357] usb 2-1.2: configuration #1 chosen from 1 choice
[    3.180784] usb 2-1.2: adding 2-1.2:1.0 (config #1, interface 0)
[    3.180821] usbhid 2-1.2:1.0: usb_probe_interface
[    3.180825] usbhid 2-1.2:1.0: usb_probe_interface - got id
[    3.183318] input: SIGMACHIP Usb Mouse as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.2/2-1.2:1.0/input/input6
[    3.183573] hid-generic 0003:1C4F:0032.0002: input,hidraw0: USB HID v1.10 Mouse [SIGMACHIP Usb Mouse] on usb-0000:00:1d.0-1.2/input0
[    3.183691] hub 2-1:1.0: port 5, status 0101, change 0000, 12 Mb/s
[    3.194608] hub 2-1:1.0: port 5 not reset yet, waiting 10ms
[    3.256513] usb 2-1.5: new full-speed USB device number 4 using ehci_hcd
[    3.267494] hub 2-1:1.0: port 5 not reset yet, waiting 10ms
[    3.341245] usb 2-1.5: ep0 maxpacket = 8
[    3.343536] usb 2-1.5: skipped 1 descriptor after interface
[    3.343906] usb 2-1.5: default language 0x0409
[    3.345131] usb 2-1.5: udev 4, busnum 2, minor = 131
[    3.345135] usb 2-1.5: New USB device found, idVendor=2047, idProduct=0855
[    3.345137] usb 2-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    3.345139] usb 2-1.5: Product: Lenovo Yoga         
[    3.345141] usb 2-1.5: Manufacturer: Invensense
[    3.345143] usb 2-1.5: SerialNumber: 65CA98461A001600
[    3.345301] usb 2-1.5: usb_probe_device
[    3.345306] usb 2-1.5: configuration #1 chosen from 1 choice
[    3.345844] usb 2-1.5: adding 2-1.5:1.0 (config #1, interface 0)
[    3.346252] usbhid 2-1.5:1.0: usb_probe_interface
[    3.346256] usbhid 2-1.5:1.0: usb_probe_interface - got id
[    3.861714] EXT4-fs (sda2): re-mounted. Opts: (null)
[    3.925873] Adding 8388604k swap on /dev/sda3.  Priority:-1 extents:1 across:8388604k SS
[    4.000302] usbhid 2-1.5:1.0: looking for a minor, starting at 96
[    4.000438] hid-generic 0003:2047:0855.0003: hiddev0,hidraw1: USB HID v1.01 Device [Invensense Lenovo Yoga         ] on usb-0000:00:1d.0-1.5/input0
[    4.000588] hub 2-1:1.0: port 7, status 0101, change 0000, 12 Mb/s
[    4.011343] hub 2-1:1.0: port 7 not reset yet, waiting 10ms
[    4.073232] usb 2-1.7: new high-speed USB device number 5 using ehci_hcd
[    4.084216] hub 2-1:1.0: port 7 not reset yet, waiting 10ms
[    4.167233] usb 2-1.7: skipped 1 descriptor after configuration
[    4.167240] usb 2-1.7: skipped 5 descriptors after interface
[    4.167244] usb 2-1.7: skipped 1 descriptor after endpoint
[    4.167248] usb 2-1.7: skipped 19 descriptors after interface
[    4.167459] usb 2-1.7: default language 0x0409
[    4.168208] usb 2-1.7: udev 5, busnum 2, minor = 132
[    4.168213] usb 2-1.7: New USB device found, idVendor=5986, idProduct=029c
[    4.168217] usb 2-1.7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    4.168221] usb 2-1.7: Product: Lenovo EasyCamera
[    4.168224] usb 2-1.7: Manufacturer: Vimicro Corp.
[    4.168227] usb 2-1.7: SerialNumber: MI1320_SOC
[    4.168350] usb 2-1.7: usb_probe_device
[    4.168354] usb 2-1.7: configuration #1 chosen from 1 choice
[    4.168456] usb 2-1.7: adding 2-1.7:1.0 (config #1, interface 0)
[    4.168745] usb 2-1.7: adding 2-1.7:1.1 (config #1, interface 1)
[    4.168955] hub 2-1:1.0: state 7 ports 8 chg 0000 evt fe80
[   10.935956] usb 2-1.2: link qh8-0601/ffff880223c8eb80 start 2 [1/2 us]
[   11.774210] EXT4-fs (sda2): re-mounted. Opts: commit=0
[  130.394427] RTL871X: rtl8723as-vau driver version=v4.1.3_6044.20121224
[  130.394432] RTL871X: build time: May 15 2013 16:18:39
[  130.394450] rtl8723au 1-1.4:1.2: usb_probe_interface
[  130.394454] rtl8723au 1-1.4:1.2: usb_probe_interface - got id
[  130.394457] RTL871X:
usb_endpoint_descriptor(0):
[  130.394460] RTL871X: bLength=7
[  130.394462] RTL871X: bDescriptorType=5
[  130.394464] RTL871X: bEndpointAddress=84
[  130.394466] RTL871X: wMaxPacketSize=512
[  130.394467] RTL871X: bInterval=0
[  130.394469] RTL871X: RT_usb_endpoint_is_bulk_in = 4
[  130.394471] RTL871X:
usb_endpoint_descriptor(1):
[  130.394473] RTL871X: bLength=7
[  130.394475] RTL871X: bDescriptorType=5
[  130.394476] RTL871X: bEndpointAddress=5
[  130.394477] RTL871X: wMaxPacketSize=512
[  130.394479] RTL871X: bInterval=0
[  130.394480] RTL871X: RT_usb_endpoint_is_bulk_out = 5
[  130.394482] RTL871X:
usb_endpoint_descriptor(2):
[  130.394484] RTL871X: bLength=7
[  130.394486] RTL871X: bDescriptorType=5
[  130.394487] RTL871X: bEndpointAddress=6
[  130.394489] RTL871X: wMaxPacketSize=512
[  130.394490] RTL871X: bInterval=0
[  130.394492] RTL871X: RT_usb_endpoint_is_bulk_out = 6
[  130.394493] RTL871X:
usb_endpoint_descriptor(3):
[  130.394496] RTL871X: bLength=7
[  130.394497] RTL871X: bDescriptorType=5
[  130.394498] RTL871X: bEndpointAddress=87
[  130.394500] RTL871X: wMaxPacketSize=64
[  130.394501] RTL871X: bInterval=3
[  130.394503] RTL871X: RT_usb_endpoint_is_int_in = 7, Interval = 3
[  130.394505] RTL871X: nr_endpoint=4, in_num=2, out_num=2

[  130.394507] RTL871X: USB_SPEED_HIGH
[  130.394518] RTL871X: CHIP TYPE: RTL8723A
[  130.394520] RTL871X: rtw_handle_dualmac(): pbuddy_padapter == NULL, Set pbuddy_padapter
[  130.394529] RTL871X: register rtw_netdev_ops to netdev_ops
[  130.394842] RTL871X: Chip Version Info: CHIP_8723A_RTL871X: Normal_Chip_RTL871X: UMC_RTL871X: B_CUT_RTL871X: 1T1R_RTL871X: RomVer(0)
[  130.394849] RTL871X: RF_Type is 3!!
[  130.395213] RTL871X: EEPROM type is E-FUSE
[  130.395216] RTL871X: ====> _ReadAdapterInfo8723AU
[  130.395591] RTL871X: Boot from EFUSE, Autoload OK !
[  130.396089] RTL871X: hal_EfuseSwitchToBank: Efuse switch bank to 0
[  130.535135] RTL871X: hal_ReadEFuse_WiFi: data end at address=0x9e
[  130.535254] RTL871X: EEPROM VID = 0x bda
[  130.535256] RTL871X: EEPROM PID = 0x1724
[  130.535265] RTL871X: _ReadBoardType(7)
[  130.535379] RTL871X: mlmepriv.ChannelPlan=0x0a
[  130.535381] RTL871X: Hal_EfuseParseThermalMeter_8723A: ThermalMeter=0xf
[  130.535383] RTL871X: readAdapterInfo(): REPLACEMENT = 0
[  130.535385] RTL871X: <==== _ReadAdapterInfo8723AU in 141 ms
[  130.535559] RTL871X: rtw_macaddr_cfg MAC Address  = 20:16:d8:be:03:73
[  130.535562] RTL871X: MAC Address from pnetdev->dev_addr= 20:16:d8:be:03:73
[  130.535787] RTL871X: bDriverStopped:1, bSurpriseRemoved:0, bup:0, hw_init_completed:0
[  130.535815] usbcore: registered new interface driver rtl8723au
[  130.543248] systemd-udevd[2625]: renamed network interface wlan0 to enp0s26u1u4i2
[  138.081148] RTL871X: +871x_drv - drv_open, bup=0
[  138.151240] RTL871X:  Rtl8723_FwUMCBCutImageArray for RTL8723A B CUT
[  138.151248] RTL871X: rtl8723a_FirmwareDownload accquire FW from embedded image
[  138.151252] RTL871X: rtl8723a_FirmwareDownload: fw_ver=30 fw_subver=0 sig=0x2302
[  138.184936] RTL871X: rtl8723a_FirmwareDownload Exit rtw_mfree pFirmware !
[  138.184941] RTL871X: rtl8723a_FirmwareDownload Exit rtw_mfree pBTFirmware !
[  138.184943] RTL871X: fw download ok!
[  138.184946] RTL871X: Set RF Chip ID to RF_6052 and RF type to 1T1R.
[  138.475902] RTL871X: IQK:Start!!!
[  138.486736] RTL871X: Path A IQK Success!!
[  138.494349] RTL871X: Path A IQK Success!!
[  138.498969] RTL871X: IQK: final_candidate is 0
[  138.498975] RTL871X: IQK: RegE94=102 RegE9C=13 RegEA4=ff RegEAC=5 RegEB4=0 RegEBC=0 RegEC4=0 RegECC=0
 RTL871X: Path A IQ Calibration Success !
[  138.607810] RTL871X: pdmpriv->TxPowerTrackControl = 1
[  138.612300] RTL871X: rtl8723au_hal_init in 532ms
[  138.612311] RTL871X: MAC Address = 20:16:d8:be:03:73
[  138.617053] ------------[ cut here ]------------
[  138.617076] WARNING: at drivers/usb/core/urb.c:414 usb_submit_urb+0x152/0x4b0()
[  138.617078] Hardware name: 20175
[  138.617079] Device: usb
BOGUS urb xfer, pipe 3 != type 1
[  138.617081] Modules linked in: 8723au(O)
[  138.617086] Pid: 2638, comm: ifconfig Tainted: G           O 3.7.10-gentoo-r1 #1
[  138.617087] Call Trace:
[  138.617093]  [<ffffffff81039f2a>] warn_slowpath_common+0x7a/0xb0
[  138.617096]  [<ffffffff8103a001>] warn_slowpath_fmt+0x41/0x50
[  138.617100]  [<ffffffff81457a82>] usb_submit_urb+0x152/0x4b0
[  138.617117]  [<ffffffffa0037519>] ? usb_read8+0x35/0x35 [8723au]
[  138.617140]  [<ffffffffa0037034>] usb_read_interrupt+0x74/0xaa [8723au]
[  138.617152]  [<ffffffffa00344a4>] rtl8723au_inirp_init+0x8b/0xfb [8723au]
[  138.617168]  [<ffffffffa002b49f>] rtw_hal_inirp_init+0x12/0x33 [8723au]
[  138.617179]  [<ffffffffa004791d>] usb_intf_start+0x9/0xb [8723au]
[  138.617189]  [<ffffffffa00471b9>] _netdev_open+0xf7/0x2f5 [8723au]
[  138.617208]  [<ffffffffa00473e6>] netdev_open+0x2f/0x4a [8723au]
[  138.617219]  [<ffffffff81580bb7>] __dev_open+0x87/0xe0
[  138.617224]  [<ffffffff81580e4c>] __dev_change_flags+0x9c/0x180
[  138.617227]  [<ffffffff81580fe3>] dev_change_flags+0x23/0x70
[  138.617231]  [<ffffffff815f6c3d>] devinet_ioctl+0x5bd/0x6c0
[  138.617235]  [<ffffffff815f7095>] inet_ioctl+0x75/0x90
[  138.617239]  [<ffffffff815674eb>] sock_do_ioctl+0x2b/0x70
[  138.617242]  [<ffffffff81568154>] sock_ioctl+0x74/0x2e0
[  138.617246]  [<ffffffff8113b276>] do_vfs_ioctl+0x96/0x550
[  138.617250]  [<ffffffff81279c85>] ? inode_has_perm.isra.36.constprop.60+0x25/0x30
[  138.617254]  [<ffffffff8127bdaf>] ? file_has_perm+0x8f/0xa0
[  138.617257]  [<ffffffff8113b7c1>] sys_ioctl+0x91/0xb0
[  138.617261]  [<ffffffff8171f152>] system_call_fastpath+0x16/0x1b
[  138.617263] ---[ end trace f0d85c2f9a91e018 ]---
[  138.617410] RTL871X: pHalData->IntrMask = 0x0000
[  138.617560] RTL871X: -871x_drv - drv_open, bup=1
[  138.617582] IPv6: ADDRCONF(NETDEV_UP): enp0s26u1u4i2: link is not ready
[  140.628943] RTL871X: ==>rtw_ps_processor .fw_state(0)
[  140.628962] RTL871X: ==>ips_enter cnts:1
[  140.628963] RTL871X: nolinked power save enter
[  140.628964] RTL871X: ===> rtw_ips_pwr_down...................
[  140.628966] RTL871X: ====> rtw_ips_dev_unload...
[  140.652247] RTL871X: usb_read_port_cancel
[  140.652371] RTL871X: usb_read_port_complete()-1446: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
[  140.652493] RTL871X: usb_read_port_complete()-1446: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
[  140.652620] RTL871X: usb_read_port_complete()-1446: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
[  140.652743] RTL871X: usb_read_port_complete()-1446: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
[  140.652865] RTL871X: usb_read_interrupt_complete() RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
[  140.652995] RTL871X: rtl8723au_inirp_deinit pHalData->IntrMask = 0x0500
[  140.653145] RTL871X: usb_write_port_cancel
[  140.653161] RTL871X: ==> rtl8723au_hal_deinit
[  140.653163] RTL871X: CardDisableRTL8723U
[  140.658489] RTL871X: <=== rtw_ips_pwr_down..................... in 30ms
[  162.415365] RTL871X: _rtw_pwr_wakeup call ips_leave....
[  162.415370] RTL871X: ==>ips_leave cnts:1
[  162.415371] RTL871X: ===>  rtw_ips_pwr_up..............
[  162.415375] RTL871X: ===> ips_netdrv_open.........
[  162.485829] RTL871X:  Rtl8723_FwUMCBCutImageArray for RTL8723A B CUT
[  162.485838] RTL871X: rtl8723a_FirmwareDownload accquire FW from embedded image
[  162.485843] RTL871X: rtl8723a_FirmwareDownload: fw_ver=30 fw_subver=0 sig=0x2302
[  162.516284] RTL871X: rtl8723a_FirmwareDownload Exit rtw_mfree pFirmware !
[  162.516291] RTL871X: rtl8723a_FirmwareDownload Exit rtw_mfree pBTFirmware !
[  162.516295] RTL871X: fw download ok!
[  162.516297] RTL871X: Set RF Chip ID to RF_6052 and RF type to 1T1R.
[  162.810345] RTL871X: pdmpriv->TxPowerTrackControl = 1
[  162.814837] RTL871X: rtl8723au_hal_init in 400ms
[  162.814852] ------------[ cut here ]------------
[  162.814873] WARNING: at drivers/usb/core/urb.c:414 usb_submit_urb+0x152/0x4b0()
[  162.814874] Hardware name: 20175
[  162.814876] Device: usb
BOGUS urb xfer, pipe 3 != type 1
[  162.814877] Modules linked in: 8723au(O)
[  162.814882] Pid: 2667, comm: ifconfig Tainted: G        W  O 3.7.10-gentoo-r1 #1
[  162.814883] Call Trace:
[  162.814890]  [<ffffffff81039f2a>] warn_slowpath_common+0x7a/0xb0
[  162.814893]  [<ffffffff8103a001>] warn_slowpath_fmt+0x41/0x50
[  162.814896]  [<ffffffff81457a82>] usb_submit_urb+0x152/0x4b0
[  162.814913]  [<ffffffffa0037519>] ? usb_read8+0x35/0x35 [8723au]
[  162.814925]  [<ffffffffa0037034>] usb_read_interrupt+0x74/0xaa [8723au]
[  162.814937]  [<ffffffffa00344a4>] rtl8723au_inirp_init+0x8b/0xfb [8723au]
[  162.814952]  [<ffffffffa002b49f>] rtw_hal_inirp_init+0x12/0x33 [8723au]
[  162.814964]  [<ffffffffa004791d>] usb_intf_start+0x9/0xb [8723au]
[  162.814974]  [<ffffffffa004746a>] ips_netdrv_open+0x69/0xd9 [8723au]
[  162.814983]  [<ffffffffa0047516>] rtw_ips_pwr_up+0x3c/0x65 [8723au]
[  162.814997]  [<ffffffffa001a559>] ips_leave+0x91/0x1bb [8723au]
[  162.815011]  [<ffffffffa001af00>] _rtw_pwr_wakeup+0x13b/0x1cb [8723au]
[  162.815025]  [<ffffffffa0027a1b>] rtw_p2p_enable+0x93/0x158 [8723au]
[  162.815036]  [<ffffffffa0045c14>] netdev_close+0x14d/0x17b [8723au]
[  162.815041]  [<ffffffff8157b5a6>] __dev_close_many+0x86/0xd0
[  162.815045]  [<ffffffff8157b618>] __dev_close+0x28/0x40
[  162.815047]  [<ffffffff81580e4c>] __dev_change_flags+0x9c/0x180
[  162.815050]  [<ffffffff81580fe3>] dev_change_flags+0x23/0x70
[  162.815055]  [<ffffffff815f6c3d>] devinet_ioctl+0x5bd/0x6c0
[  162.815059]  [<ffffffff815f7095>] inet_ioctl+0x75/0x90
[  162.815063]  [<ffffffff815674eb>] sock_do_ioctl+0x2b/0x70
[  162.815066]  [<ffffffff81568154>] sock_ioctl+0x74/0x2e0
[  162.815070]  [<ffffffff8113b276>] do_vfs_ioctl+0x96/0x550
[  162.815074]  [<ffffffff81279c85>] ? inode_has_perm.isra.36.constprop.60+0x25/0x30
[  162.815077]  [<ffffffff8127bdaf>] ? file_has_perm+0x8f/0xa0
[  162.815080]  [<ffffffff8113b7c1>] sys_ioctl+0x91/0xb0
[  162.815084]  [<ffffffff8171f152>] system_call_fastpath+0x16/0x1b
[  162.815086] ---[ end trace f0d85c2f9a91e019 ]---
[  162.815212] RTL871X: pHalData->IntrMask = 0x0000
[  162.815335] RTL871X: <===  rtw_ips_pwr_up.............. in 401ms
[  162.815336] RTL871X: nolinked power save leave
[  162.815458] RTL871X: ==> ips_leave.....LED(0x00e28282)...
[  162.815463] RTL871X: update_mgnt_tx_rate(): rate = 2
[  162.815466] RTL871X: HW_VAR_BASIC_RATE: BrateCfg(0x15d)
[  162.816082] RTL871X: -871x_drv - drv_close, bup=1
[  162.818667] RTL871X: +871x_drv - drv_open, bup=1
[  162.818672] RTL871X: -871x_drv - drv_open, bup=1
[  162.818688] IPv6: ADDRCONF(NETDEV_UP): enp0s26u1u4i2: link is not ready
[  164.817244] RTL871X: ==>rtw_ps_processor .fw_state(0)
[  164.817249] RTL871X: ==>ips_enter cnts:2
[  164.817250] RTL871X: nolinked power save enter
[  164.817251] RTL871X: ===> rtw_ips_pwr_down...................
[  164.817253] RTL871X: ====> rtw_ips_dev_unload...
[  164.840556] RTL871X: usb_read_port_cancel
[  164.840680] RTL871X: usb_read_port_complete()-1446: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
[  164.840803] RTL871X: usb_read_port_complete()-1446: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
[  164.840929] RTL871X: usb_read_port_complete()-1446: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
[  164.841052] RTL871X: usb_read_port_complete()-1446: RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
[  164.841187] RTL871X: usb_read_interrupt_complete() RX Warning! bDriverStopped(0) OR bSurpriseRemoved(0) bReadPortCancel(1)
[  164.841305] RTL871X: rtl8723au_inirp_deinit pHalData->IntrMask = 0x0500
[  164.841428] RTL871X: usb_write_port_cancel
[  164.841439] RTL871X: ==> rtl8723au_hal_deinit
[  164.841441] RTL871X: CardDisableRTL8723U
[  164.846796] RTL871X: <=== rtw_ips_pwr_down..................... in 29ms
[  301.878545] kworker/u:0 (6) used greatest stack depth: 3408 bytes left


Here's my lspci

Code:
lspci


00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:04.0 Signal processing controller: Intel Corporation 3rd Gen Core Processor Thermal Subsystem (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QS77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
00:1f.6 Signal processing controller: Intel Corporation 7 Series/C210 Series Chipset Family Thermal Management Controller (rev 04)



ifconfig -a:

Code:


enp0s26u1u4i2: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 20:16:d8:be:03:73  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 0  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

sit0: flags=128<NOARP>  mtu 1480
        sit  txqueuelen 0  (IPv6-in-IPv4)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0


iwconfig:

Code:
iwconfig

lo        no wireless extensions.

enp0s26u1u4i2  no wireless extensions.

sit0      no wireless extensions.


Here's my kernel configuration
http://pastebin.com/CZkdKRsA


After installing the driver/module on the DVD, I also didn't really see the realtek driver on lspci (although it would still work), and when I ran iwconfig, wlan0 would be shown with the wireless extension thing.
Anyone know what I have to do to get my wireless working?
Let me know if you need any more information, I'm desperate to get my wireless working for school.


Last edited by cazdli on Sat May 18, 2013 3:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1105
Location: Sofia/Bulgaria

PostPosted: Thu May 16, 2013 6:43 am    Post subject: Reply with quote

Just in case... Did you install the firmware (linux-firmware package)?
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
cazdli
n00b
n00b


Joined: 15 May 2013
Posts: 17

PostPosted: Thu May 16, 2013 7:06 am    Post subject: Reply with quote

I just installed the firmware from the package you mentioned, but I still have the same issue.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Thu May 16, 2013 10:50 am    Post subject: Reply with quote

This driver does not require firmware. That log is quite clear, there's a crash. Or maybe not a crash, but definitely something's not right. Obvious question: Does your install have the same kernel version as the live environment in which the driver worked?
Back to top
View user's profile Send private message
cazdli
n00b
n00b


Joined: 15 May 2013
Posts: 17

PostPosted: Thu May 16, 2013 11:03 am    Post subject: Reply with quote

No, the liveDVD is at 3.6.8 r1.
My install is at 3.7.10 r1.
Back to top
View user's profile Send private message
cazdli
n00b
n00b


Joined: 15 May 2013
Posts: 17

PostPosted: Fri May 17, 2013 1:56 am    Post subject: Reply with quote

bump

Also, I updated to kernel 3.9.2 and updated world.
Still have no wireless on my computer.
Also still with the same issue as posted originally.

I managed to install usbutils though, does this have anything to do with anything?
Code:
lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 0781:556b SanDisk Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 1c4f:0032 SiGma Micro
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 005: ID 0bda:1724 Realtek Semiconductor Corp.
Bus 001 Device 006: ID 04f3:000a Elan Microelectronics Corp.
Bus 002 Device 003: ID 2047:0855 Texas Instruments
Bus 002 Device 004: ID 5986:029c Acer, Inc


any help would be appreciated!
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 4055
Location: india

PostPosted: Fri May 17, 2013 5:53 pm    Post subject: Reply with quote

rtl8723ae which is what my laptop needs.
despite i try with different kernels rtl8723ae does not make the wlan0
i use toshiba C855 satellite laptop.
seems nobody got it working
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
cazdli
n00b
n00b


Joined: 15 May 2013
Posts: 17

PostPosted: Fri May 17, 2013 9:20 pm    Post subject: Reply with quote

Thing is, I have gotten it to work before, but I had issues with the installation, but I eventually somehow got it working (I don't remember what I did though). So I know that it works. Other people have gotten it to install on debian/ubuntu/etc as well.
But my computer had some issues and I had to wipe the hard-drives and re-install Gentoo. But now I can't get it working anymore.

Padoor, have you tried kernel 3.9.2? The kernel has native support for the AE version of the wireless card.

I'd also like to add, this is the ifconfig -a when I run it on the gentoo LiveDVD and when the wireless works.

Code:
wlan0: flags=4098<BROADCAST,MULTICAST> mtu 1500
   ether 20:17:d8:be:03:73 txqueuelen 1000 (Ethernet)
   RX packets 0 bytes (0.0 B)
   RX errors 0 dropped 0 overruns 0 frame 0
   TX packets 0 bythes 0 (0.0B)
   TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0.0..
Back to top
View user's profile Send private message
cazdli
n00b
n00b


Joined: 15 May 2013
Posts: 17

PostPosted: Sat May 18, 2013 12:10 am    Post subject: Reply with quote

New info:

Code:
 dmesg |grep enp0s26u1u4i2
[    2.907452] systemd-udevd[1166]: renamed network interface wlan0 to enp0s26u1u4i2
[    5.092864] IPv6: ADDRCONF(NETDEV_UP): enp0s26u1u4i2: link is not ready


Code:
lshw -C Network
  *-network               
       description: Ethernet interface
       physical id: 1
       bus info: usb@1:1.4
       logical name: enp0s26u1u4i2
       serial: 20:16:d8:be:03:73
       capabilities: ethernet physical
       configuration: broadcast=yes driver=rtl8723au multicast=yes


Code:
iwlist scan
lo        Interface doesn't support scanning.

enp0s26u1u4i2  Interface doesn't support scanning.

sit0      Interface doesn't support scanning.


Code:
modinfo 8723au
filename:       /lib/modules/3.9.2-gentoo/kernel/drivers/net/wireless/8723au.ko
version:        v4.1.3_6044.20121224
author:         Realtek Semiconductor Corp.
description:    Realtek Wireless Lan Driver
license:        GPL
srcversion:     FFAFC98AA19C3F439C4D11D
alias:          usb:v0BDAp0724d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v0BDAp1724d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v0BDAp8724d*dc*dsc*dp*icFFiscFFipFFin*
depends:       
vermagic:       3.9.2-gentoo SMP mod_unload
parm:           rtw_ips_mode:The default IPS mode (int)
parm:           ifname:The default name to allocate for first interface (charp)
parm:           if2name:The default name to allocate for second interface (charp)
parm:           rtw_initmac:charp
parm:           rtw_channel_plan:int
parm:           rtw_chip_version:int
parm:           rtw_rfintfs:int
parm:           rtw_lbkmode:int
parm:           rtw_network_mode:int
parm:           rtw_channel:int
parm:           rtw_mp_mode:int
parm:           rtw_wmm_enable:int
parm:           rtw_vrtl_carrier_sense:int
parm:           rtw_vcs_type:int
parm:           rtw_busy_thresh:int
parm:           rtw_ht_enable:int
parm:           rtw_cbw40_enable:int
parm:           rtw_ampdu_enable:int
parm:           rtw_rx_stbc:int
parm:           rtw_ampdu_amsdu:int
parm:           rtw_lowrate_two_xmit:int
parm:           rtw_rf_config:int
parm:           rtw_power_mgnt:int
parm:           rtw_smart_ps:int
parm:           rtw_low_power:int
parm:           rtw_wifi_spec:int
parm:           rtw_antdiv_cfg:int
parm:           rtw_antdiv_type:int
parm:           rtw_enusbss:int
parm:           rtw_hwpdn_mode:int
parm:           rtw_hwpwrp_detect:int
parm:           rtw_hw_wps_pbc:int
parm:           rtw_max_roaming_times:The max roaming times to try (uint)
parm:           rtw_notch_filter:0:Disable, 1:Enable, 2:Enable only for P2P (uint)


rfkill list all returns nothing

I'm guessing it doesn't recognize it as a wireless device and recognizes it as a ethernet device because of udev?
Back to top
View user's profile Send private message
imesg
Apprentice
Apprentice


Joined: 12 Jul 2002
Posts: 257

PostPosted: Thu Aug 01, 2013 3:31 pm    Post subject: Reply with quote

Since you solved the problem why not leave a clue in the thread how you solved the problem for others that might have the same problem?

Thanks for your attention.

### Edited for other that might have a similiar problem. ###

Since cadzli isn't answering I think I know what this problem was. All had the same symptoms. The problem was kernel driver configuration conflict. I had selected some realtek stuff:

Code:
> Device Drivers > Network device support > Wireless LAN
...
< >   Realtek wireless card support
...


This must be deselected. It will conflict with the external module and not allow it to control the wifi device. I did select some other wireless device to build as a module to provide proper directory structure in /lib/modules/kernel... for the external driver to install properly.

Maybe this will help someone solve a problem a bit more quickly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum