Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-libs/icu and Libreoffice-bin emerge conflict
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
KayZee
Apprentice
Apprentice


Joined: 15 Oct 2003
Posts: 197
Location: Arlington, VA

PostPosted: Sun May 05, 2013 1:39 pm    Post subject: dev-libs/icu and Libreoffice-bin emerge conflict Reply with quote

How do I resolve this emerge issue with dev-libs/icu?

Quote:
dev-libs/icu:0

(dev-libs/icu-51.1::gentoo, ebuild scheduled for merge) conflicts with
=dev-libs/icu-49* required by (app-office/libreoffice-bin-3.6.4.3::gentoo, installed)


Looks like Libreoffice-bin depends on an older version of the icu library.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Sun May 05, 2013 2:38 pm    Post subject: Reply with quote

Wait for a new libreoffice-bin ebuild :)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9842
Location: Córdoba (Spain)

PostPosted: Sun May 05, 2013 3:10 pm    Post subject: Reply with quote

In the while, you can just ignore the message or add this to package.mask:

Code:
=dev-libs/icu-51.1

_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
GFCCAE6xF
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 229
Location: England, UK

PostPosted: Sun May 05, 2013 3:22 pm    Post subject: Reply with quote

Ah - that was the one thing that kept me building libreoffice, damn icu downgrades. The devs said (iirc) they they only do libreoffice-bin updates for stable, and not ~arch - eventually I got really tired of it and moved to openoffice-bin which has no such 'old' dependencies attached. May be worth considering doing the same.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Sun May 05, 2013 3:45 pm    Post subject: Reply with quote

I suspect that openoffice just bundles its own icu. That's hardly an improvement.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
GFCCAE6xF
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 229
Location: England, UK

PostPosted: Sun May 05, 2013 3:50 pm    Post subject: Reply with quote

Possibly and probably, I admittedly have not looked in to it.
It may not be an improvement, but it's an option to be open minded towards even if just temp until libreoffice-bin is updated. I personally found it a huge improvement rather then keep doing 7 hour builds or be forced to downgrade icu and rebuild a load a packages.
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 410
Location: North~Sea~Coa~s~~t~~~

PostPosted: Sun May 05, 2013 4:43 pm    Post subject: Reply with quote

Had the same thing with the gnustep-base package (not binary), and solved it with a package mask. But how about slotted icu versions, and is this not just a problem with the ebuild not defining the proper version?

UPDATE: found a bug report (not about libreoffice-bin, but gnustep): https://bugs.gentoo.org/show_bug.cgi?id=413489

--
Cheers


Last edited by lost+found on Tue May 07, 2013 4:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
modnaruved
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2011
Posts: 85

PostPosted: Sun May 05, 2013 7:40 pm    Post subject: Reply with quote

similar conflicts

Code:

dev-libs/icu:0

  (dev-libs/icu-51.1::gentoo, installed) pulled in by
    dev-libs/icu:0/51.1= required by (dev-db/sqlite-3.7.16.2::gentoo, installed)
    dev-libs/icu:0/51.1= required by (dev-libs/libxml2-2.9.0-r2::gentoo, installed)
    >=dev-libs/icu-49:0/51.1= required by (dev-qt/qtcore-4.8.4-r4::gentoo, installed)
    dev-libs/icu:0/51.1= required by (sys-apps/gptfdisk-0.8.6::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/libvisio-0.0.26::gentoo, installed)

  (dev-libs/icu-49.1.2::gentoo, ebuild scheduled for merge) pulled in by
    =dev-libs/icu-49* required by (app-office/libreoffice-bin-3.6.4.3::gentoo, ebuild scheduled for merge)



why icu package not support slotted versions?
Back to top
View user's profile Send private message
figueroa
Apprentice
Apprentice


Joined: 14 Aug 2005
Posts: 221
Location: GA-USA

PostPosted: Fri May 10, 2013 5:20 pm    Post subject: Reply with quote

It does not appear to be healthy when the different required packages are not playing nicely with each other. I would rather not go back to openoffice-bin, but if they are bundling their own icu, it strikes me that they have made a good decision.
_________________
Andy Figueroa
andy@andyfigueroa.us
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Sat May 11, 2013 10:30 pm    Post subject: Reply with quote

figueroa wrote:
I would rather not go back to openoffice-bin, but if they are bundling their own icu, it strikes me that they have made a good decision.

That is diametrically opposed to Gentoo policy. If there is a package conflict, you investigate, and then open a bug.

Nowadays, portage (maybe 2.2 feature) even warns you ahead of icu upgrade what packages are going to be re-emerged. Which made me wait for libreoffice-4.0.3.3 to coincide with the icu upgrade.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
figueroa
Apprentice
Apprentice


Joined: 14 Aug 2005
Posts: 221
Location: GA-USA

PostPosted: Sun May 12, 2013 12:38 am    Post subject: Reply with quote

Genstorm, I don't follow your logic. The conflict is with libreoffice-bin-3.6.4.3, wich was installed Dec 15, stable then and now the only active version in portage, needing icu-49, when icu wants to upgrade to 51.1.
_________________
Andy Figueroa
andy@andyfigueroa.us
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9842
Location: Córdoba (Spain)

PostPosted: Sun May 12, 2013 7:26 am    Post subject: Reply with quote

The problem is icu, only icu, and always icu.

Each new version requires you to fix the abi for all the packages linking to icu, which are usually the bigger ones.

This thread has part of the story:

https://bugs.launchpad.net/ubuntu/+source/icu/+bug/675946

Some little planning and a stable api could probably help there :roll:
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Sun May 12, 2013 7:27 am    Post subject: Reply with quote

figueroa wrote:
The conflict is with libreoffice-bin-3.6.4.3, wich was installed Dec 15, stable then and now the only active version in portage, needing icu-49, when icu wants to upgrade to 51.1.

...which is a bug that should be (or is already?) reported.

EDIT: hmm OK, technically, it's not a bug because icu-49 is still there and arch as well. What you want is more like an enhancement request for a bump to =libreoffice-bin-3.6.6.2 or =libreoffice-bin-4*, as I can't find anything related here right now: https://bugs.gentoo.org/buglist.cgi?quicksearch=libreoffice-bin&list_id=1719022

Until then it's just a little conflict that you can ignore. I've had swt-3.7.2 conflict with my installed eclipse-sdk for ages until I just recently bumped the ebuild.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
figueroa
Apprentice
Apprentice


Joined: 14 Aug 2005
Posts: 221
Location: GA-USA

PostPosted: Mon May 13, 2013 1:05 am    Post subject: Reply with quote

Thank you both i92guboj and genstorm. I am really just an ordinary user. I recognize that there is a problem but I hardly know where the bug might be. I've never noticed icu even existed till now. I do notice, however, that libreoffice-bin is the only package installed on my mature system that requires a specific version of icu.
_________________
Andy Figueroa
andy@andyfigueroa.us
Back to top
View user's profile Send private message
GFCCAE6xF
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 229
Location: England, UK

PostPosted: Mon May 13, 2013 10:39 am    Post subject: Reply with quote

@figueroa
I guess it is just poor luck that new icu hit stable and libreoffice-bin is lagging behind a little.
I read yesterday or the day before that libreoffice-4 will be stabilized soon: https://bugs.gentoo.org/show_bug.cgi?id=456162#c6
Back to top
View user's profile Send private message
swimmer
Veteran
Veteran


Joined: 15 Jul 2002
Posts: 1291
Location: Netherlands

PostPosted: Wed May 15, 2013 7:03 am    Post subject: Reply with quote

rorgoroth wrote:
@figueroa
I guess it is just poor luck that new icu hit stable and libreoffice-bin is lagging behind a little.
I read yesterday or the day before that libreoffice-4 will be stabilized soon: https://bugs.gentoo.org/show_bug.cgi?id=456162#c6

Not sure that'll include the binary package as well ...
Back to top
View user's profile Send private message
GFCCAE6xF
Apprentice
Apprentice


Joined: 06 Aug 2012
Posts: 229
Location: England, UK

PostPosted: Wed May 15, 2013 7:34 am    Post subject: Reply with quote

Well, I assume so since the bin package only gets built/updated for stable versions.
Back to top
View user's profile Send private message
genstorm
Advocate
Advocate


Joined: 05 Apr 2007
Posts: 2467
Location: Austria

PostPosted: Wed May 15, 2013 2:03 pm    Post subject: Reply with quote

figueroa wrote:
I do notice, however, that libreoffice-bin is the only package installed on my mature system that requires a specific version of icu.

It's because the binary was built with icu-49 that it needs a dependency on that specific version or else it breaks. libreoffice (non-bin) and other source packages simply need a rebuild after icu upgrade, while with -bin you depend on the service of the packager.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum