Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
The *%$@ libsoup when emerging gnome 3.8
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Condomitti
n00b
n00b


Joined: 28 Jan 2013
Posts: 16

PostPosted: Sun May 05, 2013 6:57 am    Post subject: The *%$@ libsoup when emerging gnome 3.8 Reply with quote

Hello fellows,

How many of you have already emerged gnome 3.8?
After two hours seaching around, I'm still completely stuck on this conflict:

Code:
net-libs/libsoup:2.4

  (net-libs/libsoup-2.42.2::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/libsoup-2.42.1:2.4 required by (www-client/epiphany-3.8.1::gentoo, ebuild scheduled for merge)
    (and 8 more with the same problem)

  (net-libs/libsoup-2.40.3::gentoo, installed) pulled in by
    ~net-libs/libsoup-2.40.3[introspection?] required by (net-libs/libsoup-gnome-2.40.3::gentoo, installed)


Anyone has some clue that could help me on solving that conflict issue?
Apparently that's the last thing remaining in order to emerge 3.8. All others I could solve by myself.
Any help would be very appreciated!
Thanks in advance and have a good sunday!


EDIT: maybe this can add to the infos:

Code:

[blocks B      ] net-libs/libsoup-gnome ("net-libs/libsoup-gnome" is blocking net-libs/libsoup-2.42.2)
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0)
Back to top
View user's profile Send private message
mrpdaemon
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2004
Posts: 129

PostPosted: Sun May 05, 2013 7:55 am    Post subject: Reply with quote

Make sure you unmask these:

Code:
>=dev-cpp/glibmm-2.36.0
>=gnome-base/gnome-core-libs-3.8
>=gnome-base/gnome-extra-apps-3.8
>=gnome-base/gnome-core-apps-3.8


When I did so the libsoup issue could be automatically resolved by portage.
Back to top
View user's profile Send private message
Condomitti
n00b
n00b


Joined: 28 Jan 2013
Posts: 16

PostPosted: Sun May 05, 2013 3:37 pm    Post subject: Reply with quote

Thanks, mrpdaemon,

But unfortunately no success yet...

Even trying to emerge libsoup separately, I get

Code:
[blocks B      ] net-libs/libsoup-gnome ("net-libs/libsoup-gnome" is blocking net-libs/libsoup-2.42.2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/libsoup:2.4

  (net-libs/libsoup-2.42.2::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/libsoup-2.42 required by (dev-libs/libgdata-0.13.3::gentoo, installed)
    (and 5 more with the same problem)

  (net-libs/libsoup-2.40.3::gentoo, installed) pulled in by
    ~net-libs/libsoup-2.40.3[introspection?] required by (net-libs/libsoup-gnome-2.40.3::gentoo, installed)


Any tip?
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3961
Location: Irgendwo im Nirgendwo

PostPosted: Sun May 05, 2013 4:06 pm    Post subject: Reply with quote

Simply adjust your unmask/keywords, that =libsoup-2.42.1 is taken - all other libsoup-versions should stay masked.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5654

PostPosted: Sun May 05, 2013 4:12 pm    Post subject: Reply with quote

The blockers/dependencies are still wrong in some of the ebuilds.
In libsoup 2.42, net-libs/libsoup-gnome was merged back into net-libs/libsoup. If the blockers/deps were right, portage should have have handled this automatically.
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 905
Location: Pompano Beach, Florida

PostPosted: Sun May 05, 2013 6:41 pm    Post subject: Reply with quote

Try libsoup-2.42.2
https://bugs.gentoo.org/show_bug.cgi?id=468274
_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
Condomitti
n00b
n00b


Joined: 28 Jan 2013
Posts: 16

PostPosted: Sun May 05, 2013 9:30 pm    Post subject: Reply with quote

comprookie2000 wrote:
Try libsoup-2.42.2
https://bugs.gentoo.org/show_bug.cgi?id=468274


comprookie2000, I tried that, but still having the same errors.
I masked libsoup-2.40.3 but it took no effect. I must be taking some wrong step. :? :(
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 905
Location: Pompano Beach, Florida

PostPosted: Sun May 05, 2013 9:48 pm    Post subject: Reply with quote

You will need to post the complete error here or paste it somewhere.
As I understand it you need to get rid of net-libs/libsoup-gnome

Here is what I would try but its up to you, no guarantees :P

emerge -C net-libs/libsoup-gnome
emerge =net-libs/libsoup-2.42.2

fix keywords | blockers as needed also you may have some other packeges installed that depend on net-libs/libsoup-gnome not sure
_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
Condomitti
n00b
n00b


Joined: 28 Jan 2013
Posts: 16

PostPosted: Sun May 05, 2013 11:13 pm    Post subject: Reply with quote

Humm... ok..
well, the above is the result when I try to emerge libsoup2-42.2... the error doesn't change even if I mask libsoup-gnome (except for the warning in the end):


Code:
Calculating dependencies... done!
[ebuild     U #] net-libs/libsoup-2.42.2 [2.40.3]
[blocks B      ] net-libs/libsoup-gnome ("net-libs/libsoup-gnome" is blocking net-libs/libsoup-2.42.2)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/libsoup:2.4

  (net-libs/libsoup-2.42.2::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/libsoup-2.42 required by (dev-libs/libgdata-0.13.3::gentoo, installed)
    (and 5 more with the same problem)

  (net-libs/libsoup-2.40.3::gentoo, installed) pulled in by
    ~net-libs/libsoup-2.40.3[introspection?] required by (net-libs/libsoup-gnome-2.40.3::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- net-libs/libsoup-gnome-2.40.3::gentoo (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



Many thanks again for your patience.
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 905
Location: Pompano Beach, Florida

PostPosted: Sun May 05, 2013 11:32 pm    Post subject: Reply with quote

Go ahead and remove net-libs/libsoup-gnome
emerge -C net-libs/libsoup-gnome

You can always reinstall it if something bad happens :)

What happens then when you try;
emerge =net-libs/libsoup-2.42.2

after you remove net-libs/libsoup-gnome
_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
Condomitti
n00b
n00b


Joined: 28 Jan 2013
Posts: 16

PostPosted: Mon May 06, 2013 12:56 am    Post subject: Reply with quote

Haha, ok, I passed that conflict. Now I'm having some others.. I'm trying to solve that by emerging packages separetely...

this is what I'm getting trying to emerge libsoup:

Code:
Calculating dependencies... done!
[ebuild     U ~] dev-libs/libgee-0.10.1 [0.8.4]
[ebuild     U #] net-libs/libsoup-2.42.2 [2.40.3]
[ebuild     U #] net-im/telepathy-logger-0.8.0 [0.6.0]
[ebuild     U #] net-libs/gnome-online-accounts-3.8.1 [3.6.3]
[ebuild     U #] gnome-extra/evolution-data-server-3.8.1 [3.6.4] USE="gtk%* -google%"
[ebuild     U #] dev-libs/folks-0.9.1 [0.8.0]
[ebuild  r  U #] net-im/empathy-3.8.1 [3.6.4]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libgee:0.8

  (dev-libs/libgee-0.10.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgee-0.10:0.8[introspection] required by (dev-libs/folks-0.9.1::gentoo, ebuild scheduled for merge)

  (dev-libs/libgee-0.8.4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

net-libs/gnome-online-accounts:0

  (net-libs/gnome-online-accounts-3.6.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/gnome-online-accounts-3.8.1::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/gnome-online-accounts-3.7.90 required by (gnome-extra/evolution-data-server-3.8.1::gentoo, ebuild scheduled for merge)

gnome-extra/evolution-data-server:0

  (gnome-extra/evolution-data-server-3.6.4::gentoo, installed) pulled in by
    =gnome-extra/evolution-data-server-3.6* required by (mail-client/evolution-3.6.4::gentoo, installed)

  (gnome-extra/evolution-data-server-3.8.1::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-extra/evolution-data-server-3.7.90:= required by (dev-libs/folks-0.9.1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 905
Location: Pompano Beach, Florida

PostPosted: Mon May 06, 2013 8:22 am    Post subject: Reply with quote

try;
Code:

emerge -C dev-libs/libgee
emerge -C net-libs/gnome-online-accounts
emerge -C gnome-extra/evolution-data-server

emerge -avuND world
revdep-rebuild
emerge -1 libsoup


Make sure you don't have anything in your world file that is not wanted!

Code:

less /var/lib/portage/world


Be sure to be using the latest portage.

Code:

cat /etc/portage/package.accept_keywords/portage
sys-apps/portage **

cat /etc/portage/package.mask
>=sys-apps/portage-9999

_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
Condomitti
n00b
n00b


Joined: 28 Jan 2013
Posts: 16

PostPosted: Tue May 07, 2013 1:07 am    Post subject: Reply with quote

Hi comprookie2000,

I did all you told me to, but portage is still complaining about some conflicts, including libsoup-gnome (even though I've masked it).
:( don't know what else to do. I've tried emerging packages separately but also no success.
And for some reason I can't load gnome-shell anymore. Is it because of the uninstall of libsoup-gnome? I reinsalled it but still couldn't enter gnome shell.
Now I'm absolutely stuck =/
Back to top
View user's profile Send private message
comprookie2000
Developer
Developer


Joined: 25 Jul 2004
Posts: 905
Location: Pompano Beach, Florida

PostPosted: Tue May 07, 2013 1:35 am    Post subject: Reply with quote

post
equery depends net-libs/libsoup-gnome
and
emerge -pvDu world --tree

Also remove your mask for libsoup-gnome, its not doing anything as there is a blocker on libsoup ! libsoup-gnome
_________________
http://dev.gentoo.org/~dabbott/
Back to top
View user's profile Send private message
Condomitti
n00b
n00b


Joined: 28 Jan 2013
Posts: 16

PostPosted: Wed May 08, 2013 12:12 am    Post subject: Reply with quote

Hi comprookie2000,

this is the output of equery:

Code:
dev-libs/libgdata-0.13.3
dev-libs/libgweather-3.6.2
dev-libs/totem-pl-parser-2.32.6-r3
gnome-base/gvfs-1.14.2
mail-client/evolution-3.6.4
media-libs/libchamplain-0.12.3
media-sound/banshee-2.6.0
net-libs/libsocialweb-0.25.21
net-libs/rest-0.7.12
sci-geosciences/geocode-glib-0.99.0
sys-libs/libosinfo-0.2.2
www-client/epiphany-3.6.1



How can I grab the output of emerge? It's too long and when I tell it to go to a file only a part of it is printed in the file:

Code:

These are the packages that would be merged, in reverse order:

Calculating dependencies  ..... ... .... done!
[nomerge       ] gnome-base/gnome-3.6.2:2.0  USE="bluetooth cdr cups extras fallback -accessibility"
[ebuild     U #]  gnome-base/gnome-extra-apps-3.8.0:3.0 [3.6.2:3.0] USE="shotwell tracker" 0 kB
[ebuild     U #]  gnome-base/gnome-core-apps-3.8.0:3.0 [3.6.2:3.0] USE="bluetooth cdr cups networkmanager" 0 kB
[ebuild     U  ] app-office/libreoffice-3.6.6.2 [3.6.4.3] USE="binfilter branding cups dbus eds gnome gstreamer gtk java jemalloc mysql opengl postgres vba webdav (-aqua) -binfilterdebug -kde -odk {-test}" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer -nlpsolver -pdfimport -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7%* -python2_5% -python2_6%" PYTHON_TARGETS="python2_7%* -python2_5% -python2_6%" 112,775 kB
[nomerge       ] gnome-base/gnome-extra-apps-3.8.0:3.0 [3.6.2:3.0] USE="shotwell tracker"
[nomerge       ]  gnome-extra/gnome-calculator-3.8.1
[blocks b      ]   gnome-extra/gcalctool ("gnome-extra/gcalctool" is blocking gnome-extra/gnome-calculator-3.8.1)
[uninstall     ]    gnome-extra/gcalctool-6.6.2
[ebuild  N    #]  gnome-extra/gnome-calculator-3.8.1  1,029 kB
[ebuild     U #]  gnome-extra/gnome-tweak-tool-3.8.0 [3.6.1-r1] PYTHON_TARGETS="python2_7 -python2_6" 226 kB
[ebuild     U #]   gnome-base/gnome-shell-3.8.1 [3.6.3.1] USE="bluetooth i18n networkmanager (-systemd%)" PYTHON_TARGETS="python2_7 -python2_6" 1,468 kB
[ebuild     U #] net-im/empathy-3.8.1 [3.6.4] USE="geoloc gnome gnome-online-accounts map spell v4l -debug {-test} (-geocode%*) (-sendto%)" 4,605 kB
[nomerge       ] gnome-base/gnome-core-apps-3.8.0:3.0 [3.6.2:3.0] USE="bluetooth cdr cups networkmanager"
[ebuild     U #]  media-video/totem-3.8.0 [3.6.3-r1] USE="introspection nautilus nsplugin python -debug -flash -grilo -lirc {-test} -zeitgeist" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6" 3,071 kB
[ebuild     U #]  app-cdr/brasero-3.8.0:0/3.1 [3.6.1:0/3.1] USE="css introspection libburn mp3 nautilus (-packagekit) -playlist {-test} -tracker" 3,221 kB
[nomerge       ] gnome-base/gnome-extra-apps-3.8.0:3.0 [3.6.2:3.0] USE="shotwell tracker"
[ebuild     U #]  mail-client/evolution-3.8.1:2.0 [3.6.4:2.0] USE="bogofilter%* crypt gnome-online-accounts gstreamer ldap ssl weather -highlight% -kerberos -map -spamassassin%" 12,020 kB
[ebuild     U #]  media-gfx/gnome-screenshot-3.8.1 [3.6.1] 270 kB
[nomerge       ] gnome-base/gnome-3.6.2:2.0  USE="bluetooth cdr cups extras fallback -accessibility"
[nomerge       ]  gnome-base/gnome-shell-3.8.1 [3.6.3.1] USE="bluetooth i18n networkmanager (-systemd%)" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild     U #]   gnome-base/gnome-control-center-3.8.0-r1:2 [3.6.3-r1:2] USE="bluetooth colord cups gnome-online-accounts i18n socialweb -debug -kerberos -systemd -v4l (-networkmanager%*)" INPUT_DEVICES="-wacom" 6,635 kB
[ebuild     U #] net-misc/vinagre-3.8.1 [3.6.2] USE="rdp ssh telepathy -avahi -spice" 1,035 kB
[nomerge       ] gnome-base/gnome-extra-apps-3.8.0:3.0 [3.6.2:3.0] USE="shotwell tracker"
[ebuild     U #]  media-video/cheese-3.8.1:0/7 [3.6.2:0/7] USE="introspection -sendto {-test}" 3,642 kB
[nomerge       ] gnome-extra/gnome-shell-extensions-3.6.2  USE="-examples"
[nomerge       ]  gnome-base/gnome-shell-3.8.1 [3.6.3.1] USE="bluetooth i18n networkmanager (-systemd%)" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild     U #]   gnome-base/gnome-session-3.8.1 [3.6.2-r2] USE="ipv6 -debug -doc -gconf -systemd" 754 kB
[ebuild     U #]    gnome-base/gnome-settings-daemon-3.8.0 [3.6.4] USE="colord cups i18n policykit short-touchpad-timeout udev -debug (-packagekit) -smartcard {-test} (-systemd%)" INPUT_DEVICES="-wacom" 1,550 kB
[nomerge       ] app-office/libreoffice-3.6.6.2 [3.6.4.3] USE="binfilter branding cups dbus eds gnome gstreamer gtk java jemalloc mysql opengl postgres vba webdav (-aqua) -binfilterdebug -kde -odk {-test}" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer -nlpsolver -pdfimport -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7%* -python2_5% -python2_6%" PYTHON_TARGETS="python2_7%* -python2_5% -python2_6%"
[nomerge       ]  dev-db/mysql-connector-c++-1.1.1  USE="-debug -examples -gcov -static-libs"
[nomerge       ]   virtual/mysql-5.1  USE="-embedded -minimal -static"
[nomerge       ]    dev-db/mysql-5.1.67  USE="berkdb community perl ssl -big-tables -cluster -debug -embedded -extraengine -latin1 -max-idx-128 -minimal -pbxt -profiling (-selinux) -static {-test} -xtradb"
[ebuild     U  ]     dev-db/mysql-init-scripts-2.0_pre1-r3 [2.0_pre1-r2] 0 kB
[nomerge       ] gnome-base/gnome-core-apps-3.8.0:3.0 [3.6.2:3.0] USE="bluetooth cdr cups networkmanager"
[ebuild     U #]  app-editors/gedit-3.8.1 [3.6.2-r1] USE="introspection python spell {-test} -zeitgeist" PYTHON_SINGLE_TARGET="(-python2_6%) (-python2_7%*)" PYTHON_TARGETS="python3_2%* (-python2_6%) (-python2_7%*)" 3,033 kB
[ebuild     U #]  gnome-base/gnome-core-libs-3.8.0:3.0 [3.6.2:3.0] USE="cups -python" 0 kB
[ebuild     U #]   gnome-base/gvfs-1.16.1 [1.14.2] USE="bluetooth cdda gnome-keyring gnome-online-accounts%* gtk http samba udev udisks -afp -archive -avahi -bluray -doc -fuse -gdu -gphoto2 -ios -mtp% -systemd" 1,459 kB
[ebuild     U #]  gnome-extra/gnome-contacts-3.8.1 [3.6.2] USE="-v4l" 695 kB
[ebuild     U #]   dev-libs/folks-0.9.1:0/25 [0.8.0:0/25] USE="eds socialweb telepathy vala -debug {-test} -tracker -utils" 1,535 kB
[ebuild     U #]  gnome-extra/nm-applet-0.9.8.0 [0.9.6.4] USE="bluetooth -gconf -modemmanager%" 1,189 kB
[ebuild     U #]   net-misc/networkmanager-0.9.8.0 [0.9.6.4-r1] USE="bluetooth consolekit dhcpcd introspection modemmanager* nss ppp wext -avahi -connection-sharing -dhclient -doc -gnutls -resolvconf -systemd {-test%} -vala (-wimax%)" 2,009 kB
[ebuild  N    *]    net-misc/modemmanager-9999:0/1  USE="policykit qmi -doc -qmi-newest {-test}" 0 kB
[ebuild     U #]  x11-terms/gnome-terminal-3.8.1 [3.6.2] USE="nautilus%*" 1,575 kB
[ebuild     U #]  gnome-extra/gnome-power-manager-3.8.1 [3.6.0] USE="{-test}" 447 kB
[ebuild     U #]  app-crypt/seahorse-3.8.1 [3.6.3] USE="ldap -avahi -debug" 2,017 kB
[ebuild     U #]  net-wireless/gnome-bluetooth-3.8.0:2/11 [3.6.1:2/11] USE="introspection -debug (-sendto%)" 1,300 kB
[ebuild     U #] x11-misc/colord-0.1.31:0/1 [0.1.28:0/1] USE="gusb introspection udev -doc -examples -extra-print-profiles -systemd -vala" 926 kB
[nomerge       ] gnome-base/gnome-extra-apps-3.8.0:3.0 [3.6.2:3.0] USE="shotwell tracker"
[ebuild     U #]  gnome-extra/gnome-documents-3.8.1 [3.6.2] 638 kB
[nomerge       ] gnome-base/gnome-extra-apps-3.8.0:3.0 [3.6.2:3.0] USE="shotwell tracker"
[nomerge       ]  app-misc/tracker-0.16.1:0/16 [0.14.5:0/14] USE="exif flac gif gstreamer gtk iso jpeg libsecret%* miner-fs mp3 nautilus pdf tiff vorbis xml -cue (-eds) -firefox-bookmarks -gsf -iptc -laptop -networkmanager -playlist -rss {-test} -thunderbird -upnp-av -xine -xmp -xps (-applet%) (-flickr%) (-gnome-keyring%*)"
[ebuild     U #]   gnome-extra/nautilus-tracker-tags-0.16.1 [0.14.5] 5,831 kB
[ebuild     U #]    app-misc/tracker-0.16.1:0/16 [0.14.5:0/14] USE="exif flac gif gstreamer gtk iso jpeg libsecret%* miner-fs mp3 nautilus pdf tiff vorbis xml -cue (-eds) -firefox-bookmarks -gsf -iptc -laptop -networkmanager -playlist -rss {-test} -thunderbird -upnp-av -xine -xmp -xps (-applet%) (-flickr%) (-gnome-keyring%*)" 0 kB
[nomerge       ] net-im/empathy-3.8.1 [3.6.4] USE="geoloc gnome gnome-online-accounts map spell v4l -debug {-test} (-geocode%*) (-sendto%)"
[nomerge       ]  gnome-extra/gnome-contacts-3.8.1 [3.6.2] USE="-v4l"
[ebuild  N    #]   gnome-extra/evolution-data-server-3.8.1:0/40  USE="gnome-online-accounts gtk introspection ipv6 ldap vala weather -api-doc-extras -google -kerberos {-test}" 3,824 kB
[ebuild  N    #]    net-libs/gnome-online-accounts-3.8.1  USE="gnome introspection -debug -kerberos" 628 kB
[nomerge       ] gnome-base/gnome-extra-apps-3.8.0:3.0 [3.6.2:3.0] USE="shotwell tracker"
[ebuild     U #]  app-arch/file-roller-3.8.1 [3.6.3] USE="nautilus (-packagekit)" 1,476 kB
[ebuild     U #]  gnome-extra/sushi-3.8.1 [3.6.1] USE="-office" 302 kB
[ebuild     U #]   app-text/evince-3.8.0:0/evd3.4-evv3.3 [3.6.1:0/evd3.4-evv3.3] USE="gnome-keyring introspection nautilus postscript tiff -debug -djvu -dvi -t1lib -xps" 6,323 kB
[ebuild     U #]    gnome-base/nautilus-3.8.1 [3.6.3] USE="exif gnome introspection previewer -debug (-packagekit) -sendto {-test} -tracker -xmp" 4,865 kB
[nomerge       ] gnome-base/gnome-core-apps-3.8.0:3.0 [3.6.2:3.0] USE="bluetooth cdr cups networkmanager"
[ebuild     U #]  gnome-extra/yelp-3.8.0 [3.6.2] USE="-debug" 1,398 kB
[nomerge       ] gnome-base/gnome-extra-apps-3.8.0:3.0 [3.6.2:3.0] USE="shotwell tracker"
[ebuild     U #]  www-client/epiphany-3.8.1 [3.6.1] USE="jit nss -debug {-test} (-introspection%*)" 2,447 kB
[ebuild     U #]  net-misc/vino-3.8.1 [3.6.2-r1] USE="crypt gnome-keyring ipv6 jpeg ssl telepathy zlib -avahi -debug -networkmanager (-libnotify%*)" 737 kB
[ebuild     U ~]  media-gfx/shotwell-0.14.1 [0.14.0-r1] LINGUAS="pt_BR -af% -ar -as% -ast -bg -bn -ca -cs -da -de -el -en_GB -es -et -eu -fi -fr -gl -gu% -he -hi -hr -hu -ia -id -it -ja -kk -kn% -ko -lt -lv -mk -ml% -mr% -nb -nl -pa -pl -pt -ro -ru -sk -sl -sr -sv -ta -te -th -tr -uk -vi -zh_CN -zh_TW (-ta_IN%) (-te_IN%)" 1,587 kB
[nomerge       ] gnome-base/gnome-3.6.2:2.0  USE="bluetooth cdr cups extras fallback -accessibility"
[nomerge       ]  gnome-base/gnome-applets-3.6.0-r1  USE="gnome ipv6 policykit -networkmanager" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[nomerge       ]   dev-libs/libgweather-3.6.2:2/3-1  USE="introspection"
[ebuild  N    #]    net-libs/libsoup-gnome-2.40.3:2.4  USE="introspection -debug" 0 kB
[nomerge       ] www-client/epiphany-3.8.1 [3.6.1] USE="jit nss -debug {-test} (-introspection%*)"
[ebuild     U #]  net-libs/webkit-gtk-2.0.1:3/25 [1.10.2-r300:3/3] USE="geoloc gstreamer introspection jit spell webgl (-aqua) -coverage -debug {-test}" 9,612 kB
[ebuild     U ~]   app-crypt/libsecret-0.15 [0.12] USE="crypt introspection -debug {-test} -vala" 474 kB
[ebuild     U #] gnome-base/libgnome-keyring-3.8.0 [3.6.0] USE="introspection -debug {-test} -vala" 417 kB
[ebuild     U #]  gnome-base/gnome-keyring-3.8.1 [3.6.3] USE="caps filecaps%* pam -debug (-selinux) {-test}" 1,114 kB
[nomerge       ] gnome-base/gnome-core-apps-3.8.0:3.0 [3.6.2:3.0] USE="bluetooth cdr cups networkmanager"
[ebuild     U #]  media-gfx/eog-3.8.0:1 [3.6.2:1] USE="exif introspection jpeg lcms svg tiff -debug -xmp" 3,540 kB
[nomerge       ] gnome-base/gnome-extra-apps-3.8.0:3.0 [3.6.2:3.0] USE="shotwell tracker"
[ebuild     U #]  gnome-extra/gnome-system-monitor-3.8.0 [3.6.1] USE="-systemd" 2,740 kB
[ebuild     U #]  gnome-extra/gucharmap-3.8.1:2.90 [3.6.1:2.90] USE="introspection -cjk -debug {-test} -vala" 1,856 kB
[ebuild     U #]  sys-apps/baobab-3.8.1 [3.6.4] 1,012 kB
[ebuild     U #]  media-gfx/gnome-font-viewer-3.8.0 [3.6.2] 327 kB
[ebuild     U #]  app-admin/gnome-system-log-3.8.1 [3.6.1] 1,198 kB
[nomerge       ] gnome-base/gnome-core-apps-3.8.0:3.0 [3.6.2:3.0] USE="bluetooth cdr cups networkmanager"
[nomerge       ]  gnome-base/gnome-control-center-3.8.0-r1:2 [3.6.3-r1:2] USE="bluetooth colord cups gnome-online-accounts i18n socialweb -debug -kerberos -systemd -v4l (-networkmanager%*)" INPUT_DEVICES="-wacom"
[nomerge       ]   gnome-extra/gnome-color-manager-3.6.1  USE="-clutter (-packagekit) -raw"
[ebuild     U #]    gnome-base/gnome-desktop-3.8.0.1:3/4 [3.6.3:3/4] USE="introspection -debug" 987 kB
[nomerge       ] media-video/totem-3.8.0 [3.6.3-r1] USE="introspection nautilus nsplugin python -debug -flash -grilo -lirc {-test} -zeitgeist" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild     U #]  dev-libs/libpeas-1.8.0 [1.6.2-r1] USE="gtk python -gjs -glade -seed {-test}" PYTHON_SINGLE_TARGET="(-python2_6%) (-python2_7%*)" PYTHON_TARGETS="python2_7 python3_2%* -python2_6" 520 kB
[ebuild     U #] x11-themes/gnome-themes-standard-3.8.1 [3.6.5] USE="gtk" 3,700 kB
[nomerge       ] gnome-base/gnome-3.6.2:2.0  USE="bluetooth cdr cups extras fallback -accessibility"
[nomerge       ]  gnome-base/gnome-core-libs-3.8.0:3.0 [3.6.2:3.0] USE="cups -python"
[ebuild     U #]   gnome-base/dconf-0.16.0 [0.14.1] USE="X {-test}" 360 kB
[ebuild     U #]   gnome-base/gnome-desktop-3.8.1:3/7 [3.6.3:3/4] USE="introspection -debug" 988 kB
[nomerge       ] www-client/epiphany-3.8.1 [3.6.1] USE="jit nss -debug {-test} (-introspection%*)"
[ebuild     U #]  app-crypt/gcr-3.8.1:0/1 [3.6.2:0/1] USE="gtk%* introspection -debug {-test}" 1,377 kB
[ebuild     U  ] net-misc/dropbox-1.6.16 [1.2.48-r1] USE="X%* librsync-bundled%*" 19,152 kB
[ebuild    FU  ] app-emulation/emul-linux-x86-java-1.6.0.45:1.6 [1.6.0.43:1.6] USE="X alsa nsplugin -pax_kernel" 21,261 kB
[ebuild     U  ] app-arch/tar-1.26-r1 [1.26] USE="nls -minimal% -static -xattr%" 2,285 kB
[ebuild     U  ] sys-apps/man-pages-3.50 [3.47] USE="nls" LINGUAS="-da -de -fr -it -ja -nl -pl -ro -ru -zh_CN" 1,778 kB
[nomerge       ] gnome-base/gvfs-1.16.1 [1.14.2] USE="bluetooth cdda gnome-keyring gnome-online-accounts%* gtk http samba udev udisks -afp -archive -avahi -bluray -doc -fuse -gdu -gphoto2 -ios -mtp% -systemd"
[nomerge       ]  sys-fs/udisks-2.1.0:2  USE="crypt gptfdisk introspection -debug (-selinux) (-systemd)"
[ebuild     U  ]   sys-apps/gptfdisk-0.8.6 [0.8.4] USE="icu%*" 181 kB
[nomerge       ] net-fs/samba-3.6.12  USE="acl aio client cups fam ldap netapi pam readline server smbclient -addns -ads -avahi -caps -cluster -debug -dmapi -doc -examples -ldb -quota (-selinux) -smbsharemodes -swat -syslog -winbind"
[ebuild     U  ]  sys-libs/tdb-1.2.11 [1.2.10] USE="-python" 471 kB
[nomerge       ] gnome-extra/gnome-shell-extensions-3.6.2  USE="-examples"
[nomerge       ]  app-admin/eselect-gnome-shell-extensions-20120911
[nomerge       ]   gnome-base/gnome-shell-3.8.1 [3.6.3.1] USE="bluetooth i18n networkmanager (-systemd%)" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild     U #]    net-im/telepathy-logger-0.8.0:0/3 [0.6.0:0/3] USE="introspection {-test}" 528 kB
[ebuild     U #]    dev-libs/gjs-1.36.1 [1.34.0] USE="cairo%* -examples {-test}" 396 kB
[ebuild     U  ] sys-fs/e2fsprogs-1.42.7 [1.42] USE="nls -static-libs" 5,841 kB
[ebuild     U #] x11-libs/pango-1.34.0 [1.32.5] USE="X introspection -debug" 990 kB
[ebuild     U #]  media-libs/fontconfig-2.10.91:1.0 [2.8.0-r1:1.0] USE="-doc -static-libs%" ABI_X86="(64%*) -32% (-x32)" 1,473 kB
[nomerge       ] media-gfx/shotwell-0.14.1 [0.14.0-r1] LINGUAS="pt_BR -af% -ar -as% -ast -bg -bn -ca -cs -da -de -el -en_GB -es -et -eu -fi -fr -gl -gu% -he -hi -hr -hu -ia -id -it -ja -kk -kn% -ko -lt -lv -mk -ml% -mr% -nb -nl -pa -pl -pt -ro -ru -sk -sl -sr -sv -ta -te -th -tr -uk -vi -zh_CN -zh_TW (-ta_IN%) (-te_IN%)"
[ebuild  N     ]  dev-libs/libgee-0.6.7  USE="introspection" 0 kB
[ebuild     U #]  net-libs/libsoup-2.42.2:2.4 [2.40.3:2.4] USE="introspection ssl -debug -samba {-test}" 716 kB
[nomerge       ] gnome-base/gnome-3.6.2:2.0  USE="bluetooth cdr cups extras fallback -accessibility"
[nomerge       ]  gnome-base/gdm-3.6.2  USE="consolekit fallback gnome-shell introspection ipv6 ldap tcpd -accessibility -audit -debug -fprint -plymouth (-selinux) -smartcard -systemd {-test} -xinerama"
[nomerge       ]   gnome-base/gnome-shell-3.8.1 [3.6.3.1] USE="bluetooth i18n networkmanager (-systemd%)" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild     U #]    gnome-base/gnome-menus-3.8.0:3 [3.6.2:3] USE="introspection -debug {-test} (-python%*)" PYTHON_TARGETS="(-python2_6%) (-python2_7%*)" 411 kB
[nomerge       ] gnome-extra/gnome-contacts-3.8.1 [3.6.2] USE="-v4l"
[ebuild  N    ~]  dev-libs/libgee-0.10.1:0.8  USE="introspection" 606 kB
[ebuild     U #]   dev-libs/gobject-introspection-1.36.0 [1.34.2-r1] USE="cairo%* -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 1,173 kB
[ebuild     U #] x11-themes/gnome-icon-theme-3.8.0 [3.6.2] USE="branding" 15,717 kB
[nomerge       ] media-video/gnome-mplayer-1.0.7  USE="alsa dbus dconf gnome libnotify pulseaudio -ipod -musicbrainz"
[ebuild     U #]  x11-themes/gnome-icon-theme-symbolic-3.8.0.1 [3.6.2] 212 kB
[nomerge       ] net-misc/modemmanager-9999:0/1  USE="policykit qmi -doc -qmi-newest {-test}"
[ebuild  N    ~]  net-libs/libqmi-1.0.0  USE="-doc -static-libs {-test}" 2,343 kB
[nomerge       ] mail-client/evolution-3.8.1:2.0 [3.6.4:2.0] USE="bogofilter%* crypt gnome-online-accounts gstreamer ldap ssl weather -highlight% -kerberos -map -spamassassin%"
[ebuild  N     ]  mail-filter/bogofilter-1.2.3  USE="berkdb -sqlite -tokyocabinet" 849 kB
[ebuild  N     ]   sci-libs/gsl-1.14  USE="-cblas-external" 3,055 kB
[ebuild     U  ] sys-apps/baselayout-2.2 [2.1-r1] USE="-build" 40 kB
[nomerge       ] net-fs/samba-3.6.12  USE="acl aio client cups fam ldap netapi pam readline server smbclient -addns -ads -avahi -caps -cluster -debug -dmapi -doc -examples -ldb -quota (-selinux) -smbsharemodes -swat -syslog -winbind"
[ebuild     U  ]  sys-libs/talloc-2.0.8 [2.0.7] USE="-compat -python" 424 kB
[nomerge       ] app-office/libreoffice-3.6.6.2 [3.6.4.3] USE="binfilter branding cups dbus eds gnome gstreamer gtk java jemalloc mysql opengl postgres vba webdav (-aqua) -binfilterdebug -kde -odk {-test}" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer -nlpsolver -pdfimport -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7%* -python2_5% -python2_6%" PYTHON_TARGETS="python2_7%* -python2_5% -python2_6%"
[ebuild     U  ]  media-libs/libvisio-0.0.26 [0.0.25] USE="-doc -static-libs" 372 kB
[nomerge       ] sci-libs/gsl-1.14  USE="-cblas-external"
[ebuild  N     ]  app-admin/eselect-cblas-0.1  0 kB
[ebuild     U  ] sys-apps/mlocate-0.26 [0.25] USE="nls (-selinux)" 351 kB
[nomerge       ] net-fs/nfs-utils-1.2.6  USE="ipv6 nfsv4 tcpd -caps -kerberos -nfsdcld -nfsidmap -nfsv41 (-selinux)"
[ebuild     U  ]  sys-libs/e2fsprogs-libs-1.42.7 [1.42] USE="nls -static-libs" 559 kB
[ebuild  NS   ~] sys-devel/gcc-4.7.2-r1:4.7 [4.6.3:4.6] USE="cxx fortran gtk mudflap (multilib) nls nptl openmp (-altivec) -doc (-fixed-point) -gcj -go -graphite (-hardened) (-libssp) -multislot -nopie -nossp -objc -objc++ -objc-gc {-test} -vanilla" 81,001 kB
[nomerge       ] app-office/libreoffice-3.6.6.2 [3.6.4.3] USE="binfilter branding cups dbus eds gnome gstreamer gtk java jemalloc mysql opengl postgres vba webdav (-aqua) -binfilterdebug -kde -odk {-test}" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer -nlpsolver -pdfimport -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7%* -python2_5% -python2_6%" PYTHON_TARGETS="python2_7%* -python2_5% -python2_6%"
[ebuild     U  ]  app-text/libwps-0.2.8 [0.2.7] USE="-debug -doc -static-libs" 380 kB
[ebuild     U  ]  app-text/libwpg-0.2.2:0.2 [0.2.1:0.2] USE="-doc -static-libs" 368 kB
[ebuild     U #] dev-cpp/glibmm-2.36.2:2 [2.34.1:2] USE="-debug -doc -examples {-test}" 2,256 kB
[nomerge       ] app-office/libreoffice-3.6.6.2 [3.6.4.3] USE="binfilter branding cups dbus eds gnome gstreamer gtk java jemalloc mysql opengl postgres vba webdav (-aqua) -binfilterdebug -kde -odk {-test}" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer -nlpsolver -pdfimport -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7%* -python2_5% -python2_6%" PYTHON_TARGETS="python2_7%* -python2_5% -python2_6%"
[ebuild     U  ]  app-text/libwpd-0.9.7:0.9 [0.9.6:0.9] USE="tools -doc {-test}" 678 kB
[nomerge       ] app-office/libreoffice-3.6.6.2 [3.6.4.3] USE="binfilter branding cups dbus eds gnome gstreamer gtk java jemalloc mysql opengl postgres vba webdav (-aqua) -binfilterdebug -kde -odk {-test}" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer -nlpsolver -pdfimport -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7%* -python2_5% -python2_6%" PYTHON_TARGETS="python2_7%* -python2_5% -python2_6%"
[nomerge       ]  gnome-extra/evolution-data-server-3.8.1:0/40  USE="gnome-online-accounts gtk introspection ipv6 ldap vala weather -api-doc-extras -google -kerberos {-test}"
[nomerge       ]   app-crypt/gcr-3.8.1:0/1 [3.6.2:0/1] USE="gtk%* introspection -debug {-test}"
[ebuild     U ~]    app-crypt/p11-kit-0.18.1 [0.18.0] USE="asn1 trust -debug" 921 kB
[ebuild     U  ] app-shells/bash-4.2_p45 [4.2_p37] USE="net nls (readline) -afs -bashlogger -examples -mem-scramble -plugins -vanilla" 0 kB
[nomerge       ] app-office/libreoffice-3.6.6.2 [3.6.4.3] USE="binfilter branding cups dbus eds gnome gstreamer gtk java jemalloc mysql opengl postgres vba webdav (-aqua) -binfilterdebug -kde -odk {-test}" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer -nlpsolver -pdfimport -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7%* -python2_5% -python2_6%" PYTHON_TARGETS="python2_7%* -python2_5% -python2_6%"
[ebuild     U  ]  app-office/libreoffice-l10n-3.6.6.2 [3.6.4.3] USE="-offlinehelp" LINGUAS="en pt_BR -af -am -ar -as -ast -be -bg -bn -bn_IN -bo -br -brx -bs -ca -ca_XV -cs -cy -da -de -dgo -dz -el -en_GB -en_ZA -eo -es -et -eu -fa -fi -fr -ga -gd -gl -gu -he -hi -hr -hu -id -is -it -ja -ka -kk -km -kn -ko -kok -ks -ku -lb -lo -lt -lv -mai -mk -ml -mn -mni -mr -my -nb -ne -nl -nn -nr -nso -oc -om -or -pa_IN -pl -pt -ro -ru -rw -sa_IN -sat -sd -sh -si -sk -sl -sq -sr -ss -st -sv -sw_TZ -ta -te -tg -th -tn -tr -ts -tt -ug -uk -uz -ve -vi -xh -zh_CN -zh_TW -zu" 0 kB
[nomerge       ] gnome-base/gnome-core-apps-3.8.0:3.0 [3.6.2:3.0] USE="bluetooth cdr cups networkmanager"
[ebuild     U #]  gnome-extra/gnome-user-docs-3.8.0 [3.6.2] USE="{-test}" 8,838 kB
[nomerge       ] app-crypt/seahorse-3.8.1 [3.6.3] USE="ldap -avahi -debug"
[nomerge       ]  app-crypt/gcr-3.8.1:0/1 [3.6.2:0/1] USE="gtk%* introspection -debug {-test}"
[ebuild     U #]   dev-libs/gobject-introspection-common-1.36.0 [1.34.2] 0 kB
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0)
[blocks B      ] >=net-libs/libsoup-2.42 (">=net-libs/libsoup-2.42" is blocking net-libs/libsoup-gnome-2.40.3)
[blocks B      ] net-libs/libsoup-gnome ("net-libs/libsoup-gnome" is blocking net-libs/libsoup-2.42.2)

Total: 97 packages (85 upgrades, 11 new, 1 in new slot, 1 uninstall), Size of downloads: 404,347 kB
Fetch Restriction: 1 package (1 unsatisfied)
Conflict: 4 blocks (3 unsatisfied)

Fetch instructions for app-emulation/emul-linux-x86-java-1.6.0.45:



Thanks,

Condomitti.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5654

PostPosted: Wed May 08, 2013 12:33 am    Post subject: Reply with quote

Well, that output mostly shows, that mixing components from diffrent Gnome versions is a pain.
You need to unmask vala:0.20 and libgweather from Gnome 3.8.
Back to top
View user's profile Send private message
Condomitti
n00b
n00b


Joined: 28 Jan 2013
Posts: 16

PostPosted: Wed May 08, 2013 3:06 am    Post subject: Reply with quote

VoidMage, unmasking those components reduced the amount of conflicts I'm having... but it still complains about libsoup and libgweather though I've masked libgweather-3.6.2 and unmasked 3.8.

edit: I could manually install libsoup-2.42.2 and libgweather-3.8... let me check what comes next. In time: how could I eliminate the libsoup-gnome conflict (which tries to emerge libsoup-2.40?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5654

PostPosted: Wed May 08, 2013 8:51 am    Post subject: Reply with quote

Post the new output - last time, it was libgweather, that pulled libsoup-gnome, show what does now.
Back to top
View user's profile Send private message
ledabe
n00b
n00b


Joined: 09 May 2013
Posts: 1

PostPosted: Thu May 09, 2013 9:49 am    Post subject: Same problem ... Reply with quote

hello,

I had the same problems,

After hours and hours, I found a solution:
- mask net-libs/libsoup-gnome
- mask <net-libs/libsoup-2.42.2
- mask <gnome-base/gnome-desktop-3.8.1

- unmask =net-libs/libsoup-2.40.3
- unmask =dev-libs/libgweather-3.8.1

AND ... the package who still wants libsoup-gnome:
- unmask dev-libs/totem-pl-parser

(and a few emerge -C that I don't remember)
I've deleted the fallback gnome use flag, and deleted gnome-panel and gnome-applets, I don't know if those are related.

Hope this can help somebody
Back to top
View user's profile Send private message
moamahi
n00b
n00b


Joined: 10 Jan 2004
Posts: 5

PostPosted: Fri May 10, 2013 1:11 pm    Post subject: solution? Reply with quote

Hi all, I've tried almost everything but no way to solve conflict between libsoup and libsoupe-gnome.

Code:

  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( any-of ( deprecated ( gtk3 introspection ) ) )

  The above constraints are a subset of the following complete expression:
    any-of ( gtk gtk3 X ) deprecated? ( python ) python? ( any-of ( deprecated ( gtk3 introspection ) ) )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
nb-ced ~ # vi /etc/portage/make.conf
nb-ced ~ # emerge -avuND world

These are the packages that would be merged, in order:

Calculating dependencies -

!!! Problem resolving dependencies for app-i18n/ibus from @selected                                                                                                            ... done!

!!! The ebuild selected to satisfy "app-i18n/ibus" has unmet requirements.
- app-i18n/ibus-1.5.2::gentoo USE="X dconf gconf gtk nls python -deprecated -gtk3 -introspection -test -vala" PYTHON_SINGLE_TARGET="python2_7 -python2_5 -python2_6" PYTHON_TARGETS="python2_7 -python2_5 -python2_6"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( any-of ( deprecated ( gtk3 introspection ) ) )

  The above constraints are a subset of the following complete expression:
    any-of ( gtk gtk3 X ) deprecated? ( python ) python? ( any-of ( deprecated ( gtk3 introspection ) ) )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
nb-ced ~ # vi /etc/portage/make.conf
nb-ced ~ # vi /etc/portage/package.use
nb-ced ~ # emerge -avuND world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U #] dev-libs/gobject-introspection-common-1.36.0 [1.34.2] 1,173 kB
[ebuild     U #] x11-libs/gnome-pty-helper-0.34.4 [0.34.2] USE="hardened" 960 kB
[ebuild   R    ] media-libs/freetype-2.4.11:2  USE="X bindist bzip2 -auto-hinter -debug -doc -fontforge -infinality -static-libs -utils" 1,510 kB
[ebuild   R    ] sys-process/procps-3.3.4  USE="ncurses nls%* unicode -static-libs" 512 kB
[ebuild     U #] dev-cpp/glibmm-2.36.2:2 [2.34.1:2] USE="-debug -doc -examples {-test}" 2,256 kB
[ebuild  N    ~] net-libs/libqmi-1.0.0  USE="-doc -static-libs {-test}" 2,343 kB
[ebuild     U #] x11-themes/gnome-icon-theme-symbolic-3.8.0.1 [3.6.2] 212 kB
[ebuild     U #] media-libs/fontconfig-2.10.91:1.0 [2.8.0-r1:1.0] USE="-doc -static-libs%" ABI_X86="(64%*) -32% (-x32)" 1,473 kB
[ebuild     U #] dev-libs/gobject-introspection-1.36.0 [1.34.2-r1] USE="cairo%* -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[uninstall     ] dev-lang/vala-0.18.1:0.18  USE="vapigen {-test}"
[uninstall     ] dev-lang/vala-0.14.2-r2:0.14  USE="vapigen {-test}"
[blocks b      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0)
[ebuild     U ~] dev-python/dbus-python-1.2.0 [1.1.1-r1] USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_2 -python2_6 (-python3_3)" 589 kB
[ebuild     U #] dev-util/gdbus-codegen-2.36.1 [2.34.3] PYTHON_TARGETS="python2_7 python3_2 -python2_5 -python2_6 -python3_1 (-python3_3)" 0 kB
[ebuild     U #] dev-libs/atk-2.8.0::gentoo [2.7.91::gnome] USE="introspection nls {-test%}" 620 kB
[ebuild  NS   ~] sys-devel/gcc-4.7.2-r1:4.7 [4.6.3:4.6] USE="cxx fortran gtk mudflap (multilib) nls nptl openmp (-altivec) -doc (-fixed-point) -gcj -go -graphite (-hardened) (-libssp) -multislot -nopie -nossp -objc -objc++ -objc-gc {-test} -vanilla" 81,003 kB
[ebuild     U #] app-accessibility/at-spi2-core-2.8.0:2 [2.6.3:2] USE="introspection" 427 kB
[ebuild     U #] gnome-base/gsettings-desktop-schemas-3.8.0 [3.6.1] USE="introspection" 430 kB
[ebuild     U #] x11-themes/gnome-icon-theme-3.8.0 [3.6.2] USE="branding" 15,746 kB
[ebuild     U #] gnome-extra/yelp-xsl-3.8.0 [3.6.1] 577 kB
[ebuild     U #] gnome-base/gnome-menus-3.8.0:3 [3.6.2:3] USE="introspection -debug {-test} (-python%*)" PYTHON_TARGETS="(-python2_6%) (-python2_7%*)" 411 kB
[ebuild     U #] app-accessibility/at-spi2-atk-2.8.1:2 [2.6.2:2] USE="{-test}" 261 kB
[ebuild     U #] x11-libs/pango-1.34.0 [1.32.5] USE="X introspection -debug" 990 kB
[ebuild     U #] dev-python/pygobject-3.8.1:3 [3.4.2-r1:3] USE="cairo threads -examples {-test}" PYTHON_TARGETS="python2_7 python3_2 -python2_6 -python3_1 (-python3_3)" 638 kB
[ebuild     U #] media-libs/cogl-1.14.0:1.0/12::gentoo [1.13.4:1.0/12::gnome] USE="introspection opengl pango -debug -doc -examples -gles2 -profile% {-test}" 1,618 kB
[ebuild  N    #] net-libs/libsoup-2.40.3:2.4  USE="introspection samba ssl -debug {-test}" 0 kB
[ebuild     U #] x11-misc/colord-0.1.31:0/1 [0.1.28:0/1] USE="gusb introspection udev -doc -examples -extra-print-profiles -systemd -vala" 926 kB
[ebuild     U #] x11-libs/gtk+-3.8.1:3::gentoo [3.7.14:3::gnome] USE="X colord cups introspection (-aqua) -debug -examples (-packagekit) {-test} -vim-syntax -wayland -xinerama" 13,355 kB
[ebuild     U #] media-libs/clutter-1.14.2:1.0::gentoo [1.13.10:1.0::gnome] USE="gtk introspection -debug -doc {-test}" 4,976 kB
[ebuild     U #] gnome-base/dconf-0.16.0 [0.14.1] USE="X {-test}" 360 kB
[ebuild     U #] x11-themes/gnome-themes-standard-3.8.1 [3.6.5] USE="gtk" 3,700 kB
[ebuild     U #] x11-libs/vte-0.34.4:2.90 [0.34.2:2.90] USE="introspection -debug -glade" 0 kB
[ebuild     U #] media-libs/clutter-gtk-1.4.4:1.0 [1.4.2:1.0] USE="introspection -debug -examples" 304 kB
[ebuild     U #] gnome-base/libgnome-keyring-3.8.0 [3.6.0] USE="introspection -debug {-test} -vala" 417 kB
[ebuild  N    #] net-libs/libsoup-gnome-2.40.3:2.4  USE="introspection -debug" 0 kB
[ebuild  N    #] net-libs/libsoup-9999:2.4::gnome  USE="gnome introspection samba ssl -debug -doc {-test}" 0 kB
[ebuild  N    *] net-misc/modemmanager-9999:0/1  USE="policykit qmi -doc -qmi-newest {-test}" 0 kB
[ebuild     U #] net-misc/networkmanager-0.9.8.0 [0.9.6.4-r1] USE="avahi bluetooth consolekit dhcpcd introspection modemmanager* nss ppp wext -connection-sharing -dhclient -doc -gnutls -resolvconf -systemd {-test%} -vala (-wimax%)" 2,009 kB
[ebuild     U #] net-libs/webkit-gtk-2.0.1:3/25::gentoo [1.11.90-r300:3/3::gnome] USE="geoloc gstreamer introspection jit spell webgl (-aqua) -coverage -debug {-test}" 9,612 kB
[ebuild     U #] gnome-base/gnome-settings-daemon-3.8.0 [3.6.4] USE="colord cups i18n policykit short-touchpad-timeout udev -debug (-packagekit) -smartcard {-test} (-systemd%)" INPUT_DEVICES="-wacom" 1,550 kB
[ebuild  N    #] media-video/cheese-3.8.1:0/7  USE="introspection -sendto {-test}" 3,642 kB
[ebuild  N    #] gnome-extra/gnome-color-manager-3.8.1  USE="-clutter (-packagekit) -raw" 2,549 kB
[ebuild     U #] gnome-base/gnome-session-3.8.1 [3.6.2-r2] USE="ipv6 -debug -doc -gconf -systemd" 754 kB
[ebuild  N    #] net-libs/gnome-online-accounts-3.8.1  USE="gnome introspection -debug -kerberos" 628 kB
[ebuild  N    ~] dev-libs/libgdata-0.13.3:0/13  USE="gnome introspection -debug -static-libs -vala" 0 kB
[ebuild  N    #] gnome-extra/evolution-data-server-9999:0/43::gnome  USE="gnome-online-accounts google gtk introspection ipv6 kerberos ldap weather -api-doc-extras -doc {-test} -vala" 0 kB
[ebuild  N     ] app-mobilephone/obexd-0.46  USE="eds usb -nokia -server" 0 kB
[ebuild  N    #] net-wireless/gnome-bluetooth-3.8.0:2/11  USE="introspection -debug" 1,300 kB
[ebuild     U #] gnome-extra/nm-applet-0.9.8.0 [0.9.6.4] USE="bluetooth -gconf -modemmanager%" 1,189 kB
[ebuild  N    #] gnome-base/gnome-control-center-3.8.0-r1:2  USE="bluetooth colord cups gnome-online-accounts i18n socialweb v4l -debug -kerberos -systemd" INPUT_DEVICES="-wacom" 6,635 kB
[ebuild     U #] dev-libs/folks-0.9.1:0/25 [0.8.0:0/25] USE="eds socialweb telepathy -debug {-test} -tracker -utils -vala" 1,535 kB
[ebuild     U #] gnome-extra/gnome-contacts-3.8.1 [3.6.2] USE="v4l" 695 kB

Total: 49 packages (33 upgrades, 13 new, 1 in new slot, 2 reinstalls, 2 uninstalls), Size of downloads: 169,865 kB
Conflict: 1 block

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/libsoup:2.4

  (net-libs/libsoup-9999::gnome, ebuild scheduled for merge) pulled in by
    >=net-libs/libsoup-2.42.0:2.4[introspection?] required by (net-libs/webkit-gtk-2.0.1::gentoo, ebuild scheduled for merge)
    (and 1 more with the same problem)

  (net-libs/libsoup-2.40.3::gentoo, ebuild scheduled for merge) pulled in by
    ~net-libs/libsoup-2.40.3[introspection?] required by (net-libs/libsoup-gnome-2.40.3::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by net-libs/libsoup-gnome-2.40.3
# required by dev-libs/libgdata-0.13.3[gnome]
# required by gnome-extra/evolution-data-server-9999::gnome[google]
# required by app-mobilephone/obexd-0.46[eds]
# required by net-wireless/gnome-bluetooth-3.8.0
# required by gnome-base/gnome-control-center-3.8.0-r1[bluetooth]
# required by net-libs/gnome-online-accounts-3.8.1[gnome]
# required by gnome-extra/gnome-contacts-3.8.1
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
#<=gnome-base/gnome-menus-3.6.2:3
=net-libs/libsoup-2.40.3
# required by dev-libs/libgdata-0.13.3[gnome]
# required by gnome-extra/evolution-data-server-9999::gnome[google]
# required by app-mobilephone/obexd-0.46[eds]
# required by net-wireless/gnome-bluetooth-3.8.0
# required by gnome-base/gnome-control-center-3.8.0-r1[bluetooth]
# required by net-libs/gnome-online-accounts-3.8.1[gnome]
# required by gnome-extra/gnome-contacts-3.8.1
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
#<=gnome-base/gnome-menus-3.6.2:3
=net-libs/libsoup-gnome-2.40.3

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by net-libs/webkit-gtk-2.0.1
# required by net-libs/gnome-online-accounts-3.8.1
# required by gnome-extra/evolution-data-server-9999::gnome[gnome-online-accounts]
# required by app-mobilephone/obexd-0.46[eds]
# required by net-wireless/gnome-bluetooth-3.8.0
# required by gnome-base/gnome-control-center-3.8.0-r1[bluetooth]
>=net-libs/libsoup-9999 introspection
# required by net-libs/libsoup-gnome-2.40.3
# required by dev-libs/libgdata-0.13.3[gnome]
# required by gnome-extra/evolution-data-server-9999::gnome[google]
# required by app-mobilephone/obexd-0.46[eds]
# required by net-wireless/gnome-bluetooth-3.8.0
# required by gnome-base/gnome-control-center-3.8.0-r1[bluetooth]
# required by net-libs/gnome-online-accounts-3.8.1[gnome]
# required by gnome-extra/gnome-contacts-3.8.1
# required by @selected
# required by @world (argument)
=net-libs/libsoup-2.40.3 introspection

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
nb-ced ~ # emerge --info
Portage 2.1.11.62 (default/linux/amd64/13.0/desktop/gnome, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.7.10-gentoo-r1-x86_64-Intel-R-_Core-TM-_i7-2640M_CPU_@_2.80GHz-with-gentoo-2.2
KiB Mem:     3998212 total,   1748932 free
KiB Swap:    4000148 total,   4000148 free
Timestamp of tree: Fri, 10 May 2013 10:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p45
dev-java/java-config:     2.1.12-r1
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo java-overlay gnome
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=corei7 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=corei7 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.lagis.at/"
LANG="it_IT.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/java-overlay /var/lib/layman/gnome"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 apache2 automount avahi berkdb bindist bitmap-fonts bluetooth branding bzip2 cairo calendar cdda cdr cgi cjk cli colord consolekit cracklib crypt ctype cups curl cxx dbus dri dts dvd dvdr eds emboss emerald encode evo exchange exif fam festival ffmpeg firefox flac fortran fuse g3dvl gd gdbm gdu gif gimp gnome gnome-keyring gnome-online-accounts gphoto2 gpm gstreamer gtk gtk3 iconv icu imap ipv6 java jpeg laptop lcms libnotify libsecret logrotate mad mdnsresponder-compat mmx mng modules mp3 mp4 mpeg mudflap multilib mysql mysqli nautilus ncurses networkmanager nls nptl nsplugin ntfs odbc ogg opengl openmp pam pango pcre pdf php png policykit ppds pulseaudio python qt3support readline samba sdl session socialweb spell sqlite3 sse sse2 ssl startup-notification svg tcpd template tiff truetype udev udisks unicode upower usb v4l v4l2 vhosts video virtualbox vorbis webdav wxwidgets x264 xcb xml xv xvid xvmc zip zlib" ABI_X86="64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="it" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

nb-ced ~ #


This is the log of the last try, remove use introspection.

Please help.
My laptop is off!

:-)

Thank you in advance

moamahi
Back to top
View user's profile Send private message
HayarobiPark
n00b
n00b


Joined: 17 Apr 2013
Posts: 5

PostPosted: Sat May 11, 2013 2:51 am    Post subject: I solved this by Reply with quote

I've just solved this conflict, by unmasking some unstable packages.

I added net-libs/gssdp-0.14.2 pacakge to my package.accept_keywords

Current stable build, gssdp-0.12.x depends on libsoup-gnome, but 0.14.2 depends on libsoup:3.4 or libsoup-gnome

The other packages the depends on only libsoup-gnome are stable but somewhat old versions; there may be new unstable or masked versions of them. Lots of them might be solved by unmasking gnome-3.8 related packages. (totem-pl-parser and libgweather in my case)

If you still have trouble, run emerge -pvt gnome , look for the packages that depends on libsoup-gnome, and then install newer (unstable or masked) versions of that packages.
Back to top
View user's profile Send private message
Condomitti
n00b
n00b


Joined: 28 Jan 2013
Posts: 16

PostPosted: Sat May 11, 2013 5:34 pm    Post subject: Reply with quote

Hi guys.. I tried everything as suggested in the above messages, and also some other things, but I can't get gnome 3.8 to emerge at all! god damn it, I feel completely dumb!

Sorry my insistence but if some of you could keep trying to help me I would really appreciate that.

This what I have so far...


accept_keywords:

Code:

#Gnome 3
app-accessibility/at-spi2-core
app-accessibility/caribou
app-arch/file-roller
app-cdr/brasero
app-crypt/p11-kit
app-crypt/seahorse
app-editors/gedit
app-misc/tracker
app-text/evince
app-text/yelp-tools
dev-cpp/glibmm
dev-cpp/gtkmm
dev-lang/spidermonkey
dev-libs/atk
dev-libs/folks
dev-libs/gjs
dev-libs/glib
#dev-libs/gobject-introspection
dev-libs/gobject-introspection-common
dev-libs/libgdata
dev-libs/libgweather
dev-libs/libpeas
dev-python/pyatspi
dev-util/gtk-builder-convert
games-board/aisleriot
gnome-base/gdm
gnome-base/gnome
gnome-base/gnome-applets
gnome-base/gnome-control-center
gnome-base/gnome-core-apps
gnome-base/gnome-core-libs
gnome-base/gnome-desktop
gnome-base/gnome-extra-apps
gnome-base/gnome-fallback
gnome-base/gnome-keyring
gnome-base/gnome-menus
gnome-base/gnome-panel
gnome-base/gnome-session
gnome-base/gnome-settings-daemon
gnome-base/gnome-shell
gnome-base/libgnomekbd
gnome-base/libgnome-keyring
gnome-base/nautilus
gnome-base/librsvg
gnome-extra/evolution-data-server
gnome-extra/gcalctool
gnome-extra/gconf-editor
gnome-extra/gnome-contacts
gnome-extra/gnome-documents
gnome-extra/gnome-games
gnome-extra/gnome-power-manager
gnome-extra/gnome-screensaver
gnome-extra/gnome-system-monitor
gnome-extra/gnome-tweak-tool
gnome-extra/gnome-user-docs
gnome-extra/gnome-utils
gnome-extra/gucharmap
gnome-extra/nautilus-tracker-tags
gnome-extra/nm-applet
gnome-extra/sushi
gnome-extra/yelp
gnome-extra/yelp-xsl
mail-client/evolution
media-gfx/eog
media-gfx/shotwell
media-libs/clutter
media-libs/cogl
media-libs/gexiv2
media-libs/libchamplain
media-libs/libgnome-media-profiles
media-libs/libraw
media-sound/sound-juicer
media-video/cheese
media-video/totem
net-analyzer/gnome-nettool
net-im/empathy
net-im/telepathy-logger
net-libs/gnome-online-accounts
net-libs/liboauth
net-libs/libsocialweb
net-libs/libsoup ~amd64
net-libs/libsoup-gnome ~amd64
net-libs/telepathy-glib
net-libs/webkit-gtk
net-misc/networkmanager
net-misc/vinagre
net-misc/vino
net-print/cups-pk-helper
net-wireless/gnome-bluetooth
sys-apps/accountsservice
www-client/epiphany
x11-libs/gdk-pixbuf
x11-libs/gtk+
x11-libs/gtksourceview
x11-libs/libwnck
x11-libs/mx
x11-libs/pango
x11-libs/vte
x11-misc/notification-daemon
x11-terms/gnome-terminal
x11-themes/gnome-backgrounds
x11-themes/gnome-icon-theme-symbolic
x11-themes/gnome-themes-standard
x11-wm/metacity
x11-wm/mutter
x11-base/xorg-server

#required by x11-themes/gnome-themes-standard-3.4.2, required by gnome-base/gnome-session-3.2.1-r1, required by gnome-base/gnome-control-center-3.2.3, required by net-libs/gnome-online-accounts-3.2.1[gnome], required by gnome-extra/gnome-documents-0.2.1, required by gnome-base/gnome-extra-apps-3.2.1[tracker], required by gnome-base/gnome-3.2.1[extras], required by gnome (argument)
=gnome-base/gsettings-desktop-schemas-3.4.2 ~x86
=gnome-base/gvfs-1.12.3 ~x86
=sys-apps/util-linux-2.21.2 ~x86
=sys-fs/udisks-1.97.0-r1 ~x86
=net-libs/libgrss-0.3.0 ~x86
=dev-util/gdbus-codegen-2.32.3 ~x86
=dev-libs/gobject-introspection-1.32.1 ~x86
=x11-proto/inputproto-2.2 ~x86
=x11-libs/libpciaccess-0.13.1 ~x86
=x11-base/xorg-drivers-1.12 ~x86
#required by media-plugins/gst-plugins-meta-1.0-r1[dvd,a52], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-plugins/gst-plugins-a52dec-1.0.5 ~amd64
#required by media-plugins/gst-plugins-meta-1.0-r1[dts], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-plugins/gst-plugins-dts-1.0.5 ~amd64
#required by gnome-base/gconf-2.32.4, required by gnome-extra/gconf-editor-3.0.1, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=dev-libs/gobject-introspection-1.34.2-r1 ~amd64
#required by app-editors/gedit-3.6.2-r1[python], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=dev-python/pygobject-3.4.2-r1 ~amd64
#required by gnome-base/gnome-desktop-3.6.2, required by gnome-base/gnome-control-center-3.6.3-r1, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=gnome-base/gsettings-desktop-schemas-3.6.1 ~amd64
#required by media-plugins/gst-plugins-meta-1.0-r1[cdda], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-plugins/gst-plugins-cdparanoia-1.0.5 ~amd64
#required by gnome-base/gnome-shell-3.6.2-r1, required by gnome-base/gdm-3.6.2[gnome-shell], required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=app-accessibility/at-spi2-atk-2.6.2 ~amd64
#required by media-plugins/gst-plugins-meta-1.0-r1[aac], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-plugins/gst-plugins-faad-1.0.5 ~amd64
#required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=x11-themes/gnome-icon-theme-3.6.2 ~amd64
#required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=gnome-extra/gnome-search-tool-3.6.0 ~amd64
#required by gnome-base/gnome-core-libs-3.6.2, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=gnome-base/gvfs-1.14.2 ~amd64
#required by media-plugins/gst-plugins-mpeg2dec-1.0.5, required by media-plugins/gst-plugins-meta-1.0-r1[dvd,mpeg,-vcd], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-libs/gst-plugins-ugly-1.0.5 ~amd64
#required by app-cdr/brasero-3.6.1, required by gnome-base/gnome-core-apps-3.6.2[cdr], required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=gnome-base/gnome-common-3.6.0 ~amd64
#required by app-misc/tracker-0.14.4[iso], required by gnome-base/gnome-extra-apps-3.6.2[tracker], required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=sys-libs/libosinfo-0.2.2 ~amd64
#required by media-video/totem-3.6.3-r1, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-plugins/gst-plugins-meta-1.0-r1 ~amd64
#required by media-video/cheese-3.6.2, required by net-im/empathy-3.6.3[v4l], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-plugins/gst-plugins-vpx-1.0.5 ~amd64
#required by gnome-base/gnome-core-libs-3.6.2, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=gnome-base/dconf-0.14.1 ~amd64
#required by net-libs/farstream-0.2.2, required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-plugins/gst-plugins-libnice-0.1.3-r100 ~amd64
#required by app-admin/system-config-printer-common-1.3.11-r1, required by app-admin/system-config-printer-gnome-1.3.11, required by gnome-base/gnome-control-center-3.6.3-r1[cups], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=dev-python/dbus-python-1.1.1-r1 ~amd64
#required by gnome-base/gnome-control-center-3.6.3-r1[-systemd], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=app-admin/openrc-settingsd-1.0.1 ~amd64
#required by x11-libs/pango-1.32.5, required by gnome-base/gnome-core-libs-3.6.2, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-libs/harfbuzz-0.9.11 ~amd64
#required by gnome-base/gnome-settings-daemon-3.6.4[colord], required by gnome-base/gnome-control-center-3.6.3-r1, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=x11-misc/colord-0.1.28 ~amd64
#required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=app-dicts/gnome-dictionary-3.6.0 ~amd64
#required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=sys-apps/baobab-3.6.4 ~amd64
#required by media-plugins/gst-plugins-meta-1.0-r1[mp3], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-plugins/gst-plugins-mad-1.0.5 ~amd64
#required by media-video/cheese-3.6.2, required by net-im/empathy-3.6.3[v4l], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-plugins/gst-plugins-v4l2-1.0.5 ~amd64
#required by gnome-base/nautilus-3.6.3, required by app-text/evince-3.6.1[nautilus], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=dev-util/gdbus-codegen-2.34.3 ~amd64
#required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=net-im/telepathy-mission-control-5.14.0-r1 ~amd64
#required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-gfx/gnome-screenshot-3.6.1 ~amd64
#required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=app-admin/gnome-system-log-3.6.1 ~amd64
#required by media-plugins/gst-plugins-meta-1.0-r1[flac], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-plugins/gst-plugins-flac-1.0.5 ~amd64
#required by gnome-extra/gnome-documents-3.6.2, required by gnome-base/gnome-extra-apps-3.6.2[tracker], required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=net-libs/libzapojit-0.0.2 ~amd64
#required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-gfx/gnome-font-viewer-3.6.2 ~amd64
#required by media-plugins/gst-plugins-meta-1.0-r1[dvd], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-plugins/gst-plugins-dvdread-1.0.5 ~amd64
#required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=app-crypt/gcr-3.6.2 ~amd64
#required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-libs/clutter-gst-2.0.0 ~amd64
#required by gnome-extra/zeitgeist-0.9.5, required by dev-libs/libzeitgeist-0.3.18, required by dev-libs/folks-0.8.0[telepathy], required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=dev-python/pyxdg-0.25 ~amd64
#required by media-video/cheese-3.6.2, required by net-im/empathy-3.6.3[v4l], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-plugins/gst-plugins-jpeg-1.0.5 ~amd64
#required by gnome-extra/evolution-data-server-3.6.3, required by gnome-base/gnome-shell-3.6.2-r1, required by gnome-base/gdm-3.6.2[gnome-shell], required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=dev-util/fix-la-relink-command-0.1.1 ~amd64
#required by gnome-base/gnome-core-libs-3.6.2, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-libs/gst-plugins-good-1.0.5 ~amd64
#required by net-libs/farstream-0.2.2, required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-libs/gst-plugins-bad-1.0.5 ~amd64
#required by media-plugins/gst-plugins-meta-1.0-r1[dvd,mpeg,-vcd], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-plugins/gst-plugins-mpeg2dec-1.0.5 ~amd64
#required by gnome-base/gnome-control-center-3.6.3-r1[i18n], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=app-i18n/ibus-1.4.99.20121006 ~amd64
#required by media-plugins/gst-plugins-meta-1.0-r1[dvd], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-plugins/gst-plugins-resindvd-1.0.5 ~amd64
#required by media-plugins/gst-plugins-vpx-1.0.5, required by media-video/cheese-3.6.2, required by net-im/empathy-3.6.3[v4l], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-libs/libvpx-1.1.0 ~amd64
#required by dev-python/pygobject-3.4.2-r1[cairo], required by gnome-base/gnome-core-libs-3.6.2[python], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=dev-python/pycairo-1.10.0-r4 ~amd64
#required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=net-libs/telepathy-farstream-0.6.0 ~amd64
#required by media-video/totem-3.6.3-r1, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-plugins/gst-plugins-taglib-1.0.5 ~amd64
#required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=net-libs/farstream-0.2.2 ~amd64
#required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=x11-themes/gnome-icon-theme-extras-3.6.2 ~amd64
#required by media-libs/gst-plugins-good-1.0.5, required by media-plugins/gst-plugins-flac-1.0.5, required by media-sound/sound-juicer-3.5.1_pre20121231[flac], required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-libs/gst-plugins-base-1.0.5-r1 ~amd64
#required by gnome-base/gnome-control-center-3.6.3-r1, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=dev-libs/libpwquality-1.2.0-r2 ~amd64
#required by app-accessibility/caribou-0.4.7, required by gnome-base/gnome-shell-3.6.2-r1, required by gnome-base/gdm-3.6.2[gnome-shell], required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=dev-libs/libgee-0.8.3 ~amd64
#required by mail-client/evolution-3.6.3, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=gnome-extra/gtkhtml-4.6.2 ~amd64
#required by dev-libs/libzeitgeist-0.3.18, required by dev-libs/folks-0.8.0[telepathy], required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=gnome-extra/zeitgeist-0.9.5 ~amd64
#required by dev-libs/folks-0.8.0[telepathy], required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=dev-libs/libzeitgeist-0.3.18 ~amd64
#required by gnome-extra/zeitgeist-0.9.5, required by dev-libs/libzeitgeist-0.3.18, required by dev-libs/folks-0.8.0[telepathy], required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=dev-python/rdflib-3.2.3 ~amd64
#required by media-plugins/gst-plugins-meta-1.0-r1[x264], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-plugins/gst-plugins-x264-1.0.5 ~amd64
#required by media-plugins/gst-plugins-meta-1.0-r1[pulseaudio], required by media-sound/sound-juicer-3.5.1_pre20121231, required by gnome-base/gnome-extra-apps-3.6.2, required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-plugins/gst-plugins-pulse-1.0.5 ~amd64
#required by app-crypt/seahorse-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=app-crypt/libsecret-0.12 ~amd64
#required by media-video/cheese-3.6.2, required by net-im/empathy-3.6.3[v4l], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=media-libs/gstreamer-1.0.5 ~amd64
#required by net-misc/openssh-5.9_p1-r4[pam], required by app-crypt/seahorse-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=sys-auth/pambase-20120417-r1 ~amd64
#required by gnome-extra/gnome-documents-3.6.2, required by gnome-base/gnome-extra-apps-3.6.2[tracker], required by gnome-base/gnome-3.6.2[extras], required by @selected, required by @world (argument)
=media-libs/clutter-gtk-1.4.2 ~amd64
#required by gnome-base/gnome-control-center-3.6.3-r1[colord], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=gnome-extra/gnome-color-manager-3.6.1 ~amd64
#required by net-im/empathy-3.6.3[geocode], required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=sci-geosciences/geocode-glib-0.99.0 ~amd64
#required by media-plugins/gst-plugins-libnice-0.1.3-r100, required by net-libs/farstream-0.2.2, required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=net-libs/libnice-0.1.3-r1 ~amd64
#required by dev-python/rdflib-3.2.3, required by gnome-extra/zeitgeist-0.9.5, required by dev-libs/libzeitgeist-0.3.18, required by dev-libs/folks-0.8.0[telepathy], required by net-im/empathy-3.6.3, required by gnome-base/gnome-core-apps-3.6.2, required by gnome-base/gnome-3.6.2, required by @selected, required by @world (argument)
=dev-python/isodate-0.4.9 ~amd64
#required by virtual/udev-197, required by sys-fs/udev-init-scripts-22
=sys-fs/udev-197-r5 ~amd64
#required by takao-fonts (argument)
=media-fonts/takao-fonts-003.02.01 ~amd64
#required by nautilus-share (argument)
=gnome-extra/nautilus-share-0.7.3-r1 ~amd64
#required by dev-java/oracle-jdk-bin (argument)
=dev-java/oracle-jdk-bin-1.7.0.13 ~amd64
#required by dev-java/oracle-jre-bin (argument)
=dev-java/oracle-jre-bin-1.7.0.17 ~amd64
=sys-kernel/git-sources-3.8_rc6 ~amd64
#required by win32codecs (argument)
=media-libs/win32codecs-20071007-r4 ~amd64
#required by realcodecs (argument)
=media-libs/realcodecs-11.0.1.1056-r1 ~amd64
#required by media-plugins/gst-plugins-meta-1.0-r1[ffmpeg], required by gst-plugins-meta (argument)
=media-plugins/gst-plugins-libav-1.0.5 ~amd64
#required by gnome-rdp (argument)
=net-misc/gnome-rdp-0.3.0.9 ~amd64
#required by playonlinux (argument)
=app-emulation/playonlinux-4.1.1-r1 ~amd64
#required by arduino (argument)
=dev-embedded/arduino-1.0.3-r1 ~amd64
#required by dev-embedded/arduino-1.0.3-r1, required by arduino (argument)
=dev-embedded/uisp-20050207-r1 ~amd64
#required by nodejs (argument)
=net-libs/nodejs-0.10.1 ~amd64
#required by skype (argument)
=net-im/skype-4.1.0.20 ~amd64
#required by media-gfx/gimp-2.8.4, required by >=media-gfx/gimp-2.8.4 (argument)
=media-libs/gegl-0.2.0-r1 ~amd64
#required by media-libs/gegl-0.2.0-r1, required by media-gfx/gimp-2.8.4, required by >=media-gfx/gimp-2.8.4 (argument)
=media-libs/babl-0.1.10 ~amd64
#required by >=media-gfx/gimp-2.8.4 (argument)
=media-gfx/gimp-2.8.4 ~amd64
#required by ardour (argument)
=media-sound/ardour-2.8.16 ~amd64
# required by simple-mtpfs (argument)
=sys-fs/simple-mtpfs-0.1 ~amd64
# required by x11-base/xorg-server-1.14.0
# required by @selected
# required by @world (argument)
=x11-proto/inputproto-2.3 ~amd64
# required by x11-base/xorg-server-1.14.0[xorg]
# required by @selected
# required by @world (argument)
=x11-base/xorg-drivers-1.14 ~amd64
x11-drivers/xf86-input-synaptics ~amd64
# required by media-video/pitivi (argument)
=media-video/pitivi-0.15.2 ~amd64
# required by media-video/pitivi-0.15.2
# required by media-video/pitivi (argument)
=media-libs/gnonlin-0.10.17 ~amd64
# required by app-crypt/gcr-3.6.2
# required by gnome-base/gnome-keyring-3.6.3
# required by gnome-extra/evolution-data-server-3.6.4
# required by mail-client/evolution-3.6.4
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
=dev-libs/libtasn1-2.14 ~amd64
# required by gnome-extra/gnome-shell-extensions-3.6.2
# required by gnome-shell-extensions (argument)
=app-admin/eselect-gnome-shell-extensions-20120911 ~amd64
# required by gnome-shell-extensions (argument)
=gnome-extra/gnome-shell-extensions-3.6.2 ~amd64
# required by gnome-base/gnome-shell-3.8.1
# required by app-admin/eselect-gnome-shell-extensions-20120911
# required by gnome-extra/gnome-shell-extensions-3.6.2
# required by @selected
# required by @world (argument)
=gnome-base/gsettings-desktop-schemas-3.8.0 ~amd64
# required by dev-libs/libgee-0.8.4[introspection]
# required by app-accessibility/caribou-0.4.10
# required by gnome-base/gnome-shell-3.8.1
# required by app-admin/eselect-gnome-shell-extensions-20120911
# required by gnome-extra/gnome-shell-extensions-3.6.2
# required by @selected
# required by @world (argument)
=dev-libs/gobject-introspection-1.36.0 ~amd64
# required by x11-wm/mutter-3.8.1
# required by gnome-base/gnome-shell-3.8.1
# required by app-admin/eselect-gnome-shell-extensions-20120911
# required by gnome-extra/gnome-shell-extensions-3.6.2
# required by @selected
# required by @world (argument)
=x11-libs/libXi-1.7.1 ~amd64
# required by www-client/epiphany-3.8.1
# required by epiphany (argument)
=app-crypt/libsecret-0.15 ~amd64
# required by net-libs/webkit-gtk-2.0.1
# required by gnome-extra/gnome-documents-3.8.1
# required by gnome-documents (argument)
=sys-devel/gcc-4.7.2-r1 ~amd64
# required by net-misc/modemmanager-9999[qmi]
# required by net-misc/networkmanager-0.9.8.0[modemmanager]
# required by gnome-base/gnome-control-center-3.8.0-r1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
=net-libs/libqmi-1.0.0 ~amd64
# required by net-misc/networkmanager-0.9.8.0[modemmanager]
# required by gnome-base/gnome-control-center-3.8.0-r1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
=net-misc/modemmanager-9999 **
# required by net-im/empathy-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
=dev-libs/libgee-0.10.1 ~amd64
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
=x11-themes/gnome-icon-theme-3.8.0 ~amd64
# required by x11-libs/pango-1.32.5
# required by gnome-extra/gnome-documents-3.8.1
# required by gnome-base/gnome-extra-apps-3.8.0[tracker]
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
=media-libs/fontconfig-2.10.91 ~amd64
# required by gnome-base/gnome-core-libs-3.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
=gnome-base/gvfs-1.16.1 ~amd64
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
=sys-apps/baobab-3.8.1 ~amd64
# required by gnome-base/gnome-keyring-3.6.3
# required by www-client/epiphany-3.8.1
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
=app-crypt/gcr-3.8.1 ~amd64
# required by gnome-base/gnome-core-libs-3.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
=gnome-base/dconf-0.16.0 ~amd64
# required by gnome-base/gnome-settings-daemon-3.6.4[colord]
# required by gnome-base/gnome-session-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
=x11-misc/colord-0.1.31 ~amd64
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
=media-gfx/gnome-screenshot-3.8.1 ~amd64
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
=app-admin/gnome-system-log-3.8.1 ~amd64
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
=media-gfx/gnome-font-viewer-3.8.0 ~amd64
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
=gnome-extra/gnome-calculator-3.8.1 ~amd64
=net-libs/gssdp-0.14.2


package.unmask:

Code:

#required by virtual/udev-197, required by sys-fs/udev-init-scripts-22
# /etc/portage/package.mask/masked_pkgs:
=sys-fs/udev-197-r5
#required by amd64codecs (argument)
# /usr/portage/profiles/package.mask:
# Steve Dibb <beandog@gentoo.org> (05 Nov 2008)
# Mask realplayer codecs for security bug 245662
=media-libs/amd64codecs-20071007
#required by realcodecs (argument)
# /usr/portage/profiles/package.mask:
# Steve Dibb <beandog@gentoo.org> (05 Nov 2008)
# Mask realplayer codecs for security bug 245662
=media-libs/realcodecs-11.0.1.1056-r1
>=gnome-base/gnome-shell-3.8.0
# required by media-libs/clutter-gst-2.0.0
# required by media-video/cheese-3.6.2
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=media-libs/clutter-1.14.2
# required by x11-libs/gtk+-3.8.1
# required by gnome-base/gnome-shell-3.8.1
# required by app-admin/eselect-gnome-shell-extensions-20120911
# required by gnome-extra/gnome-shell-extensions-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=dev-libs/atk-2.8.0
# required by net-im/empathy-3.6.4
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=media-libs/cogl-1.14.0
# required by gnome-base/gnome-shell-3.8.1
# required by app-admin/eselect-gnome-shell-extensions-20120911
# required by gnome-extra/gnome-shell-extensions-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/gsettings-desktop-schemas-3.8.0
# required by gnome-base/gnome-shell-3.8.1
# required by app-admin/eselect-gnome-shell-extensions-20120911
# required by gnome-extra/gnome-shell-extensions-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=x11-wm/mutter-3.8.1
# required by media-gfx/eog-3.6.2
# required by gnome-base/gnome-core-apps-3.6.2
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/gnome-desktop-3.8.0
# required by dev-libs/gobject-introspection-1.36.0
# required by dev-libs/gjs-1.36.1
# required by gnome-base/gnome-shell-3.8.1
# required by app-admin/eselect-gnome-shell-extensions-20120911
# required by gnome-extra/gnome-shell-extensions-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=dev-libs/gobject-introspection-common-1.36.0
# required by gnome-base/gnome-core-libs-3.6.2
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=dev-libs/glib-2.36.1
# required by gnome-base/gnome-shell-3.8.1
# required by app-admin/eselect-gnome-shell-extensions-20120911
# required by gnome-extra/gnome-shell-extensions-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=dev-libs/gjs-1.36.1
# required by dev-libs/libgee-0.8.4[introspection]
# required by app-accessibility/caribou-0.4.10
# required by gnome-base/gnome-shell-3.8.1
# required by app-admin/eselect-gnome-shell-extensions-20120911
# required by gnome-extra/gnome-shell-extensions-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=dev-libs/gobject-introspection-1.36.0
# required by sys-apps/baobab-3.6.4
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=x11-libs/gtk+-3.8.1
>=gnome-extra/gnome-tweak-tool-3.8.0
>=gnome-extra/gnome-color-manager-3.8.0
>=gnome-extra/gnome-documents-3.8.0
>=www-client/epiphany-3.8.0
>=media-gfx/gnome-font-viewer-3.8.0
# required by app-misc/tracker-0.16.1[nautilus]
# required by gnome-extra/gnome-documents-3.8.1
# required by gnome-documents (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-extra/nautilus-tracker-tags-0.16.1
# required by gnome-extra/nautilus-tracker-tags-0.16.1
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=app-misc/tracker-0.16.1
# required by net-libs/webkit-gtk-2.0.1
# required by gnome-extra/gnome-documents-3.8.1
# required by gnome-documents (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=net-libs/libsoup-2.42.2
# required by gnome-extra/gnome-documents-3.8.1
# required by gnome-documents (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=app-text/evince-3.8.0
# required by gnome-extra/sushi-3.6.1
# required by gnome-base/gnome-extra-apps-3.6.2
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=net-libs/webkit-gtk-2.0.1
>=dev-cpp/glibmm-2.36.0
>=gnome-base/gnome-core-libs-3.8
>=gnome-base/gnome-extra-apps-3.8
>=gnome-base/gnome-core-apps-3.8
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=x11-themes/gnome-themes-standard-3.8.1
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=mail-client/evolution-3.8.1
# required by x11-libs/pango-1.32.5
# required by gnome-extra/gnome-documents-3.8.1
# required by gnome-base/gnome-extra-apps-3.8.0[tracker]
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=media-libs/fontconfig-2.10.91
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=sys-apps/baobab-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0[networkmanager]
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-extra/nm-applet-0.9.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=x11-themes/gnome-icon-theme-symbolic-3.8.0.1
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=net-misc/vino-3.8.1
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-extra/sushi-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-extra/gnome-user-docs-3.8.0
# required by net-im/empathy-3.6.4[v4l]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=media-video/cheese-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/gnome-settings-daemon-3.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-extra/gnome-power-manager-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-extra/gnome-contacts-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0[cdr]
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=app-cdr/brasero-3.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/gnome-session-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=media-video/totem-3.8.0
# required by gnome-base/gnome-keyring-3.6.3
# required by www-client/epiphany-3.8.1
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=app-crypt/gcr-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=app-crypt/seahorse-3.8.1
# required by gnome-base/gnome-core-libs-3.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/dconf-0.16.0
# required by gnome-base/gnome-settings-daemon-3.6.4[colord]
# required by gnome-base/gnome-session-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=x11-misc/colord-0.1.31
# required by net-im/empathy-3.6.4
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=net-im/telepathy-logger-0.8.0
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=media-gfx/gnome-screenshot-3.8.1
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=app-admin/gnome-system-log-3.8.1
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=net-misc/vinagre-3.8.1
# required by gnome-base/gnome-core-libs-3.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=x11-libs/pango-1.34.0
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-extra/gnome-system-monitor-3.8.0
# required by net-im/empathy-3.6.4
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=dev-libs/folks-0.9.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=x11-terms/gnome-terminal-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=net-im/empathy-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=media-gfx/eog-3.8.0
# required by gnome-extra/gnome-shell-extensions-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/gnome-menus-3.8.0
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=app-arch/file-roller-3.8.1
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-extra/gnome-calculator-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/gnome-keyring-3.8.1
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-extra/gucharmap-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/gnome-control-center-3.8.0-r1
# required by gnome-base/gnome-panel-3.6.2
# required by gnome-base/gnome-applets-3.6.0-r1[gnome]
# required by gnome-base/gnome-3.6.2[fallback]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
>=gnome-base/gnome-panel-3.8.0
=gnome-extra/evolution-data-server-3.8.1
# required by gnome-base/gnome-core-libs-3.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/gvfs-1.16.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=x11-themes/gnome-icon-theme-3.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/libgnome-keyring-3.8.0
# required by gnome-base/gnome-control-center-3.8.0-r1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=net-misc/networkmanager-0.9.8.0
# required by gnome-extra/gnome-user-share-2.30.1
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=net-wireless/gnome-bluetooth-3.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=app-editors/gedit-3.8.1
# required by app-editors/gedit-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=dev-libs/libpeas-1.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/nautilus-3.8.1
# required by gnome-extra/evolution-data-server-3.8.1[gnome-online-accounts]
# required by dev-libs/folks-0.9.1[eds,vala]
# required by net-im/empathy-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=net-libs/gnome-online-accounts-3.8.1
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-extra/yelp-3.8.0
>=dev-lang/vala-0.20.0
=dev-libs/libgweather-3.8.1
# required by dev-libs/totem-pl-parser-2.32.6-r3
# required by media-video/totem-3.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/masked_pkgs:
# required by gnome-base/nautilus-3.8.1
# required by gnome-extra/gnome-tweak-tool-3.8.0
# required by gnome-base/gnome-extra-apps-3.8.0
# required by gnome-base/gnome-3.6.2[extras]
# required by @selected
# required by @world (argument)
# /usr/portage/profiles/package.mask:
# Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
=gnome-base/gnome-desktop-3.8.1
>=dev-libs/totem-pl-parser-3.4.3
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/masked_pkgs:
=dev-libs/libgweather-3.6.2
# required by net-libs/libsoup-gnome-2.40.3
# required by dev-libs/libgweather-3.6.2
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/masked_pkgs:
=net-libs/libsoup-2.40.3
# required by dev-libs/totem-pl-parser-2.32.6-r3
# required by media-video/totem-3.8.0
# required by gnome-base/gnome-core-apps-3.8.0
# required by gnome-base/gnome-3.6.2
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask/masked_pkgs:
=net-libs/libsoup-gnome-2.40.3



the package.mask/masked.pkgs:

Code:

>=gnome-extra/evolution-data-server-3.6.4
net-libs/libsoup-gnome
<net-libs/libsoup-2.42.2
<gnome-base/gnome-desktop-3.8.0
=dev-libs/libgweather-3.6.2
<gnome-base/gnome-3.8.0
=gnome-extra/gnome-color-manager-3.6.1
=gnome-base/gnome-panel-3.6.2


result of 'equery depends libsoup-gnome':

Code:

dev-libs/libgdata-0.13.3
dev-libs/libgweather-3.8.1
dev-libs/totem-pl-parser-2.32.6-r3
gnome-base/gvfs-1.14.2
mail-client/evolution-3.6.4
media-libs/libchamplain-0.12.3
media-sound/banshee-2.6.0
net-libs/libsocialweb-0.25.21
net-libs/rest-0.7.12
sci-geosciences/geocode-glib-0.99.0
sys-libs/libosinfo-0.2.2
www-client/epiphany-3.6.1


result of 'emerge -uND':

Code:

Calculating dependencies  ..... . . ...... .... .... done!
[ebuild     U #] dev-libs/gobject-introspection-common-1.36.0 [1.34.2]
[ebuild     U  ] app-shells/bash-4.2_p45 [4.2_p37]
[ebuild     U #] gnome-extra/gnome-user-docs-3.8.0 [3.6.2]
[ebuild     U  ] app-office/libreoffice-l10n-3.6.6.2 [3.6.4.3]
[ebuild     U ~] app-crypt/p11-kit-0.18.1 [0.18.0]
[ebuild     U  ] app-text/libwpd-0.9.7 [0.9.6]
[ebuild     U #] dev-cpp/glibmm-2.36.2 [2.34.1]
[ebuild     U  ] app-text/libwpg-0.2.2 [0.2.1]
[ebuild     U  ] app-text/libwps-0.2.8 [0.2.7]
[ebuild     U  ] media-libs/libvisio-0.0.26 [0.0.25]
[ebuild  NS   ~] sys-devel/gcc-4.7.2-r1 [4.6.3] USE="cxx fortran gtk mudflap (multilib) nls nptl openmp (-altivec) -doc (-fixed-point) -gcj -go -graphite (-hardened) (-libssp) -multislot -nopie -nossp -objc -objc++ -objc-gc {-test} -vanilla"
[ebuild     U  ] sys-libs/e2fsprogs-libs-1.42.7 [1.42]
[ebuild     U  ] sys-apps/mlocate-0.26 [0.25]
[ebuild     U  ] sys-libs/talloc-2.0.8 [2.0.7]
[ebuild     U  ] sys-apps/baselayout-2.2 [2.1-r1]
[ebuild     U  ] app-arch/tar-1.26-r1 [1.26] USE="-minimal% -xattr%"
[ebuild  N    ~] net-libs/libqmi-1.0.0  USE="-doc -static-libs {-test}"
[ebuild     U #] x11-themes/gnome-icon-theme-symbolic-3.8.0.1 [3.6.2]
[ebuild     U #] x11-themes/gnome-icon-theme-3.8.0 [3.6.2]
[ebuild     U #] dev-libs/gobject-introspection-1.36.0 [1.34.2-r1] USE="cairo%*"
[ebuild  N    ~] dev-libs/libgee-0.10.1  USE="introspection"
[ebuild     U #] gnome-base/gnome-menus-3.8.0 [3.6.2]
[ebuild  N     ] dev-libs/libgee-0.6.7  USE="introspection"
[ebuild   R   ~] media-libs/babl-0.1.10  USE="introspection*"
[ebuild     UD#] net-libs/libsoup-2.40.3 [2.42.2]
[ebuild     U #] media-libs/fontconfig-2.10.91 [2.8.0-r1] USE="-static-libs%" ABI_X86="(64%*) -32% (-x32)"
[ebuild     U #] x11-libs/pango-1.34.0 [1.32.5]
[ebuild    FU  ] app-emulation/emul-linux-x86-java-1.6.0.45 [1.6.0.43]
[ebuild     U  ] sys-fs/e2fsprogs-1.42.7 [1.42]
[ebuild     U  ] sys-apps/gptfdisk-0.8.6 [0.8.4] USE="icu%*"
[ebuild     U  ] sys-libs/tdb-1.2.11 [1.2.10]
[ebuild     U #] dev-libs/gjs-1.36.1 [1.34.0] USE="cairo%*"
[ebuild     U #] net-im/telepathy-logger-0.8.0 [0.6.0]
[ebuild     U  ] sys-apps/man-pages-3.50 [3.47]
[ebuild     U ~] net-libs/gssdp-0.14.2 [0.12.2.1]
[ebuild     U  ] net-misc/dropbox-1.6.16 [1.2.48-r1] USE="X%* librsync-bundled%*"
[ebuild     U #] app-crypt/gcr-3.8.1 [3.6.2] USE="gtk%*"
[ebuild     U #] gnome-base/gnome-desktop-3.8.1 [3.6.3]
[ebuild     U #] gnome-base/dconf-0.16.0 [0.14.1]
[ebuild     U #] x11-themes/gnome-themes-standard-3.8.1 [3.6.5]
[ebuild     U #] dev-libs/libpeas-1.8.0 [1.6.2-r1] PYTHON_TARGETS="python3_2%*"
[ebuild     U #] app-admin/gnome-system-log-3.8.1 [3.6.1]
[ebuild     U #] sys-apps/baobab-3.8.1 [3.6.4]
[ebuild     U #] gnome-extra/gucharmap-3.8.1 [3.6.1]
[ebuild     U #] media-gfx/gnome-font-viewer-3.8.0 [3.6.2]
[ebuild     U #] gnome-extra/gnome-system-monitor-3.8.0 [3.6.1]
[ebuild     U #] media-gfx/eog-3.8.0 [3.6.2]
[ebuild     U #] gnome-base/gnome-keyring-3.8.1 [3.6.3] USE="filecaps%*"
[ebuild     U #] gnome-base/libgnome-keyring-3.8.0 [3.6.0]
[ebuild     U ~] app-crypt/libsecret-0.15 [0.12]
[ebuild     U #] net-libs/webkit-gtk-2.0.1 [1.10.2-r300]
[ebuild  N    #] net-libs/libsoup-gnome-2.40.3  USE="introspection -debug"
[ebuild     U #] net-misc/vino-3.8.1 [3.6.2-r1]
[ebuild     U ~] media-gfx/shotwell-0.14.1 [0.14.0-r1] LINGUAS="-af% -as% -gu% -kn% -ml% -mr%"
[ebuild     U #] www-client/epiphany-3.8.1 [3.6.1]
[ebuild     U #] gnome-extra/yelp-3.8.0 [3.6.2]
[ebuild     UD#] dev-libs/libgweather-3.6.2 [3.8.1]
[ebuild     U #] gnome-base/nautilus-3.8.1 [3.6.3]
[ebuild     U #] app-text/evince-3.8.0 [3.6.1]
[ebuild     U #] app-arch/file-roller-3.8.1 [3.6.3]
[ebuild     U #] gnome-extra/sushi-3.8.1 [3.6.1]
[ebuild     U #] app-misc/tracker-0.16.1 [0.14.5] USE="libsecret%*"
[ebuild     U #] gnome-extra/nautilus-tracker-tags-0.16.1 [0.14.5]
[ebuild     U #] gnome-extra/gnome-documents-3.8.1 [3.6.2]
[ebuild     U #] x11-misc/colord-0.1.31 [0.1.28]
[ebuild  N    *] net-misc/modemmanager-9999  USE="policykit qmi -doc -qmi-newest {-test}"
[ebuild     U #] net-misc/networkmanager-0.9.8.0 [0.9.6.4-r1] USE="modemmanager* {-test%}"
[ebuild     U #] gnome-extra/gnome-power-manager-3.8.1 [3.6.0]
[ebuild     U #] x11-terms/gnome-terminal-3.8.1 [3.6.2] USE="nautilus%*"
[ebuild     U  ] dev-db/mysql-init-scripts-2.0_pre1-r3 [2.0_pre1-r2]
[ebuild     U #] gnome-base/gvfs-1.16.1 [1.14.2] USE="gnome-online-accounts%* -mtp%"
[ebuild     U #] net-wireless/gnome-bluetooth-3.8.0 [3.6.1]
[ebuild     U #] dev-libs/folks-0.9.1 [0.8.0]
[ebuild     U #] app-crypt/seahorse-3.8.1 [3.6.3]
[ebuild     U #] gnome-extra/nm-applet-0.9.8.0 [0.9.6.4] USE="-modemmanager%"
[ebuild     U #] gnome-base/gnome-core-libs-3.8.0 [3.6.2]
[ebuild     U #] gnome-extra/gnome-contacts-3.8.1 [3.6.2]
[ebuild     U #] app-editors/gedit-3.8.1 [3.6.2-r1] PYTHON_TARGETS="python3_2%*"
[ebuild     U #] gnome-base/gnome-settings-daemon-3.8.0 [3.6.4]
[ebuild     U #] media-video/cheese-3.8.1 [3.6.2]
[ebuild     U #] net-misc/vinagre-3.8.1 [3.6.2]
[ebuild     U #] media-gfx/gnome-screenshot-3.8.1 [3.6.1]
[ebuild     U #] mail-client/evolution-3.8.1 [3.6.4] USE="bogofilter%* -highlight% -spamassassin%"
[ebuild     U #] gnome-base/gnome-session-3.8.1 [3.6.2-r2]
[ebuild     U #] gnome-base/gnome-control-center-3.8.0-r1 [3.6.3-r1]
[ebuild   R   ~] media-libs/gegl-0.2.0-r1  USE="(-exif%*) (-graphviz%) (-lua%) (-v4l%)"
[ebuild     U #] app-cdr/brasero-3.8.0 [3.6.1]
[ebuild     U #] media-video/totem-3.8.0 [3.6.3-r1]
[ebuild     U #] net-im/empathy-3.8.1 [3.6.4]
[ebuild     U #] gnome-base/gnome-core-apps-3.8.0 [3.6.2]
[ebuild     U  ] app-office/libreoffice-3.6.6.2 [3.6.4.3] PYTHON_SINGLE_TARGET="python2_7%* -python2_5% -python2_6%" PYTHON_TARGETS="python2_7%* -python2_5% -python2_6%"
[ebuild     U #] gnome-base/gnome-shell-3.8.1 [3.6.3.1]
[ebuild     U #] gnome-extra/gnome-tweak-tool-3.8.0 [3.6.1-r1]
[ebuild  N    #] gnome-extra/gnome-calculator-3.8.1
[uninstall     ] gnome-extra/gcalctool-6.6.2
[blocks b      ] gnome-extra/gcalctool ("gnome-extra/gcalctool" is blocking gnome-extra/gnome-calculator-3.8.1)
[ebuild     U #] gnome-base/gnome-extra-apps-3.8.0 [3.6.2]
[blocks B      ] net-libs/libsoup-gnome ("net-libs/libsoup-gnome" is blocking net-libs/libsoup-2.42.2)
[blocks B      ] >=net-libs/libsoup-2.42 (">=net-libs/libsoup-2.42" is blocking net-libs/libsoup-gnome-2.40.3)
[blocks B      ] <dev-lang/vala-0.20.0 ("<dev-lang/vala-0.20.0" is blocking dev-libs/gobject-introspection-1.36.0)

Fetch instructions for app-emulation/emul-linux-x86-java-1.6.0.45:


thanks fellows
have a nice weekend
Back to top
View user's profile Send private message
HayarobiPark
n00b
n00b


Joined: 17 Apr 2013
Posts: 5

PostPosted: Mon May 13, 2013 5:06 am    Post subject: Reply with quote

There is something that still depends on libgweather-3.6.2, but I can't feagure out which is the one, with this contexts. (maybe evolution-3.6 or other as I guess)

from your 'emerge -uDN'
Code:
 ...
[ebuild     UD#] dev-libs/libgweather-3.6.2 [3.8.1]
...


I think you had better cleanup /etc/portage/packages.unmask and /etc/portage/packages.accept_keywords, with basis of /usr/portage/profiles/package.mask. Copy line 222 to 359 and make package.unmask with it;

Code:
 # Pacho Ramos <pacho@gentoo.org> (28 Mar 2013)
# Gnome 3.8 Mask
>=app-accessibility/accerciser-3.8
>=app-accessibility/at-spi2-atk-2.8
>=app-accessibility/at-spi2-core-2.8
>=app-accessibility/orca-3.8
>=app-admin/gnome-system-log-3.8
>=app-arch/file-roller-3.8
>=app-cdr/brasero-3.8
>=app-crypt/gcr-3.8
>=app-crypt/seahorse-sharing-3.8
>=app-crypt/seahorse-3.8
>=app-editors/gedit-plugins-3.8
>=app-editors/gedit-3.8
>=app-editors/ghex-3.8
>=app-misc/gnote-3.8
>=app-misc/tracker-0.16
>=app-text/evince-3.8
>=dev-cpp/gtkmm-3.7
>=dev-libs/atk-2.8
>=dev-libs/folks-0.9
>=dev-libs/gdl-3.8
>=dev-libs/gjs-1.36
>=dev-libs/glib-2.36
>=dev-libs/gobject-introspection-common-1.36
>=dev-libs/gobject-introspection-1.36
>=dev-libs/libgweather-3.8
>=dev-libs/libpeas-1.8
>=dev-libs/libwacom-0.7
>=dev-libs/totem-pl-parser-3.4.4
>=dev-python/pyatspi-2.8
>=dev-python/pygobject-3.8
>=dev-util/anjuta-3.8
>=dev-util/devhelp-3.8
>=dev-util/gdbus-codegen-2.36
>=dev-util/gnome-devel-docs-3.8
>=gnome-base/dconf-0.16
>=gnome-base/gdm-3.8
>=gnome-base/gnome-control-center-3.8
>=gnome-base/gnome-desktop-3.8
>=gnome-base/gnome-keyring-3.8
>=gnome-base/gnome-menus-3.8
>=gnome-base/gnome-session-3.8
>=gnome-base/gnome-settings-daemon-3.8
>=gnome-base/gnome-shell-3.8
>=gnome-base/gnome-3.8
>=gnome-base/gsettings-desktop-schemas-3.8
>=gnome-base/gvfs-1.16
>=gnome-base/libgnome-keyring-3.8
>=gnome-base/nautilus-3.8
>=gnome-extra/evolution-data-server-3.8
>=gnome-extra/evolution-ews-3.8
>=gnome-extra/evolution-kolab-3.8
>=gnome-extra/gnome-clocks-3.8
>=gnome-extra/gnome-color-manager-3.8
>=gnome-extra/gnome-contacts-3.8
>=gnome-extra/gnome-documents-3.8
>=gnome-extra/gnome-power-manager-3.8
>=gnome-extra/gnome-shell-extensions-3.8
>=gnome-extra/gnome-system-monitor-3.8
>=gnome-extra/gnome-tweak-tool-3.7
>=gnome-extra/gnome-user-docs-3.8
>=gnome-extra/gnome-user-share-3.8
>=gnome-extra/gucharmap-3.8
>=gnome-extra/mousetweaks-3.8
>=gnome-extra/nautilus-sendto-3.8
>=gnome-extra/nautilus-tracker-tags-0.16
>=gnome-extra/nm-applet-0.9.8
>=gnome-extra/office-runner-1.0.1
>=gnome-extra/seahorse-nautilus-3.8
>=gnome-extra/sushi-3.8
>=gnome-extra/yelp-xsl-3.8
>=gnome-extra/yelp-3.8
>=gnome-extra/zenity-3.8
>=mail-client/evolution-3.8
>=media-gfx/eog-plugins-3.8
>=media-gfx/eog-3.8
>=media-gfx/gnome-font-viewer-3.8
>=media-gfx/gnome-screenshot-3.8
>=media-libs/clutter-gtk-1.4.4
>=media-libs/clutter-1.14
>=media-libs/cogl-1.14
>=media-libs/fontconfig-2.10.91
>=media-video/cheese-3.8
>=media-video/totem-3.8
>=net-im/empathy-3.8
>=net-im/telepathy-logger-0.8
>=net-libs/glib-networking-2.36
>=net-libs/gnome-online-accounts-3.8
>=net-libs/libsoup-2.42
>=net-libs/libzapojit-0.0.3
>=net-libs/webkit-gtk-2
>=net-misc/networkmanager-0.9.8
>=net-misc/vinagre-3.8
>=net-misc/vino-3.8
>=net-wireless/gnome-bluetooth-3.8
>=sys-apps/baobab-3.8
>=sys-apps/gnome-disk-utility-3.8
>=www-client/epiphany-3.8
>=x11-libs/gnome-pty-helper-0.34.3
>=x11-libs/gtk+-3.8
>=x11-libs/gtksourceview-3.8
>=x11-libs/libcryptui-3.8
>=x11-libs/libwnck-3.8
>=x11-libs/pango-1.34
>=x11-libs/vte-0.34.3
>=x11-misc/colord-0.1.31
>=x11-terms/gnome-terminal-3.8
>=x11-themes/gnome-backgrounds-3.8
>=x11-themes/gnome-icon-theme-symbolic-3.8
>=x11-themes/gnome-icon-theme-3.8
>=x11-themes/gnome-themes-standard-3.8
>=x11-wm/mutter-3.8
>=net-libs/libgrss-0.5
>=media-gfx/gthumb-3.2
>=app-editors/latexila-2.8
>=gnome-extra/gnome-calculator-3.8
>=net-misc/networkmanager-openconnect-0.9.8
>=net-misc/networkmanager-openswan-0.9.8
>=net-misc/networkmanager-openvpn-0.9.8
>=net-misc/networkmanager-pptp-0.9.8
>=net-misc/networkmanager-sstp-0.9.8
>=net-misc/networkmanager-vpnc-0.9.8
>=gnome-base/gnome-core-libs-3.8.0
>=gnome-base/gnome-core-apps-3.8.0
>=gnome-base/gnome-extra-apps-3.8.0
>=gnome-base/gnome-3.8.0
>=gnome-base/gnome-light-3.8.0
>=dev-cpp/glibmm-2.36
>=dev-cpp/atkmm-2.22.7
>=gnome-extra/gnome-getting-started-docs-3.8
>=dev-libs/seed-3.8
>=dev-cpp/pangomm-2.34
>=app-misc/bijiben-3.8
>=gnome-extra/gnome-weather-3.8
>=media-gfx/gnome-photos-3.8
>=net-analyzer/gnome-nettool-3.8
>=x11-misc/alacarte-3.7.90


And make packages.accept_keywords with it, appending '~amd64' to each lines, and some other package like gssdp .
Code:

>=app-accessibility/accerciser-3.8 ~amd64
>=app-accessibility/at-spi2-atk-2.8 ~amd64
>=app-accessibility/at-spi2-core-2.8 ~amd64
>=app-accessibility/orca-3.8 ~amd64
>=app-admin/gnome-system-log-3.8 ~amd64
>=app-arch/file-roller-3.8 ~amd64
>=app-cdr/brasero-3.8 ~amd64
>=app-crypt/gcr-3.8 ~amd64
>=app-crypt/seahorse-sharing-3.8 ~amd64
>=app-crypt/seahorse-3.8 ~amd64
>=app-editors/gedit-plugins-3.8 ~amd64
>=app-editors/gedit-3.8 ~amd64
>=app-editors/ghex-3.8 ~amd64
>=app-misc/gnote-3.8 ~amd64
>=app-misc/tracker-0.16 ~amd64
>=app-text/evince-3.8 ~amd64
>=dev-cpp/gtkmm-3.7 ~amd64
>=dev-libs/atk-2.8 ~amd64
>=dev-libs/folks-0.9 ~amd64
>=dev-libs/gdl-3.8 ~amd64
>=dev-libs/gjs-1.36 ~amd64
>=dev-libs/glib-2.36 ~amd64
>=dev-libs/gobject-introspection-common-1.36 ~amd64
>=dev-libs/gobject-introspection-1.36 ~amd64
>=dev-libs/libgweather-3.8 ~amd64
>=dev-libs/libpeas-1.8 ~amd64
>=dev-libs/libwacom-0.7 ~amd64
>=dev-libs/totem-pl-parser-3.4.4 ~amd64
>=dev-python/pyatspi-2.8 ~amd64
>=dev-python/pygobject-3.8 ~amd64
>=dev-util/anjuta-3.8 ~amd64
>=dev-util/devhelp-3.8 ~amd64
>=dev-util/gdbus-codegen-2.36 ~amd64
>=dev-util/gnome-devel-docs-3.8 ~amd64
>=gnome-base/dconf-0.16 ~amd64
>=gnome-base/gdm-3.8 ~amd64
>=gnome-base/gnome-control-center-3.8 ~amd64
>=gnome-base/gnome-desktop-3.8 ~amd64
>=gnome-base/gnome-keyring-3.8 ~amd64
>=gnome-base/gnome-menus-3.8 ~amd64
>=gnome-base/gnome-session-3.8 ~amd64
>=gnome-base/gnome-settings-daemon-3.8 ~amd64
>=gnome-base/gnome-shell-3.8 ~amd64
>=gnome-base/gnome-3.8 ~amd64
>=gnome-base/gsettings-desktop-schemas-3.8 ~amd64
>=gnome-base/gvfs-1.16 ~amd64
>=gnome-base/libgnome-keyring-3.8 ~amd64
>=gnome-base/nautilus-3.8 ~amd64
>=gnome-extra/evolution-data-server-3.8 ~amd64
>=gnome-extra/evolution-ews-3.8 ~amd64
>=gnome-extra/evolution-kolab-3.8 ~amd64
>=gnome-extra/gnome-clocks-3.8 ~amd64
>=gnome-extra/gnome-color-manager-3.8 ~amd64
>=gnome-extra/gnome-contacts-3.8 ~amd64
>=gnome-extra/gnome-documents-3.8 ~amd64
>=gnome-extra/gnome-power-manager-3.8 ~amd64
>=gnome-extra/gnome-shell-extensions-3.8 ~amd64
>=gnome-extra/gnome-system-monitor-3.8 ~amd64
>=gnome-extra/gnome-tweak-tool-3.7 ~amd64
>=gnome-extra/gnome-user-docs-3.8 ~amd64
>=gnome-extra/gnome-user-share-3.8 ~amd64
>=gnome-extra/gucharmap-3.8 ~amd64
>=gnome-extra/mousetweaks-3.8 ~amd64
>=gnome-extra/nautilus-sendto-3.8 ~amd64
>=gnome-extra/nautilus-tracker-tags-0.16 ~amd64
>=gnome-extra/nm-applet-0.9.8 ~amd64
>=gnome-extra/office-runner-1.0.1 ~amd64
>=gnome-extra/seahorse-nautilus-3.8 ~amd64
>=gnome-extra/sushi-3.8 ~amd64
>=gnome-extra/yelp-xsl-3.8 ~amd64
>=gnome-extra/yelp-3.8 ~amd64
>=gnome-extra/zenity-3.8 ~amd64
>=mail-client/evolution-3.8 ~amd64
>=media-gfx/eog-plugins-3.8 ~amd64
>=media-gfx/eog-3.8 ~amd64
>=media-gfx/gnome-font-viewer-3.8 ~amd64
>=media-gfx/gnome-screenshot-3.8 ~amd64
>=media-libs/clutter-gtk-1.4.4 ~amd64
>=media-libs/clutter-1.14 ~amd64
>=media-libs/cogl-1.14 ~amd64
>=media-libs/fontconfig-2.10.91 ~amd64
>=media-video/cheese-3.8 ~amd64
>=media-video/totem-3.8 ~amd64
>=net-im/empathy-3.8 ~amd64
>=net-im/telepathy-logger-0.8 ~amd64
>=net-libs/glib-networking-2.36 ~amd64
>=net-libs/gnome-online-accounts-3.8 ~amd64
>=net-libs/libsoup-2.42 ~amd64
>=net-libs/libzapojit-0.0.3 ~amd64
>=net-libs/webkit-gtk-2 ~amd64
>=net-misc/networkmanager-0.9.8 ~amd64
>=net-misc/vinagre-3.8 ~amd64
>=net-misc/vino-3.8 ~amd64
>=net-wireless/gnome-bluetooth-3.8 ~amd64
>=sys-apps/baobab-3.8 ~amd64
>=sys-apps/gnome-disk-utility-3.8 ~amd64
>=www-client/epiphany-3.8 ~amd64
>=x11-libs/gnome-pty-helper-0.34.3 ~amd64
>=x11-libs/gtk+-3.8 ~amd64
>=x11-libs/gtksourceview-3.8 ~amd64
>=x11-libs/libcryptui-3.8 ~amd64
>=x11-libs/libwnck-3.8 ~amd64
>=x11-libs/pango-1.34 ~amd64
>=x11-libs/vte-0.34.3 ~amd64
>=x11-misc/colord-0.1.31 ~amd64
>=x11-terms/gnome-terminal-3.8 ~amd64
>=x11-themes/gnome-backgrounds-3.8 ~amd64
>=x11-themes/gnome-icon-theme-symbolic-3.8 ~amd64
>=x11-themes/gnome-icon-theme-3.8 ~amd64
>=x11-themes/gnome-themes-standard-3.8 ~amd64
>=x11-wm/mutter-3.8 ~amd64
>=net-libs/libgrss-0.5 ~amd64
>=media-gfx/gthumb-3.2 ~amd64
>=app-editors/latexila-2.8 ~amd64
>=gnome-extra/gnome-calculator-3.8 ~amd64
>=net-misc/networkmanager-openconnect-0.9.8 ~amd64
>=net-misc/networkmanager-openswan-0.9.8 ~amd64
>=net-misc/networkmanager-openvpn-0.9.8 ~amd64
>=net-misc/networkmanager-pptp-0.9.8 ~amd64
>=net-misc/networkmanager-sstp-0.9.8 ~amd64
>=net-misc/networkmanager-vpnc-0.9.8 ~amd64
>=gnome-base/gnome-core-libs-3.8.0 ~amd64
>=gnome-base/gnome-core-apps-3.8.0 ~amd64
>=gnome-base/gnome-extra-apps-3.8.0 ~amd64
>=gnome-base/gnome-3.8.0 ~amd64
>=gnome-base/gnome-light-3.8.0 ~amd64
>=dev-cpp/glibmm-2.36 ~amd64
>=dev-cpp/atkmm-2.22.7 ~amd64
>=gnome-extra/gnome-getting-started-docs-3.8 ~amd64
>=dev-libs/seed-3.8 ~amd64
>=dev-cpp/pangomm-2.34 ~amd64
>=app-misc/bijiben-3.8 ~amd64
>=gnome-extra/gnome-weather-3.8 ~amd64
>=media-gfx/gnome-photos-3.8 ~amd64
>=net-analyzer/gnome-nettool-3.8 ~amd64
>=x11-misc/alacarte-3.7.90 ~amd64

=net-libs/gssdp-0.14.2 ~amd64


If emerge does not complain mask or dependency, you might have to install gcc-4.7.2 first, since some packages require the feature of gcc-4.7.2. Install gcc and change default gcc version, by using gcc-config.

I had to unmerged almost all installed pacakges related to gnome-3.6 before installing 3.8, but I think this is the last resort.

Good luck to you.
Back to top
View user's profile Send private message
HayarobiPark
n00b
n00b


Joined: 17 Apr 2013
Posts: 5

PostPosted: Mon May 13, 2013 9:30 am    Post subject: Reply with quote

there's something to tell you.

There are some more packages that should be in package.accept_keywords.
Code:

## additional accept_keywords for gnome-3.8
=dev-libs/libgdata-0.13.3 ~amd64
=x11-libs/mx-1.4.7 ~amd64
=media-sound/sound-juicer-3.5.1_pre20121231 ~amd64
=app-accessibility/caribou-0.4.10 ~amd64
=gnome-extra/gnome-search-tool-3.6.0 ~amd64
=gnome-extra/gnome-games-3.6.1-r1 ~amd64
=gnome-extra/gconf-editor-3.0.1 ~amd64
=dev-libs/libgee-0.10.1 ~amd64
=net-libs/liboauth-1.0.1 ~amd64
=x11-libs/gdk-pixbuf-2.28.1 ~amd64
=sys-devel/gcc-4.7.2-r1 ~amd64
=app-admin/openrc-settingsd-1.0.1 ~amd64
=app-dicts/gnome-dictionary-3.6.0 ~amd64
=dev-python/rdflib-3.2.3 ~amd64
=media-plugins/gst-plugins-vpx-1.0.6 ~amd64
=net-misc/modemmanager-9999 **
=x11-proto/inputproto-2.3 ~amd64
=dev-util/fix-la-relink-command-0.1.1 ~amd64
=gnome-extra/zeitgeist-0.9.12-r1 ~amd64
=media-gfx/shotwell-0.14.1 ~amd64
=media-libs/gexiv2-0.6.0 ~amd64
=dev-libs/vala-common-0.20.1 ~amd64
=dev-libs/libpwquality-1.2.0-r2 ~amd64
=gnome-base/libgnomekbd-3.6.0 ~amd64
=sys-auth/consolekit-0.4.5_p20120320-r2 ~amd64
=app-crypt/libsecret-0.15 ~amd64
=net-libs/libqmi-1.0.0 ~amd64
=x11-libs/libXi-1.7.1 ~amd64
=dev-libs/libzeitgeist-0.3.18 ~amd64
=app-i18n/ibus-1.5.2 ~amd64
=games-board/aisleriot-3.2.3.2-r1 ~amd64
=sys-auth/pambase-20120417-r1 ~amd64
=sys-apps/accountsservice-0.6.30 ~amd64
=dev-lang/vala-0.20.1 ~amd64
=media-libs/gst-plugins-good-1.0.6 ~amd64
=sys-libs/libosinfo-0.2.6 ~amd64
=dev-python/isodate-0.4.9 ~amd64


and in package.use
Code:

>=app-i18n/ibus-1.5.2 dconf
=net-misc/networkmanager-0.9.8.0 modemmanager


It's possible that there will be more when iterating 'emerge -uv gnome' after adding abobe keywords and use.


Finding packages that depnds on libsoup-gnome and unmerging them might be helpful, and you will have to unmerge packages depends on them, and so on. But, it might break current desktop env and make you in trouble, especially if you don't have other machine or ipad, which is able to use internet.

The unmerged packages themselves in this phase will be installed with newer versions when installing gnome-3.8 by dependency chain. Some packages may be missing, since the gnome-3.8 is not stable build. Some of them are required, so you have to install that required package manually.
Back to top
View user's profile Send private message
monsm
Guru
Guru


Joined: 26 Sep 2007
Posts: 463
Location: London, UK

PostPosted: Wed May 15, 2013 1:54 pm    Post subject: Reply with quote

I had this trouble as well, with the blocking between libsoup and libsoup-gnome.

I used the list of dependencies from equery and unmerged a few but updated most to the latest version (unmasking where there was one).
I unmerged libsoup-gnome and it was not pulled in again after this. I have just completed my gnome 3.8 update (and world update) and all seems fine without libsoup-gnome.

I wonder if libsoup-gnome is officially being removed, or if I am lucky not to have anything any more that depends on it. Anyone who know?

Mons
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum