Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
The *%$@ libsoup when emerging gnome 3.8
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5623

PostPosted: Wed May 15, 2013 3:55 pm    Post subject: Reply with quote

libsoup-gnome didn't get removed, but most of its useful functions were moved into libsoup.
Back to top
View user's profile Send private message
Condomitti
n00b
n00b


Joined: 28 Jan 2013
Posts: 16

PostPosted: Mon May 20, 2013 11:09 am    Post subject: Reply with quote

Hi guys,

After many many many attempts I ended up reinstalling from scratch. =/ I couldn't spend more time on that once I needed my computer fixed for a business trip.

Anyway many thanks for all the help from you buddies.
best regards.
Condomitti.
Back to top
View user's profile Send private message
omron93
n00b
n00b


Joined: 20 May 2013
Posts: 1

PostPosted: Mon May 20, 2013 8:36 pm    Post subject: Reply with quote

Because some packages still depends on libsoup-gnome -> I've added meta package package for it (data are privided by libsoup)

Code:
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup-gnome/libsoup-gnome-2.40.3.ebuild,v 1.3 2013/04/07 09:30:15 pacho Exp $

EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"

DESCRIPTION="Virtual package - GNOME plugin for libsoup"
HOMEPAGE="http://live.gnome.org/LibSoup"
SRC_URI=""

LICENSE="LGPL-2+"
SLOT="2.4"
IUSE="debug +introspection"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x86-solaris"

RDEPEND=""
DEPEND=""


and editted libsoup

Code:
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.42.2.ebuild,v 1.2 2013/05/03 00:27:33 zmedico Exp $

EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python{2_5,2_6,2_7} )

inherit eutils gnome2 python-any-r1

DESCRIPTION="An HTTP library implementation in C"
HOMEPAGE="http://live.gnome.org/LibSoup"

LICENSE="LGPL-2+"
SLOT="2.4"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE="debug +introspection samba ssl test"

RDEPEND="
   >=dev-libs/glib-2.36.0:2
   >=dev-libs/libxml2-2:2
   dev-db/sqlite:3
   >=net-libs/glib-networking-2.30.0[ssl?]
   introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
   samba? ( net-fs/samba )
"
DEPEND="${RDEPEND}
   ${PYTHON_DEPS}
   >=dev-util/intltool-0.35
   >=dev-util/gtk-doc-am-1.10
   sys-devel/gettext
   virtual/pkgconfig"
#   test? (   www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
#      apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
#      apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
#      dev-lang/php[apache2,xmlrpc]
#      net-misc/curl
#      net-libs/glib-networking[ssl])"

src_prepare() {
   if ! use test; then
      # don't waste time building tests (bug #226271)
      sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
         || die "sed failed"
   fi
   gnome2_src_prepare
}

src_configure() {
   # FIXME: we need addpredict to workaround bug #324779 until
   # root cause (bug #249496) is solved 
   addpredict /usr/share/snmp/mibs/.index

   # Disable apache tests until they are usable on Gentoo, bug #326957
   gnome2_src_configure \
      --disable-static \
      --disable-tls-check \
      --with-gnome \
      --without-apache-httpd \
      $(use_enable introspection) \
      $(use_with samba ntlm-auth '${EPREFIX}'/usr/bin/ntlm_auth)
}
Back to top
View user's profile Send private message
xdemocle
n00b
n00b


Joined: 01 Aug 2013
Posts: 1
Location: Malta

PostPosted: Thu Aug 01, 2013 11:42 am    Post subject: Solved Reply with quote

Hello omron93, I used your workaround... thanks for suggestion.

(for others that don't know how make a local portage, look here: http://forums.gentoo.org/viewtopic-p-7325834.html)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum