Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst]cdemu-daemon-2.0.0 Autostart
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3009
Location: Berlin

PostPosted: Mon Apr 29, 2013 6:57 pm    Post subject: [gelöst]cdemu-daemon-2.0.0 Autostart Reply with quote

Hallo,
ich hätte vermutet, das es nach der Installation für cdemu-daemon-2.0.0 ein Startscript in /etc/init.d/ gibt. Das ist aber nicht so. Ist das ein Fehler im ebuild? Muß ich das selbst anlegen?
MfG


Last edited by flammenflitzer on Fri May 03, 2013 5:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4112

PostPosted: Mon Apr 29, 2013 7:13 pm    Post subject: Reply with quote

existiert in cdemu 2.0 nicht mehr. Sondern wird über dbus aktiviert.

aus der postinst vom ebuild:
Quote:
elog "You will need to load the vhba module to use cdemu devices:"
elog " # modprobe vhba"
elog "To automatically load the vhba module at boot time, edit your"
elog "/etc/conf.d/modules file."

if [[ -e "${ROOT}etc/conf.d/cdemud" ]]; then
elog
elog "${PN} no longer installs an init.d service; instead, it is"
elog "automatically activated when needed via dbus."
elog "You can therefore remove ${ROOT}etc/conf.d/cdemud"
fi

_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3009
Location: Berlin

PostPosted: Mon Apr 29, 2013 7:38 pm    Post subject: Reply with quote

Das Modul habe ich geladen. Ich wollte als user ab und zu mit kcdemu arbeiten. Da wollte ich cdemu als Dienst laufen lassen.
Code:
flammenflitzer olaf # /usr/bin/cdemu-daemon
Starting CDEmu daemon with following parameters:
 - num devices: 1
 - ctl device: /dev/vhba_ctl
 - audio driver: null
 - bus type: session

cdemu: Daemon: D-Bus: failed to get proxy for 'org.freedesktop.DBus' on session bus: The connection is closed!
Daemon initialization and start failed!
flammenflitzer olaf # ls /dev/vhba_ctl
/dev/vhba_ctl
flammenflitzer olaf #
Back to top
View user's profile Send private message
Christian99
l33t
l33t


Joined: 28 May 2009
Posts: 973

PostPosted: Thu May 02, 2013 10:18 am    Post subject: Reply with quote

bist du denn in der cdemu gruppe?
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 418

PostPosted: Thu May 02, 2013 6:42 pm    Post subject: Reply with quote

Mal am Rande, wozu braucht man Cdemu unter Linux? Man kann doch ganz normal Iso-Dateien über "-o loop" mounten. :?
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3009
Location: Berlin

PostPosted: Fri May 03, 2013 5:33 pm    Post subject: Reply with quote

Ich war nicht in der cdemu-Gruppe. Jetzt funktioniert es. Danke.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum