Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
IA32 Emulation on Kernel 3.7.10
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
sebu06
n00b
n00b


Joined: 25 Apr 2013
Posts: 5

PostPosted: Thu Apr 25, 2013 7:52 am    Post subject: IA32 Emulation on Kernel 3.7.10 Reply with quote

Hi,
after my recent kernel update my 32bit librarys are no loading anymore. So I wanted to check if the IA32 Emulation option is turned on in my kernel configuration (I'm running a 3.7.10 x86_64 gentoo-sources kernel) and it seams to me that the option is missing. Is there a new option to enable support for 32 bit binary files?

Thanks,
Sebastian
Back to top
View user's profile Send private message
sebu06
n00b
n00b


Joined: 25 Apr 2013
Posts: 5

PostPosted: Thu Apr 25, 2013 9:17 am    Post subject: Reply with quote

Hey,
after another closer look my kernel is build from arch/x86 instead of arch/amd64. It seems that there is no amd64 in my arch folder. Have I done something wrong?
Back to top
View user's profile Send private message
sebu06
n00b
n00b


Joined: 25 Apr 2013
Posts: 5

PostPosted: Thu Apr 25, 2013 12:05 pm    Post subject: Reply with quote

And even eselect profile returns:

!!! Error: Failed to get a list of valid profiles
exiting

Is there any way to get my installation working again or have I screwed up at some point?
Back to top
View user's profile Send private message
Maitreya
Apprentice
Apprentice


Joined: 11 Jan 2006
Posts: 220

PostPosted: Thu Apr 25, 2013 1:27 pm    Post subject: Reply with quote

Does "ls /etc/portage/ -la" return that make.profile is still symlinked to something?

You could always download a recent portage snapshot.
Back to top
View user's profile Send private message
sebu06
n00b
n00b


Joined: 25 Apr 2013
Posts: 5

PostPosted: Thu Apr 25, 2013 2:08 pm    Post subject: Reply with quote

Hi,
yes - it's linked to /usr/portage/profiles/default/linux/amd64/13.0/desktop which should be fine I think.
Back to top
View user's profile Send private message
sebu06
n00b
n00b


Joined: 25 Apr 2013
Posts: 5

PostPosted: Fri Apr 26, 2013 5:35 pm    Post subject: Reply with quote

Hey,
just in case anyone has the same problems - in my case was the arch variable set to Linux.x86_64. This caused all the other problems. Simply resetting it to amd64, reemerging the kernel and making it solved everything.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum