Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
K3B rebuild libicuuc.so.50 missing
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
naviathan
Apprentice
Apprentice


Joined: 12 Dec 2004
Posts: 231

PostPosted: Mon Apr 22, 2013 12:35 am    Post subject: K3B rebuild libicuuc.so.50 missing Reply with quote

Recently rebuilt world and couldn't start k3b. It was looking for, and failing to find, libicuuc.so.50. upon further research this lib is part of the package dev-libs/icu which apparently recently updated to 51.1. So by simply linking libicuuc.so.51.1 to target libicuuc.so.51 k3b was back up and running with no issues (so far).

Here was the error I was getting exatly:
Code:
k3b: error while loading shared libraries: libicuuc.so.50: cannot open shared object file: No such file or directory


Just figured I'd put it out there for anyone else looking for the same issue.
_________________
I respect faith, but doubt is what gives you an education.
-- Wilson Mizner
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5414

PostPosted: Mon Apr 22, 2013 3:20 am    Post subject: Re: K3B rebuild libicuuc.so.50 missing Reply with quote

naviathan wrote:
Recently rebuilt world and couldn't start k3b. It was looking for, and failing to find, libicuuc.so.50. upon further research this lib is part of the package dev-libs/icu which apparently recently updated to 51.1. So by simply linking libicuuc.so.51.1 to target libicuuc.so.51 k3b was back up and running with no issues (so far).

Just figured I'd put it out there for anyone else looking for the same issue.

:roll:

File under "yet another way to break your system".
Back to top
View user's profile Send private message
naviathan
Apprentice
Apprentice


Joined: 12 Dec 2004
Posts: 231

PostPosted: Mon Apr 22, 2013 3:21 am    Post subject: Re: K3B rebuild libicuuc.so.50 missing Reply with quote

VoidMage wrote:
naviathan wrote:
Recently rebuilt world and couldn't start k3b. It was looking for, and failing to find, libicuuc.so.50. upon further research this lib is part of the package dev-libs/icu which apparently recently updated to 51.1. So by simply linking libicuuc.so.51.1 to target libicuuc.so.51 k3b was back up and running with no issues (so far).

Just figured I'd put it out there for anyone else looking for the same issue.

:roll:

File under "yet another way to break your system".

So you have a better suggestion or just a snide remark?
_________________
I respect faith, but doubt is what gives you an education.
-- Wilson Mizner
Back to top
View user's profile Send private message
phajdan.jr
Developer
Developer


Joined: 23 Mar 2006
Posts: 1766
Location: Poland

PostPosted: Mon Apr 22, 2013 6:16 pm    Post subject: Reply with quote

Please run revdep-rebuild (now and after other system upgrades or package removals).
_________________
http://phajdan-jr.blogspot.com/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum