Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] XFCE - configure custom action - menu
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2405
Location: Edmonton, AB

PostPosted: Sat Apr 20, 2013 10:41 pm    Post subject: [SOLVED] XFCE - configure custom action - menu Reply with quote

I'm using XFCE and went to "configure custom action" - menu trying to use gpg:
Code:
gpg -a --detach-sign %N

but no windows is popping up asking me for a signature (pass-phrase). It works from a command line:
gpg -a --detach-sign file_name

In addition when I right click on gpg sign file there is a menu "Open with gpg" and "Open with gpg2"
but clicking on any of them is not doing anything.
Does anybody know if these entries can be customized or see how they look?
_________________
#Joseph


Last edited by Joseph_sys on Thu Apr 25, 2013 7:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
ShadowCat8
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 137
Location: Arcadia, CA, USA

PostPosted: Tue Apr 23, 2013 6:24 pm    Post subject: Reply with quote

Greetings,

I haven't used XFCE for quite some time (Using LXDE over OpenBox currently), but as far as menu configuration goes, is there an option to run it in a new and/or it's own terminal? I think that would be the way you would want to go with that.

HTH. Let us know.
_________________
------
"There is no value to explaining sanity to an insane person, just as there is no value of explaining rabies to a rabid dog... They will both bite you for your effort."
-- oldbitman
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2405
Location: Edmonton, AB

PostPosted: Wed Apr 24, 2013 1:07 am    Post subject: Reply with quote

ShadowCat8 wrote:
Greetings,

I haven't used XFCE for quite some time (Using LXDE over OpenBox currently), but as far as menu configuration goes, is there an option to run it in a new and/or it's own terminal? I think that would be the way you would want to go with that.

HTH. Let us know.


No, the XFCE "configure custom action" menu doesn't have any option to start terminal.
_________________
#Joseph
Back to top
View user's profile Send private message
ShadowCat8
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 137
Location: Arcadia, CA, USA

PostPosted: Thu Apr 25, 2013 6:24 pm    Post subject: Reply with quote

Then how about using something like this:
Code:
xterm -e gpg -a --detach-sign %N


HTH. Let us know.
_________________
------
"There is no value to explaining sanity to an insane person, just as there is no value of explaining rabies to a rabid dog... They will both bite you for your effort."
-- oldbitman
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2405
Location: Edmonton, AB

PostPosted: Thu Apr 25, 2013 6:49 pm    Post subject: Reply with quote

ShadowCat8 wrote:
Then how about using something like this:
Code:
xterm -e gpg -a --detach-sign %N


HTH. Let us know.


Good suggestion.
I've tried various combination but nothing works.
I don't have xterm but terminal.

terminal |gpg -a --detach-sign ds.pdf
works form command line but not from XFCE "configure custom action"
Even simple "gpg" does not produce any output.
_________________
#Joseph
Back to top
View user's profile Send private message
ShadowCat8
Tux's lil' helper
Tux's lil' helper


Joined: 07 Oct 2008
Posts: 137
Location: Arcadia, CA, USA

PostPosted: Thu Apr 25, 2013 7:13 pm    Post subject: Reply with quote

Okay...

Having just done a combing of XFCE's docs (which seem to need a *LOT* of help. :roll: ), I think this *should* work for you:
Code:
terminal -x gpg -a --detach-sign %N

And if that doesn't get it, try changing the "-x" to "-e".

HTH. Let us know.
_________________
------
"There is no value to explaining sanity to an insane person, just as there is no value of explaining rabies to a rabid dog... They will both bite you for your effort."
-- oldbitman
Back to top
View user's profile Send private message
Joseph_sys
Advocate
Advocate


Joined: 08 Jun 2004
Posts: 2405
Location: Edmonton, AB

PostPosted: Thu Apr 25, 2013 7:17 pm    Post subject: Reply with quote

ShadowCat8 wrote:
Okay...

Having just done a combing of XFCE's docs (which seem to need a *LOT* of help. :roll: ), I think this *should* work for you:
Code:
terminal -x gpg -a --detach-sign %N

And if that doesn't get it, try changing the "-x" to "-e".

HTH. Let us know.


Brilliant, than you.
Yes that worked perfectly :-)
_________________
#Joseph
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum