Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Update alter Rechner geht nicht [gelöst]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
tazinblack
l33t
l33t


Joined: 23 Jan 2005
Posts: 942
Location: Baden / Germany

PostPosted: Wed Apr 17, 2013 6:31 am    Post subject: Update alter Rechner geht nicht [gelöst] Reply with quote

Hallo zusammen,

ich hab hier ne Kiste, welche ich schon länger nicht mehr upgedatet habe (ca. 1 Jahr).
Wenn ich jetzt einen emerge -Duav world mache bekomme ich das hier:

Code:
emerge -uav portage
!!! Unable to parse profile: '/etc/make.profile'
!!! ParseError: Profile contains unsupported EAPI '5': '/usr/portage/profiles/default/linux/amd64/13.0/eapi'
!!! Your current profile is invalid. If you have just changed your profile
!!! configuration, you should revert back to the previous configuration.
!!! Allowed actions are limited to --help, --info, --search, --sync, and
!!! --version.


Jetzt hab ich mal versucht ein anderes Profile zu wählen, aber das bringt nichts.

eselect profile list bringt das hier:

Code:
eselect profile list
Available profile symlink targets:
  [1]   default/linux/amd64/13.0
  [2]   default/linux/amd64/13.0/selinux
  [3]   default/linux/amd64/13.0/desktop
  [4]   default/linux/amd64/13.0/desktop/gnome
  [5]   default/linux/amd64/13.0/desktop/kde
  [6]   default/linux/amd64/13.0/developer
  [7]   default/linux/amd64/13.0/no-multilib
  [8]   default/linux/amd64/13.0/x32
  [9]   hardened/linux/amd64 *
  [10]  hardened/linux/amd64/selinux
  [11]  hardened/linux/amd64/no-multilib
  [12]  hardened/linux/amd64/no-multilib/selinux
  [13]  hardened/linux/uclibc/amd64


/etc/make.profile ist ein symlink nach ../usr/portage/profiles/hardened/linux/amd64
und /etc/make.globals ein symlink nach ../usr/share/portage/config/make.globals

Wenn ich einfach nur versuche portage upzudaten kommt der gleiche Fehler.


Kann da jemand helfen?
_________________
Gruß / Regards
tazinblack
_______________________________________________________
told you so


Last edited by tazinblack on Wed Apr 17, 2013 6:55 am; edited 1 time in total
Back to top
View user's profile Send private message
tazinblack
l33t
l33t


Joined: 23 Jan 2005
Posts: 942
Location: Baden / Germany

PostPosted: Wed Apr 17, 2013 6:48 am    Post subject: Reply with quote

ok, jetzt bin ich einen Schritt weiter.
Ich habe einfach in /usr/portage/profiles/eapi-5-files/eapi die eapi-Version von 5 auf 4 gestellt und dann portage upgedatet.
Danach wieder zurück auf 5.

Jetzt siehts so aus, als ginge es weiter.
Mal sehen, was noch kommt ...
_________________
Gruß / Regards
tazinblack
_______________________________________________________
told you so
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2290
Location: Germany

PostPosted: Wed Apr 17, 2013 11:37 am    Post subject: Reply with quote

Hehe, ja falsche Reihenfolge.
Wichtig ist das erst sys-apps/portage aktualisiert wird, und dann erst aufs neue Profil umgestellt wird.
Vermutlich hast du einfach die Gentoo News dazu übersehen :)
Siehe in der /usr/portage/metadata/news/2013-02-10-new-13-profiles/2013-02-10-new-13-profiles.en.txt
Quote:
We have generated a new set of profiles for Gentoo installation. These are now
called 13.0 instead of 10.0. Everyone should upgrade as soon as possible (but
please make sure sys-apps/portage is updated to current stable *before* you
switch profile).
This brings (nearly) no user-visible changes. Some new files have been added
to the profile directories that make it possible for the developers to do more
fine-grained use flag masking (see PMS-5 for the details), and this formally
requires a new profile tree with EAPI=5.

In deinem Fall hättest du am besten noch mal manuell aufs default/linux/amd64/10.0 er Profil zurück gewechselt (ja das ist noch da, auch wenn "eselect profile list" es nicht mehr mit anzeigt), dann sys-apps/portage aktuallisieren, und dann das gewünschte Profil neu setzen.

tazinblack wrote:
und /etc/make.globals ein symlink nach ../usr/share/portage/config/make.globals
Den alten /etc/make.globals Symlink kannst du löschen, der wird nicht mehr benötigt.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum