Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] failed to load module modesetting
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 249
Location: Veneto

PostPosted: Tue Apr 16, 2013 5:00 pm    Post subject: [SOLVED] failed to load module modesetting Reply with quote

I have this error in the Xorg.0.log file:

Code:
cat /var/log/Xorg.0.log|grep EE
[    17.671] Initializing built-in extension MIT-SCREEN-SAVER
[    17.926] (EE) Failed to load module "modesetting" (module does not exist, 0)


but the problem is that i have enable the KMS in the kernel config:

Code:
cat /usr/src/linux/.config |grep -i kms
CONFIG_DRM_KMS_HELPER=y
CONFIG_DRM_I915_KMS=y


make.conf video_cards:
Code:
VIDEO_CARDS="intel v4l fbdev"


What can i do to solve this problem?

ps: I'm running Gentoo ~amd64!
_________________
PC-Desktop: Ubuntu 12.04 x86
Notebook Sony Vaio VPCEH: Gentoo ~amd64


Last edited by polslinux on Tue Apr 16, 2013 5:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31365
Location: 56N 3W

PostPosted: Tue Apr 16, 2013 5:08 pm    Post subject: Reply with quote

polslinux,

Is it really a problem?

Code:
[    17.926] (EE) Failed to load module "modesetting" (module does not exist, 0)
refers to an Xorg module, not a kernel module.

Code:
VIDEO_CARDS="intel v4l fbdev"
its not required for any of those drivers, so the error message is in error.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 249
Location: Veneto

PostPosted: Tue Apr 16, 2013 5:14 pm    Post subject: Reply with quote

So can i safely ignore this error??
_________________
PC-Desktop: Ubuntu 12.04 x86
Notebook Sony Vaio VPCEH: Gentoo ~amd64
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31365
Location: 56N 3W

PostPosted: Tue Apr 16, 2013 5:16 pm    Post subject: Reply with quote

polslinux,

Yes.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2633
Location: Slovenia

PostPosted: Tue Apr 16, 2013 5:23 pm    Post subject: Reply with quote

The error refers to the xf86-video-modesetting driver: http://forums.gentoo.org/viewtopic-p-7201944.html#7201944
Back to top
View user's profile Send private message
polslinux
Apprentice
Apprentice


Joined: 12 Apr 2010
Posts: 249
Location: Veneto

PostPosted: Tue Apr 16, 2013 5:24 pm    Post subject: Reply with quote

oh! Thanks Gusar :D
_________________
PC-Desktop: Ubuntu 12.04 x86
Notebook Sony Vaio VPCEH: Gentoo ~amd64
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum