Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
media-video/ffmpeg-0.10.7 problems with SD movies
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 422
Location: Cracow, Poland

PostPosted: Tue Apr 16, 2013 2:33 pm    Post subject: media-video/ffmpeg-0.10.7 problems with SD movies Reply with quote

Hi,
I'm not sure if ffmpeg is guilty but after upgrading ffmpeg from 0.10.6 to 0.10.7 I notice that even SD (300x500) movies aren't smooth. What could I check to isolate problem.
I use:
    AMD/ATI HD6320 (from AMD E-450)
    mplayer2-2.0_p20120828
    smplayer-0.8.3
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1694
Location: Berlin, Germany

PostPosted: Sun Apr 21, 2013 2:11 am    Post subject: Reply with quote

Do you use the open source drivers and have VDPAU enabled for mesa? If so, disable it.

Only if you have a kernel which is patched for UVD and >=mesa-9.2_pre20130404 then VDPAU becomes useful. Else it will attempt to decode certain video formats using shaders with often suboptimal results.
Back to top
View user's profile Send private message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 422
Location: Cracow, Poland

PostPosted: Fri May 17, 2013 2:20 am    Post subject: Reply with quote

sorry for late answer but I didnt got email notification.

Anyway I have (and I had) open source driver without VDPAU.

I have still the issue, any other thinks to check,
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1694
Location: Berlin, Germany

PostPosted: Fri May 17, 2013 9:41 am    Post subject: Reply with quote

It could be that mplayer chooses a suboptimal video output (VO). Check the messages that are printed by mplayer to the shell. With the radeon driver and in absence of UVD acceleration, -vo xv is preferable.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum