Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
nvidia and framebuffer
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 140

PostPosted: Thu May 30, 2013 11:12 pm    Post subject: nvidia and framebuffer Reply with quote

I tried using uvesafb, following this page : http://wiki.gentoo.org/wiki/Uvesafb
...but no way to have a better resolution in other tty than X than the one I had already without any frambuffer
Curently using grub1


Any idea ?

(I also looked for this a lot in forums without finding anything that could work, did I miss something ?)
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Thu May 30, 2013 11:31 pm    Post subject: Reply with quote

you need to compile your kernel twice, and second time you must link to /usr/share/v86d/initramfs

your grub must also have the line. "video=uvesafb:1024x768-32,mtrr:3,ywrap" i have had this work before but i am also experiencing problems.

your video= line will need to be inserted somewhere. if you compiled 1 time to enable the packages building against it, then compiled another to give the initramfs location, its the video line. if you get it, please report the exact grub configuration you used.

i found a good hint for you..... in the wiki pages external resources...

http://www.funtoo.org/wiki/Uvesafb#Bootloader_configuration
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 140

PostPosted: Fri May 31, 2013 11:57 am    Post subject: Reply with quote

666threesixes666 wrote:
you need to compile your kernel twice, and second time you must link to /usr/share/v86d/initramfs


I did that link with initramfs and I recompiled my kernel like 10 times (trying to add vesa, removing it, trying uvesafb in the kernel, tried also as module etc...non worked

Quote:
your grub must also have the line. "video=uvesafb:1024x768-32,mtrr:3,ywrap" i have had this work before but i am also experiencing problems.


I have this exact line.Also tried with 16 bit color, 800x600, didn't help...Also tried with vga=resolution and vga=ask, didn't help too...

Quote:
your video= line will need to be inserted somewhere. if you compiled 1 time to enable the packages building against it, then compiled another to give the initramfs location, its the video line. if you get it, please report the exact grub configuration you used.


Here is my grub.cfg : http://bpaste.net/show/103315/

Quote:
i found a good hint for you..... in the wiki pages external resources...
http://www.funtoo.org/wiki/Uvesafb#Bootloader_configuration


Actually, I already did all these steps several times.
The only difference is : "[*] Video mode selection support" which doesn't exist in my menuconfig and "boot-update".
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Fri May 31, 2013 1:25 pm    Post subject: Reply with quote

i didnt follow the wiki closely enough, i forgot to enable firmware edid.... now i compile setup well, (wow i cant believe that crazy sentence... run grub boot loader installer) reboot into new kernel with that (firmware edid) enabled.... then emerge the packages, (do unnecessary reboot) then recompile kernel with initramfs path, update grub, and now i should be able to turn uvesa on with addition / off with removal of video=line....

make sure your actually booting your "Gentoo Linux 3.7.10" as your 3.8.13 doesnt have the video line required for the FB to load up....
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 140

PostPosted: Fri May 31, 2013 1:38 pm    Post subject: Reply with quote

Yes, still doesn't work.

Maybe I should try with grub2.

If it doesn't solve anything I'll try only to change the font size from my other tty.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Fri May 31, 2013 1:49 pm    Post subject: Reply with quote

ive only had it work with grub2. i went directly from lilo to grub2 because i was familiar with it from ubuntu (sort of)

to get grub2 quickly up....

mount /boot
mkdir /boot/grub2
grub2-mkconfig -o /boot/grub2/grub.cfg
grub2-install /dev/sda


that only requires your seeing kernel naming, or using make install on kernel sources to install your kernels to /boot (genkernel probably does this, though ive never seen it work)

edited to note that the wiki is inaccurate, and should be stubbed... you MUST reboot, and cannot slam through the entire wiki with out installing / rebooting / reloading the kernels.... i don't know the exact timings required so id posted what was known working for me before this install.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 140

PostPosted: Sun Jun 02, 2013 2:49 pm    Post subject: Reply with quote

-Changing the fonts is limited, hard to have something smaller than default
-grub2 didn't help even with new options
Back to top
View user's profile Send private message
FishB8
l33t
l33t


Joined: 17 Mar 2003
Posts: 813

PostPosted: Wed Jun 05, 2013 3:14 am    Post subject: Reply with quote

uvesafb is very limited in that it isn't able to probe the EDID of the connected monitor. The only resolutions is has access to are the ones included in the video card's firmware EDID. They are different for each card, and are generally low res. Make sure the resolution you are trying to use is one listed in the firmware EDID.
_________________
"...as we enjoy great advantages from the inventions of others, we should be glad of an opportunity to serve others by any invention of ours, and this we should do freely and generously." -Benjamin Franklin
Back to top
View user's profile Send private message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 140

PostPosted: Wed Jun 05, 2013 1:13 pm    Post subject: Reply with quote

FishB8 wrote:
Make sure the resolution you are trying to use is one listed in the firmware EDID.


I tried with several resolutions listed with "cat /sys/class/graphics/fb0/modes ", none works...
Back to top
View user's profile Send private message
alex6
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jul 2011
Posts: 140

PostPosted: Sun Jun 16, 2013 5:45 pm    Post subject: Reply with quote

Problem still not solved...

Should I report it to uvesafb bugzilla or kernel bugzilla ? (or gentoo bugzilla ?)
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 31711
Location: 56N 3W

PostPosted: Sun Jun 16, 2013 6:08 pm    Post subject: Reply with quote

alex6,

By all means search bugzilla and add to an existing open bug if you are adding new information but before you do that, I recall something on the -dev mailing list about uvesafb lacking a maintainer in Gentoo.

vesafb works for me with the nvidia binary blob Xorg driver, despite the dire warnings that horrible things may happen.
I assume you are using the nvidia binary blob driver too, as neuveau provides a framebufffer for free.

Before you make a bug of your own, post your grub.conf and your kernel .config as it is now.
Also post what
Code:
uname -a
shows.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1235
Location: 42.68n 85.41w

PostPosted: Sun Jun 16, 2013 6:19 pm    Post subject: Reply with quote

uvesafb stopped working for me, and went back to vesafb
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum