Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge of vlc failing on segmentation fault (SOLVED)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 637
Location: Stuart, Florida

PostPosted: Thu Apr 11, 2013 6:23 pm    Post subject: Emerge of vlc failing on segmentation fault (SOLVED) Reply with quote

revdep-rebuild is failing to emerge vlc. I tried it as a straight emerge and it fails as well.

It is unusual to have a segmentation fault so I tried

[list=]MAKEOPTS="-j1" emerge vlc
[/list] with the same result.

Any ideas?


Here is the pertinent listing:

    CC media_list_player.lo
    CC media_library.lo
    media_list.c: In function 'libvlc_media_list_add_file_content':
    media_list.c:272:2: warning: #warning Missing error handling! [-Wcpp]
    media_player.c: In function 'input_event_changed':
    media_player.c:230:58: warning: unused parameter 'psz_cmd' [-Wunused-parameter]
    media_player.c: In function 'libvlc_media_player_get_nsobject':
    media_player.c:874:65: warning: unused parameter 'p_mi' [-Wunused-parameter]
    media_player.c: In function 'libvlc_media_player_get_agl':
    media_player.c:900:62: warning: unused parameter 'p_mi' [-Wunused-parameter]
    media_player.c: In function 'libvlc_media_player_get_hwnd':
    media_player.c:950:60: warning: unused parameter 'p_mi' [-Wunused-parameter]
    CC media_discoverer.lo
    CC revision.lo
    GEN libvlc.pc
    CCLD libvlc.la
    config.status: creating lib/libvlc.pc
    make[3]: Leaving directory `/var/tmp/portage/media-video/vlc-2.0.5/work/vlc-2.0.5/lib'
    make[2]: Leaving directory `/var/tmp/portage/media-video/vlc-2.0.5/work/vlc-2.0.5/lib'
    Making all in bin
    make[2]: Entering directory `/var/tmp/portage/media-video/vlc-2.0.5/work/vlc-2.0.5/bin'
    CC vlc.o
    CC override.o
    CC rootwrap.o
    CC vlc_static-vlc.o
    CC vlc_static-override.o
    CC cachegen.o
    CCLD vlc
    CCLD vlc-wrapper
    CCLD vlc-cache-gen
    CCLD vlc-static
    GEN ../modules/plugins.dat
    /bin/sh: line 4: 7165 Segmentation fault ./vlc-cache-gen ../modules
    make[2]: *** [../modules/plugins.dat] Error 139
    make[2]: Leaving directory `/var/tmp/portage/media-video/vlc-2.0.5/work/vlc-2.0.5/bin'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/var/tmp/portage/media-video/vlc-2.0.5/work/vlc-2.0.5'
    make: *** [all] Error 2
    * ERROR: media-video/vlc-2.0.5 failed (compile phase):
    * emake failed
    *
    * If you need support, post the output of `emerge --info '=media-video/vlc-2.0.5'`,
    * the complete build log and the output of `emerge -pqv '=media-video/vlc-2.0.5'`.
    * The complete build log is located at '/var/tmp/portage/media-video/vlc-2.0.5/temp/build.log'.
    * The ebuild environment file is located at '/var/tmp/portage/media-video/vlc-2.0.5/temp/environment'.
    * Working directory: '/var/tmp/portage/media-video/vlc-2.0.5/work/vlc-2.0.5'
    * S: '/var/tmp/portage/media-video/vlc-2.0.5/work/vlc-2.0.5'

    >>> Failed to emerge media-video/vlc-2.0.5, Log file:

    >>> '/var/tmp/portage/media-video/vlc-2.0.5/temp/build.log'


emerge --info vlc follows:

    bopper portage # emerge --info vlc
    Portage 2.1.11.55 (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo x86_64)
    =================================================================
    System Settings
    =================================================================
    System uname: Linux-3.7.10-gentoo-x86_64-AMD_Phenom-tm-_II_X4_970_Processor-with-gentoo-2.1
    KiB Mem: 4044876 total, 797192 free
    KiB Swap: 1021948 total, 772212 free
    Timestamp of tree: Thu, 11 Apr 2013 01:30:01 +0000
    ld GNU ld (GNU Binutils) 2.22
    app-shells/bash: 4.2_p37
    dev-java/java-config: 2.1.12-r1
    dev-lang/python: 2.7.3-r3, 3.1.5-r1, 3.2.3-r2
    dev-util/cmake: 2.8.9
    dev-util/pkgconfig: 0.28
    sys-apps/baselayout: 2.1-r1
    sys-apps/openrc: 0.11.8
    sys-apps/sandbox: 2.5
    sys-devel/autoconf: 2.13, 2.69
    sys-devel/automake: 1.10.3, 1.11.6, 1.12.6
    sys-devel/binutils: 2.22-r1
    sys-devel/gcc: 4.6.3
    sys-devel/gcc-config: 1.7.3
    sys-devel/libtool: 2.4-r1
    sys-devel/make: 3.82-r4
    sys-kernel/linux-headers: 3.7 (virtual/os-headers)
    sys-libs/glibc: 2.15-r3
    Repositories: gentoo
    ACCEPT_KEYWORDS="amd64"
    ACCEPT_LICENSE="* -@EULA"
    CBUILD="x86_64-pc-linux-gnu"
    CFLAGS="-O2 -pipe"
    CHOST="x86_64-pc-linux-gnu"
    CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
    CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
    CXXFLAGS="-O2 -pipe"
    DISTDIR="/usr/portage/distfiles"
    FCFLAGS="-O2 -pipe"
    FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
    FFLAGS="-O2 -pipe"
    GENTOO_MIRRORS="http://distfiles.gentoo.org"
    LANG="en_US.UTF-8"
    LDFLAGS="-Wl,-O1 -Wl,--as-needed"
    MAKEOPTS="-j5"
    PKGDIR="/usr/portage/packages"
    PORTAGE_CONFIGROOT="/"
    PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
    PORTAGE_TMPDIR="/var/tmp"
    PORTDIR="/usr/portage"
    PORTDIR_OVERLAY=""
    SYNC="rsync://rsync.gentoo.org/gentoo-portage"
    USE="3dnow X Xaw3d a52 aac aalib acl acpi aim alsa amd64 ao apache2 apm audiofile avahi berkdb blas bluetooth branding bzip2 cairo calendar caps cdda cddb cdinstall cdparanoia cdr cgi clamav cli consolekit cracklib crypt css ctype cups curl cvs cxx dbi dbm dbus dbx dga directfb dri dts dv dvb dvd dvdr eds emboss encode enscript evo examples exif expat fam fastcgi fbcon ffmpeg firefox flac fontconfig foomaticdb fortran ftp gcj gdbm gif gimp glu gmp gnome gnuplot gnutls gphoto2 gpm graphviz gsl gsm gstreamer gtk gtkhtml guile gzip hal handbook hddtemp iconv icq icu idn ieee1394 imagemagick imlib innodb introspection iodbc ipv6 jabber java java6 javascript jbig jingle jpeg jpeg2k kde kontact lapack lcms ldap libcaca libedit libgda libnotify libwww lm_sensors lua lzma lzo mad maildir mikmod milter mime mmap mmx mng modules motif mozilla mp3 mp4 mpeg mpi mplayer msn mudflap multilib musepac mysql mysqli nas ncurses networkmanager nls nntp nptl nsplugin odbc offensive ofx ogg opengl openmp osc oscar oss pam pango pch pcntl pcre pdf perl php plasma plotutils png policykit portaudio posix postgres ppds pulseaudio python qt3support qt4 quicktime raw rdesktop readline rss ruby samba sasl sdl semantic-desktop session sharedext sharedmem simplexml smp sndfile snmp soap sockets socks5 speex spell sqlite sqlite3 sse sse2 ssl startup-notification subversion suid svg symlink syslog sysvipc szip tcl tcpd theora threads tidy tiff timiditytk tokenizer truetype udev udisks unicode upower usb v4l v4l2 vcd vorbis wmf wxwidgets x264 xcb xcomposite xft xine xinerama xinetd xml xnlrpc xosd xv xvid yahoo zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia nouveau" XFCE_PLUGINS="brightness menu trash" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
    Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

    =================================================================
    Package Settings
    =================================================================

    media-video/vlc-2.0.5 was built with the following:
    USE="X a52 aac aalib alsa avahi avcodec avformat cdda cddb dbus directfb dts dvb dvbpsi dvd encode ffmpeg flac fontconfig gcrypt gnome gnutls ieee1394 kde libcaca libnotify lua mmx mp3 mpeg (multilib) ncurses ogg opengl oss png portaudio postproc pulseaudio qt4 samba sdl speex sqlite sse svg swscale theora truetype udev v4l vorbis x264 xcb xml xosd xv (-altivec) -atmo (-audioqueue) -bidi -bluray -dc1394 -debug -dirac (-direct2d) (-directx) (-dshow) (-dxva2) -egl -fbosd -fluidsynth -gme -growl -httpd (-ios-vout) -jack -kate -libass -libproxy -libsamplerate -libtar -libtiger -linsys -lirc -live (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) -matroska (-media-library) -modplug -mtp -musepack (-neon) -omxil -optimisememory -opus -projectm -pvr -rtsp -run-as-root -schroedinger -sdl-image -shine -shout -sid -skins -switcher -taglib -twolame -upnp -vaapi -vcdx -vlm (-waveout) (-win32codecs) (-wingdi) -wma-fixed -zvbi"

    bopper portage #


Last edited by Featherfoot on Fri Jun 14, 2013 9:06 pm; edited 3 times in total
Back to top
View user's profile Send private message
Jimmy Jazz
Apprentice
Apprentice


Joined: 04 Oct 2004
Posts: 274
Location: Strasbourg

PostPosted: Fri Apr 12, 2013 1:42 pm    Post subject: Re: Emerge of vlc failing on segmentation fault Reply with quote

Featherfoot wrote:
revdep-rebuild is failing to emerge vlc. I tried it as a straight emerge and it fails as well.

It is unusual to have a segmentation fault so I tried

[list=]MAKEOPTS="-j1" emerge vlc
[/list] with the same result.

Any ideas?



I had a similar problem w/ vlc but It was during a @world update. i remember having downgraded mesa-9999
Well then, probably mesa

emerge -auv =media-libs/mesa-9.2_pre20130404
_________________
« La seule condition au triomphe du mal, c'est l'inaction des gens de bien » E.Burke
Code:

+----+----+----+
|    |::::|    |
|    |::::|    |
+----+----+----+

motto: WeLCRO
WritE Less Code, Repeat Often
Back to top
View user's profile Send private message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 637
Location: Stuart, Florida

PostPosted: Tue May 07, 2013 2:23 am    Post subject: Reply with quote

This worked!

I originally didn't try it because the emerge was masked.

Thanks for your help.

***** If this actually worked, it failed again shortly afterward.
Back to top
View user's profile Send private message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 637
Location: Stuart, Florida

PostPosted: Sat Jun 01, 2013 2:44 am    Post subject: Reply with quote

vlc is (again/still) failing for me and this is a pretty serious problem.

I'd appreciate some advice on what else I can do to make vlc compile.
Back to top
View user's profile Send private message
staysys
n00b
n00b


Joined: 30 Mar 2013
Posts: 1

PostPosted: Sat Jun 01, 2013 4:52 am    Post subject: Reply with quote

Well I'm by no means experienced enough to deal with compilation errors during emerge..

However, I've been able to solve a few emerge problems I've had (especially during an emerge world) by simply unmerging the problem package, finishing the emerge world, emerge --depclean, and revdep-rebuild
Then try to re-emerge the package. You can give that a try, it's harmless anyway
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1241
Location: 42.68n 85.41w

PostPosted: Sat Jun 01, 2013 6:28 am    Post subject: Reply with quote

im by no means an expert, but i suspect your use flags are pulling in a broken or deprecated dependency. i had to add fontconfig to VLC's use flags to get volume and subtitles in english. you probably have something that rather than fixing, throws a wrench in the gears.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 637
Location: Stuart, Florida

PostPosted: Sat Jun 01, 2013 8:22 pm    Post subject: Reply with quote

Thanks for your inputs.

I did try to unmerge vlc and then rebuild it from scratch. It didn't work.

I have tried to play with USE flags. I tried various things I thought might affect "vlc-cache-gen" which is what is crashing. This didn't help. Lately I added all of the USE flags recommended in videolan.org for gentoo.

Googling around, I see that others are having similar problems with newer versions of vlc.
Back to top
View user's profile Send private message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 637
Location: Stuart, Florida

PostPosted: Mon Jun 03, 2013 2:11 am    Post subject: Reply with quote

I downloaded the source from videolan.org and put printf statements in the code to see whether I could identify where the crash was happening. It turns out it is crashing in module_Load when it calls dlopen() with the name of a plugin when it runs the vlc-cache-gen program during the installation. The segmentation fault is actually happening inside dlopen(), which is located in glibc, I think.

It calls dlopen around 143 times before it crashes. This implies that if the problem is with the current version of glibc, it isn't serious.

I tried relinking glibc. That didn't fix it, so I probably ought to try a newer version next.

Meanwhile, I think I will chase this problem in videolan.org's forums.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1241
Location: 42.68n 85.41w

PostPosted: Mon Jun 03, 2013 4:30 am    Post subject: Reply with quote

while your at it make sure 'echo $MAKEOPTS' returns NOTHING, blank line.... just to rule that one out also.
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
alex46
n00b
n00b


Joined: 18 Apr 2011
Posts: 20
Location: Vienna/Austria

PostPosted: Fri Jun 14, 2013 8:36 pm    Post subject: Reply with quote

i had this problem too

try to build vlc with

USE="-svg -libnotify -xv -xcb"
Back to top
View user's profile Send private message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 637
Location: Stuart, Florida

PostPosted: Fri Jun 14, 2013 9:06 pm    Post subject: Reply with quote

That fixed it!

Thanks for your help.
Back to top
View user's profile Send private message
paully
n00b
n00b


Joined: 21 May 2004
Posts: 47
Location: Folkestone, Kent, UK

PostPosted: Mon Jun 17, 2013 8:29 am    Post subject: Reply with quote

Hi Folks

I now have a 'segmenting' vlc

:(

If I add --debug to the USE flags, what do I need to do start debugging?

Here is what I have tried so far...

1. rm -rf ~/.local/share/vlc and ~/.config/vlc/
2. /usr/lib/vlc/vlc-cache-gen -f /usr/lib/vlc/plugins/
3. re-emerged with minimal USE and removed qt4, no problems compiling
4. downloaded matroska test files
5. vlc --help and vlc --version work.

Do you want my various emerge --info and emerge -pv vlc, etc.?

Thanks!
_________________
PAULLY
Back to top
View user's profile Send private message
Featherfoot
l33t
l33t


Joined: 28 Dec 2002
Posts: 637
Location: Stuart, Florida

PostPosted: Mon Jun 17, 2013 10:14 pm    Post subject: Reply with quote

A solution to the problem was posted above.

When I debugged vlc, I downloaded the source from videolan.org and put "printf" statements with a message showing where the statement was, into the code. This made sense because one of their tasks was segfaulting during the install. I did locate the code in portage, but never tried to debug that code because I am not familiar with the debugger or the gentoo development environment..
Back to top
View user's profile Send private message
paully
n00b
n00b


Joined: 21 May 2004
Posts: 47
Location: Folkestone, Kent, UK

PostPosted: Tue Jun 18, 2013 9:48 am    Post subject: Reply with quote

Hi Featherfoot

Thanks for replying.

Alas, as you can see from my USE flags, your fix did not work for me...

Code:
thinkpad ~ # eix -I vlc
[I] media-video/vlc
     Installed versions:  2.0.6(09:10:16 17/06/13)(X a52 aac alsa avcodec avformat bidi cdda dbus debug dts dvbpsi dvd elibc_glibc encode ffmpeg flac gcrypt gnutls httpd jack live lua matroska mmx mp3 mpeg ncurses ogg opengl png postproc pulseaudio sdl sse swscale theora truetype udev vaapi vlm vorbis x264 xml -aalib -altivec -atmo -audioqueue -avahi -bluray -cddb -dc1394 -dirac -direct2d -directfb -directx -dshow -dvb -dxva2 -egl -fbosd -fluidsynth -fontconfig -gme -gnome -growl -ieee1394 -ios-vout -kate -kde -libass -libcaca -libnotify -libproxy -libsamplerate -libtar -libtiger -linsys -lirc -macosx -macosx-audio -macosx-dialog-provider -macosx-eyetv -macosx-qtkit -macosx-quartztext -macosx-vout -media-library -modplug -mtp -musepack -neon -omxil -optimisememory -opus -oss -portaudio -projectm -pvr -qt4 -rtsp -run-as-root -samba -schroedinger -sdl-image -shine -shout -sid -skins -speex -sqlite -svg -switcher -taglib -twolame -upnp -v4l -vcdx -waveout -wingdi -wma-fixed -xcb -xosd -xv -zvbi)
     Homepage:            http://www.videolan.org/vlc/
     Description:         VLC media player - Video player and streamer


Here is what I have installed...

Code:
paully@thinkpad ~ $ vlc --version
VLC media player 2.0.6 Twoflower (revision 2.0.6-0-gbe9623c)
VLC version 2.0.6 Twoflower (2.0.6-0-gbe9623c)
Compiled by root on thinkpad.littlefield.uk.com (Jun 17 2013 09:04:52)
Compiler: gcc version 4.7.2 (Gentoo 4.7.2 p1.3, pie-0.5.5)


Here is what happens if I try to play a movie...

Code:
paully@thinkpad ~ $ vlc ~/Downloads/matroska_test_w1_1/test1.mkv
VLC media player 2.0.6 Twoflower (revision 2.0.6-0-gbe9623c)
[0xe35bb8] main interface error: no suitable interface module
[0xd74488] main libvlc error: interface "globalhotkeys,none" initialization failed
[0xd74488] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0xe35bb8] [cli] lua interface: Listening on host "*console".
VLC media player 2.0.6 Twoflower
Command Line Interface initialized. Type `help' for help.
> Segmentation fault


Here is what is in syslog...

Code:
Jun 18 10:41:49 thinkpad klogd: vlc[4397]: segfault at 35600000000 ip 00007ff926452fa0 sp 00007ff9401f73a0 error 4 in libavcodec.so.53.61.100[7ff9260df000+703000]


Here is that file...

Code:
thinkpad ~ # qfile libavcodec.so.53.61.100
media-video/ffmpeg (/usr/lib64/libavcodec.so.53.61.100)
app-emulation/emul-linux-x86-medialibs (/usr/lib32/libavcodec.so.53.61.100)


Here is my info...

Code:
thinkpad ~ # emerge --info
Portage 2.1.12.2 (default/linux/amd64/13.0/desktop, gcc-4.7.2, glibc-2.15-r3, 3.7.9-gentoo x86_64)
=================================================================
System uname: Linux-3.7.9-gentoo-x86_64-Intel-R-_Core-TM-_i3_CPU_U_380_1.33GHz-with-gentoo-2.1
KiB Mem:     3842004 total,   1906116 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Wed, 12 Jun 2013 18:45:02 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4, 4.7.2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo wirelay java-overlay amielke-overlay steam-overlay local
ACCEPT_KEYWORDS="amd64"


Any ideas?

Thanks in advance.

:?
_________________
PAULLY
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1678
Location: Berlin, Germany

PostPosted: Tue Jun 18, 2013 6:18 pm    Post subject: Reply with quote

Try to get a backtrace in vlc.
First you can to add -g to CFLAGS and splitdebug to FEATURES in make.conf
Then emerge vlc and gdb, and run:
Code:
$ gdb vlc
(gdb) run ~/Downloads/matroska_test_w1_1/test1.mkv
...wait for segmentation fault...
Program received signal SIGSEGV, Segmentation fault.
(gdb) bt

And provide the output here. If there are any ?? () next to filenames, this means that debug info for those files is missing and the packages owning them also should be built with -g.
Back to top
View user's profile Send private message
paully
n00b
n00b


Joined: 21 May 2004
Posts: 47
Location: Folkestone, Kent, UK

PostPosted: Tue Jun 18, 2013 8:01 pm    Post subject: Reply with quote

Hi chithanh

Thanks for taking the time to reply. I now know how to debug and backtrace! :-)

Here is the output for my dodgy VLC...

Code:
paully@thinkpad ~ $ gdb vlc
GNU gdb (Gentoo 7.5.1 p2) 7.5.1
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/vlc...(no debugging symbols found)...done.

(gdb) run ~/Downloads/matroska_test_w1_1/test1.mkv
Starting program: /usr/bin/vlc ~/Downloads/matroska_test_w1_1/test1.mkv
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
VLC media player 2.0.6 Twoflower (revision 2.0.6-0-gbe9623c)
[New Thread 0x7ffff5297700 (LWP 7868)]
[New Thread 0x7ffff5196700 (LWP 7869)]
[0x6c6bc8] main interface error: no suitable interface module
[0x605498] main libvlc error: interface "globalhotkeys,none" initialization failed
[0x605498] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[New Thread 0x7ffff4c6a700 (LWP 7870)]
[New Thread 0x7ffff0c02700 (LWP 7871)]
[0x6c6bc8] [cli] lua interface: Listening on host "*console".
VLC media player 2.0.6 Twoflower
Command Line Interface initialized. Type `help' for help.
> [Thread 0x7ffff5196700 (LWP 7869) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff0c02700 (LWP 7871)]
0x00007fffdb325fa0 in avcodec_open2 () from /usr/lib64/libavcodec.so.53
(gdb) bt
#0  0x00007fffdb325fa0 in avcodec_open2 () from /usr/lib64/libavcodec.so.53
#1  0x00007fffe053cc69 in ?? () from /usr/lib64/vlc/plugins/codec/libavcodec_plugin.so
#2  0x00007fffe053de57 in ?? () from /usr/lib64/vlc/plugins/codec/libavcodec_plugin.so
#3  0x00007fffe053cb95 in ?? () from /usr/lib64/vlc/plugins/codec/libavcodec_plugin.so
#4  0x00007ffff79618d8 in vlc_module_load () from /usr/lib64/libvlccore.so.5
#5  0x00007ffff7922c56 in ?? () from /usr/lib64/libvlccore.so.5
#6  0x00007ffff7922df6 in ?? () from /usr/lib64/libvlccore.so.5
#7  0x00007ffff7927deb in ?? () from /usr/lib64/libvlccore.so.5
#8  0x00007ffff7928c9b in ?? () from /usr/lib64/libvlccore.so.5
#9  0x00007ffff7928dfb in ?? () from /usr/lib64/libvlccore.so.5
#10 0x00007ffff792bef2 in ?? () from /usr/lib64/libvlccore.so.5
#11 0x00007ffff792d3bc in ?? () from /usr/lib64/libvlccore.so.5
#12 0x00007ffff792f2ce in ?? () from /usr/lib64/libvlccore.so.5
#13 0x00007ffff7930afc in ?? () from /usr/lib64/libvlccore.so.5
#14 0x00007ffff79348e1 in ?? () from /usr/lib64/libvlccore.so.5
#15 0x00007ffff7936ae5 in ?? () from /usr/lib64/libvlccore.so.5
#16 0x00007ffff76cef4a in start_thread () from /lib64/libpthread.so.0
#17 0x00007ffff720420d in clone () from /lib64/libc.so.6
(gdb) quit


So, what does this all mean?!

:?
_________________
PAULLY
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1678
Location: Berlin, Germany

PostPosted: Tue Jun 18, 2013 8:36 pm    Post subject: Reply with quote

Code:
Reading symbols from /usr/bin/vlc...(no debugging symbols found)...done.

#1  0x00007fffe053cc69 in ?? () from /usr/lib64/vlc/plugins/codec/libavcodec_plugin.so
This means that vlc was not built with CFLAGS="-g" or something went wrong during build.
Anyway the problem seems to be in the vlc package. You could try a different version.
Back to top
View user's profile Send private message
paully
n00b
n00b


Joined: 21 May 2004
Posts: 47
Location: Folkestone, Kent, UK

PostPosted: Fri Jun 21, 2013 1:34 pm    Post subject: Reply with quote

OK, I will try a downgrade (if that's the correct term in MY case! lol) to "Gentoo stable" 2.0.5

Watch this space.

:?
_________________
PAULLY
Back to top
View user's profile Send private message
paully
n00b
n00b


Joined: 21 May 2004
Posts: 47
Location: Folkestone, Kent, UK

PostPosted: Fri Jun 21, 2013 2:34 pm    Post subject: Reply with quote

Nah, 2.0.5 with the default USE flags gives a segmentation fault too.

(sigh)

Now going to try with the tips from above with some USE flags removed...
_________________
PAULLY
Back to top
View user's profile Send private message
paully
n00b
n00b


Joined: 21 May 2004
Posts: 47
Location: Folkestone, Kent, UK

PostPosted: Fri Jun 21, 2013 3:33 pm    Post subject: Reply with quote

Nope, segfaults again. Here is the debug output:-

Code:
paully@thinkpad ~ $ gdb vlc
GNU gdb (Gentoo 7.5.1 p2) 7.5.1
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/vlc...(no debugging symbols found)...done.

(gdb) run ~/Downloads/matroska_test_w1_1/test1.mkv
Starting program: /usr/bin/vlc ~/Downloads/matroska_test_w1_1/test1.mkv
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[New Thread 0x7ffff5ef9700 (LWP 28987)]
[New Thread 0x7ffff5df8700 (LWP 28988)]
[0x6c21f8] main interface error: no suitable interface module
[0x605498] main libvlc error: interface "globalhotkeys,none" initialization failed
[0x605498] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Remote control interface initialized. Type `help' for help.
[New Thread 0x7ffff56e2700 (LWP 28989)]
[New Thread 0x7ffff55e1700 (LWP 28990)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff5df8700 (LWP 28988)]
0x00007fffdc572fef in av_dict_get () from /usr/lib64/libavutil.so.51

(gdb) bt
#0  0x00007fffdc572fef in av_dict_get () from /usr/lib64/libavutil.so.51
#1  0x00007fffdd7831e0 in ?? () from /usr/lib64/vlc/plugins/demux/libavformat_plugin.so
#2  0x00007ffff793e85c in ?? () from /usr/lib64/libvlccore.so.5
#3  0x00007ffff793ec6d in ?? () from /usr/lib64/libvlccore.so.5
#4  0x00007ffff7941634 in ?? () from /usr/lib64/libvlccore.so.5
#5  0x00007ffff7942b70 in ?? () from /usr/lib64/libvlccore.so.5
#6  0x00007ffff7926ccd in ?? () from /usr/lib64/libvlccore.so.5
#7  0x00007ffff76ddf4a in start_thread () from /lib64/libpthread.so.0
#8  0x00007ffff721320d in clone () from /lib64/libc.so.6
(gdb) quit
A


So, it looks like something is wrong with /usr/lib64/libavutil.so.51

Code:
thinkpad ~ # qfile /usr/lib64/libavutil.so.51
media-video/ffmpeg (/usr/lib64/libavutil.so.51)


I am stumped.

I am OK using mplayer but would rather use vlc.

Anyone got any ideas?

It maybe ffmpeg...

Code:
Mon May 14 19:02:30 2012 >>> media-video/ffmpeg-0.10.2
Mon Jun 11 19:50:28 2012 >>> media-video/ffmpeg-0.10.3
Mon Jun 18 15:58:20 2012 >>> media-video/ffmpeg-0.10.3
Wed Jul 11 01:05:03 2012 >>> media-video/ffmpeg-0.10.3
Sun Jul 29 12:34:43 2012 >>> virtual/ffmpeg-0.10.2-r1
Thu Dec  6 01:05:47 2012 >>> virtual/ffmpeg-0.10.3
Thu Jun 13 21:16:29 2013 >>> media-video/ffmpeg-0.10.7


Help!?!

:?
_________________
PAULLY
Back to top
View user's profile Send private message
TomWij
Developer
Developer


Joined: 04 Jul 2012
Posts: 1551

PostPosted: Sun Jun 23, 2013 2:21 pm    Post subject: Reply with quote

Please read http://www.gentoo.org/proj/en/qa/backtraces.xml on how to get rid of the ?? as the information that they are hidden are needed, then file this as a bug at https://bugs.gentoo.org; thank you in advance.
Back to top
View user's profile Send private message
paully
n00b
n00b


Joined: 21 May 2004
Posts: 47
Location: Folkestone, Kent, UK

PostPosted: Mon Jun 24, 2013 11:48 am    Post subject: Reply with quote

Hi

I have fixed the debugging issue, and the proper result is shown below:-

Code:
paully@thinkpad ~ $ gdb vlc
GNU gdb (Gentoo 7.5.1 p2) 7.5.1
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.gentoo.org/>...
Reading symbols from /usr/bin/vlc...Reading symbols from /usr/lib64/debug/usr/bin/vlc.debug...done.
done.

(gdb) run ~/Downloads/matroska_test_w1_1/test1.mkv
Starting program: /usr/bin/vlc ~/Downloads/matroska_test_w1_1/test1.mkv
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[New Thread 0x7ffff5ef9700 (LWP 24338)]
[New Thread 0x7ffff5df8700 (LWP 24339)]
[0x6c2218] main interface error: no suitable interface module
[0x605498] main libvlc error: interface "globalhotkeys,none" initialization failed
[0x605498] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Remote control interface initialized. Type `help' for help.
[New Thread 0x7ffff56e2700 (LWP 24340)]
[New Thread 0x7ffff49e0700 (LWP 24341)]
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7ffff49e0700 (LWP 24341)]
0x00007fffdc572fef in av_dict_get () from /usr/lib64/libavutil.so.51

(gdb) bt
#0  0x00007fffdc572fef in av_dict_get () from /usr/lib64/libavutil.so.51
#1  0x00007fffdd7831e0 in Control (p_demux=0x7fffe00048f8, i_query=<optimized out>, args=<optimized out>) at demux.c:867
#2  0x00007ffff793e85c in demux_vaControl (args=0x7ffff49dfc58, i_query=<optimized out>, p_demux=<optimized out>) at input/demux.h:48
#3  demux_Control (p_demux=p_demux@entry=0x7fffe00048f8, i_query=i_query@entry=11) at input/demux.h:56
#4  0x00007ffff793ec6d in InputSourceMeta (p_input=p_input@entry=0x7ffff0000b28, p_meta=p_meta@entry=0x7fffe054df40, p_source=<optimized out>,
    p_source=<optimized out>) at input/input.c:2723
#5  0x00007ffff7941634 in Init (p_input=p_input@entry=0x7ffff0000b28) at input/input.c:1315
#6  0x00007ffff79449d5 in Run (obj=0x7ffff0000b28) at input/input.c:550
#7  0x00007ffff76ddf4a in start_thread () from /lib64/libpthread.so.0
#8  0x00007ffff721320d in clone () from /lib64/libc.so.6
(gdb)


Do I now report this to bugzilla?
_________________
PAULLY
Back to top
View user's profile Send private message
paully
n00b
n00b


Joined: 21 May 2004
Posts: 47
Location: Folkestone, Kent, UK

PostPosted: Mon Jun 24, 2013 11:59 am    Post subject: Reply with quote

Ah, I have just realised that my VLC will play mp3 music files OK.
_________________
PAULLY
Back to top
View user's profile Send private message
paully
n00b
n00b


Joined: 21 May 2004
Posts: 47
Location: Folkestone, Kent, UK

PostPosted: Mon Jun 24, 2013 12:03 pm    Post subject: Reply with quote

I have submitted my first bug... hope it's ok!

https://bugs.gentoo.org/show_bug.cgi?id=474596
_________________
PAULLY
Back to top
View user's profile Send private message
paully
n00b
n00b


Joined: 21 May 2004
Posts: 47
Location: Folkestone, Kent, UK

PostPosted: Tue Jun 25, 2013 5:18 pm    Post subject: Reply with quote

I have installed the git 9999 version and it's an improvement.

It does not segfault but sits there...

paully@thinkpad ~ $ vlc ~/Downloads/matroska_test_w1_1/test1.mkv

VLC media player 2.1.0-pre1 Rincewind (revision 2.1.0-git-3-g06005e8)
[0xbedef8] main interface error: no suitable interface module
[0xb274a8] main libvlc error: interface "globalhotkeys,none" initialization failed
[0xb274a8] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Remote control interface initialized. Type `help' for help.
[0x7fdac0c01758] main demux error: corrupt module: /usr/lib64/vlc/plugins/demux/libavformat_plugin.so
[0x7fdac0c04fc8] main decoder error: corrupt module: /usr/lib64/vlc/plugins/codec/libavcodec_plugin.so
status change: ( audio volume: 188 )
[0x7fdac0c55fc8] main decoder error: corrupt module: /usr/lib64/vlc/plugins/codec/libavcodec_plugin.so
_________________
PAULLY
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum