Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Neues Notebook Lenovo ThinkPad T430U
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
ibaF
n00b
n00b


Joined: 12 May 2010
Posts: 36

PostPosted: Tue Apr 09, 2013 7:32 pm    Post subject: Neues Notebook Lenovo ThinkPad T430U Reply with quote

Hi,

ich habe mir letze Woche das oben genannte Notebook gekauft und Gentoo darauf installiert.
Leider läuft noch nicht alles so, wie gewünscht.

1.) Ich schaffe es nicht die W-LAN Karte zum Laufen zu bringen es ist eine Intel Centrino® Wireless-N 2230. Ich habe die Treiber und die Firmware gemäß der Anleitung auf http://wiki.gentoo.org/wiki/Wifi installiert und den Kernel auch entsprechend konfiguriert.
ifconfig zeigt folgendes an:
Quote:
enp9s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.178.21 netmask 255.255.255.0 broadcast 192.168.178.255
inet6 fe80::a9e:1ff:fe2d:913f prefixlen 64 scopeid 0x20<link>
ether 08:9e:01:2d:91:3f txqueuelen 1000 (Ethernet)
RX packets 18177 bytes 18303017 (17.4 MiB)
RX errors 0 dropped 3 overruns 0 frame 0
TX packets 15918 bytes 2563519 (2.4 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 0 (Lokale Schleife)
RX packets 52 bytes 3584 (3.5 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 52 bytes 3584 (3.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlp3s0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 60:36:dd:65:5a:72 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Wobei ich denke dass es sich bei wlp3s0 um das Wireless device handelt. Jedoch wenn ich iwconfig ausführe sehe ich folgendes:
Quote:
wlp3s0 no wireless extensions.

lo no wireless extensions.

enp9s0 no wireless extensions.

sit0 no wireless extensions.

Um meine Drathlosen Netzwerke zu verwalten verwende ich wicd.
Das kabelgebundene Netzwerk funktionert.


2.) Ich habe als Desktop-Umgebung KDE (kdebase-meta) installiert, wenn ich jedoch eine externe Festplatte (USB) an das Notebook anschließe wird sie nicht automatisch gemountet und ich kann sie auch nicht unter /dev/sd* sehen. Wenn ich jedoch eine Maus über USB anstecke wird sie erkannt.
Könnte es sein das hier noch ein Treiber fehlt oder muss KDE neuerdings mit einer spzeiellen EInstellung kompiliert werden?

3.) Das Notebook hat neben der Intel HD4000 Grafik noch eine Nvidia Gforce 620M Grafikkarte. Diese wollte ich eingentlich auch verwenden, doch nach der Installation des Basissystems und der Installation des X-Servers mit gesetzem "VIDEO_CARDS=NVIDIA" konnte der X-Server nicht starten.
Ich habe xorg.conf mit X -configure erstellen lassen.


HIer noch meine Config-Dateien:
make.conf
Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=corei7 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="kde -gnome qt4 gtk bluetooth bash-completion alsa aac acpi ctype cups dbus ffmpeg icu imap smtp jpeg mime mp3 mp4 mplayer oscar pdf semantic-desktop syslog latex notebook laptop thinkpad lightning xinerama nls spell udev unicode wifi xscreensaver vim-syntax sound usb threads consolekit dbus polkit udisks bindist mmx sse sse2 sse3 sqlite"

KEYWORDS_ACCEPT="amd64"
ACCEPT_LICENSE="*"
LINGUAS="de"
VIDEO_CARDS="intel"
ALSA_CARDS="snd_hda_intel"
INPUT_DEVICES="evdev synaptics"
MAKEOPTS="-j5"
AUTOCLEAN="yes"


lspic
Code:
00:00.0 Host bridge: Intel Corporation 3rd Gen Core processor DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation UM77 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M / GT 620M/625M/630M] (rev a1)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
04:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
04:00.1 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 07)


uname -a:
Code:

Linux think-schnecki 3.7.10-gentoo #8 SMP Tue Apr 9 20:44:55 CEST 2013 x86_64 Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz GenuineIntel GNU/Linux


Vielen Dank für eure HIlfe.

Sagt bescheid, wenn Ihr noch weitere Infos braucht.

Grüße

Fabi
_________________
...under construction!
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 237

PostPosted: Wed Apr 10, 2013 2:53 am    Post subject: Reply with quote

Du notig treiber fur:
Code:

03:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1009
Location: Schweiz

PostPosted: Wed Apr 10, 2013 10:01 am    Post subject: Reply with quote

Das mit der zweiten Grafikkarte wird wahrscheinlich nicht funktionieren da die meisten muxless sind und damit kann der Linux Kernel nicht wirklich was anfangen.
http://www.tonymacx86.com/attachments/hp-probook-4530s/14488d1342992672-radeon-6470m-6490m-project-muxed-muxless.png
Muxless ist wohl auch nicht dazu gedacht die ganze Anzeige über die zweite Grafikkarte laufen zu lassen sondern nur wenige ausgewählte Programme.

EDIT:
Es gibt allerdings eine Möglichkeit die zweite Grafikkarte genau so zu verwenden wie das bei einer muxless gedacht ist jedoch nur über einen extremen Mehraufwand:
http://forums.gentoo.org/viewtopic-t-934992.html
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
ibaF
n00b
n00b


Joined: 12 May 2010
Posts: 36

PostPosted: Wed Apr 10, 2013 3:42 pm    Post subject: Reply with quote

@all: Ersteinmal vielen Dank für Eure Hilfe.

Also mein W-Lan läuft jetzt ich hatte im Kernel tatsächlich den falschen Treiber ausgewählt.

Das Thema mit der Grafikkarte ist auch nicht weiter tragisch.
Was allerdings immer noch offen ist, ist das Thema mit dem Automounten der Festplatten.

Ich war jetzt eine weile weg von Gentoo und habe fürher immer KDE verwendet und damals gab es noch HAL (ist jetzt ca. zwei Jahre her).
Es scheint so als gäbe es HAL nicht mehr, oder?

Was mich ein bisschen stuzig macht ist die Tatsache, dass wenn ich folgendes ausführe:
Quote:

think-schnecki fabi # ls -l /dev/ | grep sd
brw-rw---- 1 root disk 8, 0 10. Apr 2013 sda
brw-rw---- 1 root disk 8, 1 10. Apr 17:37 sda1
brw-rw---- 1 root disk 8, 2 10. Apr 2013 sda2
brw-rw---- 1 root disk 8, 3 10. Apr 17:37 sda3
brw-rw---- 1 root disk 8, 4 10. Apr 17:37 sda4


Ich nur meine primäre Festplatte (SSD) sehe aber keinen USB-Stick oder eine USB Festplatte.
Diese sollte ich ja normalerweise sehen, damit ich sie wenigstens von Hand mounten kann.

Jemand ne Idee?

Grüße
Fabi
_________________
...under construction!
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1009
Location: Schweiz

PostPosted: Wed Apr 10, 2013 4:10 pm    Post subject: Reply with quote

HAL ist erledigt und wird so weit ich weis nur noch von den BSD'lern am leben gehalten, heute wird das mit udev und udisks gemacht.
udisks hat aber ein paar Abhängigkeiten die einigen ziemlich sauer aufstoßen (sogenannte poterware) und das nicht ganz ungerechtfertigt. Um das zu benutzen wird unter anderem polkit und consolekit (oder der nachfolger aus systemd) benötigt was als Unterwanderung des UNIX Rechtesystem angesehen werden kann.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)


Last edited by schmidicom on Wed Apr 10, 2013 5:29 pm; edited 2 times in total
Back to top
View user's profile Send private message
ibaF
n00b
n00b


Joined: 12 May 2010
Posts: 36

PostPosted: Wed Apr 10, 2013 4:20 pm    Post subject: Reply with quote

Ok, vielen Dank für die Info.

Aber wie bekomm ich jetzt den automount zum laufen?
Im Wiki hab ich dazu nichts gefunden.

Gibt es da evtl eine Anleitung dazu?

Grüße

Fabi
_________________
...under construction!
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1009
Location: Schweiz

PostPosted: Wed Apr 10, 2013 5:25 pm    Post subject: Reply with quote

Auf dem offiziellem Wiki von Gentoo gibt es einen Artikel dazu:
http://wiki.gentoo.org/wiki/Udisks
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
ibaF
n00b
n00b


Joined: 12 May 2010
Posts: 36

PostPosted: Wed Apr 10, 2013 6:10 pm    Post subject: Reply with quote

Ich habe die entsprechenden USE-Flags eingestellt und baue jetzt das gesamte System neu.
Ich hoffe mal das hilft dann.

Bin aber trotzdem für jeden weiteren Input dankbar.

Grüße

Fabi
_________________
...under construction!
Back to top
View user's profile Send private message
ibaF
n00b
n00b


Joined: 12 May 2010
Posts: 36

PostPosted: Thu Apr 11, 2013 6:47 pm    Post subject: Reply with quote

@schmidicom: Ich bin jetzt nach der Wikipage vorgegangen und habe mein System nochmal komplett neu gebaut.
Leider hat das auch nichts genutzt.
Hast du vielleicht noch nen Tipp?

Grüße

Fabi
_________________
...under construction!
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1009
Location: Schweiz

PostPosted: Thu Apr 11, 2013 7:05 pm    Post subject: Reply with quote

Ich habe mal nachgesehen welcher Treiber bei mir geladen wird wenn ich einen USB-Stick einstecke:
Code:
Device Drivers
> USB support
>> USB Mass Storage support

Wenn es das nicht ist wüsste ich jetzt auch nicht mehr weiter.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2281
Location: Germany

PostPosted: Thu Apr 11, 2013 7:19 pm    Post subject: Reply with quote

Hm, ich denke es ist keine gute Idee mehre Themen in ein Thread zu packen - das gibt doch meist nur ein heilloses durcheinander.

Bezüglich externe USB-Platten nutze zb auch den Gentoo Linux USB Guide
Wenn dann im dmesg die Platte mit ihren Laufwerken aufgelistet wird, und manuelles mounten funktioniert, dann sollte es auch mit udisks und KDE klappen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum