Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[udev] ¿Que pasa con udev? (SOLUCIONADO)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 717

PostPosted: Sat Apr 06, 2013 11:57 pm    Post subject: [udev] ¿Que pasa con udev? (SOLUCIONADO) Reply with quote

Hola a todos.

Hoy al intentar realizar un emerge de vlc, me ha aparecio este error:


Code:

virtual/udev:0

  (virtual/udev-171::gentoo, installed) pulled in by
    <virtual/udev-196 required by (sys-fs/lvm2-2.02.88::gentoo, installed)
    ~virtual/udev-171 required by (net-wireless/bluez-4.99::gentoo, installed)

  (virtual/udev-197-r1::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/udev-197-r1 required by (sys-fs/udev-198-r1::gentoo, ebuild scheduled for merge)
    >=virtual/udev-197-r1 required by (sys-apps/hwids-20130309-r1::gentoo, ebuild scheduled for merge)
    (and 17 more with the same problems)

sys-fs/udev:0

  (sys-fs/udev-171-r9::gentoo, installed) pulled in by
    ~sys-fs/udev-171[gudev?,hwdb?,introspection?,keymap?,selinux?] required by (virtual/udev-171::gentoo, installed)

  (sys-fs/udev-198-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?] required by (virtual/udev-197-r1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The following installed packages are masked:
- sys-fs/lvm2-2.02.88::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (07 Mar 2013)
# Remove redudant version of udev now that 197-r8 will
# work down to Linux 2.6.32.60 on most arches.
# Removal in 90 days.



Lo que yo entiendo es que la version que tengo instalada de udev se a enmascarado (segun el comunicado de Samuli Suominen) y que al parecer, dice que tengo que actualizar a udev-197-r8.

¿Esto es asi exactamente?

¿Como puedo solucionar este bloqueo, sin tener que actualizar udev?
Para un futuro... ¿Tendré que actualizar udev a la fuerza? ¿es recomendable?


Muchas gracias.
Saludos.
_________________
--
http://www.monovarlinux.org
Pagina web del proyecto AutoLinux (Autodetección e instalación de drivers para linux) y tutoriales
En Mantenimiento...


Last edited by ZaPa on Mon Apr 22, 2013 11:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1545

PostPosted: Sun Apr 07, 2013 9:26 am    Post subject: Reply with quote

Si por un casual te decides a actualizar a pelo y desinstalando cosas aunque por otra parte hacer esto último te será obligatorio (no lo afirmo rutundamente, pero...) ejecuta << quickpkg --include-config udev >> y luego procede a desenmascarar a desinstalar y/o actualizar segun te vaya pidiendo, en caso de que algo salga mal si no has ido demasiado lejos podrás reinstalar el antiguo udev con <<emerge -G udev >>.
De la forma que te describo arriba es como he actualizado a udev-200, un consejo más al ejecutar rc-update procura guardar con otro nombre los archivos de configuracion que vayas a sustituir ejem. archivo.conf.movido por si las moscas pues posiblemente te actualice << baselayout >>.
Suerte.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Sun Apr 07, 2013 6:10 pm    Post subject: Reply with quote

No exactamente.
Lo que dice es que el emerge que has pedido produce un par de conflictos (paquetes sys-fs/udev y virtual/udev).
En el caso de virtual/udev, la actualización que has pedido instalaría virtual/udev-197-r1 pero tienes un par de paquetes instalados (lvm2 y bluez) que requieren la versión de virtual/udev que tienes instalada.
El conflicto de sys-fs/udev es consecuencia de este y se resolverá a la vez.

La parte final lo que dice es que aparte de los paquetes implicados en la actualización quedará en el sistema un paquete enmascarado (lvm2-2.02.88).
El comentario de Samuli es una explicación al por qué de ese enmascaramiento.

Para solucionar el bloqueo sin actualizar udev tendrías que poner el comando emerge y la salida completa pero dudo mucho que se pueda evitar. Si te empeñas mucho podrías eliminar la USE="udev" de vlc y quizá funcionara pero no se si querrás un vlc sin udev.

Siendo prácticos no se puede estar con un paquete enmascarado cuando es tan básico como udev. Tendrás que actualizarlo.

Lo único que tiene de especial actualizar a la versión 197 (y a la 200) es el tema del renombrado (opcional) de las interfaces de red. Mira los eselect news para mas información.
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 717

PostPosted: Mon Apr 08, 2013 10:55 am    Post subject: Reply with quote

mmmm y ahora.... la pregunta final...


¿Alguien a actualizado al último udev sin problemas?


Un saludo.
_________________
--
http://www.monovarlinux.org
Pagina web del proyecto AutoLinux (Autodetección e instalación de drivers para linux) y tutoriales
En Mantenimiento...
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1545

PostPosted: Mon Apr 08, 2013 11:01 am    Post subject: Reply with quote

Quote:
¿Alguien a actualizado al último udev sin problemas?

No he tenido problemas en un desktop pero estoy teniendo problemas con el portatil.
Es largo de contar pero creo que lo solucionaré, ya no tengo mas remedio.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
edgar_uriel84
Guru
Guru


Joined: 21 Dec 2008
Posts: 458
Location: Tultitlan, México

PostPosted: Mon Apr 08, 2013 11:12 am    Post subject: Reply with quote

ZaPa wrote:
mmmm y ahora.... la pregunta final...


¿Alguien a actualizado al último udev sin problemas?


Un saludo.


Seguí las instrucciones que hay en eselect news y no tuve problema alguno, ahora hay una entrada en el wiki oficial donde lo ponen todavía más claro. http://wiki.gentoo.org/wiki/Udev/upgrade
_________________
Algún día habrá una persona mejor que yo, pero esa persona no eres tú ni ese momento es ahora.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Mon Apr 08, 2013 11:25 am    Post subject: Reply with quote

@ZaPa

Ahora estoy con la 200.

En la actualización a la 197 si tuve problemas. No arrancaba por no tener configurado el kernel con DEVTMPFS, En la actualización a 200 también los he tenido porque he definido mi propio esquema de nombrar las interfaces de red.

Es muy recomendable tener algún sistema alternativo (livecd por ejemplo) para conectarse a internet y para montar la partición raiz y la /boot en su caso y modificar lo que sea necesario.
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 717

PostPosted: Mon Apr 08, 2013 10:04 pm    Post subject: Reply with quote

Hola de nuevo.

Bueno, he estado revisando el texto en eselect y de la wiki oficial y he realizado todo lo que indica. Pero a la hora de intentar instalar udev:




Code:
# emerge sys-fs/udev
Calculating dependencies... done!
[ebuild     U  ] app-arch/xz-utils-5.0.4-r1 [5.0.4]
[ebuild  N     ] sys-apps/kmod-12-r1  USE="lzma tools zlib -debug -doc -static-libs"
[uninstall     ] sys-apps/module-init-tools-3.16-r2
[blocks b      ] sys-apps/module-init-tools ("sys-apps/module-init-tools" is blocking sys-apps/kmod-12-r1)
[blocks b      ] sys-apps/kmod ("sys-apps/kmod" is blocking sys-apps/module-init-tools-3.16-r2)
[ebuild     U ~] sys-fs/udev-198-r1 [171-r9] USE="acl%* kmod%* openrc%* -doc% -static-libs%"
[ebuild     U  ] virtual/udev-197-r1 [171] USE="kmod%*"
[ebuild     U ~] sys-apps/hwids-20130309-r1 [20121119] USE="udev%*"
[ebuild  N     ] sys-fs/udev-init-scripts-23
[blocks B      ] <sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-23)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

virtual/udev:0

  (virtual/udev-171::gentoo, installed) pulled in by
    ~virtual/udev-171 required by (net-wireless/bluez-4.99::gentoo, installed)

  (virtual/udev-197-r1::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/udev-197-r1 required by (sys-fs/udev-198-r1::gentoo, ebuild scheduled for merge)
    >=virtual/udev-197-r1 required by (sys-apps/hwids-20130309-r1::gentoo, ebuild scheduled for merge)
    (and 17 more with the same problems)

sys-fs/udev:0

  (sys-fs/udev-171-r9::gentoo, installed) pulled in by
    ~sys-fs/udev-171[gudev?,hwdb?,introspection?,keymap?,selinux?] required by (virtual/udev-171::gentoo, installed)

  (sys-fs/udev-198-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-fs/udev-197-r8[gudev?,hwdb?,introspection?,keymap?,kmod?,selinux?,static-libs?] required by (virtual/udev-197-r1::gentoo, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



De verdad que me llevo mal con los bloqueos y portage. ¿Como soluciono esto entonces?


Otra cosa es que, solo me aparece para actualizar HASTA la version 197 de udev, no la 200...


emerge -s udev


Code:


*  sys-fs/udev
      Latest version available: 198-r1
      Latest version installed: 171-r9
      Size of files: 2,091 kB
      Homepage:      http://www.freedesktop.org/wiki/Software/systemd
      Description:   Linux dynamic and persistent device naming support (aka userspace devfs)
      License:       LGPL-2.1 MIT GPL-2


*  virtual/udev
      Latest version available: 197-r1
      Latest version installed: 171
      Size of files: 0 kB
      Homepage:     
      Description:   Virtual to select between sys-fs/udev and sys-fs/eudev


Tampoco entiendo muy bien que es y para que es el paquete virtual/udev..


Espero me puedan ayudar.
Un saludo.
_________________
--
http://www.monovarlinux.org
Pagina web del proyecto AutoLinux (Autodetección e instalación de drivers para linux) y tutoriales
En Mantenimiento...
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Mon Apr 08, 2013 11:07 pm    Post subject: Reply with quote

Para que aparezca la 200 haz emerge --sync
Para eliminar el bloqueo mete a bluez en la actualización:
Code:
emerge --oneshot sys-fs/udev bluez
Back to top
View user's profile Send private message
deovex
n00b
n00b


Joined: 27 Jun 2007
Posts: 74
Location: Buenos Aires, Argentina.

PostPosted: Tue Apr 09, 2013 12:45 am    Post subject: Reply with quote

Actualice a la ultima versión de udev-200 y no tuve problemas.
Pregunta, probaste revdep-rebuild antes de instalar udev?
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 717

PostPosted: Tue Apr 09, 2013 10:45 am    Post subject: Reply with quote

Hola.

Minutos despues de la publicación de mi mensaje lo solucione sin problemas. Estaba claro que tenia que hacer un emerge --sync, hacia tiempo que no lo realizaba por eso no me aparecia la 200 de udev.

Ya estoy terminando el ultimo proceso (revdep-rebuild) de mi actualización, cuando lo termine, publicaré a modo de pequeño HOWTO como lo he conseguido.

Un saludo.
_________________
--
http://www.monovarlinux.org
Pagina web del proyecto AutoLinux (Autodetección e instalación de drivers para linux) y tutoriales
En Mantenimiento...
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3748

PostPosted: Tue Apr 09, 2013 10:55 am    Post subject: Reply with quote

lo primero que creo que tienes que arreglar es esto :

Quote:
<sys-fs/udev-186 ("<sys-fs/udev-186" is blocking sys-fs/udev-init-scripts-23)


es decir, esa versión de udev-init-scripts no es compatible con versiones inferiores a la 186, desinstala udev-init-scripts y acto seguido ejecuta de nuevo emerge -av1 udev.
Dicho esto, no reinicies o apagues la máquina hasta que tengas alguna versión de udev-init-scripts instalada.

Quote:
solo me aparece para actualizar HASTA la version 197 de udev, no la 200...


partiendo de la base de que tengas el árbol sincronizado, que te dice emerge -av1 =udev-200 ?

Quote:
para que es el paquete virtual/udev


simplemente porque existe tb. eudev, que es un fork de udev ( y no sé si habrá alguno mas pululando por ahí). Uno de los motivos por los que existen los virtuals es para tener control sobre paquetes que instalan binarios con el mismo nombre o paquetes que instalan las mismas funcionalidades o están concebidas con el mismo objetivo. Quiero decir, si tienes udev instalado virtual/udev te dará un block cuando intentes instalar eudev, porque ambos básicamente sirven para lo mismo y ambos no pueden coexistir por el motivo que sea.

Por lo demás, yo sigo con la versión 198. Versiones superiores tardan muchísimo en cargar el firmware de mi wifi en el portátil que uso a diario.
Con o sin la USE firmware-loader y tener un kernel 3.9-rc5 aparentemente no sirvió de nada.

saluetes
Back to top
View user's profile Send private message
ZaPa
l33t
l33t


Joined: 13 Feb 2007
Posts: 717

PostPosted: Mon Apr 22, 2013 11:31 pm    Post subject: Reply with quote

Bueno, perdonar por el retraso, pero ya lo solucioné.

Para solucionarlo seguí los pasos de http://wiki.gentoo.org/wiki/Udev/upgrade .

Edito el POST y lo dejo como deberia estar, en SOLUCIONADO.
_________________
--
http://www.monovarlinux.org
Pagina web del proyecto AutoLinux (Autodetección e instalación de drivers para linux) y tutoriales
En Mantenimiento...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum