Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Help for Bug #464876 "dev-libs/icu-51.1 wrong subslot"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
jarealist
Apprentice
Apprentice


Joined: 07 Oct 2002
Posts: 227

PostPosted: Sat Apr 06, 2013 9:14 pm    Post subject: Help for Bug #464876 "dev-libs/icu-51.1 wrong subslot& Reply with quote

I got caught on this before it was fixed. Can not run emerge --sync. or emerge any pkg.
Back to top
View user's profile Send private message
jarealist
Apprentice
Apprentice


Joined: 07 Oct 2002
Posts: 227

PostPosted: Sat Apr 06, 2013 9:40 pm    Post subject: Reply with quote

Okay. Worked around it by renaming:

/usr/lib/libicui18n.so.51 >>> /usr/lib/libicui18n.so.50

and

/usr/lib/libicuuc.so.51 >>> /usr/lib/libicuuc.so.50
Back to top
View user's profile Send private message
megabaks
Apprentice
Apprentice


Joined: 22 Jan 2012
Posts: 253
Location: Russia && Saint-Petersburg

PostPosted: Sat Apr 06, 2013 10:03 pm    Post subject: Reply with quote

wrong way!
downgrade icu to 50
upgrade up to 51
_________________
sorry my bad english
Back to top
View user's profile Send private message
jarealist
Apprentice
Apprentice


Joined: 07 Oct 2002
Posts: 227

PostPosted: Sat Apr 06, 2013 11:44 pm    Post subject: Reply with quote

Reply to megabaks:

You can't downgrade when dev-db/sqlite was compiled with "icu" use flag.
Back to top
View user's profile Send private message
megabaks
Apprentice
Apprentice


Joined: 22 Jan 2012
Posts: 253
Location: Russia && Saint-Petersburg

PostPosted: Sat Apr 06, 2013 11:56 pm    Post subject: Reply with quote

jarealist wrote:
Reply to megabaks:

You can't downgrade when dev-db/sqlite was compiled with "icu" use flag.
WUT? o_O
_________________
sorry my bad english
Back to top
View user's profile Send private message
donmartio
Apprentice
Apprentice


Joined: 11 Dec 2004
Posts: 179

PostPosted: Mon Apr 08, 2013 9:48 pm    Post subject: Reply with quote

Hoho,

downgrade does not work (as mentioned before).
unmerge and remerge does work but has no effect.

For now i did an

ln -s /usr/lib/libicuuc.so.51 /usr/lib/libicuuc.so.50

and i can use my system again. This is a hack and no solution.

I tried to recompile everything that equery tells me depends on dev-lib/icu but that doesn't work.
Any other suggestions?

Greetings
DonMartio
_________________
Always code as if the person who ends up maintaining your code will be a violent psychopath who knows where you live.
Back to top
View user's profile Send private message
megabaks
Apprentice
Apprentice


Joined: 22 Jan 2012
Posts: 253
Location: Russia && Saint-Petersburg

PostPosted: Mon Apr 08, 2013 11:02 pm    Post subject: Reply with quote

donmartio wrote:
Hoho,

downgrade does not work (as mentioned before).
unmerge and remerge does work but has no effect.

For now i did an

ln -s /usr/lib/libicuuc.so.51 /usr/lib/libicuuc.so.50

and i can use my system again. This is a hack and no solution.

I tried to recompile everything that equery tells me depends on dev-lib/icu but that doesn't work.
Any other suggestions?

Greetings
DonMartio
lol - man emerge, man
_________________
sorry my bad english
Back to top
View user's profile Send private message
Shamus397
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 155
Location: Ur-th

PostPosted: Sun Apr 14, 2013 12:39 am    Post subject: Reply with quote

Like the others said, you can't downgrade icu, as portage will complain:
Code:
# emerge -av1 =icu-50.1.2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] dev-libs/icu-50.1.2:0/50.1 [51.1:0/51.1] USE="-debug -doc -examples -static-libs" 0 kB

Total: 1 package (1 downgrade), Size of downloads: 0 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/icu:0

  (dev-libs/icu-51.1::gentoo, installed) pulled in by
    dev-libs/icu:0/51.1= required by (media-libs/harfbuzz-0.9.12::gentoo, installed)
    dev-libs/icu:0/51.1= required by (sys-apps/gptfdisk-0.8.6::gentoo, installed)
    >=dev-libs/icu-49:0/51.1= required by (dev-qt/qtcore-4.8.4-r5::gentoo, installed)
    dev-libs/icu:0/51.1= required by (dev-libs/libxml2-2.9.0-r2::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/raptor-2.0.9::gentoo, installed)
    dev-libs/icu:0/51.1= required by (dev-db/sqlite-3.7.16.1::gentoo, installed)
    dev-libs/icu:0/51.1= required by (app-text/libmspub-0.0.5::gentoo, installed)
    dev-libs/icu:0/51.1= required by (media-libs/libcdr-0.0.12::gentoo, installed)
    (and 1 more with the same problems)

  (dev-libs/icu-50.1.2::gentoo, ebuild scheduled for merge) pulled in by
    =icu-50.1.2

and there's something seriously borked that reemerging packages doesn't fix, like ksmserver:
Code:
# ldd /usr/bin/ksmserver | grep libicuuc
        libicuuc.so.50 => not found
        libicuuc.so.51 => /usr/lib/libicuuc.so.51 (0xb20b1000)

I rebuilt that package and it still linked against a nonexistant libicuuc.so.50. 8O I'm at a complete loss as to how to fix this, other than by symlinking the way the others have done--which is a really, really crappy solution. :(
Back to top
View user's profile Send private message
megabaks
Apprentice
Apprentice


Joined: 22 Jan 2012
Posts: 253
Location: Russia && Saint-Petersburg

PostPosted: Sun Apr 14, 2013 1:39 am    Post subject: Reply with quote

man emerge
again!!1
_________________
sorry my bad english
Back to top
View user's profile Send private message
donmartio
Apprentice
Apprentice


Joined: 11 Dec 2004
Posts: 179

PostPosted: Sun Apr 14, 2013 10:49 am    Post subject: Reply with quote

This is what enlightened me
http://www.gossamer-threads.com/lists/gentoo/dev/267904

That's what i did

emerge --unmerge icu
emerge =dev-libs/icu-50.1-r2
emerge -u dev-libs/icu

Than i look for packages
equery depends dev-libs/icu

and recompile just a few of them
emerge dev-db/ArangoDB dev-db/sqlite dev-libs/boost =dev-libs/libxml2-2.9.0-r2 dev-qt/qtcore dev-qt/qtwebkit

Hope that helps
DonMartio
_________________
Always code as if the person who ends up maintaining your code will be a violent psychopath who knows where you live.
Back to top
View user's profile Send private message
Shamus397
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 155
Location: Ur-th

PostPosted: Mon Apr 15, 2013 3:19 am    Post subject: Reply with quote

Saying RTFM is not helpful *at all*. I know how to use portage, and I know how to uninstall/reinstall packages. Doing that *does not solve the problem*.

These are the steps I followed:

1. Uninstall icu (emerge -C icu).
2. Install the previous version of icu (emerge =dev-libs/icu-50.1-r2).
3. Upgrade to the latest version of icu (emerge icu).
4. Reemerge something that relies on libicu (emerge ksmserver).

Nothing changed as a result of doing these actions:
Code:
# ldd `which ksmserver` | grep libicuuc
        libicuuc.so.50 => not found
        libicuuc.so.51 => /usr/lib/libicuuc.so.51 (0xb20b5000)

It's *still* linking in a nonexistant library. Telling me to RTFM IS NOT HELPFUL.
Back to top
View user's profile Send private message
NuMPTy
Tux's lil' helper
Tux's lil' helper


Joined: 04 Mar 2012
Posts: 75

PostPosted: Mon Apr 15, 2013 7:17 pm    Post subject: Reply with quote

Same problem everyone else is having...just here for the ride
_________________
ACCEPT_KEYWORDS="~amd64"


Last edited by NuMPTy on Mon Apr 15, 2013 7:24 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2364
Location: UK

PostPosted: Mon Apr 15, 2013 7:21 pm    Post subject: Reply with quote

Note for paludis users, the -D flag is a big help in cases like this: "cave resolve icu -D icu" will reinstall ICU and everything dependent on it.
Back to top
View user's profile Send private message
donmartio
Apprentice
Apprentice


Joined: 11 Dec 2004
Posts: 179

PostPosted: Thu Apr 18, 2013 5:32 pm    Post subject: Reply with quote

Ho Shamus397,

as far as i could see ksmserver does not depend directly on icu. But it depends on
qtcore and qtwebkit which depends on icu.

Did you try the line i posted (without ArangoDB of course). This line is exactly what i did
after the icu stuff and it worked for me.

May you try
emerge dev-qt/qtcore dev-qt/qtwebkit
?

Hope this helps
DonMartio
_________________
Always code as if the person who ends up maintaining your code will be a violent psychopath who knows where you live.
Back to top
View user's profile Send private message
donmartio
Apprentice
Apprentice


Joined: 11 Dec 2004
Posts: 179

PostPosted: Thu Apr 18, 2013 5:33 pm    Post subject: Reply with quote

may you check

equery depgraph --depth=1 kde-base/ksmserver
and
equery depends dev-libs/icu

on your machine?
_________________
Always code as if the person who ends up maintaining your code will be a violent psychopath who knows where you live.
Back to top
View user's profile Send private message
Shamus397
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 155
Location: Ur-th

PostPosted: Tue Apr 23, 2013 1:54 pm    Post subject: Reply with quote

@donmartio: Thank you, that worked. :) Who knew that there was no direct dependency between ksmserver and libicu?

For the record. I re-emerged the packages reported by:
Code:
equery depends dev-libs/icu

after downgrading then upgrading libicu.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum