Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Evdev is not working after profile change
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
taho
n00b
n00b


Joined: 26 Aug 2011
Posts: 9

PostPosted: Sun Mar 31, 2013 5:04 pm    Post subject: Evdev is not working after profile change Reply with quote

Hello

I have updated portage and world. After updating it asked to relink profile. Next reboot showed me the keyboard and mouse don't work in the X environment more. Reemerging xf86-input-evdev didn't help me. I have investigated /var/log/Xorg.0.log and didn't find any mentions to evdev or Input devices. Only adding to INPUT_DEVICES keyboard and mouse with disabling "AutoAddDevices" in xorg.conf resolved problem. Please help me to return working evdev.

My configuration:
Code:

taho-dsk ~ # cat /etc/X11/xorg.conf | sed -e '/^\s*#/d;/^\s*$/d'
Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          0 "Screen0" 0 0
EndSection
Section "ServerFlags"
        Option          "AutoAddDevices" "Off"
        Option          "AIGLX" "On"
        Option          "AllowEmptyInput" "True"
EndSection
Section "Files"
        ModulePath      "/usr/lib64/xorg/modules"
        FontPath        "/usr/share/fonts/corefonts/"
        FontPath        "/usr/share/fonts/cyrillic/"
        FontPath        "/usr/share/fonts/default/"
        FontPath        "/usr/share/fonts/dejavu/"
        FontPath        "/usr/share/fonts/intlfonts/"
        FontPath        "/usr/share/fonts/lyx/"
        FontPath        "/usr/share/fonts/misc/"
        FontPath        "/usr/share/fonts/OTF/"
        FontPath        "/usr/share/fonts/Speedo/"
        FontPath        "/usr/share/fonts/terminus/"
        FontPath        "/usr/share/fonts/TTF/"
        FontPath        "/usr/share/fonts/Type1/"
        FontPath        "/usr/share/fonts/urw-fonts/"
        FontPath        "/usr/share/fonts/util/"
        FontPath        "/usr/share/fonts/100dpi/"
        FontPath        "/usr/share/fonts/75dpi/"
EndSection
Section "Module"
        Load  "synaptics"
EndSection
Section "Device"
        Identifier      "Card0"
        Driver          "radeon"
        BusID           "PCI:1:0:0"
        Option          "AccelMethod" "EXA"
        Option          "DRI" "true"
        Option          "VideoOverlay" "True"
        Option          "EnablePageFlip" "True"
        Option          "DDCMode" "True"
        Screen          0
EndSection
Section "Monitor"
        Identifier      "laptop"
        VendorName      "AUO"
        ModelName       "163c"
        Option          "DPMS"
EndSection
Section "Monitor"
        Identifier      "vga"
        VendorName      "LG"
        ModelName       "Flatron W1943se"
        Modeline        "1360x768_50.00"  69.92  1368 1424 1568 1768  768 769 772 791  -HSync +Vsync
EndSection
Section "Screen"
        Identifier              "Screen0"
        Device                  "Card0"
        DefaultDepth            24
        Monitor                 "vga"
        SubSection "Display"
                Depth           24
                Virtual         2726 768
        EndSubSection
EndSection
Section "DRI"
        Mode    0666
EndSection
Section "Extensions"     
        Option  "Composite" "On"
EndSection

Code:

taho-dsk ~ # cat /etc/make.conf
CFLAGS="-march=amdfam10 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
CHOST="x86_64-pc-linux-gnu"
MAKEOPTS="-j2"
#SYNC="rsync://rsync1.ru.gentoo.org/gentoo-portage"
#SYNC="rsync://taho/gentoo-portage"
GENTOO_MIRRORS="ftp://mirror2.corbina.ru/gentoo-distfiles/"

USE="mmx sse sse2 bash-completion jpeg jpeg2k png tiff djvu acpi alsa usb \
     pdf 3dnow xinerama nsplugin caps gstreamer nfsv4 -ipv6 \
     -avahi bluetooth -kerberos ldap -startup-notification -vdpau \
     -bindist threads -kde -cdda"
LINGUAS="ru ru_RU"
VIDEO_CARDS="radeon"
ALSA_CARDS="hda-intel"
INPUT_DEVICES="evdev synaptics keyboard mouse"
ACCEPT_LICENSE="PUEL skype-4.0.0.7-copyright dlj-1.1 Q3AEULA AdobeFlash-11.x Oracle-BCLA-JavaSE"
DISTDIR=/home/distfiles


PS: sorry for my English
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Thu Apr 04, 2013 8:36 pm    Post subject: Reply with quote

Code:
rm -v /etc/X11/xorg.conf


See if X Starts without it, and if not use
Gentoo ATI FAQ
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
taho
n00b
n00b


Joined: 26 Aug 2011
Posts: 9

PostPosted: Tue Apr 09, 2013 7:08 am    Post subject: Reply with quote

Ok, i'll try today. Thank you.
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1492

PostPosted: Tue Apr 09, 2013 7:21 am    Post subject: Reply with quote

I wouldn't do that!

Removing config files is always a risky move and is better avoided. What you need to do is disable the config file so you can restore it if needed. I would suggest that you use mv to move the config file to your home directory or other location. It will have the same effect but it will not destroy the data. Form your home directory (or wherever you want to put it), do
Code:
mv /etc/X11/xorg.conf .
That will copy the config file to a new location and delete the original. Backups are good.
_________________
First things first, but not necessarily in that order.
Back to top
View user's profile Send private message
taho
n00b
n00b


Joined: 26 Aug 2011
Posts: 9

PostPosted: Thu Apr 11, 2013 8:58 pm    Post subject: Reply with quote

I have moved xorg configurations files to safe place. Without success. I put to .xinitrc only one string -
xterm -geometry +0-100
and after startx a got hanged up xterm console (I mean I can't move mouse or type any key)
Ready to reemerge all @world on my notebook. I don't know how to investigate evdev interaction with Xorg without any mentions in logs.
Kernel evdev works fine. Input devices have been created without problems.
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 246

PostPosted: Thu Apr 11, 2013 10:09 pm    Post subject: Reply with quote

taho, do you use kms driver? It works if you access tty[0-6] with ctrl+alt+F[1-6] ?

p.s. that another question.
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4339

PostPosted: Thu Apr 11, 2013 10:13 pm    Post subject: Reply with quote

taho wrote:
I don't know how to investigate evdev interaction with Xorg without any mentions in logs.

Imagine how hard it will be for us then without even those logs... Because xorg.conf is useless, as your configuration for evdev should be in xorg.conf.d
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum