Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cairo Dock crashes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
treeman1111
n00b
n00b


Joined: 06 Mar 2013
Posts: 69

PostPosted: Sun Mar 31, 2013 1:39 pm    Post subject: Cairo Dock crashes Reply with quote

After installing cairo from the Sunrise overlay, I ran Cairo-Dock from the terminal, this is what I got. I am using the fglrx radeon drivers to provide my graphics. Am I missing some program?
Code:

Feel free to report this bug on glx-dock.org to help improving the dock!
info on the system :
cairo_dock_create_surface_from_image_simple: assertion `cImageFile != NULL' failed
Linux Edison 3.7.10-gentoo #1 SMP Sat Mar 30 13:42:45 EDT 2013 x86_64 AMD FX(tm)-8150 Eight-Core Processor AuthenticAMD GNU/Linux
Couldn't guess if it was an applet's fault or not. It may have crashed inside the core or inside a thread
restarting with 'cairo-dock -m -q 3'...
warning :  (/var/tmp/portage/x11-misc/cairo-dock-3.1.2.1-r300/work/cairo-dock-3.1.2/src/gldit/cairo-dock-opengl.c:cairo_dock_initialize_opengl_backend:208) 
  couldn't find an appropriate visual, trying to get one without Stencil buffer
(it may cause some little deterioration in the rendering) ...

 ============================================================================
   Cairo-Dock version : 3.1.2
   Compiled date      : Mar 30 2013 23:32:22
   Built with GTK     : 3.4
   Running with OpenGL: 1
 ============================================================================

warning :  (/var/tmp/portage/x11-misc/cairo-dock-3.1.2.1-r300/work/cairo-dock-3.1.2/src/cairo-dock.c:main:705) 
  showing the maintenance mode ...
warning :  (/var/tmp/portage/x11-misc/cairo-dock-3.1.2.1-r300/work/cairo-dock-3.1.2/src/cairo-dock.c:main:707) 
  end of the maintenance mode.
cairo_dock_create_surface_from_image_simple: assertion `cImageFile != NULL' failed
cairo_dock_create_surface_from_image_simple: assertion `cImageFile != NULL' failed
cairo_dock_create_surface_from_image_simple: assertion `cImageFile != NULL' failed
cairo_dock_create_surface_from_image_simple: assertion `cImageFile != NULL' failed
warning :  (/var/tmp/portage/x11-plugins/cairo-dock-plugins-3.1.2-r300/work/cairo-dock-plugins-3.1.2/shortcuts/src/applet-drives.c:cd_shortcuts_list_drives:297) 
  couldn't detect any drives
warning :  (/var/tmp/portage/x11-misc/cairo-dock-3.1.2.1-r300/work/cairo-dock-3.1.2/src/cairo-dock.c:_cairo_dock_intercept_signal:156) 
  Cairo-Dock has crashed (sig 11).
It will be restarted now.
Feel free to report this bug on glx-dock.org to help improving the dock!
cairo_dock_create_surface_from_image_simple: assertion `cImageFile != NULL' failed
info on the system :
Linux Edison 3.7.10-gentoo #1 SMP Sat Mar 30 13:42:45 EDT 2013 x86_64 AMD FX(tm)-8150 Eight-Core Processor AuthenticAMD GNU/Linux
Couldn't guess if it was an applet's fault or not. It may have crashed inside the core or inside a thread
restarting with 'cairo-dock -m -q 4'...
Sorry, Cairo-Dock has encoutered some problems, and will quit.
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2379
Location: Hilbert space

PostPosted: Sun Mar 31, 2013 2:55 pm    Post subject: Re: Cairo Dock crashes Reply with quote

treeman1111 wrote:
I ran Cairo-Dock from the terminal

- From some X-teminal you mean ?
- What does eselect opengl tell ?
- Which use flags did you emerge cairo-dock / cairo-dock-plugins with ?
_________________
Back to top
View user's profile Send private message
treeman1111
n00b
n00b


Joined: 06 Mar 2013
Posts: 69

PostPosted: Sun Mar 31, 2013 4:38 pm    Post subject: Reply with quote

I am doing this from xfce4-terminal
eselect opengl show gives me:
Code:

ati

What use flags should I have emerged it with?
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2379
Location: Hilbert space

PostPosted: Sun Mar 31, 2013 5:40 pm    Post subject: Reply with quote

treeman1111 wrote:
I am doing this from xfce4-terminal
What use flags should I have emerged it with?

- Did you emerge the plugins with the xfce use flag set or not ?
- Do you use Xinerama ?
_________________
Back to top
View user's profile Send private message
treeman1111
n00b
n00b


Joined: 06 Mar 2013
Posts: 69

PostPosted: Sun Mar 31, 2013 8:21 pm    Post subject: Reply with quote

I did not emerge it with the xfce flag set and no, I do not use Xinerama.
Thanks for helping me :)
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2379
Location: Hilbert space

PostPosted: Mon Apr 01, 2013 8:32 am    Post subject: Reply with quote

Can you please try launching :

- cairo-dock -c (What happens ?)
- cairo-dock -l debug (And pastebin the log)
_________________
Back to top
View user's profile Send private message
treeman1111
n00b
n00b


Joined: 06 Mar 2013
Posts: 69

PostPosted: Wed Apr 03, 2013 9:05 pm    Post subject: Reply with quote

Code:

cairo-dock -c

gives me the same errors.
======================
Here is the link to the Pastebin with the errors:
http://pastebin.com/B7tptDrN
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2379
Location: Hilbert space

PostPosted: Thu Apr 04, 2013 6:42 am    Post subject: Reply with quote

Could it be you already get something in your $HOME/.config related to some ancient (not gentoo-sunrise) install of the cairo-docks ?
Code:
$ ls -ails ~/.config/cairo-dock

If yes (as I suspect this from the log) then remove it ( rm -r ~/.config/cairo-dock ) (unless you do absolutely want to keep this ancient configuration) and retry.

What I suspect is that your ancient config is referring to some particular plugin that the gentoo-sunrise cairo-dock-plugins ebuild does not install.
_________________
Back to top
View user's profile Send private message
treeman1111
n00b
n00b


Joined: 06 Mar 2013
Posts: 69

PostPosted: Thu Apr 04, 2013 10:54 pm    Post subject: Reply with quote

Sadly, I get the same thing.
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2379
Location: Hilbert space

PostPosted: Thu Apr 04, 2013 11:16 pm    Post subject: Reply with quote

treeman1111 wrote:
Sadly, I get the same thing.

OK so can you please now re-pastebin the log produced by cairo-dock -l debug after having removed the old config directory ?
_________________
Back to top
View user's profile Send private message
treeman1111
n00b
n00b


Joined: 06 Mar 2013
Posts: 69

PostPosted: Fri Apr 05, 2013 1:09 am    Post subject: Reply with quote

http://pastebin.com/7r57NVGp
Back to top
View user's profile Send private message
aCOSwt
Moderator
Moderator


Joined: 19 Oct 2007
Posts: 2379
Location: Hilbert space

PostPosted: Fri Apr 05, 2013 10:40 am    Post subject: Reply with quote

- Did you emerge the plugins with the disks use flag set or not ?

If not, can you please re-emerge cairo-dock-plugins with the disks use flag set.

- Have you in the past installed any custom set of cairo-dock plugins ?

- Did you unmerge (emerge -C) your preceding non-gentoo-sunrise install of the cairo-dock and cairo-dock-plugins packages prior to emergeing the gentoo-sunrise-version.
If you did not then please proceed with the unmerge of the old versions then re-emerge dock & plugins from sunrise after having made sure that no other overlay including the cairo-docks & plugins is active on your system.
_________________
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum