Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
uvesafb @2560x1600 with EVGA Nvidia Geforce 560 TI 448
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
chrisk2305
n00b
n00b


Joined: 05 Sep 2007
Posts: 35

PostPosted: Sat Mar 30, 2013 4:31 pm    Post subject: uvesafb @2560x1600 with EVGA Nvidia Geforce 560 TI 448 Reply with quote

Hi,

I am having problems getting my framebuffer to work at 2560x1600 with my EVGA Nvidia Geforce 560 TI 448.

I used to have this uvesafb resolution with my ATI Cards for quite some time, so I cannot believe this won't work with a quite new Nvidia Graphics Card.

Code:

fs1 ~ # dmesg | grep uvesafb
[    0.000000] Command line: BOOT_IMAGE=/kernel-3.8.4-gentoo root=/dev/sda3 ro video=uvesafb:2560x1600-32,mtrr:3,ywrap
[    0.000000] Kernel command line: BOOT_IMAGE=/kernel-3.8.4-gentoo root=/dev/sda3 ro video=uvesafb:2560x1600-32,mtrr:3,ywrap
[    0.607613] uvesafb: NVIDIA Corporation, GF110 Board - 12630010, Chip Rev   , OEM: NVIDIA, VBE v3.0
[    0.665661] uvesafb: VBIOS/hardware doesn't support DDC transfers
[    0.665817] uvesafb: no monitor limits have been set, default refresh rate will be used
[    0.666287] uvesafb: scrolling: redraw
[    1.649395] uvesafb: framebuffer at 0xd7000000, mapped to 0xffffc90011c00000, using 14336k, total 14336k


Code:

fs1 ~ # cat /sys/class/graphics/fb0/modes
U:1600x1200p-60
V:1600x1200p-85
V:1600x1200p-75
V:1600x1200p-70
V:1600x1200p-65
V:1600x1200p-60
V:1280x1024p-85
V:1280x1024p-75
V:1280x1024p-60
V:1024x768p-85
V:1024x768p-75
V:1024x768p-70
V:1024x768p-60
V:1024x768i-43
V:800x600p-85
V:800x600p-75
V:800x600p-72
V:800x600p-60
V:800x600p-56
V:640x480p-85
V:640x480p-75
V:640x480p-72
V:640x480p-60
V:640x400p-85
U:1280x800p-60
U:1600x1200p-60
U:320x240p-60
U:320x400p-59
U:320x200p-59
U:1280x1024p-59
U:1024x768p-60
U:800x600p-59
U:640x480p-60
U:640x400p-59


Code:

GRUB_CMDLINE_LINUX_DEFAULT="video=uvesafb:2560x1600-32,mtrr:3,ywrap"



Does the Bios of the Card really not support my desired resolution? I mean not even 1920x1200 is there.

What am I doing wrong. Will another GPU Bios eventually solve my problem?

Thanks!

Christian
Back to top
View user's profile Send private message
Ant P.
Advocate
Advocate


Joined: 18 Apr 2009
Posts: 2520
Location: UK

PostPosted: Sat Mar 30, 2013 4:59 pm    Post subject: Reply with quote

VESA only defines standard modes up to 1600x1200. If your video card doesn't support a specific resolution beyond that then there's nothing you can do.
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 851
Location: Montréal

PostPosted: Sat Mar 30, 2013 5:35 pm    Post subject: Reply with quote

I never have to use the Nvidia framebuffer in the Linux kernel (CONFIG_FB_NVIDIA). So, I just mention that maybe you can have highers résolutions using it (if it work).
_________________
Paul
Back to top
View user's profile Send private message
chrisk2305
n00b
n00b


Joined: 05 Sep 2007
Posts: 35

PostPosted: Sat Mar 30, 2013 8:37 pm    Post subject: Reply with quote

thanks for your answers.

I am just wondering because with ATI Cards I never had that problem. I am not talking about standard VESA but uvesafb.

Can anybody tell the me the settings I need for Nvidia? Maybe I messed something up when switching from ATI to Nvidia.

Thanks!
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2643
Location: Slovenia

PostPosted: Sat Mar 30, 2013 9:17 pm    Post subject: Reply with quote

chrisk2305 wrote:
I am not talking about standard VESA but uvesafb.

Err, yeah... :)

There's nothing you can do. The resolutions in that list is what the graphic card provides. Vesa can't use anything but that.
Back to top
View user's profile Send private message
chrisk2305
n00b
n00b


Joined: 05 Sep 2007
Posts: 35

PostPosted: Sat Mar 30, 2013 9:27 pm    Post subject: Reply with quote

ok, thanks for explaining ;)
Back to top
View user's profile Send private message
colo-des
n00b
n00b


Joined: 20 May 2011
Posts: 11

PostPosted: Sun May 12, 2013 7:50 pm    Post subject: Re: uvesafb @2560x1600 with EVGA Nvidia Geforce 560 TI 448 Reply with quote

chrisk2305 wrote:
Hi,

I am having problems getting my framebuffer to work at 2560x1600 with my EVGA Nvidia Geforce 560 TI 448.

I used to have this uvesafb resolution with my ATI Cards for quite some time, so I cannot believe this won't work with a quite new Nvidia Graphics Card.

Does the Bios of the Card really not support my desired resolution? I mean not even 1920x1200 is there.

What am I doing wrong. Will another GPU Bios eventually solve my problem?

Thanks!

Christian


Effectively in the new kernels don't work $ cat /sys/class/graphics/fb0/modes, but with # hwinfo --framebuffer if walking
Of course this is an ATI HD6670, not a nvidia.
Thanks for notice of this change, I used cat /sys/class/graphics/fb0/modes in previous kernels.
Regards


$ uname -r
3.9.2-gentoo

$ eix -I xf86-video-ati
[I] x11-drivers/xf86-video-ati
Available versions: 6.13.2 (~)6.14.3-r1 6.14.6-r1 7.0.0 (~)7.0.0-r1 (~)7.1.0 {glamor udev}
Installed versions: 7.1.0(15:40:23 09/05/13)(udev -glamor)
Homepage: http://xorg.freedesktop.org/
Description: ATI video driver

$ zcat /proc/config.gz |grep -i radeon/
CONFIG_EXTRA_FIRMWARE="radeon/TURKS_mc.bin radeon/TURKS_me.bin radeon/TURKS_pfp.bin radeon/BTC_rlc.bin radeon/SUMO_uvd.bin"

$ X -version

X.Org X Server 1.14.1
Release Date: 2013-04-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.9.0-gentoo x86_64 Gentoo
Current Operating System: Linux myhost 3.9.2-gentoo #1 SMP PREEMPT Sun May 12 02:54:22 ART 2013 x86_64
Kernel command line: root=/dev/md2 init=/bin/initd ro splash=verbose,theme:livecd-2007.0 console=tty1
Build Date: 09 May 2013 03:30:15PM

Current version of pixman: 0.30.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.


$ cat /sys/class/graphics/fb0/modes
U:1920x1080p-0

# hwinfo --framebuffer
02: None 00.0: 11001 VESA Framebuffer
[Created at bios.459]
Unique ID: rdCR.x9mbrolCBkF
Hardware Class: framebuffer
Model: "(C) 1988-2010, AMD TURKS"
Vendor: "(C) 1988-2010, AMD Technologies Inc."
Device: "TURKS"
SubVendor: "AMD ATOMBIOS"
SubDevice:
Revision: "01.00"
Memory Size: 16 MB
Memory Range: 0xd0000000-0xd0ffffff (rw)
Mode 0x0300: 640x400 (+640), 8 bits
Mode 0x0301: 640x480 (+640), 8 bits
Mode 0x0303: 800x600 (+832), 8 bits
Mode 0x0305: 1024x768 (+1024), 8 bits
Mode 0x0307: 1280x1024 (+1280), 8 bits
Mode 0x0310: 640x480 (+1280), 15 bits
Mode 0x0311: 640x480 (+1280), 16 bits
Mode 0x0313: 800x600 (+1600), 15 bits
Mode 0x0314: 800x600 (+1600), 16 bits
Mode 0x0316: 1024x768 (+2048), 15 bits
Mode 0x0317: 1024x768 (+2048), 16 bits
Mode 0x0319: 1280x1024 (+2560), 15 bits
Mode 0x031a: 1280x1024 (+2560), 16 bits
Mode 0x030d: 320x200 (+640), 15 bits
Mode 0x030e: 320x200 (+640), 16 bits
Mode 0x0320: 320x200 (+1280), 24 bits
Mode 0x0393: 320x240 (+320), 8 bits
Mode 0x0395: 320x240 (+640), 16 bits
Mode 0x0396: 320x240 (+1280), 24 bits
Mode 0x03b3: 512x384 (+512), 8 bits
Mode 0x03b5: 512x384 (+1024), 16 bits
Mode 0x03b6: 512x384 (+2048), 24 bits
Mode 0x03c3: 640x350 (+640), 8 bits
Mode 0x03c5: 640x350 (+1280), 16 bits
Mode 0x03c6: 640x350 (+2560), 24 bits
Mode 0x0333: 720x400 (+768), 8 bits
Mode 0x0335: 720x400 (+1472), 16 bits
Mode 0x0336: 720x400 (+2944), 24 bits
Mode 0x0353: 1152x864 (+1152), 8 bits
Mode 0x0355: 1152x864 (+2304), 16 bits
Mode 0x0356: 1152x864 (+4608), 24 bits
Mode 0x0363: 1280x960 (+1280), 8 bits
Mode 0x0365: 1280x960 (+2560), 16 bits
Mode 0x0366: 1280x960 (+5120), 24 bits
Mode 0x0321: 640x480 (+2560), 24 bits
Mode 0x0322: 800x600 (+3200), 24 bits
Mode 0x0323: 1024x768 (+4096), 24 bits
Mode 0x0324: 1280x1024 (+5120), 24 bits
Mode 0x0343: 1400x1050 (+1408), 8 bits
Mode 0x0345: 1400x1050 (+2816), 16 bits
Mode 0x0346: 1400x1050 (+5632), 24 bits
Mode 0x0373: 1600x1200 (+1600), 8 bits
Mode 0x0375: 1600x1200 (+3200), 16 bits
Mode 0x0376: 1600x1200 (+6400), 24 bits
Mode 0x0383: 1792x1344 (+1792), 8 bits
Mode 0x0385: 1792x1344 (+3584), 16 bits
Mode 0x0386: 1792x1344 (+7168), 24 bits
Mode 0x03d3: 1856x1392 (+1856), 8 bits
Mode 0x03d5: 1856x1392 (+3712), 16 bits
Mode 0x03d6: 1856x1392 (+7424), 24 bits
Mode 0x03e3: 1920x1440 (+1920), 8 bits
Mode 0x03e5: 1920x1440 (+3840), 16 bits
Mode 0x03e6: 1920x1440 (+7680), 24 bits
Config Status: cfg=new, avail=yes, need=no, active=unknown

$ fbset -i -v
Linux Frame Buffer Device Configuration Version 2.1 (23/06/1999)
(C) Copyright 1995-1999 by Geert Uytterhoeven

Opening frame buffer device `/dev/fb0'
Using current video mode from `/dev/fb0'

mode "1920x1080"
geometry 1920 1080 1920 1080 32
timings 0 0 0 0 0 0 0
accel true
rgba 8/16,8/8,8/0,0/0
endmode

Getting further frame buffer information
Frame buffer device information:
Name : radeondrmfb
Address : 0xd0375000
Size : 8294400
Type : PACKED PIXELS
Visual : TRUECOLOR
XPanStep : 1
YPanStep : 1
YWrapStep : 0
LineLength : 7680
Accelerator : No
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum