Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Mouting NFS at boot time w/NetworkManager
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Evilguru
Guru
Guru


Joined: 16 Aug 2005
Posts: 380
Location: England

PostPosted: Thu Mar 28, 2013 10:55 am    Post subject: Mouting NFS at boot time w/NetworkManager Reply with quote

I have been using NetworkManager (which runs at start-up) along with an entry in /etc/fstab:
Code:

server:/srv/shared      /home/freddie/Shared     nfs     auto,bg

in order to have my shares mounted automatically (by nfsmount). However, a couple of days ago, after an update to NetworkManager, this stopped working. In /var/log/messages I see:
Code:

Mar 25 09:08:44 localhost /etc/init.d/nfsmount[19147]: WARNING: nfsmount is scheduled to start when NetworkManager has started

and hence am wondering if I am doing something wrong here?

Regards, Freddie.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6505
Location: Goose Creek SC

PostPosted: Thu Mar 28, 2013 5:54 pm    Post subject: Reply with quote

that is supposed to be just an info message, the question would be: Does nfsmount start, without you starting it, in the next minute or two?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Evilguru
Guru
Guru


Joined: 16 Aug 2005
Posts: 380
Location: England

PostPosted: Thu Mar 28, 2013 6:21 pm    Post subject: Reply with quote

DONAHUE wrote:
that is supposed to be just an info message, the question would be: Does nfsmount start, without you starting it, in the next minute or two?

No. I am forced to run /etc/init.d/nfsmount restart after logging in for the share to be mounted. I have waited in excess of 10 minutes in the past, to no avail. Seems as if it is giving up rather than trying to background mount.

Regards, Freddie.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6505
Location: Goose Creek SC

PostPosted: Thu Mar 28, 2013 6:27 pm    Post subject: Reply with quote

rc_parallel="NO" in /etc/rc.conf might help
_________________
Defund the FCC.
Back to top
View user's profile Send private message
Evilguru
Guru
Guru


Joined: 16 Aug 2005
Posts: 380
Location: England

PostPosted: Sun Mar 31, 2013 3:03 pm    Post subject: Reply with quote

DONAHUE wrote:
rc_parallel="NO" in /etc/rc.conf might help

RC parallel is indeed disabled.

Regards, Freddie.
Back to top
View user's profile Send private message
fredbear5150
n00b
n00b


Joined: 11 Oct 2003
Posts: 28

PostPosted: Fri May 03, 2013 12:17 am    Post subject: Reply with quote

I myself had the same problem and have "rc_parallel=YES" on all my machines. I also use NetworkManager.

The strange thing is that the same two NFS shares I use mount okay on boot on two other machines but not on one of them - maybe it's something to do with the time it takes for the network interface to come up.

Anyway, I fixed it by adding two scripts in /etc/NetworkManager/dispatcher.d:

Code:
55-rpcbind:

#!/bin/bash

/etc/init.d/rocbind status | grep -q "started"

if test "$2" == "up" -a "$?" != "0" ; then
        rc-config start rpcbind
else
        rc-config stop rpcbind
fi



and:

Code:
60-nfsmount:

#!/bin/bash

/etc/init.d/nfsmount status | grep -q "started"

if test "$2" == "up" -a "$?" != "0" ; then
        rc-config start nfsmount
else   
        rc-config stop nfsmount
fi



You will need to make them executable and then remove nfsmount and rpcbind from rc-update to let the NetworkManager dispatcher start these two services after the network interface has come up.
Back to top
View user's profile Send private message
orzel
n00b
n00b


Joined: 22 Jan 2014
Posts: 3
Location: Paris, France

PostPosted: Thu Feb 27, 2014 12:22 am    Post subject: Reply with quote

fredbear5150 wrote:
You will need to make them executable and then remove nfsmount and rpcbind from rc-update to let the NetworkManager dispatcher start these two services after the network interface has come up.


I had the problem here, at every boot. I could clearly see from my dhcp server log that nfsmount is started before the network is up.

This tip fixed it, thanks a lot !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum