Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udev and util-linux,help me ,please
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
wgwnxu
n00b
n00b


Joined: 15 Jan 2012
Posts: 20

PostPosted: Thu Mar 28, 2013 10:09 am    Post subject: udev and util-linux,help me ,please Reply with quote

I want to update udev,and emerge udev:



* IMPORTANT: 11 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


* IMPORTANT: 2 config files in '/etc/portage' need updating.
* See the CONFIGURATION FILES section of the emerge
* man page to learn how to update config files.
Calculating dependencies... done!


[ebuild U ] sys-fs/udev-197-r8 [164-r2] USE="acl%* gudev%* hwdb%* introspection%* keymap%* kmod%* openrc%* -doc% (-selinux) -static-libs% (-build%) (-extras%*) (-test%)" 2,011 kB
[ebuild N ] sys-fs/udev-init-scripts-23 5 kB
[ebuild N ] sys-apps/hwids-20130302 USE="udev" 1,452 kB
[ebuild N ] sys-apps/util-linux-2.22.2 USE="cramfs crypt ncurses nls udev unicode -ddate -old-linux -perl (-selinux) -slang -static-libs {-test}" 0 kB
[ebuild N ] virtual/udev-197-r1 USE="gudev hwdb introspection keymap kmod (-selinux) -static-libs" 0 kB

Total: 5 packages (1 upgrade, 4 new), Size of downloads: 3,467 kB

* Error: circular dependencies:

(sys-fs/udev-197-r8::gentoo, ebuild scheduled for merge) depends on
(sys-apps/util-linux-2.22.2::gentoo, ebuild scheduled for merge) (buildtime)
(virtual/udev-197-r1::gentoo, ebuild scheduled for merge) (buildtime)
(sys-fs/udev-197-r8::gentoo, ebuild scheduled for merge) (runtime)

* Note that circular dependencies can often be avoided by temporarily
* disabling USE flags that trigger optional dependencies.

!!! The following installed packages are masked:
- www-plugins/adobe-flash-11.1.102.55::gentoo (masked by: AdobeFlash-10.3 license(s))
A copy of the 'AdobeFlash-10.3' license is located at '/usr/portage/licenses/AdobeFlash-10.3'.

- sys-fs/lvm2-2.02.73-r1::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Samuli Suominen <ssuominen@gentoo.org> (07 Mar 2013)
# Remove redudant version of udev now that 197-r8 will
# work down to Linux 2.6.32.60 on most arches.
# Removal in 90 days.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

I had unmerged util-linux,but I can not emerge udev or util-linux,how can I do?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 6715
Location: Goose Creek SC

PostPosted: Thu Mar 28, 2013 5:48 pm    Post subject: Reply with quote

I'd try
Code:
emerge --unmerge virtual/udev
emerge -1 --nodeps util-linux
emerge -1 --no-deps udev
emerge -1 --no-deps virtual/udev

_________________
Defund the FCC.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum