Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Guitar Pro 6 on Gentoo x86_64
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
hereiam
n00b
n00b


Joined: 28 Mar 2013
Posts: 1

PostPosted: Thu Mar 28, 2013 4:17 am    Post subject: Guitar Pro 6 on Gentoo x86_64 Reply with quote

Hello world!
Recently i used Ubuntu studio on my desktop and now i`m using gentoo and i have a problem w/ Guitar pro 6. I have no libraries:

ldd /opt/GuitarPro6/GuitarPro | grep found
Code:

   libGL.so.1 => not found
   libGPCore.so => not found
   libOverLoud.so => not found
   libPickupModeling.so => not found
   libRSEAudioCore.so => not found
   libRSECore.so => not found
   libWavFile.so => not found
   libasound.so.2 => not found
   libboost_filesystem-gcc43-mt-1_39.so.1.39.0 => not found
   libboost_system-gcc43-mt-1_39.so.1.39.0 => not found
   libboost_thread-gcc43-mt-1_39.so.1.39.0 => not found
   libchunk.so => not found
   libexception.so => not found
   libfactory.so => not found
   libfilesystem.so => not found
   libmemory.so => not found
   libmmap.so => not found
   libobject.so => not found
   libportaudio.so.2 => not found
   libprofiler.so => not found
   libpulse.so.0 => not found
   libpulse-simple.so.0 => not found
   libregister.so => not found
   libthread.so => not found
   libtimer.so => not found
   libvariant.so => not found
   libxml.so => not found
   libQtCore.so.4 => not found
   libQtGui.so.4 => not found
   libQtNetwork.so.4 => not found
   libQtOpenGL.so.4 => not found
   libQtSvg.so.4 => not found
   libQtXmlPatterns.so.4 => not found
   libQtXml.so.4 => not found
   libX11.so.6 => not found
   libXrender.so.1 => not found


What should i install to get all this libraries and will it help me to start guitar pro?

ps sorry for my english.
Back to top
View user's profile Send private message
Chiitoo
l33t
l33t


Joined: 28 Feb 2010
Posts: 871
Location: Here and Away Again

PostPosted: Sat Mar 30, 2013 3:37 am    Post subject: ><)))°€ Reply with quote

Teegrins, hereiam!


Well, there is this:

Code:
http://www.portagefilelist.de/site/query/file

Also:

Code:
* app-portage/pfl
     Available versions:  2.3 (~)2.3-r3 {+network-cron PYTHON_TARGETS="python2_6 python2_7"}
     Homepage:            http://www.portagefilelist.de
     Description:         Searchable online file/package database for Gentoo

For packages you have installed, there is also equery, which is a part of

Code:
app-portage/gentoolkit


You might want to consider filing a bug for an ebuild for this. If you feel adventumarous enough, I'd suggest you to make one yourself.
With a quick search, I found some that have been written for Funtoo from the looks of it, so things exist that might give an easy place to start from.

With that said, since this thing isn't in the Portage, I imagine the question would fit better into the 'Unsupported Software' forum (reported for move). ^^


Good luck~
I hope this helps!
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Sat Mar 30, 2013 10:16 pm    Post subject: Reply with quote

Moved from Multimedia to Unsupported Software as Guitar Pro is not in the Portage tree.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum