Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Postfix launch dhcp client when using bridge devices
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
guid0
Apprentice
Apprentice


Joined: 06 Jul 2003
Posts: 281
Location: The Netherlands / Nederland

PostPosted: Sat Mar 30, 2013 10:53 am    Post subject: [solved]Postfix launch dhcp client when using bridge devices Reply with quote

My box has no IP set for both eth0 or eth1.

Code:
eth0: flags=4419<UP,BROADCAST,RUNNING,PROMISC,MULTICAST>  mtu 1500
        ether 00:25:90:6e:94:fc  txqueuelen 1000  (Ethernet)
        RX packets 15846113197  bytes 21025107832049 (19.1 TiB)
        RX errors 0  dropped 1199261  overruns 27  frame 0
        TX packets 11872464826  bytes 11768381533276 (10.7 TiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xfb920000-fb940000
eth1: flags=4419<UP,BROADCAST,RUNNING,PROMISC,MULTICAST>  mtu 1500
        ether 00:25:90:6e:94:fd  txqueuelen 1000  (Ethernet)
        RX packets 24656507833  bytes 2893130107855 (2.6 TiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 24562942737  bytes 5552907337463 (5.0 TiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device memory 0xfb900000-fb920000


However I do have 2 bridge devices into which eth0 and eth1 are assigned in /etc/conf.d/net.
Code:
bridge_br0="eth0 b0x00 b0x01 b0x02"
bridge_br1="eth1 b1x00 b1x01 b1x02"


Now when I want to launch postfix I get the following strange and rather unwanted behaviour.

Code:
~ # /etc/init.d/postfix start
 * Caching service dependencies ...  [ ok ]
 * Bringing up interface eth0
 *   No configuration specified; defaulting to DHCP
 *   dhcp ...
 *     Running udhcpc ...
 *     start-stop-daemon: failed to start `/bin/busybox'  [ !! ]
 * ERROR: net.eth0 failed to start
 * Bringing up interface eth1
 *   No configuration specified; defaulting to DHCP
 *   dhcp ...
 *     Running udhcpc ...
 *     start-stop-daemon: failed to start `/bin/busybox'  [ !! ]
 * ERROR: net.eth1 failed to start
 * Starting postfix  ...  [ ok ]


It seems that postfix is happy about the system and seems to be able to deal with mail. However I would rather not fire up udhcpc in the process.

Any hints anyone on how to prevent udhcpc from being launched?

Cheers,
guid0


Last edited by guid0 on Sat Mar 30, 2013 5:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
khayyam
Advocate
Advocate


Joined: 07 Jun 2012
Posts: 2336

PostPosted: Sat Mar 30, 2013 12:43 pm    Post subject: Reply with quote

guid0 ...

"you need to configure the ports to null values so dhcp does not get started", see the section "Bridging" in /usr/share/doc/openrc-<version>/net.example.bz2

Code:
config_eth0="null"
config_eth1="null"

HTH & best ... khay
Back to top
View user's profile Send private message
guid0
Apprentice
Apprentice


Joined: 06 Jul 2003
Posts: 281
Location: The Netherlands / Nederland

PostPosted: Sat Mar 30, 2013 5:51 pm    Post subject: Reply with quote

thanks. that works perfectly fine. and congrats on the 1000 posts ;)

guid0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum