Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnustep-base-1.24.3 fails to merge....
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
tameritoke
n00b
n00b


Joined: 08 Sep 2005
Posts: 38
Location: Germany

PostPosted: Thu Mar 28, 2013 3:30 pm    Post subject: gnustep-base-1.24.3 fails to merge.... Reply with quote

gnustep-base-1.24.3 fails to merge....

Hi people!
on a world and system update gunstep-base needs to be updated, as well gnustep-base on my system is broken too, many links are broken...
On my gentoo box gnustep-base always reports this error:

"I don't seem to be able to use your Objective-C compiler to produce working binaries! Please check your Objective-C compiler installation.If you are using gcc-3.x make sure that your compiler's libgcc_s and libobjc....."


Here is the complete log and the gcc info.

I remerged gcc with all necessary flags, but nothing changed so far.....

gnustep-base log:
http://pastebin.com/raw.php?i=6D42zFpP

gcc info:
http://pastebin.com/raw.php?i=Qw5hBW0W


for any advises, I am thankfully.



Tamer
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2859
Location: Omnipresent

PostPosted: Thu Mar 28, 2013 4:15 pm    Post subject: Reply with quote

It works for me with gcc-4.5.3 . I do not have the "graphite" USE flag enabled for gcc, and my CFLAGS are "-march=native -O2 -pipe", not "-O3" as you have.

You could try re-emerging gcc after changing these settings, then see if it works.
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 402
Location: North~Sea~Coa~s~~t~~~

PostPosted: Thu Mar 28, 2013 5:58 pm    Post subject: Reply with quote

Maybe the same cause as in this bug report... recompiling gnustep-make probably solves it, or use gnustep-updater.
https://bugs.gentoo.org/show_bug.cgi?id=454192
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum