Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Remmina missing Plugin for SSh
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
olli.bo
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 174
Location: Oldenburg / Germany

PostPosted: Fri Mar 22, 2013 9:44 am    Post subject: [solved] Remmina missing Plugin for SSh Reply with quote

Hi,

after emerging remmina I have no Plugin for SSh. Other Plugins are working:

Code:
# ls -l /usr/lib/remmina/plugins/
insgesamt 160
-rwxr-xr-x 1 root root 43164 22. Mär 10:32 remmina-plugin-nx.so
-rwxr-xr-x 1 root root 59868 22. Mär 10:32 remmina-plugin-rdp.so
-rwxr-xr-x 1 root root 34812 22. Mär 10:32 remmina-plugin-vnc.so
-rwxr-xr-x 1 root root 13828 22. Mär 10:32 remmina-plugin-xdmcp.so


I Think the USE-Flags are correct...!?

Code:
# emerge -pv remmina

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] net-misc/remmina-1.0.0_p20121004  USE="crypt freerdp nls ssh -avahi (-ayatana) -debug -gnome-keyring -telepathy -vte" 0 kB


What am I doing wrong or is it a bug?


Last edited by olli.bo on Mon Apr 08, 2013 11:40 am; edited 1 time in total
Back to top
View user's profile Send private message
tuber
Apprentice
Apprentice


Joined: 12 Nov 2004
Posts: 267

PostPosted: Sun Mar 24, 2013 10:02 pm    Post subject: Reply with quote

I don't have the SSH plugin either, but it seems to be working:
Code:
:[ 1018/0 ]:0-> $ ls -l /usr/lib/remmina/plugins/
total 160K
-rwxr-xr-x 1 root root  39K Jan 28 18:42 remmina-plugin-nx.so*
-rwxr-xr-x 1 root root  63K Jan 28 18:42 remmina-plugin-rdp.so*
-rwxr-xr-x 1 root root 5.6K Jan 28 18:42 remmina-plugins-gnome.so*
-rwxr-xr-x 1 root root  34K Jan 28 18:42 remmina-plugin-vnc.so*
-rwxr-xr-x 1 root root 9.5K Jan 28 18:42 remmina-plugin-xdmcp.so*
Back to top
View user's profile Send private message
olli.bo
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 174
Location: Oldenburg / Germany

PostPosted: Mon Mar 25, 2013 10:24 am    Post subject: Reply with quote

Hi tuber

thanks for your answer. Can you please post your USE-Flags for remmina?
Code:
emerge -pv remmina


regards
olli
Back to top
View user's profile Send private message
kolszak
n00b
n00b


Joined: 20 Aug 2007
Posts: 36
Location: Toruń

PostPosted: Thu Mar 28, 2013 10:56 am    Post subject: Reply with quote

Code:

corleone karol # emerge -pv remmina

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] net-misc/remmina-1.0.0_p20121004  USE="crypt freerdp gnome-keyring nls ssh -avahi (-ayatana) -debug -telepathy -vte" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


Maybe bug in ebuild. Flags ssh, enable sftp only in libssh.
_________________
Karol Olszewki
Back to top
View user's profile Send private message
tuber
Apprentice
Apprentice


Joined: 12 Nov 2004
Posts: 267

PostPosted: Mon Apr 01, 2013 7:28 am    Post subject: Reply with quote

Here's what I have:
Code:
[ebuild   R    ] net-misc/remmina-1.0.0_p20121004  USE="crypt freerdp gnome-keyring nls ssh -avahi (-ayatana) -debug -telepathy -vte" 0 kB
Back to top
View user's profile Send private message
hasufell
Developer
Developer


Joined: 29 Oct 2011
Posts: 260

PostPosted: Mon Apr 01, 2013 2:50 pm    Post subject: Reply with quote

Your assumption is wrong.

Code:

if(LIBSSH_FOUND AND XKBFILE_FOUND)
   add_subdirectory(nx)
endif()
Back to top
View user's profile Send private message
olli.bo
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 174
Location: Oldenburg / Germany

PostPosted: Thu Apr 04, 2013 10:51 am    Post subject: Reply with quote

Post in next answer...

Last edited by olli.bo on Thu Apr 04, 2013 11:02 am; edited 1 time in total
Back to top
View user's profile Send private message
olli.bo
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 174
Location: Oldenburg / Germany

PostPosted: Thu Apr 04, 2013 11:00 am    Post subject: Reply with quote

I tried the same USE-Flags:

Code:
[ebuild   R    ] net-misc/remmina-1.0.0_p20121004  USE="crypt freerdp gnome-keyring nls ssh -avahi (-ayatana) -debug -telepathy -vte" 0 kB


Here my USE-Flags for libssh:
Code:
[ebuild   R    ] net-libs/libssh-0.5.4:0/4  USE="server sftp zlib -debug -doc -examples -gcrypt -pcap -ssh1 -static-libs {-test}"


The remmina-plugins-gnome.so is there now but a simple SSh connection doesn't work as before.
Here the error from the console when I try to open a SSh connection (last line):

Code:
# remmina
Remmina plugin VNC (type=Protokoll) registered.
Remmina plugin VNCI (type=Protokoll) registered.
Remmina plugin RDP (type=Protokoll) registered.
Remmina plugin RDPF (type=File) registered.
Remmina plugin RDPS (type=Preference) registered.
Remmina plugin XDMCP (type=Protokoll) registered.
Remmina plugin GKEYRING (type=Secret) registered.
NX: detected keyboard type evdev/de
Remmina plugin NX (type=Protokoll) registered.
Remmina plugin SFTP (type=Protokoll) registered.
Plugin not found (type=0, name=SSH)


I don't understand this... Why is the Plugin not found?
What can I do now? Please help...
Back to top
View user's profile Send private message
tuber
Apprentice
Apprentice


Joined: 12 Nov 2004
Posts: 267

PostPosted: Sat Apr 06, 2013 11:21 pm    Post subject: Reply with quote

Here's what I have for libssh:
Code:
[ebuild   R    ] net-libs/libssh-0.5.4:0/4  USE="examples sftp zlib -debug -doc -gcrypt -pcap -server -ssh1 -static-libs {-test}" 0 kB

Can you try running
Code:
strace remmina
and show any output with the string "ssh"?
Back to top
View user's profile Send private message
floppymaster
Developer
Developer


Joined: 07 Jul 2010
Posts: 218
Location: Detroit, MI, USA

PostPosted: Sun Apr 07, 2013 2:39 am    Post subject: Reply with quote

Enable both the ssh and vte use flags to enable ssh terminal support.
Back to top
View user's profile Send private message
olli.bo
Apprentice
Apprentice


Joined: 16 Jul 2003
Posts: 174
Location: Oldenburg / Germany

PostPosted: Mon Apr 08, 2013 11:40 am    Post subject: Reply with quote

floppymaster wrote:
Enable both the ssh and vte use flags to enable ssh terminal support.


This worked... Thank you... :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum