Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst][KDE]Update 4.9.3 -> 4.9.5 und nichts geht mehr
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
LeftShift
n00b
n00b


Joined: 16 Feb 2004
Posts: 32

PostPosted: Wed Mar 20, 2013 5:09 pm    Post subject: [gelöst][KDE]Update 4.9.3 -> 4.9.5 und nichts geht mehr Reply with quote

Hallo,

ich habe eine Update für den Kernel (3.7.10), den passenden Nvidiatreiber und auf KDE 4.9.5 gemacht. Vor diesem Update konnte ich ohne Probleme arbeiten.
Jetzt kommt er beim Starten von KDE bis zu diesem Anfangsbild in dem nach und nach so kleine Symbole (Laufwerke usw.) eingeblendet werden und dann wird X wieder beendet.

Hier ist mal das X.log
Code:

[   500.803]
X.Org X Server 1.13.1
Release Date: 2012-12-13
[   500.803] X Protocol Version 11, Revision 0
[   500.803] Build Operating System: Linux 3.5.7-gentoo x86_64 Gentoo
[   500.804] Current Operating System: Linux phenom 3.7.10-gentoo #2 SMP Mon Mar 11 17:48:17 GMT 2013 x86_64
[   500.804] Kernel command line: root=/dev/sdb5
[   500.804] Build Date: 02 January 2013  02:00:50PM
[   500.804] 
[   500.804] Current version of pixman: 0.28.0
[   500.804]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   500.804] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   500.805] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 20 17:44:18 2013
[   500.827] (==) Using config file: "/etc/X11/xorg.conf"
[   500.828] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   500.831] (==) ServerLayout "Layout0"
[   500.831] (**) |-->Screen "Screen0" (0)
[   500.831] (**) |   |-->Monitor "Monitor0"
[   500.839] (**) |   |-->Device "Device0"
[   500.839] (**) |-->Input Device "Keyboard0"
[   500.839] (**) |-->Input Device "Mouse0"
[   500.839] (==) Automatically adding devices
[   500.839] (==) Automatically enabling devices
[   500.839] (==) Automatically adding GPU devices
[   500.862] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[   500.862]    Entry deleted from font path.
[   500.862] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[   500.862]    Entry deleted from font path.
[   500.862] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[   500.862]    Entry deleted from font path.
[   500.862] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[   500.862]    Entry deleted from font path.
[   500.862] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[   500.862]    Entry deleted from font path.
[   500.862] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[   500.862]    Entry deleted from font path.
[   500.862] (==) FontPath set to:
   
[   500.862] (==) ModulePath set to "/usr/lib64/xorg/modules"
[   500.863] (II) Loader magic: 0x815c00
[   500.863] (II) Module ABI versions:
[   500.863]    X.Org ANSI C Emulation: 0.4
[   500.863]    X.Org Video Driver: 13.1
[   500.863]    X.Org XInput driver : 18.0
[   500.863]    X.Org Server Extension : 7.0
[   500.865] (--) PCI:*(0:1:0:0) 10de:0421:1043:8264 rev 161, Mem @ 0xfa000000/16777216, 0xd0000000/268435456, 0xf8000000/33554432, I/O @ 0x0000df00/128, BIOS @ 0x????????/131072
[   500.865] (II) Open ACPI successful (/var/run/acpid.socket)
[   500.877] Initializing built-in extension Generic Event Extension
[   500.877] Initializing built-in extension SHAPE
[   500.877] Initializing built-in extension MIT-SHM
[   500.877] Initializing built-in extension XInputExtension
[   500.877] Initializing built-in extension XTEST
[   500.877] Initializing built-in extension BIG-REQUESTS
[   500.877] Initializing built-in extension SYNC
[   500.877] Initializing built-in extension XKEYBOARD
[   500.878] Initializing built-in extension XC-MISC
[   500.878] Initializing built-in extension XINERAMA
[   500.878] Initializing built-in extension XFIXES
[   500.878] Initializing built-in extension RENDER
[   500.878] Initializing built-in extension RANDR
[   500.878] Initializing built-in extension COMPOSITE
[   500.878] Initializing built-in extension DAMAGE
[   500.879] Initializing built-in extension MIT-SCREEN-SAVER
[   500.879] Initializing built-in extension DOUBLE-BUFFER
[   500.879] Initializing built-in extension RECORD
[   500.879] Initializing built-in extension DPMS
[   500.879] Initializing built-in extension X-Resource
[   500.879] Initializing built-in extension XVideo
[   500.879] Initializing built-in extension XVideo-MotionCompensation
[   500.879] Initializing built-in extension XFree86-VidModeExtension
[   500.880] Initializing built-in extension XFree86-DGA
[   500.880] Initializing built-in extension XFree86-DRI
[   500.880] Initializing built-in extension DRI2
[   500.880] (II) LoadModule: "glx"
[   500.912] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   501.529] (II) Module glx: vendor="NVIDIA Corporation"
[   501.529]    compiled for 4.0.2, module version = 1.0.0
[   501.529]    Module class: X.Org Server Extension
[   501.529] (II) NVIDIA GLX Module  313.26  Wed Feb 27 13:10:40 PST 2013
[   501.534] Loading extension GLX
[   501.534] (II) LoadModule: "nvidia"
[   501.563] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[   501.653] (II) Module nvidia: vendor="NVIDIA Corporation"
[   501.653]    compiled for 4.0.2, module version = 1.0.0
[   501.653]    Module class: X.Org Video Driver
[   501.671] (II) LoadModule: "evdev"
[   501.671] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so
[   501.691] (II) Module evdev: vendor="X.Org Foundation"
[   501.691]    compiled for 1.13.0, module version = 2.7.3
[   501.691]    Module class: X.Org XInput Driver
[   501.691]    ABI class: X.Org XInput driver, version 18.0
[   501.691] (II) NVIDIA dlloader X Driver  313.26  Wed Feb 27 12:52:26 PST 2013
[   501.691] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   501.701] (--) using VT number 7

[   501.704] (II) Loading sub module "wfb"
[   501.704] (II) LoadModule: "wfb"
[   501.704] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[   501.713] (II) Module wfb: vendor="X.Org Foundation"
[   501.713]    compiled for 1.13.1, module version = 1.0.0
[   501.713]    ABI class: X.Org ANSI C Emulation, version 0.4
[   501.713] (II) Loading sub module "ramdac"
[   501.713] (II) LoadModule: "ramdac"
[   501.713] (II) Module "ramdac" already built-in
[   501.716] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[   501.717] (==) NVIDIA(0): RGB weight 888
[   501.717] (==) NVIDIA(0): Default visual is TrueColor
[   501.717] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[   501.718] (**) NVIDIA(0): Enabling 2D acceleration
[   502.738] (II) NVIDIA(GPU-0): Display (Samsung SyncMaster (DFP-0)) does not support NVIDIA
[   502.738] (II) NVIDIA(GPU-0):     3D Vision stereo.
[   502.739] (II) NVIDIA(0): NVIDIA GPU GeForce 8500 GT (G86) at PCI:1:0:0 (GPU-0)
[   502.739] (--) NVIDIA(0): Memory: 524288 kBytes
[   502.739] (--) NVIDIA(0): VideoBIOS: 60.86.5b.00.00
[   502.739] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[   502.743] (--) NVIDIA(0): Valid display device(s) on GeForce 8500 GT at PCI:1:0:0
[   502.743] (--) NVIDIA(0):     CRT-0
[   502.743] (--) NVIDIA(0):     CRT-1
[   502.743] (--) NVIDIA(0):     TV-0
[   502.743] (--) NVIDIA(0):     Samsung SyncMaster (DFP-0) (connected)
[   502.743] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[   502.743] (--) NVIDIA(0): CRT-1: 400.0 MHz maximum pixel clock
[   502.743] (--) NVIDIA(0): TV-0: 400.0 MHz maximum pixel clock
[   502.743] (--) NVIDIA(0): Samsung SyncMaster (DFP-0): 330.0 MHz maximum pixel clock
[   502.743] (--) NVIDIA(0): Samsung SyncMaster (DFP-0): Internal Dual Link TMDS
[   502.743] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[   502.743] (**) NVIDIA(0):     device Samsung SyncMaster (DFP-0) (Using EDID frequencies
[   502.743] (**) NVIDIA(0):     has been enabled on all display devices.)
[   502.747] (==) NVIDIA(0):
[   502.747] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[   502.747] (==) NVIDIA(0):     will be used as the requested mode.
[   502.747] (==) NVIDIA(0):
[   502.747] (II) NVIDIA(0): Validated MetaModes:
[   502.747] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select"
[   502.747] (II) NVIDIA(0): Virtual screen size determined to be 1680 x 1050
[   502.791] (--) NVIDIA(0): DPI set to (90, 88); computed from "UseEdidDpi" X config
[   502.791] (--) NVIDIA(0):     option
[   502.791] (--) Depth 24 pixmap format is 32 bpp
[   502.792] (II) NVIDIA: Using 768.00 MB of virtual memory for indirect memory access.
[   502.807] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select"
[   502.864] Loading extension NV-GLX
[   502.928] (==) NVIDIA(0): Disabling shared memory pixmaps
[   502.928] (==) NVIDIA(0): Backing store disabled
[   502.928] (==) NVIDIA(0): Silken mouse enabled
[   502.930] (**) NVIDIA(0): DPMS enabled
[   502.930] Loading extension NV-CONTROL
[   502.930] Loading extension XINERAMA
[   502.930] (II) Loading sub module "dri2"
[   502.930] (II) LoadModule: "dri2"
[   502.930] (II) Module "dri2" already built-in
[   502.930] (II) NVIDIA(0): [DRI2] Setup complete
[   502.930] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   502.930] (--) RandR disabled
[   502.945] (II) Initializing extension GLX
[   503.192] (II) Using input driver 'evdev' for 'Keyboard0'
[   503.192] (**) Option "CoreKeyboard"
[   503.192] (**) Keyboard0: always reports core events
[   503.192] (EE) evdev: Keyboard0: No device specified.
[   503.192] (EE) PreInit returned 2 for "Keyboard0"
[   503.192] (II) UnloadModule: "evdev"
[   503.192] (II) Using input driver 'evdev' for 'Mouse0'
[   503.192] (**) Option "CorePointer"
[   503.192] (**) Mouse0: always reports core events
[   503.192] (EE) evdev: Mouse0: No device specified.
[   503.192] (EE) PreInit returned 2 for "Mouse0"
[   503.192] (II) UnloadModule: "evdev"
[   503.201] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[   503.201] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   503.201] (II) Using input driver 'evdev' for 'Power Button'
[   503.201] (**) Power Button: always reports core events
[   503.201] (**) evdev: Power Button: Device: "/dev/input/event1"
[   503.201] (--) evdev: Power Button: Vendor 0 Product 0x1
[   503.201] (--) evdev: Power Button: Found keys
[   503.201] (II) evdev: Power Button: Configuring as keyboard
[   503.201] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1"
[   503.201] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[   503.201] (**) Option "xkb_rules" "evdev"
[   503.201] (**) Option "xkb_model" "evdev"
[   503.201] (**) Option "xkb_layout" "us"
[   503.252] (II) config/udev: Adding input device Power Button (/dev/input/event0)
[   503.252] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[   503.252] (II) Using input driver 'evdev' for 'Power Button'
[   503.252] (**) Power Button: always reports core events
[   503.252] (**) evdev: Power Button: Device: "/dev/input/event0"
[   503.252] (--) evdev: Power Button: Vendor 0 Product 0x1
[   503.252] (--) evdev: Power Button: Found keys
[   503.252] (II) evdev: Power Button: Configuring as keyboard
[   503.253] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0"
[   503.253] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[   503.253] (**) Option "xkb_rules" "evdev"
[   503.253] (**) Option "xkb_model" "evdev"
[   503.253] (**) Option "xkb_layout" "us"
[   503.253] (II) config/udev: Adding input device Genius 4D Scroll Mouse (/dev/input/event3)
[   503.253] (**) Genius 4D Scroll Mouse: Applying InputClass "evdev pointer catchall"
[   503.253] (II) Using input driver 'evdev' for 'Genius 4D Scroll Mouse'
[   503.253] (**) Genius 4D Scroll Mouse: always reports core events
[   503.254] (**) evdev: Genius 4D Scroll Mouse: Device: "/dev/input/event3"
[   503.254] (--) evdev: Genius 4D Scroll Mouse: Vendor 0x458 Product 0x56
[   503.254] (--) evdev: Genius 4D Scroll Mouse: Found 3 mouse buttons
[   503.254] (--) evdev: Genius 4D Scroll Mouse: Found scroll wheel(s)
[   503.254] (--) evdev: Genius 4D Scroll Mouse: Found relative axes
[   503.254] (--) evdev: Genius 4D Scroll Mouse: Found x and y relative axes
[   503.254] (II) evdev: Genius 4D Scroll Mouse: Configuring as mouse
[   503.254] (II) evdev: Genius 4D Scroll Mouse: Adding scrollwheel support
[   503.254] (**) evdev: Genius 4D Scroll Mouse: YAxisMapping: buttons 4 and 5
[   503.254] (**) evdev: Genius 4D Scroll Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[   503.254] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:13.0/usb2/2-2/2-2:1.0/input/input3/event3"
[   503.254] (II) XINPUT: Adding extended input device "Genius 4D Scroll Mouse" (type: MOUSE, id 8)
[   503.254] (II) evdev: Genius 4D Scroll Mouse: initialized for relative axes.
[   503.254] (**) Genius 4D Scroll Mouse: (accel) keeping acceleration scheme 1
[   503.254] (**) Genius 4D Scroll Mouse: (accel) acceleration profile 0
[   503.254] (**) Genius 4D Scroll Mouse: (accel) acceleration factor: 2.000
[   503.254] (**) Genius 4D Scroll Mouse: (accel) acceleration threshold: 4
[   503.255] (II) config/udev: Adding input device Genius 4D Scroll Mouse (/dev/input/mouse0)
[   503.255] (II) No input driver specified, ignoring this device.
[   503.255] (II) This device may have been added with another device file.
[   503.255] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event2)
[   503.255] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[   503.255] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[   503.255] (**) AT Translated Set 2 keyboard: always reports core events
[   503.255] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event2"
[   503.255] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[   503.255] (--) evdev: AT Translated Set 2 keyboard: Found keys
[   503.255] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[   503.255] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input2/event2"
[   503.255] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[   503.255] (**) Option "xkb_rules" "evdev"
[   503.255] (**) Option "xkb_model" "evdev"
[   503.255] (**) Option "xkb_layout" "us"
[   514.747] (EE)
[   514.747] (EE) Backtrace:
[   514.755] (EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x598016]
[   514.755] (EE) 1: /usr/bin/X (0x400000+0x19bf09) [0x59bf09]
[   514.756] (EE) 2: /lib64/libpthread.so.0 (0x7fbf2282c000+0x10460) [0x7fbf2283c460]
[   514.756] (EE) 3: ?? [0x40050f88]
[   514.756] (EE)
[   514.756] (EE) Segmentation fault at address 0x0
[   514.756]
Fatal server error:
[   514.756] Caught signal 11 (Segmentation fault). Server aborting
[   514.756]
[   514.756] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   514.756] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   514.756] (EE)
[   514.772] (II) evdev: Power Button: Close
[   514.772] (II) UnloadModule: "evdev"
[   514.788] (II) evdev: Power Button: Close
[   514.788] (II) UnloadModule: "evdev"
[   514.804] (II) evdev: Genius 4D Scroll Mouse: Close
[   514.804] (II) UnloadModule: "evdev"
[   514.820] (II) evdev: AT Translated Set 2 keyboard: Close
[   514.820] (II) UnloadModule: "evdev"
[   515.240] Server terminated with error (1). Closing log file.


Hat jemand einen Tip an was es liegen könnte? Ich habe die alten Settings von nvidia sowie alles was nach KDE aussah (im Userverzeichnis) gelöscht.
Vielen Dank im voraus.

leftshift
_________________
Man muß wissen, wie weit man zu weit gehen kann.
Jean Cocteau


Last edited by LeftShift on Fri Mar 29, 2013 10:23 am; edited 1 time in total
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2298
Location: Germany

PostPosted: Wed Mar 20, 2013 6:54 pm    Post subject: Reply with quote

Nur ein blinder Schuss ins Blaue,
versuche es doch zunächst erst mal mit deaktivierten Composite und Desktop-Effekten
Deaktiviere es mal indem du in der
~/.kde4/share/config/kwinrc
unter [Compositing]
Enabled=true
auf
Enabled=false setzt.

Ansonsten schaue auch mal ob in der /var/log/kdm.log ein hilfreicher Ansatz zu finden ist.
Back to top
View user's profile Send private message
LeftShift
n00b
n00b


Joined: 16 Feb 2004
Posts: 32

PostPosted: Fri Mar 29, 2013 10:23 am    Post subject: Reply with quote

So lieber spät als garnicht. Ohne KDE lief X ohne Probleme. Nach einem beherztem: 'emerge --update --newuse world' funktionierte alles wieder. Warum ... keine Ahnung.

leftshift
_________________
Man muß wissen, wie weit man zu weit gehen kann.
Jean Cocteau
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum