Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't play DVD.
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 369
Location: Tokyo, Japan

PostPosted: Sun Mar 17, 2013 7:47 am    Post subject: Can't play DVD. Reply with quote

I haven't been able to play DVD's and was able to determine it is because the DVD isn't being mounted. I was able to mount it manually by creating the folder /mnt/dvd and executing
Code:
mount -t auto /dev/sr0 /mnt/dvd/
.

Of course I would like to be able to just insert a dvd into the drive an have it auto mount but when researching about fstab entries I read that it is no longer necessary with the new kernels.

Is this true?

How do I get my DVD/RW Player to auto mount?

If I do have to add it to fstab what would the syntax be?

This is my current fstab:

Quote:
# /etc/fstab: static file system information.
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed); notail increases performance of ReiserFS (at the expense of storage
# efficiency). It's safe to drop the noatime options if you want and to
# switch between notail / tail freely.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# See the manpage fstab(5) for more information.
#

# <fs> <mountpoint> <type> <opts> <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#/dev/BOOT /boot ext2 noauto,noatime 1 2
#/dev/ROOT / ext3 noatime 0 1
#/dev/SWAP none swap sw 0 0
/dev/cdrom /mnt/cdrom auto noauto,ro 0 0
/dev/fd0 /mnt/floppy auto noauto 0 0

/dev/sda6 /boot ext2 noauto,noatime 1 2
/dev/mapper/vg-root / ext4 noatime 0 1
/dev/mapper/vg-swap none swap sw 0 0
/dev/mapper/vg-var /var ext4 noatime 0 1
/dev/mapper/vg-home /home ext4 noatime,user_xattr 0 1


dmesg:

http://bpaste.net/show/84233/

lspci:

Quote:
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Caicos [Radeon HD 6400M/7400M Series]
02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 [Rainbow Peak] (rev 34)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
04:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller


Thanks.[/url]
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32027
Location: 56N 3W

PostPosted: Sun Mar 17, 2013 12:05 pm    Post subject: Reply with quote

Budoka,

You do not need to mount a DVD to play it. I assume we are discussing video DVDs, not data DVDs?

DVD players use raw device access and retrieve block lists to determine what order to play the data blocks so you see the movie.
Indeed, many filesystem blocks are deliberately corrupt, so you cannot use cp -a to copy a video.

Your normal user needs to be in the cdrom group to be permitted raw device access, then all should be well.
mplayer is a good test.

If your symlinks are set up properly,
Code:
mplayer dvd://1
will play the first video on a dvd. Be aware that it might only be a single frame, so you may need to try other numbers too. You might need the -dvd-device option too. I think its -dev-device=/dev/sr0 for the first cdrom but check the man page.

Hint: when mplayer starts, it recovers all the keys for the videos on the DVD and shows the sizes of each video. The biggest one is normally the one you want.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 369
Location: Tokyo, Japan

PostPosted: Mon Mar 18, 2013 1:30 am    Post subject: Reply with quote

NeddySeagoon wrote:
Budoka,

You do not need to mount a DVD to play it. I assume we are discussing video DVDs, not data DVDs?

DVD players use raw device access and retrieve block lists to determine what order to play the data blocks so you see the movie.
Indeed, many filesystem blocks are deliberately corrupt, so you cannot use cp -a to copy a video.

Your normal user needs to be in the cdrom group to be permitted raw device access, then all should be well.
mplayer is a good test.

If your symlinks are set up properly,
Code:
mplayer dvd://1
will play the first video on a dvd. Be aware that it might only be a single frame, so you may need to try other numbers too. You might need the -dvd-device option too. I think its -dev-device=/dev/sr0 for the first cdrom but check the man page.

Hint: when mplayer starts, it recovers all the keys for the videos on the DVD and shows the sizes of each video. The biggest one is normally the one you want.


Thanks for the info Neddy.

Yes I was speaking of video DVD's not data. I'll test data and reading/writing this week.

I was in the cdrom, plugdev, and cdrw groups when having this problem. The reason I thought it was a mount issue is because, although I could see the disc, I couldn't access it from a file manager or CLI as well.

However, now the problem has "gone away". I am not sure why so perhaps you can help me. The only thing I did post problem was issue the mount command that I indicated, which then allowed me to access and play the dvd. But I assume upon re-boot that would no longer be in effect.

I also commented out
Code:
/dev/cdrom /mnt/cdrom auto noauto,ro 0 0
/dev/fd0 /mnt/floppy auto noauto 0 0
in my fstab based on a thread I saw on another linux forum. This would be preserved on reboot so I am assuming that is why I can play DVD's now?

I would just kind of like to understand what happened in case I encounter it again on future installs. Thanks
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32027
Location: 56N 3W

PostPosted: Mon Mar 18, 2013 5:30 pm    Post subject: Reply with quote

Budoka,

If its not reproducable, its difficult to fault find.

Commenting out your
Code:
/dev/cdrom /mnt/cdrom auto noauto,ro 0 0
/dev/fd0 /mnt/floppy auto noauto 0 0
is required for some auto mounters to work, so its not that.

Even if the DVD was mounted, raw access still works, so playing the DVD should work.

Are you testing with the same DVD that caused the issue?
It could be a scratch or dirt on the DVD.

I have a few optical discs, CDs and DVDs that are very fussy about how they are placed in the drive, so there are several possible intermittent causes.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 369
Location: Tokyo, Japan

PostPosted: Tue Mar 19, 2013 1:30 am    Post subject: Reply with quote

NeddySeagoon wrote:
Budoka,

If its not reproducable, its difficult to fault find.

Commenting out your
Code:
/dev/cdrom /mnt/cdrom auto noauto,ro 0 0
/dev/fd0 /mnt/floppy auto noauto 0 0
is required for some auto mounters to work, so its not that.

Even if the DVD was mounted, raw access still works, so playing the DVD should work.

Are you testing with the same DVD that caused the issue?
It could be a scratch or dirt on the DVD.

I have a few optical discs, CDs and DVDs that are very fussy about how they are placed in the drive, so there are several possible intermittent causes.


Hi. I have no idea what is going on but would like to try to understand. Haha.

OK so after some playing around it is indeed reproducible. I am not sure why but if I comment out the two lines I referenced in fstab the DVD will auto mount and play in VLC. If I leave those two lines in the fstab, not only will it not play, it won't mount the DVD thus denying me access in any file manager.

The file manager gives a rather generic "can't mount" error. But I can see the DVD label.

VLC threw the following error:

Quote:
Playback failure:

DVDRead could not open the disc "/dev/dvd".

Your input can't be opened:

VLC is unable to open the MRL 'dvd:///dev/dvd'.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32027
Location: 56N 3W

PostPosted: Tue Mar 19, 2013 6:50 pm    Post subject: Reply with quote

Budoka,

Set your system up so it fails. I suspect that /dev/dvd and all the other symlinks to /dev/sr0 no longer exist.

/dev/sr0 is the real device node for the first optical drive, then its sr1, sr2 ...
As you have used the symlink in /etc/fstab, it needs to be there in /dev too.

The only symlink I have is /dev/cdrom, which I also don't use. Over the years, the symlinks have proven to be more trouble than they are worth.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2131
Location: Finland

PostPosted: Tue Mar 19, 2013 7:00 pm    Post subject: Reply with quote

NeddySeagoon wrote:
I suspect that /dev/dvd and all the other symlinks to /dev/sr0 no longer exist.
The only symlink I have is /dev/cdrom, which I also don't use. Over the years, the symlinks have proven to be more trouble than they are worth.


You are right, it was an decision of udev upstream to drop everything else than the /dev/cdrom symlink, it always points to /dev/sr0.

So if anyone is seeing an application defaulting to /dev/dvd, it's an actual bug and the default should be changed in the source code to /dev/cdrom.


Last edited by ssuominen on Tue Mar 19, 2013 7:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2131
Location: Finland

PostPosted: Tue Mar 19, 2013 7:04 pm    Post subject: Reply with quote

NeddySeagoon wrote:

Commenting out your
Code:
/dev/cdrom /mnt/cdrom auto noauto,ro 0 0
/dev/fd0 /mnt/floppy auto noauto 0 0
is required for some auto mounters to work, so its not that.


You are right, partly.

The entries in /etc/fstab will conflict with sys-fs/udisks:0 but not anymore with sys-fs/udisks:2, so if user has gnome-base/gvfs built using UDisks2 (USE="udisks udev") instead of UDisks1 then both GNOME and Xfce will be fine even with the entries in /etc/fstab, however if it's built with UDisks1 (USE="gdu udev"), then the conflict will still be there.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32027
Location: 56N 3W

PostPosted: Tue Mar 19, 2013 7:10 pm    Post subject: Reply with quote

ssuominen,

Just when I think I'm getting the hang of it, you devs change it :)
Still, it keeps me on my toes.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 369
Location: Tokyo, Japan

PostPosted: Thu Mar 21, 2013 2:20 am    Post subject: Reply with quote

The conversation went a bit over my head. So what does this mean for me. Do I leave those two lines commented out or should I be doing something else. You indicated I should set it up to fail?
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2131
Location: Finland

PostPosted: Thu Mar 21, 2013 3:25 am    Post subject: Reply with quote

Budoka wrote:
The conversation went a bit over my head. So what does this mean for me. Do I leave those two lines commented out or should I be doing something else. You indicated I should set it up to fail?


We got a bit off-topic. My bad.

Well, if you don't use old sys-fs/udisks:0, then having line for /dev/cdrom which will always point to /dev/sr0 in /etc/fstab is OK.
However if you still use sys-fs/udisks:0, then make sure you don't have lines in /etc/fstab for removable medias, like optical drives, like /dev/cdrom, as with old udisks it's either handled by fstab OR udisks.

I'd run some media player with `strace` and once it fails, also look at `dmesg`.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 369
Location: Tokyo, Japan

PostPosted: Thu Mar 21, 2013 3:37 am    Post subject: Reply with quote

ssuominen wrote:
Budoka wrote:
The conversation went a bit over my head. So what does this mean for me. Do I leave those two lines commented out or should I be doing something else. You indicated I should set it up to fail?


We got a bit off-topic. My bad.

Well, if you don't use old sys-fs/udisks:0, then having line for /dev/cdrom which will always point to /dev/sr0 in /etc/fstab is OK.
However if you still use sys-fs/udisks:0, then make sure you don't have lines in /etc/fstab for removable medias, like optical drives, like /dev/cdrom, as with old udisks it's either handled by fstab OR udisks.

I'd run some media player with `strace` and once it fails, also look at `dmesg`.


Thanks. So how do I determine that? This is a relatively new install. Is it safe to assume that since the behaviour "out of the box" was to not play the media until I commented out those two lines that I am using sys-fs/udisks?

If I am not using udisks how do I get get the fstab to always point to /dev/sr0? Can you point me to a how to or wiki. I did a quick search but didn't have much luck.
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 238

PostPosted: Thu Mar 21, 2013 4:45 am    Post subject: Reply with quote

why did you say mplayer dvd://1 ?
I've try
mplayer2 dvd://mnt/xfs/dune
or
mplayer2 dvd://mnt/xfs/dune/1
it's not pla moe like that.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2131
Location: Finland

PostPosted: Thu Mar 21, 2013 5:17 am    Post subject: Reply with quote

syn0ptik wrote:
why did you say mplayer dvd://1 ?
I've try
mplayer2 dvd://mnt/xfs/dune
or
mplayer2 dvd://mnt/xfs/dune/1
it's not pla moe like that.


That mount point doesn't belong to the command. Look at the manpage:

"man mplayer", use "/" key for search and type "dvd", press "n" key for next:

Quote:

mplayer [dvd|dvdnav]://[title|[start_title]-end_title][/device] [options]
[ .. snip .. ]
-dvd-device <path to device> (DVD only)
Specify the DVD device or .iso filename (default: /dev/dvd). You can also specify a directory that contains files previ‐
ously copied directly from a DVD (with e.g. vobcopy).
[ .. snip .. ]


I'd try with:

mplayer dvd://1 -dvd-device=/dev/cdrom
mplayer dvd://1 -dvd-device=/dev/sr0
mplayer dvd://1 -dvd-device=/dev/sr1
mplayer dvdnav:////dev/cdrom
mplayer dvdnav:////dev/sr0
mplayer dvdnav:////dev/sr1

Or if you insist with mountpoint, it should be the directory with VOB files:

mplayer dvd://1 -dvd-device=/mnt/xfs/dune/1
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 238

PostPosted: Thu Mar 21, 2013 5:31 am    Post subject: Reply with quote

ok,
for me will work
mplayer2 dvd://1 --dvd-device=/mnt/xfs/dune/
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2131
Location: Finland

PostPosted: Thu Mar 21, 2013 7:09 am    Post subject: Reply with quote

I patched media-video/mplayer to use /dev/cdrom instead of /dev/dvd as a default device (no revision bump for so minor change)

Quote:

+ 21 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> mplayer-1.1-r1.ebuild,
+ mplayer-9999.ebuild:
+ Use /dev/cdrom instead of /dev/dvd as default DVD device:
+ http://forums.gentoo.org/viewtopic-t-954272-highlight-.html


http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-video/mplayer/mplayer-1.1-r1.ebuild?r1=1.20&r2=1.21
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-video/mplayer/mplayer-9999.ebuild?r1=1.140&r2=1.141

But I don't maintain media-video/mplayer2 or otherwise care about it, so if you want that one fixed too, you should likely file a bug at http://bugs.gentoo.org/
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 369
Location: Tokyo, Japan

PostPosted: Fri Mar 22, 2013 2:08 am    Post subject: Reply with quote

Sorry guys. Although I appreciate all the comments/assistance I am still not clear what "I" am suppose to be doing on my box.

I use VLC not mplayer.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32027
Location: 56N 3W

PostPosted: Fri Mar 22, 2013 6:48 pm    Post subject: Reply with quote

Budoka,

What you need to do depends on what
Code:
emerge -pv sys-fs/udisks:0 gnome-base/gvfs
shows.
Please run that command and post the output.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 369
Location: Tokyo, Japan

PostPosted: Sat Mar 23, 2013 1:08 am    Post subject: Reply with quote

NeddySeagoon wrote:
Budoka,

What you need to do depends on what
Code:
emerge -pv sys-fs/udisks:0 gnome-base/gvfs
shows.
Please run that command and post the output.


Thanks Neddy. This is what it gave me:

Code:
# emerge -pv sys-fs/udisks:0 gnome-base/gvfs

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] sys-fs/udisks-1.0.4-r5  USE="nls -debug -remote-access (-selinux)" 0 kB
[ebuild   R    ] gnome-base/gvfs-1.12.3  USE="bluetooth cdda gdu http ios udev -afp -archive -avahi -bluray -doc -fuse -gnome-keyring -gphoto2 -samba (-udisks)" 0 kB

Total: 2 packages (2 reinstalls), Size of downloads: 0 kB


I gather this means I am using udisks? But still not sure what that means for me.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5586

PostPosted: Sat Mar 23, 2013 1:16 am    Post subject: Reply with quote

Any chance it's something as simple as not rebuilding vlc after libudev got ABI bump ?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7987

PostPosted: Sat Mar 23, 2013 2:21 am    Post subject: Reply with quote

Budoka wrote:
Sorry guys. Although I appreciate all the comments/assistance I am still not clear what "I" am suppose to be doing on my box.

I use VLC not mplayer.
Have you tried setting the default DVD device used by VLC? From what I read here, it seems that modifying ~/.config/vlc/vlcrc to include the following should suffice:
Code:
dvd=/dev/sr0
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 369
Location: Tokyo, Japan

PostPosted: Sat Mar 23, 2013 2:47 am    Post subject: Reply with quote

desultory wrote:
Budoka wrote:
Sorry guys. Although I appreciate all the comments/assistance I am still not clear what "I" am suppose to be doing on my box.

I use VLC not mplayer.
Have you tried setting the default DVD device used by VLC? From what I read here, it seems that modifying ~/.config/vlc/vlcrc to include the following should suffice:
Code:
dvd=/dev/sr0


I'll give it a try but what I am not clear about at the moment is if I am suppose to have the 2 lines commented out or active in my fstab?
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7987

PostPosted: Sat Mar 23, 2013 2:59 am    Post subject: Reply with quote

That was addressed earlier by ssuominen. In short, if you are using sys-fs/udisks:0 leaving them uncommented could cause conflicts with the automounter, but with sys-fs/udisks:2 no such conflicts are present. So just check which slot you are using and go from there, if you are even using the automounter, if you are not then leave them active.
Back to top
View user's profile Send private message
Budoka
Guru
Guru


Joined: 03 Jun 2012
Posts: 369
Location: Tokyo, Japan

PostPosted: Sun Mar 24, 2013 1:09 am    Post subject: Reply with quote

desultory wrote:
That was addressed earlier by ssuominen. In short, if you are using sys-fs/udisks:0 leaving them uncommented could cause conflicts with the automounter, but with sys-fs/udisks:2 no such conflicts are present. So just check which slot you are using and go from there, if you are even using the automounter, if you are not then leave them active.


OK. So I umnerged sys-fs/udisks:0, emerged sys-fs/udisks:2, and uncommented the 2 lines in fstab in question.

Now my DVD does not mount at all nor is it recognized by any media player. What's up?

All I want is to be able to stick a disc in the box, have it automount,and be able to play it.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 32027
Location: 56N 3W

PostPosted: Sun Mar 24, 2013 12:13 pm    Post subject: Reply with quote

Budoka,

You are missing the point. DVDs are not mounted to be able to play them.
If they are mounted, the filesystem found at the mount point is ignored, since the filesystem is deliberately corrupt as a means of copy protection.

You either need to configure your DVD player of choice to use /dev/sr0 as the place to look for DVDs, or give the correct options on the DVD player command line. Most players the at provide a GUI also have a setup option. For mplayer, you need to edit its configuration file.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum