Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
abi_x86_32 Multilib madness [Not as SOLVED as I thought]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
daddio
Tux's lil' helper
Tux's lil' helper


Joined: 11 Oct 2003
Posts: 135
Location: Richland WA

PostPosted: Wed Mar 13, 2013 6:28 am    Post subject: abi_x86_32 Multilib madness [Not as SOLVED as I thought] Reply with quote

...at least I think so.

For anyone whose emerge world is broken...

There is a new keyword:

do not bother trying to change your USE flags to add abi_x86_32

add the following line to make.conf
Code:

ABI_X86="64 32"


Voila! For the first time on gentoo, a multilib system compiled entirely from source.
and then you might need to unmerge precompiled 32 bit libraries:

Code:

# emerge -C app-emulation/emul-linux-x86-xlibs
# emerge -C app-emulation/emul-linux-x86-soundlibs
# emerge -C app-emulation/emul-linux-x86-medialibs


[UPDATE: as noted in comments, It seems that some popular 32 bit packages have not been updated yet.]

Wine wants to add those emul-linux libraries back in.
Bye for now wine :x
Code:

# emerge -C wine


[UPDATE 2:] its worse than I thought:
Code:

 # equery d emul-linux-x86-xlibs
 * These packages depend on emul-linux-x86-xlibs:
app-emulation/emul-linux-x86-opengl-20130224 (>=app-emulation/emul-linux-x86-xlibs-20100611)
sys-devel/gcc-4.6.3 (multilib ? app-emulation/emul-linux-x86-xlibs)
sys-devel/gcc-4.7.2-r1 (multilib ? app-emulation/emul-linux-x86-xlibs)
www-plugins/adobe-flash-11.2.202.273 (vdpau ? >=app-emulation/emul-linux-x86-xlibs-20110129)


Code:

# emerge -DuNav world



adding emul-linux-x86-xlibs to /etc/portage/package.mask...

That seems to help... still not fully correct, I have a couple of binary overlay packages that need removed before I know if I succeeded


Last edited by daddio on Wed Mar 13, 2013 2:36 pm; edited 4 times in total
Back to top
View user's profile Send private message
Arkhelion
Tux's lil' helper
Tux's lil' helper


Joined: 07 Sep 2010
Posts: 131
Location: France

PostPosted: Wed Mar 13, 2013 6:58 am    Post subject: Reply with quote

It seems like you're right, I heard some dev was working on real multilib, it seems it got to the tree. But I'm actually looking for some doc about it, can't find any in 'man make.conf'. Is there some doc about this USE flag somewhere?
_________________
Arkhelion
Back to top
View user's profile Send private message
daddio
Tux's lil' helper
Tux's lil' helper


Joined: 11 Oct 2003
Posts: 135
Location: Richland WA

PostPosted: Wed Mar 13, 2013 7:12 am    Post subject: Abi_x86 Reply with quote

I was not able to find much about ABI_X86.
It is listed next to packages if you "emerge -pv" them.
It looks like the options are 64, 32, and x32. I have no idea what would happen if you tried to enable 64 and x32 on the same system. IIRC they are incompatible.

The inability to find a matching USE flag was the giveaway for me.
Back to top
View user's profile Send private message
ToeiRei
Veteran
Veteran


Joined: 03 Jan 2005
Posts: 1156
Location: Austria

PostPosted: Wed Mar 13, 2013 7:23 am    Post subject: Reply with quote

you might also need to remove skype, teamviewer, wine - seems like those packages are not 32/64-ready yet
_________________
Blog | btrfs | Please stand by - The mailer daemon is busy burning your messages in hell...
Back to top
View user's profile Send private message
kiksen
Guru
Guru


Joined: 24 Jun 2002
Posts: 396
Location: Denmark

PostPosted: Wed Mar 13, 2013 7:49 am    Post subject: Reply with quote

The ABI_X86="64 32" was enough to get me going again.

Thanks!
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2290
Location: Dallas area

PostPosted: Wed Mar 13, 2013 10:13 am    Post subject: Reply with quote

I started going down that rabbit hole this morning and just masked the trigger package with

=app-emulation/emul-linux-x86-xlibs-20130224-r1

in portage.mask



Thank god the developers know what they're doing and can communicate it to us mere end users.
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4
Back to top
View user's profile Send private message
norg
Tux's lil' helper
Tux's lil' helper


Joined: 23 Aug 2010
Posts: 102
Location: Augsburg (Germany)

PostPosted: Wed Mar 13, 2013 10:31 am    Post subject: Reply with quote

Emerging ~amd64 wine results in huge portage message with lots of ABI stuff and a lot of my stable packages should get unstable. I guess there is still some work todo.
At least for wine i hope it will soon be fixed or some documentation available.

This is what i get, when i want to emerge ~amd64 wine and also the emul-linux ~amd64:
https://paste.geekosphere.org/r
Back to top
View user's profile Send private message
daddio
Tux's lil' helper
Tux's lil' helper


Joined: 11 Oct 2003
Posts: 135
Location: Richland WA

PostPosted: Wed Mar 13, 2013 2:32 pm    Post subject: Not solved yet. Possibly need ebuild fixes Reply with quote

It does seem that we are currently in a half baked state for multilib systems.
I notice this morning that th ABI_X86="32" packages depend on emul-linux-86-baselibs, so theoretically this transition can happen in smaller steps, but so far we are seeing packages BLOCKED as they leak through into ~amd64
Looks like we need ebuild fixes to really clear the issue
I'm going to remove the [SOLVED] tag for now.

Seems more and more like the solution is going to be something like:

1) remove all 32 bit packages
2) wait for ABI_X86 to be fixed for packages that we care about
3) emerge them again
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2448
Location: Germany

PostPosted: Wed Mar 13, 2013 3:02 pm    Post subject: Reply with quote

Well, it looks like for once, testing/unstable branch deserves its name. :lol:

Thanks for the heads up. Might just as well not update for half a year (said no Gentoo user ever). 8)
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2128
Location: Finland

PostPosted: Wed Mar 13, 2013 3:27 pm    Post subject: Reply with quote

ABI_X86="32 64" to make.conf and keywording of =app-emulation/emul-linux-x86-xlibs-20130224-r1 which is empty package that doesn't have files because the files come now directly from the x11-libs/

No need to mask anything, but some may have keyworded x11-libs/ packages on stable and that would cause quite a mess if not everything required if keyworded too
Back to top
View user's profile Send private message
vootey
n00b
n00b


Joined: 24 Jul 2010
Posts: 29
Location: Austria

PostPosted: Wed Mar 13, 2013 3:46 pm    Post subject: Reply with quote

So everything should be working out of the box on the testing-tree?

What should I do in this case?

Code:
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-emulation/emul-linux-x86-soundlibs-20130224::gentoo, ebuild scheduled for merge) pulled in by
    >=app-emulation/emul-linux-x86-soundlibs-20120520 required by (net-im/skype-4.1.0.20::gentoo, installed)
    ~app-emulation/emul-linux-x86-soundlibs-20130224 required by (app-emulation/emul-linux-x86-medialibs-20130224::gentoo, installed)
    >=app-emulation/emul-linux-x86-soundlibs-2.1 required by (app-emulation/wine-1.5.20::gentoo, installed)
    ~app-emulation/emul-linux-x86-soundlibs-20130224 required by (app-emulation/emul-linux-x86-sdl-20130224::gentoo, installed)
    app-emulation/emul-linux-x86-soundlibs required by (app-emulation/wine-1.5.20::gentoo, installed)

  (sci-libs/fftw-3.3.3-r2::gentoo, ebuild scheduled for merge) pulled in by
    sci-libs/fftw:3.0 required by (media-sound/pulseaudio-3.0::gentoo, installed)
    >=sci-libs/fftw-3 required by (media-libs/libofa-0.9.3::gentoo, installed)
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2128
Location: Finland

PostPosted: Wed Mar 13, 2013 4:12 pm    Post subject: Reply with quote

vootey wrote:
So everything should be working out of the box on the testing-tree?

What should I do in this case?

Code:
 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (app-emulation/emul-linux-x86-soundlibs-20130224::gentoo, ebuild scheduled for merge) pulled in by
    >=app-emulation/emul-linux-x86-soundlibs-20120520 required by (net-im/skype-4.1.0.20::gentoo, installed)
    ~app-emulation/emul-linux-x86-soundlibs-20130224 required by (app-emulation/emul-linux-x86-medialibs-20130224::gentoo, installed)
    >=app-emulation/emul-linux-x86-soundlibs-2.1 required by (app-emulation/wine-1.5.20::gentoo, installed)
    ~app-emulation/emul-linux-x86-soundlibs-20130224 required by (app-emulation/emul-linux-x86-sdl-20130224::gentoo, installed)
    app-emulation/emul-linux-x86-soundlibs required by (app-emulation/wine-1.5.20::gentoo, installed)

  (sci-libs/fftw-3.3.3-r2::gentoo, ebuild scheduled for merge) pulled in by
    sci-libs/fftw:3.0 required by (media-sound/pulseaudio-3.0::gentoo, installed)
    >=sci-libs/fftw-3 required by (media-libs/libofa-0.9.3::gentoo, installed)


Almost out-of-box, I'm still waiting for a reply from certain another developer that are responsible for these so that we could add ABI_X86="32 64" by default for amd64 multilib profile

And your output seems to hint you are possibly using stable with not all app-emulation/emul-linux-x86- packages keyworded, some are 20120520 and some are 20130224 and they can't be mixed together
But I'm not entirely sure, you should rather post output of something like "emerge -pvt emul-linux-x86-xlibs" or possibly "emerge -pvDNut world", the -t (tree) flag is the one that will show what is pulling what
Back to top
View user's profile Send private message
ToeiRei
Veteran
Veteran


Joined: 03 Jan 2005
Posts: 1156
Location: Austria

PostPosted: Wed Mar 13, 2013 5:42 pm    Post subject: Reply with quote

my approach would be making use of sci-libs/fftw by adding this to the ebuild:

Quote:
rm -f "${S}"/usr/lib32/libfftw3*


... and removing the RDEPEND blocker. That way we'd use the system-libs instead of the bundled one.
_________________
Blog | btrfs | Please stand by - The mailer daemon is busy burning your messages in hell...
Back to top
View user's profile Send private message
vootey
n00b
n00b


Joined: 24 Jul 2010
Posts: 29
Location: Austria

PostPosted: Wed Mar 13, 2013 5:51 pm    Post subject: Reply with quote

ssuominen wrote:
And your output seems to hint you are possibly using stable with not all app-emulation/emul-linux-x86- packages keyworded, some are 20120520 and some are 20130224 and they can't be mixed together
But I'm not entirely sure, you should rather post output of something like "emerge -pvt emul-linux-x86-xlibs" or possibly "emerge -pvDNut world", the -t (tree) flag is the one that will show what is pulling what

Actually I'm using pure testing.

This is the emerge -pavUNDt world output: (Previously I did a `emerge -avuND1 emul-linux-x86-xlibs` which did a fine rebuild of a bunch of packages with the new flag.)
Code:
$ emerge -pavuNDt world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] net-misc/mediatomb-0.12.1-r5  USE="curl exif ffmpeg inotify javascript magic mp4 sqlite taglib zlib -debug -id3tag -l
astfm -libextractor -mysql -thumbnail"
[ebuild   R    ]  media-libs/libexif-0.6.21-r1  USE="nls -doc -static-libs" ABI_X86="32* (64) (-x32)" 0 kB
[nomerge       ] net-im/kde-telepathy-meta-0.5.2:4
[nomerge       ]  net-im/ktp-presence-applet-0.5.2:4  USE="(-aqua) -debug" LINGUAS="de ja zh_CN zh_TW -ca -cs -da -el -es -et -fi -fr
-ga -gl -hu -it -km -lt -nb -nds -nl -pl -pt -pt_BR -ru -sk -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -uk"
[nomerge       ]   net-libs/telepathy-qt-0.9.3  USE="farstream -debug -farsight {-test}"
[ebuild     U  ]    net-libs/telepathy-farstream-0.6.0:0/3 [0.4.0:0/0] USE="introspection%* -examples (-python%*)" 582 kB
[ebuild     U  ] app-portage/gentoolkit-0.3.0.7-r2 [0.3.0.7-r1] 0 kB
[ebuild   R    ] app-office/calligra-2.5.5:4  USE="crypt eigen exif fontconfig gif glib gsf jpeg kdcraw kdepim lcms marble* okular ope
ngl pdf semantic-desktop ssl threads tiff truetype xml xslt (-aqua) -attica -fftw -freetds -glew -gsl -handbook -jpeg2k -mysql -openex
r -opengtl (-postgres) -spacenav (-sybase) {-test} -word-perfect -xbase" CALLIGRA_FEATURES="braindump flow karbon krita sheets stage w
ords -kexi -plan" 0 kB
[nomerge       ] net-libs/telepathy-farstream-0.6.0:0/3 [0.4.0:0/0] USE="introspection%* -examples (-python%*)"
[ebuild  NS    ]  net-libs/farstream-0.2.2:0.2 [0.1.2-r1:0.1] USE="introspection msn upnp {-test}" 1,217 kB
[ebuild  NS    ]   media-plugins/gst-plugins-libnice-0.1.4-r100:1.0 [0.1.4:0.10] 0 kB
[nomerge       ]     app-text/texlive-core-2012-r1  USE="X -cjk -doc -source -tk -xetex"
[ebuild     U  ]      virtual/perl-Getopt-Long-2.390.0 [2.380.0-r2] 0 kB
[ebuild  N     ]       perl-core/Getopt-Long-2.390.0  42 kB
[ebuild  N     ]        virtual/perl-PodParser-1.510.0-r1  0 kB
[blocks B      ] >=sci-libs/fftw-3.3.3-r1[abi_x86_32] (">=sci-libs/fftw-3.3.3-r1[abi_x86_32]" is blocking app-emulation/emul-linux-x86-soundlibs-20130224)

Total: 14 packages (3 upgrades, 3 new, 5 in new slots, 3 reinstalls), Size of downloads: 7,558 kB
Conflict: 1 block (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/telepathy-farstream:0

  (net-libs/telepathy-farstream-0.6.0::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/telepathy-farstream-0.4.0::gentoo, installed) pulled in by
    <net-libs/telepathy-farstream-0.6 required by (net-im/ktp-call-ui-0.5.2::gentoo, installed)
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2128
Location: Finland

PostPosted: Wed Mar 13, 2013 6:35 pm    Post subject: Reply with quote

vootey wrote:
ssuominen wrote:
And your output seems to hint you are possibly using stable with not all app-emulation/emul-linux-x86- packages keyworded, some are 20120520 and some are 20130224 and they can't be mixed together
But I'm not entirely sure, you should rather post output of something like "emerge -pvt emul-linux-x86-xlibs" or possibly "emerge -pvDNut world", the -t (tree) flag is the one that will show what is pulling what

Actually I'm using pure testing.

This is the emerge -pavUNDt world output: (Previously I did a `emerge -avuND1 emul-linux-x86-xlibs` which did a fine rebuild of a bunch of packages with the new flag.)
Code:
$ emerge -pavuNDt world

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:



Put this line to /etc/portage/package.use:
sci-libs/fftw -abi_x86_32

Reading from ChangeLog of emul-linux-x86-soundlibs says:

Quote:

03 Feb 2013; Christoph Junghans <ottxor@gentoo.org>
emul-linux-x86-soundlibs-20121028.ebuild,
emul-linux-x86-soundlibs-20121202.ebuild:
added blocker on 32bit fftw


However I'm not sure why, you can e-mail him and ask :-)
You could even file a bug at http://bugs.gentoo.org/ since this seems to be an actual bug, as in, the profiles/ should have that line for you in profiles/base/package.use, if it's currently broken/blocked by default and doesn't come out with resolved dependencies
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 412
Location: Maryland, US

PostPosted: Thu Mar 14, 2013 4:01 am    Post subject: Reply with quote

ssuominen wrote:
ABI_X86="32 64" to make.conf and keywording of =app-emulation/emul-linux-x86-xlibs-20130224-r1

After my world update this evening I see that in order to add the ABI_X86 of 32, (have ABI_X86="64 32" in my /etc/portage/make.conf), I also needed to unmask app-emulation/emul-linux-x86-xlibs-20130224-r1. If I leave it masked then my system will have app-emulation/emul-linux-x86-xlibs-20130224 installed instead, but then I need to remove the ABI_X86 32 parameter from my make.conf.

FWIW..
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5485
Location: ~Brussels - Belgique

PostPosted: Thu Mar 14, 2013 7:51 am    Post subject: Reply with quote

Hello,

In my case, I only needed 32 bits ABI in package.use and everything updated fine.
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2828

PostPosted: Thu Mar 14, 2013 8:31 am    Post subject: Reply with quote

Thanks @jasn, the unmask was fix for the madness here.
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
ToeiRei
Veteran
Veteran


Joined: 03 Jan 2005
Posts: 1156
Location: Austria

PostPosted: Thu Mar 14, 2013 8:47 am    Post subject: Reply with quote

it gets even more dirty on ~amd64 here. digging into it.
_________________
Blog | btrfs | Please stand by - The mailer daemon is busy burning your messages in hell...
Back to top
View user's profile Send private message
Polynomial-C
Developer
Developer


Joined: 01 Jun 2003
Posts: 1391
Location: germany

PostPosted: Thu Mar 14, 2013 8:59 am    Post subject: Reply with quote

If anyone being on X86_ABI="32 64" now encounters tons of blockers, just do the following:
Code:
echo "=app-emulation/emul-linux-x86-xlibs-20130224-r1" >> /etc/portage/package.unmask
See bug 461608 for details.
_________________
The manual said "Requires Windows7 or better" so I installed GNU/Linux...

my portage overlay

Need a stage1 tarball? (Unofficial builds)
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5485
Location: ~Brussels - Belgique

PostPosted: Thu Mar 14, 2013 8:59 am    Post subject: Reply with quote

Hehe, back to years < 2008, where ~arch was REALLY unstable 8)
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
ryszardzonk
Apprentice
Apprentice


Joined: 18 Dec 2003
Posts: 182
Location: Rzeszów, POLAND

PostPosted: Thu Mar 14, 2013 11:57 am    Post subject: Reply with quote

On my system I quite a few emul-linux libs. Is it safe to remove them all now or just a few or perhaps only xlibs?
Code:
app-emulation/emul-linux-x86-baselibs-20130224
app-emulation/emul-linux-x86-db-20130224
app-emulation/emul-linux-x86-medialibs-20130224
app-emulation/emul-linux-x86-opengl-20130224
app-emulation/emul-linux-x86-sdl-20130224
app-emulation/emul-linux-x86-soundlibs-20130224
app-emulation/emul-linux-x86-qtlibs-20130224
app-emulation/emul-linux-x86-xlibs-20130224


So far I have removed all of them and place them into package.provided, but it seems they might be a cause of an error I just hit, which I never faced before
Code:
checking for uuid_create... no
checking for LIBUUID... no
configure: error: requested libuuid support but uuid.pc not found
no
checking for LIBUUID... yes

!!! Please attach the following file when seeking support:
!!! /tmp/portage/x11-libs/libSM-1.2.1-r1/work/libSM-1.2.1-x86/config.log
 * ERROR: x11-libs/libSM-1.2.1-r1 failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 3708:  Called xorg-2_src_configure
configure: creating ./config.status
 *        environment, line 4419:  Called autotools-multilib_src_configure
 *        environment, line  723:  Called multilib_parallel_foreach_abi 'autotools-utils_src_configure'
 *        environment, line 3283:  Called multibuild_parallel_foreach_variant '_multilib_multibuild_wrapper' 'autotools-utils_src_configure'
 *        environment, line 3045:  Called multibuild_foreach_variant '_multibuild_parallel' '_multilib_multibuild_wrapper' 'autotools-utils_src_configure'
 *        environment, line 3023:  Called _multibuild_run '_multibuild_parallel' '_multilib_multibuild_wrapper' 'autotools-utils_src_configure'
 *        environment, line 3021:  Called _multibuild_parallel '_multilib_multibuild_wrapper' 'autotools-utils_src_configure'
 *        environment, line 3036:  Called _multilib_multibuild_wrapper 'autotools-utils_src_configure'
 *        environment, line  618:  Called autotools-utils_src_configure
 *        environment, line  820:  Called econf '--docdir=/usr/share/doc/libSM-1.2.1-r1' '--enable-shared' '--disable-static' '--enable-ipv6' '--disable-docs' '--without-xmlto' '--with-libuuid' '--without-fop'
 *   phase-helpers.sh, line  521:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=x11-libs/libSM-1.2.1-r1'`,
 * the complete build log and the output of `emerge -pqv '=x11-libs/libSM-1.2.1-r1'`.
/usr/lib64/portage/bin/isolated-functions.sh: line 215: wait: `econf failed': nie jest to nr PID ani prawidłowe określenie zadania
 * The complete build log is located at '/tmp/logs/x11-libs:libSM-1.2.1-r1:20130314-114055.log'.
 * For convenience, a symlink to the build log is located at '/tmp/portage/x11-libs/libSM-1.2.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/x11-libs/libSM-1.2.1-r1/temp/environment'.
 * Working directory: '/tmp/portage/x11-libs/libSM-1.2.1-r1/work/libSM-1.2.1-x86'
 * S: '/tmp/portage/x11-libs/libSM-1.2.1-r1/work/libSM-1.2.1'
config.status: creating Makefile
config.status: creating doc/Makefile
config.status: creating src/Makefile
config.status: creating sm.pc
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing libtool commands
Maybe it is something else, but why else would it find LIBUUID in one place and not find itr in another and then fail...

EDIT: installing back emul-linux-x86-baselibs & emul-linux-x86-db make libSM compile again so one of those packages is still definetly nedded

EDIT 2: different compile error happen for me with x11-libs/libpciaccess-0.13.1-r1 & media-libs/fontconfig-2.10.2-r1 but reinstalling above emul-linux packages made them compile again for ABI_X86="64 32"
_________________
Sky is not the limit...


Last edited by ryszardzonk on Thu Mar 14, 2013 1:40 pm; edited 2 times in total
Back to top
View user's profile Send private message
ExecutorElassus
l33t
l33t


Joined: 11 Mar 2004
Posts: 754
Location: Stuttgart, Germany

PostPosted: Thu Mar 14, 2013 12:42 pm    Post subject: Reply with quote

Just as an aside: I got a huge pile of conflicting packages when I tried 'emerge -uD world' until I manually emerged emul-linux-x86-xlibs with the new "32 64" ABI set in make.conf. It pulled in all its dependencies with the abi_x86_32 flag set, remerged them, and then the world update went through without further issues.

PS I'm on ~amd64.

Cheers,

EE
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 659

PostPosted: Thu Mar 14, 2013 2:01 pm    Post subject: Reply with quote

ExecutorElassus wrote:
Just as an aside: I got a huge pile of conflicting packages when I tried 'emerge -uD world' until I manually emerged emul-linux-x86-xlibs with the new "32 64" ABI set in make.conf. It pulled in all its dependencies with the abi_x86_32 flag set, remerged them, and then the world update went through without further issues.

PS I'm on ~amd64.

Cheers,

EE

Do you by any chance have skype and wine on your system?
Can they emerge ok after your rebuild?

Cheers,
john
Back to top
View user's profile Send private message
XavierMiller
Moderator
Moderator


Joined: 23 Jul 2004
Posts: 5485
Location: ~Brussels - Belgique

PostPosted: Thu Mar 14, 2013 7:05 pm    Post subject: Reply with quote

Hello,

I can emerge skype and wine (~amd64 multilib) with the "ABI_X86" feature (tested today, with the unmasked emul-blah-blah-r1 ebuild).
_________________
Xavier Miller
(FR) Merci de respecter les règles du forum.
http://www.xaviermiller.be
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum