Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Blender 2.66 - seems to be held back by Python 3.3
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
MisteR_TwO
n00b
n00b


Joined: 09 Feb 2007
Posts: 21

PostPosted: Mon Mar 11, 2013 9:05 pm    Post subject: Blender 2.66 - seems to be held back by Python 3.3 Reply with quote

Hello everyone,

Getting back into Gentoo after being away for a while using Ubuntu. I've been having a heck of a time trying to get Blender 2.66 to install through Portage, and it appears to be hanging on python 3.3 not being recognized.

Python 3.3 is current installed, and I've unmasked it in Portage. It also shows up as something that can be chosen in eselect python:

Code:

Available Python interpreters:
  [1]   python2.7
  [2]   python3.2
  [3]   python3.3 *


I've entered it into the make.conf as well as part of python_targets and single targets:

Code:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=amdfam10 -O2 -pipe"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="bindist mmx sse sse2 3dnow aac acpi cdr sse3 opengl svg nvidia wacom python cycles ffmpeg openal ndof"
MAKEOPTS="-j7"
FEATURES="parallel-fetch"
GENTOO_MIRRORS="http://gentoo.mirrors.easynews.com/linux/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo rsync://rsync.gtlib.gatech.edu/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo rsync://mirrors.rit.edu/gentoo/ ftp://mirrors.rit.edu/gentoo/ http://mirrors.rit.edu/gentoo/"
VIDEO_CARDS="nvidia"
#PYTHON_SINGLE_TARGET="python3_3"
PYTHON_TARGETS="python3_3 python3_2"


The odd thing is when I use python 2.7 or python 3.2 in the python_single_target area, it shows up for "emerge --info". But using the current make.conf above:

Code:
Portage 2.1.11.52 (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo x86_64)
=================================================================
System uname: Linux-3.7.10-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.1
KiB Mem:     8179072 total,   2670884 free
KiB Swap:    7903236 total,   7903236 free
Timestamp of tree: Mon, 11 Mar 2013 17:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3, 3.3.0
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.mirrors.easynews.com/linux/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo rsync://rsync.gtlib.gatech.edu/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo rsync://mirrors.rit.edu/gentoo/ ftp://mirrors.rit.edu/gentoo/ http://mirrors.rit.edu/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx cycles dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses ndof nls nptl nvidia ogg openal opengl openmp pam pango pcre pdf png policykit ppds python qt3support qt4 readline sdl session spell sse sse2 sse3 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wacom wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


After removing the comment for the python_single_target line:

Code:
Portage 2.1.11.52 (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo x86_64)
=================================================================
System uname: Linux-3.7.10-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.1
KiB Mem:     8179072 total,   1526440 free
KiB Swap:    7903236 total,   7903236 free
Timestamp of tree: Mon, 11 Mar 2013 17:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3, 3.3.0
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.mirrors.easynews.com/linux/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo rsync://rsync.gtlib.gatech.edu/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo rsync://mirrors.rit.edu/gentoo/ ftp://mirrors.rit.edu/gentoo/ http://mirrors.rit.edu/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx cycles dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses ndof nls nptl nvidia ogg openal opengl openmp pam pango pcre pdf png policykit ppds python qt3support qt4 readline sdl session spell sse sse2 sse3 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wacom wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


It completely ignores the python_single_target, where it was previously using python 2.7 on it's own. I've checked over the forums and it appears there was a patch to the eclass that controlled these things in January, but I'm not 100% on if it affects me in this case.

http://forums.gentoo.org/viewtopic-p-7218814.html

I'm going to say that it doesn't since the version of that file on my system is from 30 January 13.

Any help or guidance on this is appreciated!
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Mon Mar 11, 2013 9:53 pm    Post subject: Reply with quote

Code:
emerge -pv blender
. I have a hunch that the python-3_3 value has been masked... more after your answer...
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
MisteR_TwO
n00b
n00b


Joined: 09 Feb 2007
Posts: 21

PostPosted: Mon Mar 11, 2013 9:56 pm    Post subject: Reply with quote

Thanks for your reply! Here's the requested information:

Code:
emerge -pv blender

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    #] media-gfx/blender-2.66  USE="boost bullet collada cycles dds elbeem ffmpeg game-engine ndof nls openal openexr openmp player sdl sse tiff -colorio -debug -doc -fftw -jack -jpeg2k -redcode -sndfile" PYTHON_SINGLE_TARGET="(-python3_3)" PYTHON_TARGETS="(-python3_3)" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


And to round things out:

Code:
emerge -pv python

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   *] dev-lang/python-3.3.0:3.3  USE="gdbm ipv6 ncurses readline ssl threads xml -build -doc -examples -sqlite -tk -wininst" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Mon Mar 11, 2013 10:14 pm    Post subject: Reply with quote

now lets try compounding it, and see what we get:
Code:
export PYTHON_SINGLE_TARGET="python3_3" emerge -pv blender

Let's see if the minus is stuck in the output. If so, we need to unmask a masked flag. Upon Further investigation care of the emerge man page:
Quote:
[ebuild U *] sys-apps/portage-2.2.0_alpha6 [2.1.9.25]
Portage 2.1.9.25 is installed, but if you run the command, then portage will upgrade to version 2.2.0_alpha6. In this case, the * symbol is displayed, in order to indicate that version 2.2.0_alpha6 is masked by missing keyword. This type of masking display is disabled by the --quiet option if the --verbose option is not enabled simultaneously. The following symbols are used to indicate various types of masking:
Symbol Mask Type
---------------------------
# package.mask
* missing keyword
~ unstable keyword


Is this Version of Blender Hard-masked by your Profile?? According to your output, you have a #...
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper


Last edited by eyoung100 on Mon Mar 11, 2013 10:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
MisteR_TwO
n00b
n00b


Joined: 09 Feb 2007
Posts: 21

PostPosted: Mon Mar 11, 2013 10:21 pm    Post subject: Reply with quote

I had to modify your command slightly so the export command would like it:

Code:
Downloads # export PYTHON_SINGLE_TARGET="python3_3"; emerge blender -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    #] media-gfx/blender-2.66  USE="boost bullet collada cycles dds elbeem ffmpeg game-engine ndof nls openal openexr openmp player sdl sse tiff -colorio -debug -doc -fftw -jack -jpeg2k -redcode -sndfile" PYTHON_SINGLE_TARGET="(-python3_3)" PYTHON_TARGETS="(-python3_3)" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Downloads # echo $PYTHON_SINGLE_TARGET
python3_3


As far as unmasking a masked flag, that's taken care of through /etc/portage/package.unmask correct? If so here's that file:

Code:
#required by blender (argument)
# /usr/portage/profiles/package.mask:
# Julian Ospald <hasufell@gentoo.org> (10 Mar 2013)
# Depends on maked dev-lang/python:3.3
=media-gfx/blender-2.66
=dev-lang/python-3.3.0
Back to top
View user's profile Send private message
The Doctor
Veteran
Veteran


Joined: 27 Jul 2010
Posts: 1545

PostPosted: Mon Mar 11, 2013 10:28 pm    Post subject: Reply with quote

the "export" modifier is unnecessary. That exports the variable to the global shell, which is not necessarily what you want. You should use this PYTHON_SINGLE_TARGET="python3_3" emerge -pv blender This also works with whatever else you need to set an a trial basis, USE="<foo>", MAKEOPTS="-j1", etc.
_________________
First things first, but not necessarily in that order.


Last edited by The Doctor on Mon Mar 11, 2013 10:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Mon Mar 11, 2013 10:29 pm    Post subject: Reply with quote

Yes, but you need to modify 2 Files:
Code:
/etc/portage/package.unmask
media-gfx/blender
dev-lang/python <-- This catches every version that is masked in the tree.
(save)
/etc/portage/package.keywords
media-gfx/blender      *
(save)

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper


Last edited by eyoung100 on Mon Mar 11, 2013 10:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Mon Mar 11, 2013 10:33 pm    Post subject: Reply with quote

The Doctor wrote:
the "export" modifier is unnecessary. That exports the variable to the global shell, which is not necessarily what you want. You should use this PYTHON_SINGLE_TARGET="python3_3" emerge -pv blender This also works with whatever else you need to set an a trial basis, USE="", MAKEOPTS="-j1", etc.


As you said, I know we shouldn't export globally, but I needed someway to find the if the export would override the flag setting. Regardless after the research I added, the package is masked...
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
MisteR_TwO
n00b
n00b


Joined: 09 Feb 2007
Posts: 21

PostPosted: Mon Mar 11, 2013 10:51 pm    Post subject: Reply with quote

Thanks to both of you for helping out with this! I've made the suggested modification and python3_3 is still not coming up as available when I run "emerge -pv blender".

I've also tried putting entries into /etc/portage/profile/package.use.mask and /etc/portage/profile/use.mask. I don't believe they're helping though.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Mon Mar 11, 2013 10:54 pm    Post subject: Reply with quote

post the output of:
Code:
emerge -pv blender
to see if we've properly unmasked it :?:

I just realized what we forgot:
Code:
/etc/portage/package.unmask
media-gfx/blender
dev-lang/python <-- This catches every version that is masked in the tree.
(save)
/etc/portage/package.keywords
media-gfx/blender      *
dev-lang/python        *
(save)

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
MisteR_TwO
n00b
n00b


Joined: 09 Feb 2007
Posts: 21

PostPosted: Mon Mar 11, 2013 11:17 pm    Post subject: Reply with quote

No change on this end with those changes either.

package.unmask:
Code:
#required by blender (argument)
# /usr/portage/profiles/package.mask:
# Julian Ospald <hasufell@gentoo.org> (10 Mar 2013)
# Depends on maked dev-lang/python:3.3
media-gfx/blender
dev-lang/python


package.keywords:

Code:
media-gfx/blender *
dev-lang/python *


running the emerge command:

Code:
emerge blender -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    #] media-gfx/blender-2.66  USE="boost bullet collada cycles dds elbeem ffmpeg game-engine ndof nls openal openexr openmp player sdl sse tiff -colorio -debug -doc -fftw -jack -jpeg2k -redcode -sndfile" PYTHON_SINGLE_TARGET="(-python3_3)" PYTHON_TARGETS="(-python3_3)" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Thanks again for your help with this!
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Mar 12, 2013 2:15 am    Post subject: Reply with quote

About to emerge this on my system. I have been at dinner.
Code:
package.unmask should contain:
dev-lang/python
media-gfx/blender

According to paludis/cave, we will also need:
Code:
These are the actions I will take, in order:

n   dev-cpp/gflags:0::gentoo 2.0 to ::installed
    "Google's C++ argument parsing library"
    -static-libs build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: dev-cpp/glog-0.3.2:0::gentoo
    Masked by keyword
        Keywords ~amd64 ~amd64-linux ~arm ~x86 ~x86-linux
    501.70 kBytes to download
n   dev-cpp/glog:0::gentoo 0.3.2 to ::installed
    "Google's C++ logging library"
    Need changes for: gflags No changes needed: -static-libs -unwind (-test) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons requiring changes: media-gfx/blender-2.66:0::gentoo
    Masked by keyword
        Keywords ~amd64 ~amd64-linux ~arm ~x86 ~x86-linux
    467.45 kBytes to download
n   sci-libs/suitesparseconfig:0::gentoo 4.0.2 to ::installed
    "Common configurations for all packages in suitesparse"
    -static-libs build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: sci-libs/ldl-2.1.0:0::gentoo
    Masked by keyword
        Keywords ~alpha ~amd64 ~amd64-fbsd ~amd64-linux ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-linux ~x86-macos
    317.57 kBytes to download
n   media-libs/glew:0::gentoo 1.9.0 to ::installed
    "The OpenGL Extension Wrangler Library"
    doc -static-libs build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: media-gfx/blender-2.66:0::gentoo
    531.68 kBytes to download
n   sci-libs/ldl:0::gentoo 2.1.0 to ::installed
    "Simple but educational LDL^T matrix factorization algorithm"
    doc -static-libs build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: media-gfx/blender-2.66:0::gentoo
    Masked by keyword
        Keywords ~alpha ~amd64 ~amd64-fbsd ~amd64-linux ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-linux ~x86-macos
    405.82 kBytes to download
which gives us:
Code:
n   media-gfx/blender:0::gentoo 2.66 to ::installed
    "3D Creation/Animation/Publishing System"
    boost bullet -collada -colorio -cycles dds -debug doc elbeem ffmpeg -fftw game-engine jack jpeg2k -ndof nls openal openexr openmp -player -redcode sdl sndfile sse tiff PYTHON_SINGLE_TARGET: (-python3_3) PYTHON_TARGETS: (-python3_3) build_options: symbols=split -dwarf_compress -optional_tests -trace work=tidyup
    Reasons: target
    35.20 MBytes to download


Following that, we add:
Code:
/etc/make.conf
PYTHON_TARGETS="python2_7 python3_2 python3_3"
PYTHON_SINGLE_TARGET="python2_7 python3_3"


Continuing:
Code:
package.use should end up like so:
dev-cpp/glog            gflags
sci-libs/hdf5            -cxx -fortran threads
media-libs/opencolorio      doc python
media-gfx/blender         collada colorio cycles fftw player

Code:
Package.keywords like so:
dev-lang/python               **
dev-cpp/gflags               ~amd64
dev-cpp/glog               ~amd64
sci-libs/suitesparseconfig         ~amd64
media-libs/opencollada         ~amd64
sci-libs/ldl                       ~amd64
media-gfx/blender            ~amd64


This adds every flag but redcode.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Mar 12, 2013 2:36 pm    Post subject: Reply with quote

See:
Properly setting Python variables

I plan on getting that thread merged with this one once a fix is found. In case you're curious I can't set PYTHON_SINGLE_TARGET either.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
MisteR_TwO
n00b
n00b


Joined: 09 Feb 2007
Posts: 21

PostPosted: Tue Mar 12, 2013 3:46 pm    Post subject: Reply with quote

Thanks for your replies on this! It seems that is the big issue here, since it can't pass that check, since portage doesn't see that as an active option under PYTHON_TARGETS or PYTHON_SINGLE_TARGET. As for the brackets around "-python3_3" in the options, I've removed those by adding

Code:
media-gfx/blender -python_targets_python3_3


to /etc/portage/profile/package.use.mask . Picked that up from http://forums.gentoo.org/viewtopic-t-945522-start-0.html . Still doesn't affect it showing up in "emerge --info".
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Mar 12, 2013 3:51 pm    Post subject: Reply with quote

what happens if you remove the minus in package.use.mask??

I thought so. Since I'm not at my machine, will you:
Code:
cat  /usr/portage/profiles/base/use.mask


According to that post you linked python 3.3 is hard masked in that file. Catting it will confirm it, and if it is still there, I'll show you how to turn it off.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper


Last edited by eyoung100 on Tue Mar 12, 2013 4:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
MisteR_TwO
n00b
n00b


Joined: 09 Feb 2007
Posts: 21

PostPosted: Tue Mar 12, 2013 3:56 pm    Post subject: Reply with quote

It puts the brackets back on around that option. Just for $h1t$ and giggles I decided to add

Code:
-python_single_target_python3_3


to that list and:

Code:
These are the packages that would be merged, in order:

Calculating dependencies  ^[[A^[ /^[... done!
[ebuild  N    #] media-gfx/blender-2.66  USE="boost bullet collada cycles dds elbeem ffmpeg game-engine ndof nls openal openexr openmp player sdl sse tiff -colorio -debug -doc -fftw -jack -jpeg2k -redcode -sndfile" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="-python3_3" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


8O
Back to top
View user's profile Send private message
MisteR_TwO
n00b
n00b


Joined: 09 Feb 2007
Posts: 21

PostPosted: Tue Mar 12, 2013 3:58 pm    Post subject: Reply with quote

Code:
 * The implementation chosen as PYTHON_SINGLE_TARGET must be added
 * to PYTHON_TARGETS as well. This is in order to ensure that
 * dependencies are satisfied correctly. We're sorry
 * for the inconvenience.


so close...
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Mar 12, 2013 4:14 pm    Post subject: Reply with quote

read my post again. Create the following File:
Code:
nano -w /etc/portage/profile/use.mask
Add:
-python_targets_python3_3
-python_single_target_python3_3
(Save)


That's what I missed yesterday at 1AM. This setting should allow us to:
Code:
nano -w /etc/portage/package.use
sys-apps/portage   python3
(Save)
emerge --sync <--This will rewrite the file in /usr/portage/profiles/base/package.use back to default
emerge -v portage
eselect python set 3 (python 3.3)
python-updater
emerge -v blender


It's kinda dangerous using a hard masked python as the system wide interpreter. If you start having issues, see:
Gentoo Linux Documentation: python-r1 User's Guide. Particularly Code Listing 1.6. Never rewrite the profile info in the profile directory for 2 reasons:
  1. It gets overwritten everytime you emerge --sync.
  2. Creating the file above is the proper way to do it.


Let me explain why. These steps allowed us to create a user profile override. In terms of hierarchy due to inheritance, a profile is the parent. It controls all. Adding a flag override works only if the flag isn't masked in the profile itself. Since this setting was profile masked, we must create a profile override, not just a user override.

I'll let you know my findings tonight.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper


Last edited by eyoung100 on Tue Mar 12, 2013 4:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 412
Location: Maryland, US

PostPosted: Tue Mar 12, 2013 4:35 pm    Post subject: Reply with quote

NOTE: I actually got my system slightly hosed by doing this. Basically after every update I would have a package that needed it's own specific python_targets set to less than 3.3, (usually 2.7), and I finally got into a sort of circular python_target dependency hell, from which I couldn't extricate my system. I rolled back most of these changes, (keeping just keywording python-3.3 and unmasking blender-2.66), and switched to enabling python-3.3 for JUST blender-2.66 as described in my subsequent post below. My recommendation is that unless you know what you're doing, that you do not enable python-3.3 system wide as this post describes.
-------------------------------------------------------------------
I figured that since python-3.3 is currently being masked for testing, that it would be ok to install it and make it my system interpreter as long as I was willing to chase down any issues.

/usr/portage/profiles/base/use.mask
Code:
# Mike Gilbert <floppym@gentoo.org> (08 Oct 2012)
# Python 3.3 is masked for testing.
python_targets_python3_3
python_single_target_python3_3

So here are the configuration changes that I did in order to emerge python-3.3.0 and blender-2.66 into my system, (which alread has python-2.7 and python-3.2 already installed and python-3.2 selected as my system python interpreter);

/etc/portage/make.conf
Code:
PYTHON_TARGETS="python2_7 python3_2 python3_3"
PYTHON_SINGLE_TARGET="python3_3"

/etc/portage/profile/use.mask
Code:
-python_targets_python3_3
-python_single_target_python3_3

/etc/portage/package.keywords/[filename]
Code:
=dev-lang/python-3.3.0 **

and

/etc/portage/package.unmask/[filename]
Code:
media-gfx/blender

I then emerged dev-lang/python-3.3.0, and ran eselect python to set the system python interpreter to the newly installed 3.3.0. I then emerged media-gfx/blender-2.66. Afterwards I noticed that several installed packages didn't emerge again cleanly with;
Code:
PYTHON_SINGLE_TARGET="python3_3"

So in order to fix these, I added the following lines to;

/etc/portage/package.use/[filename]
Code:
=app-office/scribus-1.4.2-r2 python_single_target_python2_7
=dev-libs/gobject-introspection-1.34.2-r1 python_single_target_python2_7
=media-gfx/graphviz-2.28.0 python_single_target_python2_7
=media-libs/alsa-lib-1.0.26-r1 python_single_target_python2_7
=net-wireless/bluez-4.101-r5 python_single_target_python2_7

=x11-libs/xpyb-1.3.1-r1 -python_single_target_python3_3 python_single_target_python2_7
=x11-proto/xcb-proto-1.8-r1 -python_single_target_python3_3 python_single_target_python2_7

=kde-base/kate-4.10.1:4 -python_single_target_python3_3 python_single_target_python3_2

Good Luck..


Last edited by jasn on Wed Mar 13, 2013 12:43 pm; edited 3 times in total
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Mar 12, 2013 4:40 pm    Post subject: Reply with quote

jasn wrote:
I figured that since python-3.3 is currently being masked for testing, that it would be ok to install it and make it my system interpreter as long as I was willing to chase down any issues.

/usr/portage/profiles/base/use.mask

See my note in bold regarding this file and profiles. Thank you for your input BTW. We fought this for a few hours yesterday. Instead of clouding up your use file with that Set the System Wide Interpreter to 2.7/3.2, then only add the ovverride flags for blender if desired.
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
MisteR_TwO
n00b
n00b


Joined: 09 Feb 2007
Posts: 21

PostPosted: Tue Mar 12, 2013 5:29 pm    Post subject: Reply with quote

Thanks to the both of you for helping out! I've gone ahead and made the requested changes, outside of playing around in /usr/portage, and we have made progress:

Code:

Portage 2.1.11.52 (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo x86_64)
=================================================================
System uname: Linux-3.7.10-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.1
KiB Mem:     8179072 total,   5512776 free
KiB Swap:    7903236 total,   7903236 free
Timestamp of tree: Tue, 12 Mar 2013 16:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3, 3.3.0
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.mirrors.easynews.com/linux/gentoo/ http://www.gtlib.gatech.edu/pub/gentoo rsync://rsync.gtlib.gatech.edu/gentoo ftp://ftp.gtlib.gatech.edu/pub/gentoo rsync://mirrors.rit.edu/gentoo/ ftp://mirrors.rit.edu/gentoo/ http://mirrors.rit.edu/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx cycles dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses ndof nls nptl nvidia ogg openal opengl openmp pam pango pcre pdf png policykit ppds python python3_3 qt3support qt4 readline sdl session spell sse sse2 sse3 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wacom wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python2_7 python3_2 python3_3" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


So python3_3 is showing up now. I still wasn't able to emerge blender 2.66 due to the ebuild not seeing python3_3 in the python_targets variable for some reason. After appending

Code:
PYTHON_TARGETS="python3_3"


to the front, it now runs:

Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-python/python-exec-0.3.1 [0.2] PYTHON_TARGETS="(jython2_5) (jython2_7) (pypy1_9*) (pypy2_0*) (python2_5) (python2_6) (python2_7) (python3_1) (python3_2) (python3_3*)" 73 kB
[ebuild   R   ~] dev-python/setuptools-0.6.33  PYTHON_TARGETS="python3_3* -pypy1_9 -pypy2_0 -python2_5 -python2_6 -python2_7 -python3_1 -python3_2*" 0 kB
[ebuild     U ~] dev-python/numpy-1.7.0 [1.6.2-r2] USE="-doc -lapack {-test}" PYTHON_TARGETS="python3_3%* -python2_5 -python2_6 -python2_7 -python3_1 -python3_2*" 2,767 kB
[ebuild  N    #] media-gfx/blender-2.66  USE="boost bullet collada cycles dds elbeem ffmpeg game-engine ndof nls openal openexr openmp player sdl sse tiff -colorio -debug -doc -fftw -jack -jpeg2k -redcode -sndfile" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python3_3" 0 kB

Total: 4 packages (2 upgrades, 1 new, 1 reinstall), Size of downloads: 2,839 kB


I'll give it a shot and see if it works. Afterwards, I'll track down why I still needed to add that after making all of the requested changes.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Mar 12, 2013 5:35 pm    Post subject: Reply with quote

Go up 4 posts, and add:
Code:
nano -w /etc/portage/profile/use.mask
Add:
-python_targets_python3_3
-python_single_target_python3_3
(Save)
Then Edit:
Code:

/etc/make.conf
PYTHON_TARGETS="python2_7 python3_2 python3_3"
PYTHON_SINGLE_TARGET="python2_7 python3_3"
(Save)

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
MisteR_TwO
n00b
n00b


Joined: 09 Feb 2007
Posts: 21

PostPosted: Tue Mar 12, 2013 5:45 pm    Post subject: Reply with quote

I had already added those to the proper files. The only thing I left off was the "python2_7" declaration in PYTHON_SINGLE_TARGET for make.conf when I ran it orginally. After adding that declaration, it still gives the error when I leave off the PYTHON_TARGETS variable declaration before running "emerge blender".

Everything appears to have built at this time, so I'm super plussed right now! Much thanks for your help getting this far! :D

I'll close this one out once I've solved that issue with python not seeing "python3_3" when emerging Blender. When I get back from work tonight I'll go over the settings files and make sure everything's kosher.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1411

PostPosted: Tue Mar 12, 2013 6:11 pm    Post subject: Reply with quote

Code:
package.use:
Add:
media-gfx/blender     python_targets_python3_3 -python_targets_python3_2 -python_targets_python2_7
(Save)

Since we have multiple targets, we must specify the one we want for this package only. This keeps us from Having to type PYTHON_TARGETS="python3_3" during a world update etc....
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 412
Location: Maryland, US

PostPosted: Wed Mar 13, 2013 12:31 pm    Post subject: Reply with quote

eyoung100 wrote:
Instead of clouding up your use file with that Set the System Wide Interpreter to 2.7/3.2, then only add the ovverride flags for blender if desired.

This is apt advice. I've quickly gotten my system into a sort of circular python_target dependency hell trying to use 3.3 as my system wide interpreter. So I've taken your advice and done the following things;

1) Remove both PYTHON_TARGET lines from my /etc/portage/make.conf
2) eselect python and set it to 3.2
3) Remove both python_target lines from my /etc/portage/profile/use.mask
4) Add the following to;

/etc/portage/profile/package.use.mask
Code:
=dev-python/python-exec-0.3.1 -python_targets_python3_3
=dev-python/numpy-1.7.0 -python_targets_python3_3
=dev-python/setuptools-0.6.33 -python_targets_python3_3
=media-gfx/blender-2.66 -python_single_target_python3_3 -python_targets_python3_3

5) Add the following to;

/etc/portage/package.use/[filename]
Code:
=dev-python/python-exec-0.3.1 python_targets_python3_3
=dev-python/numpy-1.7.0 python_targets_python3_3
=dev-python/setuptools-0.6.33 python_targets_python3_3
=media-gfx/blender-2.66 python_single_target_python3_3 python_targets_python3_3

I'm re-emerging a bunch of related packages, and my system should be stable again and I now heartily concur. It's much safer and easier to just enable python-3.3 for blender alone.

Thanks..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum