Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas con libsoup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
maurixio
n00b
n00b


Joined: 08 Mar 2013
Posts: 3

PostPosted: Sat Mar 09, 2013 2:50 pm    Post subject: Problemas con libsoup Reply with quote

Cuando hago un emerge --update --newuse --deep --with-bdeps=y @world , comienza a compilar libsoup-9999 desde gentoo y no finaliza dando el error :

http://pastebin.com/pUME5HXv
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 811

PostPosted: Sat Mar 09, 2013 8:27 pm    Post subject: Re: Problemas con libsoup Reply with quote

maurixio wrote:
Cuando hago un emerge --update --newuse --deep --with-bdeps=y @world , comienza a compilar libsoup-9999 desde gentoo y no finaliza dando el error :

http://pastebin.com/pUME5HXv

Parece que tu sistema tenía un problema en el momento en que intentaba emerger libsoup: (shell-init: error retrieving current directory). Es posible que sólo sea temporal debido a alguna actualización reciente. Prueba a reiniciar el ordenador e interntarlo de nuevo.

La versión del paquete que quieres instalar es la que está en desarrollo en este momento. Salvo que sepas exactamente lo que haces esto probablemente te traerá problemas, ahora o en el futuro. Además la estas instalando desde el repositorio gnome (en gentoo no está disponible esa versión). El utilizar repositorios distintos al oficial puede llevarte a situaciones sin salida. Si quieres puedes instalar la versión que hay en portage con
Code:
emerge --oneshot libsoup::gentoo
.
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9836
Location: Córdoba (Spain)

PostPosted: Sun Mar 10, 2013 10:04 am    Post subject: Reply with quote

El problema con getcwd puede ser simplemente por estar en un directorio que ya no existe. Estas cosas pasan cuando se trabaja de forma simultánea en varios shells y no tiene mayor importancia. Para ver cual es el problema real habría que mirar en el build log que señala esa misma salida que has pegado en pastebin.

En cualquier caso, primero, piensa si de verdad necesitas el overlay de gnome, y si no es así bórralo para simplificar tu sistema un poco. Si lo necesitas, entonces seguramente tengas que vivir con libsoup-9999, porque me imagino que será una dependencia de algún ebuild de dicho overlay que estés usando. Este tipo de ebuilds puede fallar en cualquier momento, por su naturaleza cambiante (live). Si falla, prueba otra vez mañana, y si vuelve a fallar tendrás que contactar con quien quiera que sea que mantenga ese overlay en estos momentos.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum