Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge --update problem with steam
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
paraw
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 77
Location: Coventry (UK)

PostPosted: Sat Mar 09, 2013 1:26 pm    Post subject: emerge --update problem with steam Reply with quote

Hi, all, I was updating my system today, but after syncing, if I run
emerge --update --deep --newuse -pv world
I get

Quote:
These are the packages that would be merged, in order:

Calculating dependencies ... done!
[...]
!!! Problems have been detected with your world file
!!! Please run emaint --check world


!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
games-util/steam-meta

However, if I run
emerge -pv steam-meta
I get
Quote:
These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild R ~] games-util/steam-meta-9999::steam-overlay 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

which suggests that the package is correctly unmasked (after all, I installed it without problems). Just in case, I also ran
eix-update && eix steam-meta
which returned
Quote:
[I] games-util/steam-meta [1]
Available versions: (~)9999
Installed versions: 9999(12:40:02 03/09/13)
Homepage: https://steampowered.com
Description: Meta package for Valve's Steam environment

[1] "steam-overlay" /var/lib/layman/steam-overlay

that suggests once more the unmasking is correct. So what's the problem? Is portage correctly seeing the overlay when emerging a single package but now when updating world?
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1407

PostPosted: Mon Mar 11, 2013 8:37 pm    Post subject: Reply with quote

Code:
emerge -pv layman
echo "source /var/lib/layman/make.conf" >> /etc/make.conf
layman -a steam-overlay

Gentoo Overlays: Users' Guide
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
paraw
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 77
Location: Coventry (UK)

PostPosted: Mon Mar 11, 2013 9:17 pm    Post subject: Reply with quote

Hi, eyoung100, thanks for your answer. However, I'm afraid that your suggestion is not exact. In fact, allow me to make you notice two things:
1) If I hadn't already correctly installed the overlay, how could have I emerged steam-meta, as I say in the original post? and
2) If I hadn't already correctly installed the overlay, how would eix see the package?

Therefore, the problem must lie elsewhere.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1407

PostPosted: Mon Mar 11, 2013 9:24 pm    Post subject: Reply with quote

I apologize, but one can install an overly w/o making use of layman. Have you done as the error suggests?
Code:
emaint --check world

_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
paraw
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 77
Location: Coventry (UK)

PostPosted: Mon Mar 11, 2013 9:30 pm    Post subject: Reply with quote

Yes, but no problem is found.
My guess is that there is some dependency that is not properly checked, either because of an actual bug in portage or, more likely, because of some problem in the ebuilds in the overlay. I'll check and see if I can fix it.
Back to top
View user's profile Send private message
eyoung100
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1407

PostPosted: Mon Mar 11, 2013 9:34 pm    Post subject: Reply with quote

1. Paste the contents of /var/db/world
2. Try unmerging steam meta.
3. Try world update
4. Emerge steam meta
_________________
The Birth and Growth of Science is the Death and Atrophy of Art -- Unknown
Registerd Linux User #363735
Adopt a Post | Strip Comments| Emerge Wrapper
Back to top
View user's profile Send private message
paraw
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2005
Posts: 77
Location: Coventry (UK)

PostPosted: Sat Mar 16, 2013 12:31 pm    Post subject: Reply with quote

Alright. Sorry for letting this go so long. It turned out that my intuition was somehow right. The package steam-meta depends on libsdl version 2, which is contained in the overlay, but it's masked. However, for a reason or another, instead of receiving a message telling me that a necessary dependence was masked, I was receiving the message in the original post. The bottom line is I just added the line
Code:
=media-libs/libsdl-2.0.0_pre6940 ~amd64

to /etc/portage/package.keywords and updated world without problems. However, while this is a clear workaround, it doesn't tell us why the original error message was ambiguous.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum