Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[portage] emerge -uvaDN world me obliga a instalar paquetes
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Fri Mar 08, 2013 3:49 pm    Post subject: [portage] emerge -uvaDN world me obliga a instalar paquetes Reply with quote

¿Cómo puedo saber quien me obliga a instalar unos paquetes específicos?

Code:
# emerge -uvpDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-java/icedtea-bin-6.1.12.2:6  USE="X alsa cups -cjk -doc -examples -nsplugin -source" 37,440 kB
[ebuild  N     ] virtual/jdk-1.6.0-r1:1.6  0 kB
[ebuild  N     ] virtual/jre-1.6.0:1.6  0 kB
[ebuild  N     ] dev-java/jrexx-1.1.1-r1  USE="-doc -source" 62 kB

Total: 4 packages (4 new), Size of downloads: 37,502 kB


tengo instalado ya el jdk de oracle para la versión 1.7

gracias anticipadas y un saludo
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
tuxtor
n00b
n00b


Joined: 22 Apr 2007
Posts: 41
Location: Guatemala

PostPosted: Fri Mar 08, 2013 7:51 pm    Post subject: Reply with quote

Pareciera que el jdk de oracle estuviera instalado fuera de portage, jrexx depende solo de virtual/jdk de acuerdo a la salida de qdepends

dev-java/jrexx-1.1.1-r1: >=virtual/jdk-1.4 app-arch/unzip >=dev-java/java-config-2.1.9-r1


Lo que podrias hacer en ese caso es instalar oracle-jdk-bin con portage y si ya esta instalado dentro de portage instalar virtual/jdk con emerge --oneshot, es extraño dado que cualquier jdk con portage instala virtual/jdk pero puede ser problema en algun depclean previo.
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 899

PostPosted: Fri Mar 08, 2013 8:27 pm    Post subject: Re: [portage] emerge -uvaDN world me obliga a instalar paque Reply with quote

Theasker wrote:
¿Cómo puedo saber quien me obliga a instalar unos paquetes específicos?
...

Code:
equery depends <nombredelpaquete>
te lo dirá.
Back to top
View user's profile Send private message
Theasker
l33t
l33t


Joined: 18 Nov 2006
Posts: 636
Location: Zaragoza (Spain)

PostPosted: Wed Mar 13, 2013 8:35 am    Post subject: Reply with quote

he mirado e instalé netbeans con la 1.6 que es sun-jdk no oracle-jdk-bin, por lo que igual aunque haya hecho un emerge oracle-jdk-bin para que me instale la 1.7 hay algún programa que necesita la 1.6 y por eso la pide.

Yo todo lo instalao mediante portage para que no haya problemas nunca, si instalo algo sin portage, no lo instalo, son programas "portables" que funcionan sin instalación, pero en el sistema nunca meto nada a mano, ahí portage siempre es el jefe.

thx
_________________
"Oigo y olvido. Veo y recuerdo. Hago y comprendo"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum